toc

Team LiB
Next Section

Secrets of the Game Business
Secrets of the Game Business
by Francois Dominic Laramee (ed) ISBN:1584502827
Charles River Media © 2003

This book unveils the inner workings of the flashy but very serious game development and publishing industry. Everything is covered, from how the retail market works to financing a start-up and deciding on the right business model for your game.

Table of Contents
 | Secrets of the Game Business
 | Preface
 | Section 1 - Publishers and Developers
 | Chapter 1.0 | - | Introduction
 | Chapter 1.1 | - | The Top Ten Misconceptions New Game Developers Have About Publishers
 | Chapter 1.2 | - | The Role of Each Entity in Game Publishing
 | Chapter 1.3 | - | How Developers Get Paid: The Retail Market for Games
 | Chapter 1.4 | - | A Publishing Project: From Concept to Launch and Beyond
 | Chapter 1.5 | - | The Producer, Friend or Foe?
 | Chapter 1.6 | - | The European Challenge in Videogame Software: The "French Touch" and the "Britsoft Paradox"
 | Section 2 - Game Development Startups
 | Chapter 2.0 | - | Introduction
 | Chapter 2.1 | - | Development Misery and How to Avoid It
 | Chapter 2.2 | - | Writing a Business Plan for a Game Development Startup
 | Chapter 2.3 | - | Strategies for Staffing a Startup
 | Chapter 2.4 | - | Financing from the Buyer's Side: Evaluating and Acquiring a Game Company
 | Chapter 2.5 | - | Financing Projects and Startups
 | Chapter 2.6 | - | Wireless Business Models
 | Chapter 2.7 | - | Online Business Models: Using the Net for Profit
 | Chapter 2.8 | - | Creating a Successful Freelance Game Development Business
 | Section 3 - Taking a Game to Market
 | Chapter 3.0 | - | Introduction
 | Chapter 3.1 | - | Public Relations: Making the Most of the Gaming Press
 | Chapter 3.2 | - | Securing a Development Contract: The Art of Pitching
 | Chapter 3.3 | - | The Whys and Wherefores of Game Agents
 | Chapter 3.4 | - | Effective Development Contracts
 | Chapter 3.5 | - | Pros and Cons of Worldwide and Country-by-Country Deals
 | Chapter 3.6 | - | Techniques to Increase Upsell for Online Games
 | Section 4 - Managing Game Development
 | Chapter 4.0 | - | Introduction
 | Chapter 4.1 | - | The Stages of Game Development
 | Chapter 4.2 | - | Managing the Development Process
 | Chapter 4.3 | - | Customer Support in Massively Multiplayer Online Games
 | Chapter 4.4 | - | Offshore Game Development Outsourcing
 | Chapter 4.5 | - | Localizations
 | Chapter 4.6 | - | Leadership: The Making of Effective and Happy Teams
 | Chapter 4.7 | - | Quality Assurance: Bug Tracking and Test Cases
 | Index
 | List of Figures
 | List of Tables
 | List of Case Studies
 | List of Sidebars

Team LiB
Next Section


backcover

Team LiB

Back Cover

As the game industry continues to grow, you might be considering jumping in, but before you do, read what the insiders have to say and learn from their experiences. You'll explore the inner workings of the game development and publishing industry through the experiences and insights of industry experts. These publishing executives, developers, veteran producers, designers, owners of independent studios, and academics have written a unique collection of articles that really delve into the intricacies of the business. The articles, case studies, and interviews cover all aspects of the industry, providing real-world examples that illustrate how successful companies and individuals have achieved their goals. Everything is covered, from how the retail market works to financing a start-up and deciding on the right business model for your game.

About the Editor

François Dominic Laramée (Verdun, QC) has designed, programmed, and/or produced over 20 games for con-soles, personal computers, interactive television, and online networks over the last decade. He is a prolific writer and the holder of graduate degrees in computer science and business administration. He is also the editor of Game Design Perspectives and he has contributed to the Game Programming Gems and AI Game Programming Wisdom series.

Team LiB


Secrets of the Game Business

EDITED BY FRANÇOIS DOMINIC LARAMÉE
CHARLES RIVER MEDIA, INC.
Hingham , Massachusetts

Copyright © 2003 by CHARLES RIVER MEDIA, INC.

All rights reserved.

No part of this publication may be reproduced in any way, stored in a retrieval system of any type, or transmitted by any means or media, electronic or mechanical, including, but not limited to, photocopy, recording, or scanning, without prior permission in writing from the publisher.

Publisher: Jenifer Niles

Production: Publishers' Design and Production Services, Inc.

Cover Design: The Printed Image

10 Downer Avenue
Hingham, Massachusetts 02043
781-740-0400
781-740-8816 (FAX)
<info@charlesriver.com>
www.charlesriver.com

This book is printed on acid-free paper.

ISBN: 1-58450-282-7

All brand names and product names mentioned in this book are trademarks or service marks of their respective companies. Any omission or misuse (of any kind) of service marks or trademarks should not be regarded as intent to infringe on the property of others. The publisher recognizes and respects all marks used by companies, manufacturers, and developers as a means to distinguish their products.

Library of Congress Cataloging-in-Publication Data

Laramée, François Dominic.
  Secrets of the game business / François Dominic Laramée.
       p. cm.
  ISBN 1-58450-282-7

1. Computer games—Programming. 2. Computer games—Marketing. I. Title.

QA76.76.C672L365 2003

794.8'1526—dc21

2002154755

Printed in the United States of America

03 7 6 5 4 3 2 First Edition

CHARLES RIVER MEDIA titles are available for site license or bulk purchase by institutions, user groups, corporations, etc. For additional information, please contact the Special Sales Department at 781-740-0400.

Requests for replacement of a defective CD-ROM must be accompanied by the original disc, your mailing address, telephone number, date of purchase and purchase price. Please state the nature of the problem, and send the information to CHARLES RIVER MEDIA, INC., 10 Downer Avenue, Hingham, Massachusetts 02043. CRM's sole obligation to the purchaser is to replace the disc, based on defective materials or faulty workmanship, but not on the operation or functionality of the product.

To my dad—I wish you would have lived to see this.

ACKNOWLEDGMENTS

As always, many thanks to all the wonderful people who contributed to the creation of this book: the authors who wrote such wonderful articles, the dozens of industry insiders who agreed to share their wisdom in interviews and case studies, and, of course, the entire crew at Charles River Media, starting with David Pallai (who actually came up with the idea for this book and offered me the editor's job) and Jenifer Niles. I am humbled by your talent and generosity.

Thanks to the readers who inspire me to continue writing these books and articles with their kind letters. You have my undying gratitude.

And, of course, thanks to Julie for pushing me to do something productive with my time!

ABOUT THE AUTHORS

Sean Timarco Baggaley

Sean began his game industry career as an artist in the 1980s. He designed and programmed several games in the 1990s, ported a popular PC soccer management sim to the Amiga long after the platform had been pronounced dead, and was responsible for naming the comp.games.* newsgroup hierarchy. He recently wrote the user guide for RenderWare Graphics, a popular middleware solution, and currently works as a freelance writer and game design consultant.

Ed Bartlett

Ed Bartlett is business development director for the legendary London-based independent developer The Bitmap Brothers. At nearly 27 years of age, Ed is already less than three years from his 10th anniversary in the industry. With well over 10 published titles to his name on formats ranging from PC through console to handheld, he has intimate hands-on experience of QA, production, product acquisition, game design, and business management, all at the most senior levels. Ed also works extensively with the IGDA and has a passion for writing, with numerous published features to his name.

Tom Buscaglia

Tom is a principal in the law firm T.H. Buscaglia and Associates in Miami, Florida. He has been the chapter coordinator for the South Florida Chapter of the International Game Developers' Association since its inception several years ago, and is a moderator for the IGDA's Business and Legal Web forum. He is also the president of BallroomGames, Inc., which holds the exclusive license for the use of the Arthur Murray Dance Studio name and materials in conjunction with developing a series of games based on the exciting world of ballroom dance.

Beverly Cambron

Beverly Cambron is the founder of Rocco Media, LLC, a public relations and marketing firm. Before entering the world of game industry public relations, Beverly was a litigation attorney in both Texas and California. She received her degree in finance and international business from the University of Texas at Austin, and her law degree from Southern Methodist University in Dallas. Beverly has contributed to several game industry books, magazines, and online publications, and is a published writer on the subject of wine.

Melanie Cambron

Melanie Cambron is a recruiter for game industry leaders such as EA, THQ, Infogrames, and Sony. Featured in several books for her industry knowledge, she is a popular guest speaker at universities and high schools on the game development business. Melanie is frequently interviewed by major media such as the Dallas Morning News and serves as a consultant to the City of Austin's Interactive Industry Development Committee. At E32002, she moderated the Will Wright and Yu Suzuki panel on game design secrets. Her monthly "Interview with the Goddess," featuring industry celebrities, appears in GIGnews.com.

Chris Campbell

Chris has worked as quality assurance lead on the Age of Empires game series. He has also worked in the quality assurance field in several different sectors, including telecom, supply chain, and finance. For fun, he runs a videogame trivia mailing list, and has been an avid gamer for more than 20 years.

Sande Chen

A Grammy-nominated music video director, Sande Chen is an award-winning writer active in the gaming industry. Her past credits include Terminus, Siege of Avalon, and Scooby Doo. She has written for numerous publications, including the Boston Globe.

Thomas Djafari

Thomas has been working in the game industry for over 12 years. During this time, he has occupied various positions, has worked for major publishers, and has also completed independent projects. He has been evaluating proposals made to publishers as well as seeking financial support for teams, earning knowledge from these two points of views.

François Dominic Laramée

A game development professional since 1991 and a full-time freelancer since 1998, François Dominic Laramée has designed, produced, and programmed more than 20 games for half a dozen platforms. In addition to this book, he edited Charles River Media's Game Design Perspectives and has written more than 50 articles and book chapters for and about game developers. He holds graduate degrees in management and computer science, teaches graphics programming and other computer science topics at Concordia University, and moonlights as a comedy writer.

Philippe Larrue

Philippe Larrue is a research fellow at INSEAD to William Lazonick and Mary O'Sullivan. He completed a Ph.D. in economics from Bordeaux University in May 2000. His thesis focused on the coordination of research and innovation activities in the early years of an industry. He particularly examined precompetitive research consortia to assess the extent to which and under which conditions these can be efficient vehicles for collection action during this early stage. This research was applied to the case of advanced batteries for electric and hybrid vehicles. While still devoting some time to these issues, he is now working at INSEAD on a cross-national comparative analysis of the institutional infrastructures supporting the funding of startups in France and the UK. This project is carried on through the case of the videogames industry.

William Lazonick

William Lazonick holds a joint appointment as distinguished research professor at INSEAD and university professor at the University of Massachusetts Lowell. He is also Professor-II at the Norwegian School of Management BI, where he teaches a doctoral course on innovative enterprise. Previously, he was assistant and associate professor of economics at Harvard University (1975–1984), and professor of economics at Barnard College of Columbia University (1985–1993). He specializes in the study of industrial development and international competition. Many of his published papers can be accessed at http://faculty.insead.edu/lazonick/.

Heather Maxwell

Heather Maxwell has been working in the games industry since 1996. She has worked at Activision, Electronic Arts, and Red Storm Entertainment in a variety of production roles. She has a BA from Vanderbilt University and an MA from the USC School of Cinema-Television.

Mason McCuskey

Mason is the leader of Spin Studios (www.spin-studios.com), an independent game studio currently hard at work on a brand new game. Mason has been programming games since the days of the Apple II, and has run his own game development business for several years.

Mitzi McGilvray

Mitzi McGilvray has spent the last 15 years in the interactive entertainment business. She has worked with such premiere game publishers as Midway, Electronics Arts, Activision, Maxis, and Time Warner Interactive. Her production credits include NCAA Football, Michelle Kwan Figure Skating, Figure Skating, March Madness, NHL 97, Wayne Gretzky Hockey, and various ports of SimCity and SimEarth.

Prior to founding Slam Dunk Productions, Mitzi was most recently a senior producer at EA.COM, where she was responsible for building budgets and business plans for mass-market online games, project management, game integration, and leading production teams.

Mary O'Sullivan

Mary O'Sullivan is an associate professor of strategy and management at INSEAD. She completed her undergraduate degree in 1988 at University College Dublin. After two years as a business analyst at McKinsey & Co. in London, she went to Harvard Business School and completed her MBA there in 1992. She then joined the Ph.D. program in business economics at Harvard University. Having completed that degree in June 1996, she spent six months as a visiting scholar at the University of Tokyo. Her broad research interests include political economy, the history of economic thought, and economic history. Oxford University Press has just published her book Contests for Corporate Control: Corporate Governance in the United States & Germany. O'Sullivan developed the elective course on "Innovation, Strategy, and Corporate Governance" at INSEAD since 1997. She has been twice awarded the prize for the Best MBA Elective Teacher at INSEAD.

Javier Otaegui

Javier F. Otaegui is project leader of Sabarasa Entertainment, an Argentine game development outsourcing studio based in Buenos Aires. He has been creating games since 1996, when he started Malvinas 2032, a local success. Nowadays, he is leading outsourced projects for American and European customers. Javier can be contacted via e-mail at <javier@sabarasa.com>.

Terri Perkins

Terri Perkins ventured into the online game world with Lambda Moo and a 1200- baud modem while completing a bachelor's degree in education in 1994. She has administered and worked with volunteer programs for the Realms of Despair MUD, Everquest, and DragonRealms before finding her home as founder and director for Funcom Inc.'s Anarchy-Online volunteer program. She has assisted in public relations, customer service design, project coordination, and consulting for various game organizations and companies.

She presently works in IT for Information International Associates and devotes spare time to combating Internet illiteracy and studying cyberculture.

Borut Pfeifer

An avid gamer since the second grade, Borut Pfeifer co-founded White Knuckle Games, with his partners Dedrick Duckett and Doug Hayes in May 2001. His responsibilities at White Knuckle Games include serving as lead designer and AI and gameplay programmer. They are currently working on a third-person cyberpunk noir action role-playing game entitled Reality's Edge. Borut can be reached at <borut@whiteknucklegames.com>.

Jay Powell

Jay Powell received his BA from the University of North Carolina at Chapel Hill. He has arranged numerous deals across the globe for PC, GameCube, PlayStation 2, and Xbox games. Jay regularly provides advice for the development community through GIGnews and has lectured twice at the Game Developer Conference. Jay also contributed two articles to the Charles River Media book Game Design Perspectives. With almost two decades of gaming experience, Jay's industry insight has allowed Octagon to create and maintain a property evaluation and acceptance methodology that exceeds the standards and expectations of the interactive industry.

Kathy Schoback

As director of external publishing and development at Sega, Kathy Schoback oversees relationships with Sega's external North American developers and publishing partners. She has served in various roles in her tenure at Sega, including head of Dream-cast third-party publisher management, regional sales, and consumer service. Kathy has also worked on the Game Developers Conference as part of the management team, and is currently a board member of the International Game Developers Association.

Michael Sellers

Michael Sellers is the founder of Online Alchemy, a game development studio in Austin, Texas. He has co-founded two other companies, Archetype Interactive in 1994, where he led the design for Meridian 59, and The Big Network in 1997, where he led the development of several online games and the ground-breaking MyPlace community software. Following that, he spent three years as a senior designer for Electronic Arts, leading such efforts as SimCity Online, The Sims 2, and the next Ultima Online, and contributing to the The Sims Online. Sellers has a degree in cognitive science.

Tom Sloper

Tom's game business career began at Western Technologies, where he designed LCD games and the Vectrex games Spike and Bedlam. There followed stints at Sega Enterprises (game designer), Rudell Design (toy designer), Atari Corporation (director of product development), and Activision (producer, senior producer, executive producer, creative director). In his 12 years at Activision, he produced 36 unique game titles (plus innumerable ports and localizations), and won five awards. He worked for several months in Activision's Japan operation, in Tokyo, and is perhaps best known for designing, managing, and producing Activision's Shanghai line. Tom is currently consulting, writing, speaking, and developing original games. He can be contacted at <tomster@sloperama.com>.

Grant Stanton

Grant Stanton is executive vice president of TSC and a professional recruiter in the games industry. He has recruited development staff and executives in the games industry for over 12 years and has consulted with numerous game company startups offering strategies for staffing. He is a second-generation recruiter in the industry, his father having helped staff companies such as Midway, Taito, Atari, and Collecovision in the early 1970s. He can be reached via e-mail at <Grant@TSCsearch.com>.

Johanna Wilson

Johanna Wilson is the CEO and a founder of OpenPath Products. She has over a decade of IT experience and has spent the past five years managing and growing wireless Internet technologies within wireless carriers and enterprises. OpenPath Products develops standards-based wireless software tools for creating and testing wireless applications. OpenPath Products uses these tools to create SMS, WAP, and J2ME wireless games.


Preface

François Dominic Laramée

<francoislaramee@videotron.ca>

Welcome to Secrets of the Game Business, a book that unveils the inner workings of the flashy but very serious game development and publishing industry. If you are thinking about creating a new game development company, want your existing studio to prosper for a long time, or just want to understand how and why the business evolved to its current dynamics, you have come to the right place!

This book gathers the wisdom of dozens of industry insiders, publishing executives, veteran producers, owners of independent studios, writers, and academics. It is divided into four major topic areas:

  • Section 1 , Publishers And Developers: Section 1 examines the work of publishers and retailers, explains how games get from their developers to the players, and shows how the industry's economics influence the ways we work and live.

  • Section 2 , Game Development Startups: This section describes how to prepare for the creation of a new game development company and succeed in a difficult market.

  • Section 3 , Taking a Game to Market: Section 3 teaches developers how to approach publishers, maximize the odds of their games reaching store shelves, and negotiate contracts that protect their long-term interests.

  • Section 4 , Managing Game Development: This section contains advice on ways to make the long, arduous production process as smooth and pleasant as possible for everyone involved.

However, before we get to the heart of the matter, let's pause and take a look at the state of our industry as of late 2002.

An Entertainment Powerhouse?

Sales figures for the game industry as a whole are staggering, and getting more so every year—impressive, but misleading. True, game software sales have exceeded Hollywood's box office receipts in North America since the late 1990s. However, the fact that the price of a game is 5 to 10 times higher than that of a movie ticket accounts for much of this mind-boggling "profit"—and once the home video market is taken into consideration, game sales suddenly don't seem so impressive.

Still, it seems that demographic changes are transforming interactive entertainment into a mass-market experience. As game players (and developers) get older, we can expect new genres and game topics to emerge to satisfy the increased demand.

Sustained Growth

According to an Informa Media Group report quoted in [Reuters02], the videogame industry's global sales for 2002 are expected to exceed $31 billion, a 12% increase over the previous year. Almost 70% of this impressive number, or $22 billion, comes from sales of consoles and other hardware, while software accounts for the remaining $9 billion. Although this means that software sales are expected to remain similar to 2001's figure of $9.4 billion [Gamasutra02], we must keep in mind that 2001 broke all records, besting the industry's previous banner year (1999) by almost 35%.

An Excess of Product

Because of the very large number of games battling for a share of the players' attention, each title can only expect to receive a minute fraction of this lofty number. While Hollywood releases approximately 100 movies to theaters every year, some of them in very limited distribution, the game industry launches thousands of titles on multiple incompatible platforms. Consequently, a game that sells a few hundred thousand units is considered a moderate hit, while a movie that fails to draw at least 10 million viewers to theaters is perceived as a commercial failure. Sure, movie production budgets dwarf ours, and it takes many more $5 tickets to pay for a $100 million film than it takes $50 boxes to make a $3 million game profitable. However, in the end, while most movies end up being profitable (Hollywood accounting practices notwithstanding), the vast majority of games lose money for their developers, their publishers, or both.

Difficult Consolidation

Thus, while the industry as a whole keeps growing, many of the individual companies that make and sell games are struggling to survive. The stock market crash that followed the bursting of the dot-com bubble and the terrorist attacks of 2001 severely hurt many game publishers; for example, Interplay (de-listed by NASDAQ when its market capitalization fell below a minimum threshold), and especially the French companies that had pursued an aggressive policy of acquisition financed by stock swaps. Moreover, with high-profile games requiring development budgets that grow by leaps and bounds (to $3 million on average, more on some consoles), small and mid-sized publishers find it increasingly difficult to compete in the global marketplace. It is likely that fewer than 20 global companies will survive the next five years; the rest of the publishing landscape will be dotted with much smaller players concentrating on specific nations and territories.

Can Startups Still Thrive?

With fewer large publishers competing for their products, game developers will need to work harder to find a channel to market—and to approach alternate sources of funding for their projects. Taking a game to market, which wasn't easy in the past, will become more difficult in the future.

However, this business is still built on talent. We must remember that many of the most successful games in recent history—for example, Half-Life, Asheron's Call, and Age of Empires—were developed by startups or relatively young companies, not all of which were populated by industry veterans. Runaway hits can still, once in a while, be created by a small resourceful team working on a shoestring (Deer Hunter), or even by a single individual with very little help (e.g., Roller Coaster Tycoon and Tetris). Breaking into games can be difficult, especially if you dream of making a console blockbuster right out of college, but it is by no means impossible.


Players and Developers Around the World

While Secrets of the Game Business focuses on the way things work in the western world, the game industry is truly a global phenomenon, and the ways in which people play vary wildly from one part of the world to the next. Let's look at some of the interesting phenomena happening out of the North American public's eye.

Unknown Genres

The Japanese console game market is far more diverse than what we see in our stores. For example, small games sold for the equivalent of a few dollars and designed to be played through in a single sitting, possibly during a party, are, if not commonplace, at least relatively easy to find. And if you think some American games are edgy, you would be surprised to learn how far Asian games have pushed the envelope in terms of violent and sexy content.

Perhaps the most interesting game genre indigenous to Japan and all but unknown everywhere else is the dating simulator, where the player must flirt with and conquer the hearts of virtual characters with surprisingly well-rounded personalities. Sometimes campy, sometimes serious, the dating simulator subculture has given birth to a number of incredibly popular characters, whose appeal has outgrown the boundaries of their original platforms.

Fan Appropriation

[Carter02] reports on this growing phenomenon: Japanese players appropriate popular characters and storylines from videogames and create doujinshi, books that contain fan fiction, artwork, and similar materials. These doujinshi are then printed in small quantities and traded at fan conventions, by mail, and in specialty shops. In some cases, fans have even created whole new games featuring beloved characters; for example, there is an entire series of fan-produced fighting games starring the cast of a famous dating sim available in the gaming underground.

While legally dubious, the doujinshi movement has pushed the popularity of some game properties far beyond the wildest dreams of their creators, and has created a market for (legitimate) anime, manga, and novels based on them.

The Game Rooms of Korea

The most successful persistent online game of all time isn't EverQuest or Quake III Arena: it is Lineage, a product of Korean developer NCSoft. Lineage was already the most lucrative game of its kind, with over 4 million subscribers, by the time it was first marketed in the United States—a feat that is even more impressive when you realize that the overwhelming majority of its players don't even own home computers.

Indeed, Korean players gather to play online games in "game rooms," where they rent computers and online access by the hour. A given game room can host dozens or hundreds of people at the same time, many of whom never use a computer for any other purpose. Jake Song, one of Lineage's creators, told an amazed audience at the 2002 Game Developer's Conference that the game's extremely simple gameplay was due to the fact that many of its players weren't very comfortable with a mouse, and that his company's customer support had to rely on the telephone because the players did not know how to send e-mail to ask for help!

Online games are so popular in Korea that a number of first-rate North American players have moved there to play professionally on a full-time basis—and the best of them can't get out of their homes without being mobbed by autograph chasers.

A Global Community

Finally, game development has truly gone global. Of course, the demographic centers of the industry remain Japan, California, Texas, and Great Britain. However, large and/or highly successful game development communities have coalesced in Korea, Taiwan, British Columbia, Maryland, Germany, France, Québec, Florida, and Australia. Several companies located in Russia, Ukraine, the Czech Republic, and Poland entered the market over the past several years, often as subcontractors, and are becoming major players. And few are the areas of the world where no developers at all can be found.

As a result, the membership of the International Game Developers' Association (IGDA) has been growing by leaps and bounds, and local chapters have been formed in over 20 countries.

Start Sidebar
Emerging Game Development Communities

The game industry is going global, with significant players emerging in countries located far from the centers of the business.

"Game development has been going on in Malaysia for more than 10 years," says Brett Bibby of GameBrains. "We have two large studios, several small startups, some amateur groups, and a few dozen hobbyists. GameBrains has developed Backyard Baseball, The Mummy Returns, Buffy the Vampire Slayer, Madden 2002, and several other games for the Game Boy Advance, and we are currently working on console titles. Phoenix Game Studios is finishing a game based on the Fung Wan franchise for the PC platform."

For his part, Jeferson Valadares, co-founder of Brazil's Jynx Playware, estimates that his country hosts half a dozen professional studios and about 20 teams of semi-pros and amateurs. "Jynx managed to get VC money, and we are now going through the process of publishing a massive online multiplayer soccer management game in several markets, starting with the United States and Japan."

Israel is another small but emerging game development area. "We have several companies, but only a few are mainstream game developers," says Ohad Barzilay, coordinator of the Israeli chapter of the IGDA. "We have more companies working on edutainment and alternative platforms such as cable set-top boxes and mobile phones. And since the individual companies working in the field are mostly unaware of each other, it's still a community discovering itself."

Development companies share some of the same problems, no matter where they are located: lack of funding, a rarity of seasoned professionals, and so forth. "Local CEO's told me that the banks, venture capitalists, and other financial organization don't take game development seriously at all," comments Ohad Barzilay, "so they refuse to support companies. Distance from the large markets (U.S./Europe) is also a problem; outside of the big events like E3, most companies cannot 'mingle' with experienced studios without high expenses, and most prefer to save that money."

However, some countries and regions have found innovative ways to help their developers thrive. Malaysia's Multimedia University and the Universidade Federal de Pernambuco in Brazil have created undergraduate and graduate courses in game development. Technology-oriented companies located in a specific area near Kuala Lumpur can apply for a special status that allows them to be exempted from taxes for up to 10 years, relaxes restrictions on foreign ownership, and eases the obtention of work visas for foreign knowledge workers. A similar program, the Cité du Multimédia, has been implemented in Montreal, Canada. The Brazilian cities of Recife and Curitibe also offer tax incentives that game developers can benefit from, and the national government's cultural incentive laws allow interactive entertainment companies to apply for subsidies. "But it's tricky and no one has accomplished it yet," says Jeferson Valadares. And sometimes, going far away has its advantages. "Malaysia has a very active and supportive investment willing to work with game companies," says Brett Bibby. "This helps overcome the experience problem because there are funds available for training. Besides, Malaysia rocks! The cost of living is low, the country is near the equator so the weather is tropical year-round, it has many resorts and beaches nearby, it is extremely modern, has excellent healthcare and education, and the people are very nice."

End Sidebar


The Major Issues Facing the Industry

It is no secret that the game industry has bad press. Interactive entertainment has been blamed for everything, including school violence, exploitation of women, teenage obesity, dysfunctional development of children's social skills, degradation of society's moral fiber, and even [Gamasutra02.2] permanent damage to the areas of the brain controlling creativity and emotion.

Some of the issues facing our community, however, are more serious than others.

Violence

Violent games and their supposed impact on the mental health of children have been a major political issue for over a decade. Commentators, both on the right and on the left, have blamed games for driving the Columbine murderers and the perpetrators of other school shootings to action. Grant Theft Auto's content, especially the part where the player can hire, rob, and kill a prostitute, has been the stuff of headlines all over the world. In addition, in the days following the Washington D.C. sniper shootings of October 2002, [Levine02] stated that the suspected killers were avid chess players, as if a love of the noble game were somehow relevant to the affair.

There is no doubt that a sizable share of the industry's production is made up of violent games. Among the reasons explaining this phenomenon is the fact that violence is much easier to implement into artificial intelligence characters than other human behaviors and emotions, like compassion and self-sacrifice. And some of these games' content is, indeed, very edgy. However, like the 1980's hysteria over so-called "satanic messages" heard when playing music records backward, this one fails in two crucial areas:

  • Anyone who could be "driven to murder by a game" (or a movie, for that matter) could just as easily be influenced by acquaintances, by the phases of the moon, or by "voices" emanating from a toaster.

  • Homicidal impulses would be much harder to act on if weapons were harder to come by and, in the case of children, if parents paid enough attention to notice the early signs of mental instability.

While covering an ever-wider variety of themes in our games would be healthy for many reasons, censorship of violent games is not a solution to the ills of society, and we must not tolerate it. It was not so long ago that Senator Joe Liebermann, the perennial critic of our industry who came within a hair's breadth of becoming vice president of the United States in 2000, sponsored a proposed constitutional amendment banning violent games so that children would be protected from Mortal Kombat and similar material. We must remain vigilant.

Start Sidebar
Freedom of Expression

Jason Della Rocca, program director for the International Game Developers Association, comments on the issues of violent games and freedom of expression:

"Public concern over violence in games, the addictiveness of games, and sexual stereotyping are just a few of the ongoing issues affecting the game industry and its perception in the media. And, with some courts stating that games are a medium incapable of expressing ideas, it is tough not to become overwhelmed by the battering of our creative endeavors.

"The various ratings systems around the world, and their associated marketing guidelines, have been a significant initiative in dealing with these negative perceptions. Yet, what is the true impact—creatively and financially—of a game's rating? What influences does the looming threat of government regulations have? How does all this play into the retail side, which seemingly wields the most power to censor content?

"Simply put, many developers do not take into account the full ramifications that game ratings, the threat of government regulation, and retail sensitivities have on the ultimate success (or failure) of their game. It is not uncommon for large retailers to reject your game because of questionable content—never mind an entire country banning it, which has happened in Australia and Germany, for example.

"Yes, but what about our creative freedom? True, this is a nascent art form, but we still have to sell our games. While we are pushing boundaries on many fronts, it is still important that we play by the rules. The last thing we need is for our games to be sold from the back room wrapped in brown paper . . ."

Links to help you stay in the loop:

  • www.igda.org

  • www.idsa.com

  • www.esrb.org

End Sidebar

Hate Games

While playing the role of a drug dealer bent on revenge, as in Grand Theft Auto: Vice City, is bound to raise some controversy, there is much worse out there. Religious fundamentalists and racist fringe groups have taken to using games as vehicles for their repulsive political statements—and even as recruitment tools. [Blenkinsop02] reports that, among the hate games available for download on the Internet, are titles in which the player:

  • Takes on the role of a suicide bomber trying to kill as many innocent civilians as possible

  • Manages a concentration camp

  • Scores points as a member of the Klu Klux Klan or of a skinhead gang by shooting at members of racial minorities

While the industry can do little to prevent this sort of thing, we can at least make sure to distance ourselves from the products produced by these people. Again, this does not mean that we should apply preemptive censorship where it isn't warranted: even if using a career criminal as a player character will not appeal to everyone, it is a legitimate design choice, and one that is crucial to the consistency of a game such as GTA or Kingpin. However, when game developers and publishers choose shock value for shock value's sake—for example, by advertising on tombstones or putting naked characters in an extreme sports game whose core audience is 10 to 12 years old—it smears us all with an aura of sleaze and, well, stupidity. It might even lend these hate games a modicum of legitimacy, because in the eye of the general public, they will not seem so different from what the official game industry does.

Piracy

Hackers and other software pirates are costing us a huge share of the income that is rightfully ours. The Interactive Digital Software Association, which regroups the world's major publishers and organizes the Electronic Entertainment Expo, estimates that worldwide piracy has cost the U.S. game industry alone over $3 billion in 2001 [IDSA02].

Pirates always come up with new types of fallacies to justify their actions: games cost too much, all of the money goes to greedy publishers instead of developers anyway, and so forth. The bottom line is that the game developers are always the ones who end up paying for piracy. Publishers have to account for probable losses by paying lower advances and royalties. Independent developers selling their games online lose sales to warez sites and have to waste time that would be better spent making new games on anti-hacking routines. Therefore, we make less money for our work. We don't have any sympathy for robbers who break into our homes, and we shouldn't have any for those who break into our computers.


Conclusion

The game industry is a fascinating, exhausting, fun, stimulating, stressful, blissful, and sometimes cruel place to be. However, above all, it is a business, and its economics have a significant impact on the way we live and work. We hope that this book will help shed some light on the way the industry works, and give you one more tool on the way to success.


References

[Blenkinsop02] Blenkinsop, P., "Hate Games Spread on Web, Group Says," Reuters, July 8, 2002.

[Carter02] Carter, B., "Character Interaction Outside the Game World," Game Design Perspectives, Charles River Media, 2002.

[Charne02] Charne, J., "Toward an Alternative to the Advances, Recoupment, and Royalty Model for Developers," available online at www.igda.org/Endeavors/Articles/jcharne_royalties.htm, August 2002.

[DiCarlo02] DiCarlo, L., "Good Times Continue for Gamers," Forbes.com, June 14, 2002.

[Gamasutra02] Gamasutra news report, July 2, 2002.

[Gamasutra02.2] Gamasutra news report, July 9, 2002.

[Gardner02] Gardner, D., "Why videogames are proving to be hard work for developers," Sunday Herald, available online at www.sundayherald.com/28515, October 2002.

[IDSA02] Interactive Digital Software Association anti-piracy program; outline available online at www.idsa.com/piracy.html.

[Levine02] Levine, D., "Muhammad et Malvo aimaient jouer aux échecs," La Presse, October 26, 2002.

[Reuters02] Reuters, "Video Games Sales to Top $31 Billion in 2002—Study," June 24, 2002.

[Takahashi02] Takahashi, D., "The games industry still has much to prove," Red Herring, May 29, 2002.


Section 1: Publishers and Developers

Chapter List

Chapter 1.0: Introduction
Chapter 1.1: The Top Ten Misconceptions New Game Developers Have About Publishers
Chapter 1.2: The Role of Each Entity in Game Publishing
Chapter 1.3: How Developers Get Paid: The Retail Market for Games
Chapter 1.4: A Publishing Project: From Concept to Launch and Beyond
Chapter 1.5: The Producer, Friend or Foe?
Chapter 1.6: The European Challenge in Videogame Software: The "French Touch" and the "Britsoft Paradox"


Chapter 1.0: Introduction

Game publishing is an enormous business. North American game sales, which have outpaced the motion picture box office for several years, are expected to top $10 billion per year by the time this book goes to print. In fact, games are just about the only high-technology industry that not only survived the stock market debacle of 2001 to 2002 unscathed, but actually experienced sustained growth in the process.

While the game industry is much larger and far more diverse than the consumer magazines would lead us to believe—in the past two years alone, this author has worked on board games, webisodics, comedy broadcast on cell phones, crossover projects involving multi-billion dollar corporations from other fields, and even interactive edutainment for museums—its canonical business model remains the developer-publisher-retailer continuum. This first section of the book explores the inner workings of each of its components and discusses such issues as the consequences of the ever-increasing cost of game development; concentration of the publishing world as a result of the high risks of game marketing; how developers can make the most of their relationships with publishers; the power wielded by retailers; who makes money from games, how, and when; and how a publishing company takes a game to market.

The articles in this section explore these issues from the (at times contradictory) points of view of developers and publishers:

  • Mason McCuskey, president of independent development company Spin Studios, explains the mistaken assumptions that mine the relationships between some developers and their publishers.

  • Kathy Schoback, director of developer relations at Sega of America, discusses the roles of all of the entities involved in game publishing, including little-known contributors such as testing studios and regional distributors.

  • In a pair of articles, François Dominic Laramée, freelance game development consultant, discusses the inner workings of the retail market for games, how successful developers can earn profits in this environment, and how publishers bring games to market.

  • Senior producer Mitzi McGilvray explains how developers can establish harmonious relationships with the producers assigned to their projects by the publisher.

  • And finally, Philippe Larrue, Mary O'Sullivan, and William Lazonick, a team of researchers at INSEAD, Europe's premier graduate business school, explore the winning strategies of some of the world's most successful publishers.


Chapter 1.1: The Top Ten Misconceptions New Game Developers Have About Publishers

Overview

Mason McCuskey

<mason@spin-studios.com>

For most game developers, the most difficult problem isn't 3D math or complicated AI systems. In fact, it isn't even how to make a game, but rather how to get that game out to the gamers. To many aspiring game developers, the definition of success is getting one of their games on the shelf at a major retailer—it brings profit, as well as the prestige of being able to walk in to a retailer anywhere in the country and show your creation to the masses.

Unfortunately, the path toward that goal is shrouded in mystery. Publishers seem to be magical beasts, capable of granting wishes or destroying fortunes, often for no better reason than their own whims or desires. Some games they publish, other games they don't, and most developers don't know why one game, seemingly inferior to another, gets a spot on the shelf at the local videogame store.

This article attempts to shed some light on that, by enumerating the top 10 misconceptions of new game development teams regarding publishers. We'll spare you the suspense and start with the most prominent misconception, then progress downward to number 10, showing you at each stage what the misconception is and why it's detrimental, as well as some things you can do to increase the chances of landing a publishing deal.


#1: You Can Get a Publishing Deal on a Design Doc Alone

This is easily the most common misconception of all. Most amateur developers elaborate master plans that go something like this:

  1. Create a 400-page design document outlining the entire game in excruciating detail.

  2. Send this tome to a publisher, who will carefully read it and realize the greatness contained within.

  3. Achieve fame and retire on the royalty checks the publisher sends you.

Unfortunately, that's not how it usually works. If you're Sid Meier, Will Wright, or Bruce Shelley, you might have a chance of getting a game funded this way, but otherwise, this method is not going to work.

Obviously, to land a publishing contract you're going to need a good design. However, the general rule of thumb is that once you have that design, you have about 10% of what you need to approach a publisher. The other 90% includes the following:

  • A solid playable demo.

  • A good team with strong skills and a proven track record.

  • A whole slew of other budgeting, marketing, treatment, and scheduling documents. ([Powell02] and [Bartlett03] describe the contents of the submission package—and how to approach publishers once you have assembled one—in some detail.)

So, how big should your design doc be? You should strive to create enough documentation to adequately describe your game, but no more. Einstein once said, "Things should be made as simple as possible, but no simpler." Take this advice to heart when writing your design doc. If you're developing a highly complex war game, you might need a few hundred pages explaining how the simulation works. If you're designing a simple puzzle game, you might be able to get by with a dozen pages, maybe less.

In fact, disregard the page count entirely. Have your design doc address all of the major variables in your game: enemies, levels, player actions, back story, and so forth. You need to think about all of these matters, and more. If it turns out that you can adequately describe a topic in half a page of bullet points, then keep those bullet points and move on. If it turns out that you need dozens of pages, then you need dozens of pages.

An important point: write your design doc with your development team as your audience, not the publisher. The primary purpose of a design doc is to explain your game to the people who will be developing it. Rely on other documents (such as treatments or key feature lists) to convey your game to potential publishers.


#2: Publishers Are Your Biggest Fans

This misconception probably accounts for more broken development deals than any other. Realize that publishers are not game players. Specifically, this means that:

  • Not all publishers like playing games.

  • Not all publishers know gamer lingo.

  • Not all publishers know how your real-time strategy game is different from its competitors.

  • Not all publishers have your interests at heart.

Publishers Are Not Game Players

Sure, most publishers have game players working for them, but just because they publish games doesn't mean that everyone there loves videogames. And even the people there who do like to play games won't want to (or won't have the time to) play through yours entirely, getting stuck on the hard puzzles and trying for days to beat the tough bosses.

This means that any demo you send to a publisher should also contain walk-through documentation, and preferably a way to quickly jump to the game's most exciting parts. A guided tour is also a good idea, as is anything that will let the publisher see why they would want to publish your game, without having to actually play it. You want to make it very easy for them to see why your game is better than the other submissions they have received—you need to hook them as quickly as possible.

Don't Assume that Publishers Know the Lingo

They know some of it—for example, genres—but they don't usually know the meaning of words such as llama or camper or LPB. In addition, even if you're pretty sure they do understand these terms, you should leave them out of your documentation, because they're a form of slang and make you appear unprofessional.

Publishers Don't Know What Makes Your Game Unique

Taking this to heart is essential to developing the proper demo and pitch. Although it might appear on the surface that publishers are only interested in me-too titles, underneath, most publishers want something that's new—just not too new. By explicitly presenting what makes your title unique, you do yourself a big favor.

Publishers Pursue Their Own Interests

Finally, realize that publishers do not always have your own financial, creative, or artistic interests at heart. Both parties are in it to make as much money as possible, which naturally puts them at odds with each other. For example, what you see as an awesome design idea, the publisher might see as a financial risk, while the licensed property the publisher wants you to use in the game to drive its sales might seem unnecessarily stifling to you. Contract negotiations are a difficult and sometimes distressing process for this reason.

You can spend all day debating whether this is good, but at the end of the day, it is reality. Just remember this fact, and you'll go a long way toward establishing empathy toward your publisher. Knowing what the other side is after is often your most valuable tool when negotiating.


#3: The Game Stands On Its Own

Another thing some aspiring developers assume is that quality is everything: the game stands alone, the good games will naturally get publishing deals, and it doesn't matter who you are, just as long as your game is "cool enough."

This is referred to as the inventor mindset. Inventors live and die by the strength of their ideas, and they tend to think (incorrectly) that the rest of the world does too. We game developers, being inventors of a sort, also live in the idea plane, so even though we routinely see horrible excuses for interactive entertainment littering the shelves, we have a habit of thinking that the strength of our games will single-handedly carry us to greatness.

The reality is that having a strong game idea and a strong demo still isn't enough. Even if your game is almost entirely finished, potential publishers will still look at the people behind the game, and they'll still rely on demographic and marketing data to determine if a game gets the green light. And there's a whole bunch of other variables in the equation too, including how well you pitch your game, how good your company's financial picture is, how responsive you are to change, how well you connect with people, and even how prompt you are about returning telephone calls.

One big variable developers forget to account for is the track record of the team making a game. Publishers look at this very carefully—they want to know for certain that the team is going to be able to deliver the final product, on time and on budget.

On a related note, publishers also look at how mature the team itself is. Even if your team consists of proven professionals, if this is their first game together, a publisher will be a little concerned. It takes a professional development team some time to find a groove, and there's no guarantee that even an all-star team will be able to click and deliver a solid product right away. Of course, every team will have new members—but to have the best chances of getting a publishing deal, the core of the team will need to have a few successes under their collective belt.

So, what do you do if this doesn't describe your company? The best thing you can do to help yourself is get the game as close to done as you can. If your game is at beta and looking solid, publishers are going to be less concerned about your team's dynamics. Not completely unconcerned, but less concerned.


#4: Any Deal Is a Good Deal

Getting a publishing deal is a great reason to throw a party, especially if it's the first for your new game development shop. However, your goals extend much farther than that important milestone. Ultimately, you must be concerned with distribution (e.g., how many stores your game gets into), the advance money you will receive to pay for development, the royalty you will get for each copy sold, and how the relationship with this publisher works after the game is released. All of these things are important—they play a part in determining whether you'll still be in business long enough to finish your title and see it succeed.

It's hard to get a publishing deal. It's even harder to get one you can live with. Be careful about selling yourself short, about capitulating to any terms for the sake of getting a deal. Sometimes, no deal is better than a bad deal.

Think long and hard about the terms you need in a deal in order to survive. For example, it hurts you (and it hurts the publisher) to sign a deal with an advance so low that you go bankrupt before you complete the game. You can also doom yourself by setting your schedule too short, your scope too large, or by giving the publisher too much control over your company's future. You need to recognize your goals and your situation and bring those to the negotiating table to craft out a contract that won't kill you.

A basic negotiating skill is to identify your BATNA: Best Alternative To Negotiated Agreement. In other words, it's the alternative you have if you can't come to an agreement during the negotiation. For example, depending on your situation and how many publishers you've talked to, your BATNA might be to self-publish your game, or to go with another publisher's less-appealing (but still profitable) terms.

You should also know at what point a publisher's terms become worse than your BATNA. This is the point at which you abandon negotiations—you thank the publisher for their time, get up, and leave the room.

If you don't know your BATNA before you enter negotiations, you might very well come out of negotiations with a contract that's so horrible that it's worse than having no contract at all. Be careful.


#5: Publishers Negotiate through E-Mail

We "nerds" rely on e-mail much more than "normal" people do. We type at each other in IRC, we debate on ICQ, and sometimes we e-mail each other when we're within speaking distance. This works fine for us, but it's often detrimental when it comes to talking to, and especially negotiating with, a publisher.

The simple rule is, "never negotiate through e-mail." Pick up the telephone or arrange to speak face to face. E-mail is an impersonal way of communicating, good for conveying technical facts but embarrassingly bad for conveying the nuances of personality. When negotiating, these nuances matter as much as (and possibly more than) the words being spoken.

When you communicate with a publisher, use your voice as your primary communication device, backed up by e-mail. However, do not assume that publishers always return telephone calls. Most of the time they do, but everyone gets busy, forgets, or accidentally deletes someone's contact information, so err on the side of safety and don't be afraid to pick up the telephone just to ask "how's it going?"

Don't overdo it, however. Use good judgment, as if you were looking for a job. When in doubt, just ask the persons on the other end of the line when you should contact them next, and then don't call them back until then.


#6: Your Publisher Will Create a Schedule for Your Game

This one is partly true—usually, once you and your publisher agree to work together, you'll negotiate the dates of the milestones and what will be expected at each. However, this doesn't mean that you shouldn't develop a schedule on your own. If you approach a publisher without a definite finish date (backed up by a comprehensive project plan), you'll either look like someone who doesn't know what he's doing, or someone way too egotistical to be bothered with things such as due dates. Either way, it's a strike against you.

Of course, this shouldn't be the main reason why you write up a schedule. Like design docs, schedules are just as beneficial for you as they are for your publisher. Take the time to draft a schedule, and review it periodically to make sure it's accurate and that you're on track.

This is a big enough job that most game companies now have full-time producers and/or project managers, responsible for wrangling the dependencies of a project and making sure that everyone is working on the right thing at the right time.


#7: Make a Good Pitch to the Right Person and You're Good to Go

Most publishers have teams or bureaus of people who evaluate incoming submissions and decide which ones to publish. You might be able to isolate and pitch your game to one of these team members, but you usually won't be able to pitch to all of them at once. So, even though your initial pitch to a publisher is important, it's not the only thing that matters.

When you pitch to a publisher, you should play your best cards, but you should also be truthful. Pitching the features that set your game apart from the competition is a smart move; saying you're in beta when you're not is asking for trouble.

Your pitch should be supported by paper materials that reiterate what you've just talked about. Your materials should project the best (accurate) image of your company and your product, as concisely as possible. Be professional—don't hard sell, and don't get too technical. Whet their appetite, show them the greatness of your ideas, and make sure they know whom to contact if they'd like to know more. Don't just give a <sales@somewhere.com> e-mail address—give complete contact information for a specific individual.


#8: All Publishers Are the Same

You owe it to yourself to pitch your game to as many different publishers as possible. However, you should also realize that all publishers are not the same. Some work with definite genres, platforms, or budgets, while others seem to be scattered all over the shelves.

Before you approach a publisher, make sure that your title would fit with their repertoire. Research titles they've already published, and ask them where they'd like to concentrate their efforts in the future.

In addition, play some of their games. This not only gives you a clever excuse to play more games, but also could give you a good sense of whether the publisher is right for you. Also, even though this should go without saying, buy the games or have the publisher give you some evaluation copies.


#9: Platform Doesn't Matter

Another facet of the "not all publishers are the same" misconception is the sister misconception that the platform you develop your game on doesn't matter. This is incorrect—don't develop your game for the easiest platform (the PC) thinking that you'll get a publishing deal and port it later. A much better approach is to choose the prominent platform for your particular genre (e.g., PC for real-time strategy, PS2 for sports), develop for that platform, and be ready to port to the other platforms if you and your publisher decide that it would be worth your time.

Sometimes this is easier said than done; some console manufacturers require large amounts of cash, an approval process, or even a signed deal with a prominent publisher before they'll give you access to the development kits. Try very hard to get a development kit, but don't give up if you can't. Just make sure the publisher knows that the demo they're seeing isn't running on the proper hardware, and that they know why.


#10: Publishers Are the Enemy

This last item is key. After the last nine misconceptions, you might find yourself thinking that a publisher is an enemy, an evil entity one must deal with in order to accomplish a greater good. It can't be stressed enough that this is not the case. Virtually all publishers are moral, ethical entities comprised of people trying to earn an honest living by providing entertainment to large audiences. You and the publisher might have different priorities and different approaches, but ultimately you are working toward the same end—you both want to release a good game.

Don't forget that a developer/publisher relationship is a win/win situation—the end result benefits both parties. Both you and the publisher make money when things go well, and lose money when they don't, so remember that publishers are your allies, not your enemies. With the right publisher, a developer can go farther than other developers, and with the right developer, a publisher can go farther than other publishers. Approach publishers in the spirit of cooperation and respect, and if everything works, you'll end up with a game on the shelves.


Conclusion

One could fill an entire book on the topic of how to get a publishing deal. This article has given you a start; you now know the 10 misconceptions that can sabotage your own efforts. However, you are far from knowing everything you need to secure a successful deal.

If you are seriously pursuing a deal, you need to do much more research. You also need to find a good lawyer, someone you trust who can look over contracts and show you where the gaping holes are. You might think that you can identify these holes on your own, but you can't—get a lawyer.

In addition, talk with other developers who have been there. All of them have opinions and things they wish they had done, or hadn't done. Find a developer with a situation similar to your own and talk to the deal-maker for that company—learning from the experience of others is always a good idea.

Also, keep up with the times. The game industry changes very quickly, and people have been predicting the death of retail for a long time. Again, it all goes back to your own situation. Make sure you're doing things not because of some superficial reason ("I want to walk into the store and show my mom/spouse/arch-nemesis my game sitting there on the shelf!"), but because it's really the best move.

Finally, don't stop trying. The road to the store shelf is long, but many companies have walked it, and some have achieved tremendous success. You might be next. Good luck!


References

[Bartlett03] Bartlett, E., "How to Secure a Development Contract," Secrets of the Game Business, Charles River Media, 2003.

[Powell02] Powell, J., "Showing Publishers What They Want to See," Game Design Perspectives, Charles River Media, 2002.


Chapter 1.2: The Role of Each Entity in Game Publishing

Overview

Kathy Schoback, director of external development and publishing, Sega of America

<kathy.schoback@segaamerica.com>

Delivering a game into a consumer's hands has become an increasingly complex, lengthy, and costly process. Members of the interactive entertainment industry constantly debate the relative importance of game developers as creative auteurs versus publishers as soulless businesspeople, or retailers as channel arbiters versus media as opinion mongers. However, financial and logistical market forces have created a system in which each "driver" entity on the highway to the consumer—developer, publisher, platform owner, retailer—is essential to the transaction, and profits accordingly. "Adjunct" entities that feed into the channel offer a plethora of service alternatives that reduce cost, save time, or improve quality along the channel and, ultimately, for consumers.

In this article, we examine the roles of 14 entities that collaborate to bring a game to market.


Game Developers

Without game developers, entertainment would no doubt be a duller and more complacent activity. Whether independent companies of 15 to 200 people or subsidiaries of larger publishers, developers create the immersive experiences that inspire millions to forego reality for fantasy. Game development involves the very technical disciplines of programming, including code optimization for target hardware, physics and artificial intelligence simulations, camera and interface development, and creation of tools to improve development efficiency. The art of game development lies with designers who envision everything from game balance to placement of doors in a level, artists who realize previously unimagined characters and worlds with an eye toward technical efficiency, and animators who marry a character's appearance and personality through motion. Producers keep the train on the track, identifying roadblocks before (or as) they occur and negotiating solutions among all stakeholders (Figure 1.2.1).

Click To expand
Figure 1.2.1: Position of each entity in the product path for a console game.

Full-Service Game Developers

Game developers in this category incorporate all the disciplines necessary to create millions of lines of game code from a single idea. Projects range from six-month, tightly focused opportunistic releases to three years of complex asset integration into a whole that is vast in scope. More than one recent project has exceeded five years and US $50 million to complete, although the cost for a current-generation console release on a single platform now ranges 12 to 24 months and US $2 to $5 million.

The proverbial brainstorm-turned-million-seller is rarer than industry aspirants care to believe. Of games actually published, the majority are based on intellectual property owned or controlled by the publisher, initiated by the publisher with a team whose qualifications (not the least of which is cost) complement that IP. Publishers can initiate "surefire" projects based on a blockbuster movie or book license, or "questionable" pet projects of a particular executive. Larger publishers can mine the seam of past releases for remakes, due to the hotly debated publisher practice of acquiring intellectual property rights to a promising developer's original game idea. Two truisms unite all these methods: a "no-brainer" concept does not guarantee a great game, and an offbeat idea, regardless of the source, sometimes sells spectacularly.

Developers interact primarily with their publisher and, on occasion, with the platform provider, who provides them with direct technical assistance for the target platform. When called upon by the publisher, developers also grant interviews and preview their progress to the media.

Independent development companies work with publishers on a contract basis. The publisher pays the developer "advances" against a schedule of development milestones. Frequently, the publisher also grants a royalty per unit sold to the developer; however, the royalty is only paid once the publisher's advance payments have been recouped against sales volume. In one recent example, a developer was granted $4/unit royalty, but recoupment against significant development advances ensured the developer would only receive royalties after the 900,000th unit sold. Scenarios like this feed ongoing industry debates about more equitable revenue-sharing for developers. Many developers have quietly resorted to building their target profit margin into their proposed advance payment schedule.

Development groups also exist as wholly or partially owned subsidiaries of publishers. As employees of either the parent company or the subsidiary, internal team members draw corporate salary and benefits. Stock options, bonuses for achieving sales targets, and profit-sharing programs vary widely by publisher; the development community generally acknowledges that the relative stability of working for a major publisher goes hand in hand with a smaller piece of the profit pie on momentous successes.

Other funding alternatives such as venture capital, completion bond funding, and angel financing play a small but growing part in game development, and are addressed elsewhere in this book.

Historically, many development groups have gotten their technological start creating PC games. Wide availability of technical information and a small but active engineering community supported many of today's marquee developers as they created early hits such as Doom. Today, developers such as Bioware, id Software, Valve, and 3D Realms include user-creation modules in their games, with which their player communities can modify parts of their games. Many entry-level designers or programmers in the industry today earned their position through a compelling "mod" presented as part of their portfolio.

Development for today's consoles—Sony's PlayStation 2 computer entertainment system, the Nintendo Gamecube, and the Xbox videogame system from Microsoft— is harder to break into. The expense of proprietary development kits—up to US $10,000—and the requirement of a preexisting relationship with a publisher closes the door to all but the most innately talented startup groups. Consequently, many developers earn their credentials in PC gaming, and then make the leap to console on the strength of proven technology, design, and relationships.

Motion-Capture Service Providers

As hardware platforms follow Moore's law of increasing computing power, consumers and publishers have demanded increasing realism in certain types of games. In particular, developers can now replicate the uniquely identifiable characteristics of human motion with great accuracy for the first time in gaming. Mechanical leg movements on a football player gliding as if on ice have been replaced by true running steps with the inherent force, momentum, and style of the original player. To be sure, we cannot ignore the stunning contributions of painstaking manual animation to this advancement. However, for the speed and efficiency of achieving realism in human movement, we have motion-capture technology to thank.

Motion capture is the technological process by which scripted movements of human actors are "captured" by magnetic or optical sensors, yielding data which is then inserted into the game engine. "Mocap" is usually used when lifelike human movement is essential to the game concept. For example, a perfectly replicated signature move in a football videogame is a selling point to consumers playing as their favorite wide receiver, while a cartoon character might benefit from manual exaggeration of certain animations to emphasize its unreality. A mocap session is similar to a movie shoot, usually involving a director, a script or "moves list," an engineer manipulating the software that processes captured data, and actor(s) selected for their ability to repeat the desired action sequence accurately. Once the session is complete, the animation team works through the raw data, tweaking an elbow position or sword arc until the model behaves exactly as desired in-game.

Developers access motion-capture facilities in two ways: the publisher makes its onsite studio available, with costs allocated internally to the project, or the publisher directly subcontracts an external mocap service provider. Only rarely does a developer possess its own mocap studio, as costs involve much more than purchasing the hardware. As with any marriage of the subjective with technology, mocap works best with trained specialists at every level. Publishers with key franchises requiring mocap (such as football games) can recoup on the investment and training for an in-house studio; for most others, mocap is contracted out at costs exceeding US $150,000 for a full-service session.

As demand has increased for motion-capture services, the competition among independent mocap studios has led to price pressure. Some leading providers have honed their service-side offering as a result, providing not only shoot management but also data processing, animation tuning, assistance with engine integration, and post-shoot troubleshooting. One provider has productized their data processing software, offering it for license independently of its services. All providers continue to refine the accessibility of data throughout their processes, so developers can benefit from the efficiency of mocap without sacrificing the artistry of keyframed animation.

Art and Animation Service Providers

The increase in computer processing capability in game hardware has provoked an exponential increase in the quantity of art assets required. Onscreen processing limits of several characters comprising a few hundred textured polygons have exploded to millions of polygons making up a main character, several AI characters, a 3D deformable environment with actionable objects, extensive special effects, and realistic environmental lighting. The resulting productivity demands sometimes require outsourcing of the art production process.

Generally, the publisher and developer agree upon the outsourcing of art at contract. A full-service developer might bring an art group to the table based on a previous working relationship, or a publisher might specify a group on its vendor list. In either case, the cost of outsourcing is factored into the project cost and paid during the advance period. Developers generally list contracted art as a separate line item in their proposal.

Art production is one way for fledgling developers to build their reputation on a console platform, particularly if the group's members have a PC background. The developer not only gains access to the proprietary development systems, but also learns the constraints of art production for the target platform and game engine— from simpler matters such as per-character polygon count to the currently bedeviling issue of limited texture memory. Art production teams who master these issues, build impeccable working relationships with their partner publishers, and carefully hire top-flight programmers have the best chance at breaking through to full-service independent development.

The cost of art production varies wildly with desired quality level, quantity of assets requested, duration of project, and extent of process/logistical integration with the full-service development team. In addition, art production houses run the gamut from long-established, full-time art houses charging top dollar for experience, to startup groups looking to break in at any price. Billing can be per man-month, per minute of cutscene animation, or flat-fee, and can occasionally include royalties if the artwork is integral to the project's brand identity. For the pressured development team who receives a perfectly executed art asset delivery in time to hit a key milestone, and for the publisher whose high expectations for graphic quality were met in that milestone, every dollar is worth it.


Publishers

If developers are the artistic brain behind videogames, publishers are the muscle and nerve that coordinate all aspects of bringing a game to a consumer. The publisher's role is so extensive and influential that publishers have taken on the aura of medieval fiefdoms, where money flows in mysterious directions and decisions are cloaked in secrecy. Acting as the "suits" to developer "geeks," publishers make up the second half of the classic "art versus commerce" conflict that inspires hyperbolic excesses on game industry message boards. If we step back from the rhetoric, we see wide variation within the category: global conglomerates with multiple regional divisions covering internal and external development, marketing and sales, quality assurance, finance and licensing for any viable delivery platform; smaller companies specializing in marketing and sales of certain genres for certain territories; groups specializing in specific platforms such as PC or mobile phones; entities focusing on discovering gems in one territory for distribution in another; and Web sites offering pay-per-pay downloads. To choose the best partner, developers must extensively research prospective publishers' strategic priorities, business model, and execution strengths and weaknesses— much of which can be inferred from publicly available information. Mismatched expectations on any of these fronts can doom the best-executed game to the bargain bin before its time.

Console and PC Publishers

For brevity, and because the vast majority of packaged games wind up in consumers' hands through this model, we will focus on "traditional" console/PC publishers such as Electronic Arts, Activision, THQ, Infogrames, and Sega. We examine the role of publishers who also control a hardware platform (such as Sony or Nintendo) in a later section. Finally, since we reviewed game development previously, for this overview we will set aside that function of a publisher's role.

Traditional publishers sit in the conceptual center of the videogame industry, primarily because they bear the executional and financial burden of every process between code creation and game purchase. Responsibilities and accountabilities include:

  • Management of the game development process. Publishers are involved in everything from time-to-market scheduling to creative input. The foundation of a publisher's relationship with retail partners is a good product shipped on time in the right quantities.

  • Debugging, playtesting, and other quality assurance. Publishers are legally liable for the game's quality to both consumers and the platform holder.

  • Securing all necessary licenses. These include in-game music; creative properties, trademarks or technologies controlled by other companies; athletic leagues and players; and the right to publish on controlled platforms (consoles). Experienced developers obtain an indemnity from the publisher against any licensing omissions the publisher might make.

  • Manufacturing and shipping the finished game. This responsibility includes writing and printing the manual, designing the cover, buying the case, placing orders with media manufacturers, assembling all the elements into a game package, and shipping it to the channel. Aside from the QA implications of an unstable assembly process, lackluster packaging encourages consumers to look elsewhere on the store shelf.

  • Maintaining good relationships with retailers via cooperative channel inventory management. More than just the "schmooze" of golf and expensive dinners, publishers' sales efforts must include in-store merchandising programs, funding for product placement in retail circulars ("white space"), joint assessment of a title's sales potential, and markdowns or returns at publisher cost if the title does not perform as expected.

  • Communicating title features and availability to the consumer. Whether via "meta-channels" such as press events for game industry media, or direct communication with gamers via television, print, demo opportunities, Web site, or internet/direct mail, publishers are responsible for letting the public know what's out there.

  • Housekeeping. This responsibility includes all the human resource, tax and finance, investor relations, and legal services issues involved in running the company.

Industry voices frequently criticize publishers for "unfairly" sharing revenue with their developer, without whose creativity there would be nothing to sell. Since revenue sharing is established at contract, a knowledgeable and firm negotiating stance goes far in ensuring fairness for the developer; the many factors that can strengthen a developer's negotiating position are covered elsewhere in this book. In pure financial terms, however, the market law of risk versus reward explains why publishers keep the lions' share of revenue, if not of profit. Table 1.2.1 answers the gamer's frequent question: "Where does my $50 go?"

Table 1.2.1: Generalized Breakdown of Revenue from a $50 Console Game
Amount | Purpose | Paid By | Paid To
$3 | Cost of goods | Publisher | Media manufacturer
$7 | Publishing license royalty | Publisher | Platform holder
$13 | Retailer profit | Consumer | Retailer
$3 | Markdown reserve | Publisher | Retailer
$8 | Development cost | Publisher | Developer
$10 | Operating cost | Publisher | Internal (overhead, freight, co-op, bad debt)
$6 | Marketing | Publisher | Ad agencies and media
Items in bold can be converted to profit through careful publisher cost management.

Quality Assurance Service Provider

Occasionally, a publisher will decide not to maintain quality assurance as an internal core competency. Companies such as Absolute Quality or Beta Breakers provide complete debugging and gameplay evaluation to such publishers on a contract basis. The clear advantage is peace of mind about product quality without the necessity of managing the significant human-resource issues and financial overhead of an in-house test team.

Contracted QA has a long history of success with PC publishers, who bear the unique burden of ensuring that their latest release works within a range of hardware specifications. Depending on the publisher's defined compatibility set, the contract QA house can be asked to test hundreds of variants on PC game software + operating system software + hardware + peripherals, as well as projecting results for configurations not tested. Such companies can recoup the significant investment in equipment representing the current gaming market (the "test bed") over multiple projects.

Console publishers are gradually warming up to the idea of contract testing. One obstacle to date has been the expense and proprietary nature of development and debugging systems for controlled platforms. If the publisher provides such equipment to its external QA partner, the platform holder holds the publisher responsible for proper security and authorized use. Another more emotional than factual objection is the perceived risk of code leaks from sources beyond the publisher's own walls; if a game is to be pirated, better to control the leak internally than pursue legal remedies against a partner. During the most recent console transition, contract QA houses made great strides in accommodating these issues, and have since worked closely with both publishers and platform holders to ensure that the figurative firewall includes rather than excludes their services.

Public-Relations Firms, Advertising Agencies, and Merchandising Teams

Although marketing departments at some publishers look as populated as E3 on opening day, few heads of marketing deny the efficiencies of contracting external firms for public relations, advertising generation, and in-store merchandising assistance. Much more than additional heads and hands, such companies combine effectiveness through relationships, the creativity that comes from time to brainstorm, and a reach that falls just short of handing a game directly to the consumer.

Publishers occasionally learn to their dismay that some brand-name PR firms specializing in national media such as USA Today and Newsweek can fail miserably at communicating their message to videogame industry media such as Electronic Game Monthly and Edge. The best game industry communications managers successfully pitch the latest role-playing game to a sophisticated news outlet while, on the other phone line, explaining this year's business plan to the local game journalist. The publisher gives the PR firm complete access to its game's development, while the PR firm coaches the publisher on speaking skillfully and consistently to all of its constituencies.

Similarly, a lack of alignment between publisher and ad agency on the creative vision for the marketing plan directly impacts sales. Many top-shelf ad agencies approach the videogame industry as a creative soul mate, believing that innovative interactive entertainment requires bleeding-edge advertising. Experienced game industry marketing executives, on the other hand, know that their audience wants to see in-game footage. (Such creative tension results in either a memorable commercial or a new ad agency.) Agency partnerships range from a fully retained relationship covering all software releases, to different agencies retained for distinct product lines, to per-title arrangements.

In-store merchandising assistance is a luxury best afforded by platform holders. With anywhere from 4 to 24 linear feet devoted to its hardware and software in key retailers, for example, Nintendo is legendary for its merchandising team's deep relationships with store managers, enabling them to update signage, straighten displays, restock empty shelf slots, and chat up the electronics section manager on upcoming releases. Publishers whose key releases are integral to a platform holder's lineup can obtain preferential placement and subsequent coddling of their titles by the platform holder's in-store team. Publishers have been known to maintain merchandising teams for shorter or longer periods, but the justification for such cost begins with shelf space; sending staff to straighten up just a few facings is desirable in principle but questionable in financial practice.


Platform Holders

"Platform holders" are companies that manufacture the hardware (and in some cases, the software) that game software runs on. As with publishers, a wide variety of companies comprise game platform holders: cell phone providers, personal digital assistant (PDA) and other handheld device manufacturers, PC makers (both the boxes and the chips inside them), videogame console manufacturers, development software/ tools providers such as Microsoft and Silicon Graphics, and Web-based development and delivery services such as WildTangent. Such companies share the characteristic of owning, controlling, or influencing the software that appears on their platform, whether by providing application programming interfaces (APIs) to help developers access the features of their hardware, or by outright permission-based control of anything that involves the platform. Frequently, platform holders also create software for their own hardware; in this section, we review the platform holder's role exclusive of publishing functions.

Platform holders derive their revenue from any of the following sources:

  • Sales of the hardware itself

  • Sales of (or licensing fees from) any peripherals compatible with the hardware

  • Sales of their own games compatible with the hardware ("first-party games")

  • Licensing fees from compatible games made by other companies ("third-party games")

  • Licensing of development tools or APIs necessary to create games for the hardware

  • Manufacturing proprietary delivery media for the hardware (such as game cartridges)

Consoles and PCs differ fundamentally in that console makers strictly regulate access to their platform via various licensing permissions, while PC makers provide their APIs for free to any interested developer. For this reason, we categorize the PC platform as "open" and consoles as "closed." Handhelds such as PDAs and to a certain extent cell phones follow the "open" PC model, while proprietary handhelds such as Nintendo's Game Boy Advance are just as "closed" as Nintendo's Gamecube.

PCs as a Platform

The "PC platform" is in fact a conglomeration of intersecting partnerships among CPU manufacturers, development software/tools providers, graphics chip manufacturers, and box assemblers. Look in the manual for your new PC and you might see:

  • Intel Pentium primary processor (CPU)

  • NVIDIA GeForce graphics processor

  • Microsoft Direct X application software layer

  • Assembled and sold by Dell

Each of these categories provides support to game developers, mostly for free, with the intent of making money from compatible software or hardware sales.

As the most visible example of successful "ingredient marketing," Intel has spent years courting game developers in order to maintain its image as provider of the fastest CPUs available. It provides sample boards and technical assistance to game developers, and will even work closely with leading game developers on R&D for its future generations of chips. The objective, of course, is for gamers to specify "Intel Inside" when they purchase their next gaming PC.

Graphics chip companies such as NVIDIA and ATI have built a healthy complementary market to CPUs by creating graphics chips customized for multimedia and, of course, games. In addition to the developer benefits already listed, graphics chip companies will secure cutting-edge games under development on an exclusive basis, paying the developer to incorporate the technological bells and whistles that set their chip aside from the rest. Graphics chipmakers also create APIs that allow developers to take advantage of their chip's unique features. Once "hardcore" gamers realize that their longed-after new releases look best when run on a particular graphics chip, they gladly upgrade.

Two well-known technology companies have made names for themselves in the development software/tools space. Microsoft, with its Direct X API, has succeeded over the years in stabilizing the technological risk of game development on PCs, much as it has standardized its operating system for the user. Silicon Graphics has created a less widespread, but popular among game developers, API called OpenGL. Both companies give their APIs away to qualified engineers for free, encouraging information sharing among their developer communities and placing as few limits as possible on use. The advantage for developers is learning a software platform that is invisibly compatible with the multiple hardware combinations available in the market.

PC "box-makers" such as Dell, Gateway, and Compaq play a less active part in promoting game development on their PCs, since the tough work is done by their "ingredient" companies. However, to the extent they target gamers as potential customers, they might secure an exclusive set of games to pre-load on the PC before it's sold to consumers.

One important factor in PC publishing for developers and publishers is the lack of royalty paid to the hardware company for the privilege of platform compatibility. The beneficial effects are lower cost-of-goods and higher profit margins for publishers, and easier access to both development and self-publishing for developers. However, since nearly any competent and inspired PC development group can complete and ship a PC game at relatively low cost, many groups do so. The resulting competition among thousands of titles for shelf space at retail has created a cutthroat sales culture for PC games, where retailers return units unsold after eight weeks to publishers, and only the top 30 games sell more than 300,000 units.

Consoles as a Platform

In direct contrast to the open and loosely affiliated PC game development scenario, development for game consoles such as Sony's PlayStation 2, Nintendo's Gamecube, and Microsoft's Xbox is tightly controlled at all levels by the respective companies. To create and sell games on these platforms, a developer/publisher requires the following licenses and permissions:

  • License to use development software and hardware. Only provided after the console platform holder's favorable evaluation of the applicant's potential for bringing quality games to market. For developers, a publisher's recommendation carries great weight in obtaining development systems.

  • License to conduct general marketing and sales activities. Again, granted only if the platform holder believes the company has the structure and resources to succeed. Smaller publishers without a direct sales force or consistent product flow struggle to establish credibility on a console platform, sometimes signing its products over to a licensed publisher for distribution.

  • License to use the platform holder's trademarks and logos in-game, on packaging, and in advertising. Platform holders provide templates for all logo and trademark use, and review all materials for correct use before the product can be assembled.

  • Permission to create a game. Granted after platform holder review of the game concept early in the development process. Instances in which platform holders reject a concept, although rare, cause great vexation, as usually the publisher has already sunk funding into the project.

  • License to release the game to the channel. After extensive testing by developer, publisher, and platform holder. Platform holder certification is a tense part of the process, as the game can be rejected any number of times for bug fixes or standards violations.

According to industry logic, the company that creates the console, engineers the APIs that developers use to build games for the hardware, and incurs the cost for marketing and selling the hardware to consumers is entitled to royalties from game sales—generally around $7/unit—to cover those costs. At launch, the retail price of the console rarely covers its actual component cost, and that cost doesn't include R&D amortization. Many millions of units later, after multiple reengineering efforts to reduce actual cost of goods, successful console platforms can generate vast software-side profits while the platform holder breaks even on the hardware. Over a successful console's lifespan of five to seven years, the platform holder recoups the current console's R&D costs over the first few years, and invests in R&D for the next-generation console during the last few years. An imbalance of software revenues against hardware costs has driven more than one console platform holder out of the hardware business entirely.

Delivery Media Manufacturers

An often-overlooked cog in the publishing machine is the actual game manufacturing and assembly company. With the exception of Nintendo's Game Boy Advance, today's platforms are disk-based; this welcome change reduced cost of goods for publishers and cut manufacturing time dramatically, enabling (almost) just-in-time inventory management. Manufacturers obtain a license from console platform holders to work with the proprietary disk medium and/or other anti-piracy technology on the disk, and generally pay a nominal per-unit royalty for that technology to the platform holder.

Historically, console platform holders have always controlled manufacturing directly, with Sony and Nintendo continuing this model. Publishers submit their orders directly to the platform holder, or simultaneously to the platform holder and the manufacturer. The publisher pays both manufacturing cost and royalty directly to the platform holder, sometimes on a cash-in-advance basis. During busy seasons when manufacturing capacity is strained, the platform holder has final say over which products receive priority. However, in general the manufacturer adheres to a certain turnaround time as part of its terms of service. All the same, for an AAA title release date when every day in the schedule counts, even one day over "the standard turn-around time" can cause headaches and urgent telephone calls up and down the publishing chain.

With its Dreamcast, Sega was the first to offer complete publisher control of the manufacturing process. Based on publisher feedback, Microsoft has continued this trend with its Xbox. In this scenario, once the platform holder releases tested game code to the manufacturer, the publisher is free to negotiate turnaround times and pricing based on the strength of its relationship with the manufacturer. In practice, the cost of goods does not vary widely, but the licensing of three or four manufacturing companies ensures that the terms remain competitive.

To save additional time or cost, publishers often receive their goods from the licensed manufacturer as unpackaged disks on spindles, and ship them to a separate facility to assemble. Since such "pack-out houses" are not licensed or controlled by the console platform holder, the publisher is free to pursue the most advantageous partnership based on cost, turnaround time, proximity to the publisher's distribution center, or expertise with different kinds of packaging. Such processes must be managed carefully to prevent Murphy's law from afflicting the extra shipping and handling steps.


Retail

As the most visible part of the videogame publishing trail to the consumer, retail is rewarded handsomely with as much as 30% margin on a game sale. Many routes a game takes to a consumer's hands are not visible to the consumer, but certainly influence the game choices with which he's presented. For the purposes of this discussion, we examine primarily brick-and-mortar stores; online sales of packaged goods have steadily increased but are largely controlled by brick-and-mortar establishments. Long download times and insufficient storage on the client device continue to hamper commercial downloading of games over the Internet, excluding casual games with smaller file sizes. In practice, mass-market online distribution of games awaits greater penetration of broadband connections and further reduction of memory cost.

Distributors

Although it might seem odd to begin a discussion of retail with the middleman, it's useful to know that distributors enable smaller regional store chains, individual "mom and pop" stores, and other niche retail outlets to service their customer base uniquely in the face of stiff competition from national discount chains. Distributors buy nearly every game a publisher releases; their strengths are breadth of selection, close cost management, and the ability to sell to stores whose size or business practices preclude dealing directly with the publisher. In short, the distributor brings the publisher incremental sales more efficiently than if the publisher were to service those accounts directly.

Distributors might specialize in differing product lineups. Some distributors located closer to major population centers claim the advantage of quickest delivery of the latest releases. Although the service is frowned upon by publishers, distributors also try to boost their allocation of high-demand titles to supplement national retailers' supply in the critical days between sellout of the first shipment and arrival of the next. Others might focus on "closeouts"—marked-down or discontinued games that make their way from the publisher or retailer's warehouse to the bargain bin at a loss for the publisher but profit for the distributor and retailer. Some distributors focus on making games "rental-ready," repackaging games in sturdy cases for small rental chains. Some distributors act as publishers on import or other low-visibility titles, taking the financial risk on the hope that one might turn out a gem.

In its role of making the market for games more efficient, the distributor itself must be extremely efficient in order to secure its roughly 3% margin on sales. Generally, distributors secure massive warehouse space in low-rent areas, depend on the publisher for sales materials rather than creating their own, and pay their salespeople with heavy emphasis on commission. The cliché of "making it up on volume" is possible for a distributor that works every angle to its benefit.

Manufacturers' Representatives

Manufacturer's representatives, or "rep groups," are a testament to the lasting power of relationships in a high-tech world. Usually small companies of just a few people, rep groups secure agreements allowing them to act as contracted salespeople on the publisher's behalf. They're responsible for knowing the product line, the target retailer's operation, publisher practices, and when to sell more versus mark down (although they must recommend the latter to their publisher first). For these services, the publisher pays them approximately 3% of net sales (all sales minus any returns).

Rep groups are usually of most value in situations where the rep group's relationship and credibility with a retailer is stronger than the publisher's. This includes launches of new product lines, a new publisher's entry into the market, or reaching out to a retailer not yet included in the publisher's existing retailer base. The rep group acts as go-between, advising both publisher and retailer on how to work through new processes on each side. Despite hard work and sincere commitment by leading rep groups, publisher sales executives constantly reexamine the wisdom of contracting external companies for such a vital task. Perhaps it's disappointing sales on a key product that prompts the initial questioning, or cost watchers eyeing the rep group's commission percentage. The result in either case, and the bane of every rep group, is the publisher's call informing them "we've decided to go direct."

Regional Retailers

Despite the increasing standardization of the retail experience nationwide, successful regional retailers have learned the keys to survival: know your customer, provide exactly what he wants, give great service, and offer occasional surprises. These precepts apply perfectly to the game market, where smaller videogame-only retailers and mom-and-pop stores can't compete on price or speedy availability of new releases. The smaller retailer can provide detailed knowledge on the latest game or on an obscure release from years back—and if the store manager or buyer is very good, he will know where to lay his hands on both.

The key to regional retailers' success is good relationships with both their distributor and, ideally, with each publisher as well. Although economies of scale prevent a publisher from servicing regional retailers directly, solid chains with several stores can attract the publisher's notice, either through the grapevine or via distributor's advocacy with the publisher on their behalf for things such as in-store merchandising items and, rarely, markdowns. Since regional chains are frequently staffed by hardcore gamers, publishers can use such chains to create word-of-mouth recommendations from "experts" for their latest releases.

Rental Retailers

Rental retailers such as Blockbuster Video and Hollywood Video have emerged from relative obscurity as a retail category to major drivers in the channel. Until recently, publishers treated rental retail with respect but not much attention; although the sell-in quantity "per door" was less than at traditional retailers, those units were never returned or marked down. Recently, however, industry market research from many sources has shown that the primary driver behind consumer purchase intent is hands-on experience with the game. As rentals can encourage sales of a good game, so also can they stop a bad game's sales dead at launch. As a result, publishers now work their lineup out carefully with rental retailers, evaluating rental retailers' value in advance promotion side by side with actual units sold.

Rental retailers, in turn, have identified the game market as a potential growth segment of their business. Some chains are experimenting with revenue-sharing models. Other rental retailers are moving into sales as well; having created a potential buyer for a game through rental, such retailers have stopped sending the buyer to a competitor for the purchase. In short, rental retailing is transforming into a new service model for gaming consumers.

National Retailers

Finally, we come to the names that consumers know: Wal-Mart, Target, Best Buy, Toys-R-Us, Electronics Boutique, and Babbages. The lineup varies slightly from publisher to publisher, but this group of national retailers makes up the core of the industry's sales efforts, and represents the most cost-efficient way for publishers to get a game into a consumer's hands.

National retailers have direct relationships with the publisher, which means that that publisher provides them with:

  • Games shipped directly to the retailer's warehouse, or direct to store if the retailer can accommodate.

  • In-store merchandising materials, such as standees, posters, shelf talkers, and box fronts for display.

  • Extensive sales materials on each title, usually including a direct pitch by the publisher's marketing and sales staff to the buyer.

  • Generous terms on sales (average net 60, although retailers with clout stretch this as desired).

  • Hands-on inventory management, including publisher sales staff poring over store-by-store inventory to increase sales efficiency.

  • Various relationship-building perks, such as tickets to a local sports event or an expensive dinner after the sales call. (Wal-Mart is notably strict in its policy of "no freebies" to its buyers.)

  • Credits against existing invoices or free goods to help the retailer mark down and move through stagnant inventory.

  • Unique sales programs customized by retailers, whether a gift-with-purchase, instore event or celebrity appearance, or sales contest for in-store staff.

The retail buyer has great clout in the process of getting a game to consumers. The buyer is usually responsible for the entire videogame category, but depending on the relative importance of videogames to the retailer's revenue, videogame buyers might also be responsible for related categories such as video, electronics, or toys. The best buyers listen to the salespeople but also conduct their own research, accept the publisher's stance but listen to the needs of their own customers. The worst buyers pay little attention to videogames, failing to keep abreast of trends or failing to pass information along to store-level employees. Frequently, the difference between a coherent, well-stocked videogame department at one retailer and a disorganized jumble of last year's games at a different chain is directly attributable to the buyer.

For publishers, the buyer controls several elements that can mean sales success or failure: whether to stock a game at all, how deeply to stock it, "white space" or co-op advertising in retail circulars, and in-store pricing. The decision to pass on a game can mean forecast deficits of thousands of units if that retailer is responsible for 40% of a game's launch volume. Smaller publishers suffer from buyer "cherry picking" of the best titles only, while larger publishers and platform holders can benefit from the buyer's courtesy in taking the entire product line. A buyer's decision to stock a game in "gamer-heavy" stores in key locations, but not in minor secondary locations, is a strong sign to a publisher to redouble its in-store efforts, in order to achieve chainwide distribution. A buyer's decision to show a title in the retailer's "white space" circulars (usually bundled with the daily newspaper) creates a measurable sales spike the week the ad is viewed by millions of avid gamers watching for the next release. Finally, buyers have the authority to designate a key title as a loss-leader, pricing it below the usual $49 at launch to drive store traffic to higher-margin purchases. For hot releases, publishers designate a manufacturer's advertised price ("MAP") program, in which any retailer who reduces their advertised price below a certain level is denied co-op funding for the offending ad. However, this relatively weak penalty is only effective when combined with a strong buyer-salesperson relationship that neither party wishes to damage.

Much as "going direct" are two words rep groups dread, "no open to buy" are four words that bedevil publishers. "Open to buy" is the amount of money the buyer can spend buying games within a certain period, usually quarterly or 30 days. Essentially a budget, it's calculated from a combination of cost of inventory on hand, sales rate or "turnover" of that inventory, and revenue expected against that inventory for the period. Open to buy is very restricted around the Thanksgiving-Christmas holiday interval, when large numbers of games are expected to sell huge quantities. A publisher salesperson pitching an excellent game who receives the response "no open to buy" is chastised by his or her management for not pitching the buyer earlier on the game's quality. A salesperson hearing the phrase in response to a poor-quality game should understand this message: Your game isn't good enough to compete with the other releases during this time period. In short, if the publisher manages its retail relationships well, open-to-buy issues should be no surprise.

To manage such relationships to this degree, publishers require voluminous data quickly and frequently. Publishers can derive sales of their own games from internal sales information, of course, but sales data on competitive games or titles released during the same period puts an important context around one's own sales. For example, poor sales of a publisher's franchise platform title can mean anything; poor sales of the next platformer to appear might mean that that console's audience doesn't look for the platform genre; and poor sales of all games during that period might indicate overall industry softness, or poor supply of the hardware platform at retail. To fill this need for competitive data, a company called NPD publishes data called TRSTS in which major retailers report their weekly sales, which then get aggregated and sent back to publishers. Unfortunately, several retailers recently declined to send NPD their weekly numbers, rendering the sample invalid. The industry continues to benefit from NPD's monthly reports, but the weekly updates are sorely missed.


Conclusion

A favorable review on a Web site informs gamers of a new release. A store sets up a pre-sell list, thus allowing devoted fans to reserve their copies of an eagerly awaited sequel. A game's wide availability in rental outlets drives extra sales. A clearance sale generates a few extra dollars out of an old title.

With luck, hard work, and good knowledge about who touches your game after you're done with it, the next game consumers buy will be yours.


Chapter 1.3: How Developers Get Paid: The Retail Market for Games

Overview

François Dominic Laramée

<francoislaramee@videotron.ca>

While online distribution and subscriptions have become viable revenue models for specific segments of the game development community, the industry as a whole remains bound to the retail market, and will stay bound to it for the foreseeable future. However, the way the retail market for games is organized doesn't make it easy for developers and publishers to make money—at least not in a reliable and predictable fashion.

This article explains the inner mechanics of the retail game market, how publishers cope with its limitations, and how its dynamics impact the financial well-being of developers.


Monetary Aspects of Development Contracts

Before we look at the retail market itself, let's examine the contracts that developers sign with publishers; specifically, the clauses that specify how (and when) the developers get paid. For the purposes of this discussion, the enormous variability of development contracts will be reduced to two broad categories: cost-based deals and royalty-based partnerships.

Cost + Margin Deals

This model, commonplace in subcontracting but also becoming more prevalent in the context of full development deals, minimizes risk for the developer, but at the cost of lower potential profits. In short, cost and margin deals involve four steps:

  1. Call for proposals. The publisher asks the developer for a proposal based on broad parameters; for example, a racing game featuring the publisher's licensed property, for console X, to be delivered in the third quarter of 2004.

  2. Evaluation. The developer evaluates the cost of making the game.

  3. Negotiation. The parties agree on an acceptable profit margin for the developer. Sometimes this is done explicitly: the developer discloses their cost evaluation and the price is set at 20 or 40% above this figure. More often, the publisher asks several teams for competing bids, and the developers include their own (secret) profit margins in their proposals.

  4. Development. If the developer is able to deliver the product for less than the expected cost, they pocket the difference. Conversely, if costs run out of control, their profits diminish. In extreme cases, the developer might end up completing the project at a loss; while publishers will occasionally agree to pay more than expected rather than seeing a high-payoff game be cancelled, they will only do so if they are convinced that it is the only way to save the game—and they won't forget the incident.

For developers, cost-based contracts might be attractive because risk is confined to the developer's own operations: accurate evaluations and smooth projects guarantee profitability, no matter what happens in the marketplace. However, if the game turns out to be a hit, the developer might regret trading away a share of royalties in exchange for safety.

Advance + Royalty Deals

The royalty model, borrowed from book publishing, is the traditional framework in the game business. It involves three major steps:

  1. Advance. The publisher agrees to pay the developer a fixed amount, which might or might not cover development costs, before the game is published.

  2. Earning back the advance (or "recouping"). The advance is tied to the game's initial sales. For example, if an advance of $500,000 is paid based on $10 per copy, the developer will receive no additional money until the game has sold over 50,000 units. (If the game never reaches this sales target, the developer will never see another dollar, but at least they get to keep the advance. Deals that require reimbursement of un-recouped advances are all but unheard of, and should be avoided at all costs.)

  3. Royalties. Once the game's sales have earned back the advance, the developer receives additional money for each copy of the game sold. This amount might be defined in dollars (e.g., $5 per copy) or as a percentage of the publisher's gross sale price, which can vary a great deal during the game's life cycle.

For developers, the royalty model might involve greater risk if the advances do not cover the cost of production. However, if the game becomes a best seller, the developer stands to earn much more money than in a cost-based arrangement.


Retail Statistics

Unfortunately, while the royalty model worked reasonably well in the old days of $100,000 development budgets, the associated risks are far less manageable in today's market.

A Hit-Driven Business

The overwhelming majority of PC games sell fewer than 100,000 units before going out of print; for most professionally developed and published titles, sales will begin to taper off at 15,000 to 40,000 copies, with any remaining inventory being liquidated by the publisher for little more than the cost of printing the box and CD-ROM. On the console side, the average title stands a much better chance of breaking even, but few teams can break into the console market without proving their worth in the PC world first. The bottom line: the vast majority of game projects lose money for the developer, the publisher, or both.

Therefore, the industry must rely on a small number of best-selling titles to earn enough profits to offset the losses suffered on the bulk of the projects.

Hedging Your Bets

Since all but the largest independent development companies release at most one or two games a year, the low probability of a hit makes it very difficult for developers to finance their own work. Therefore, most developers seek to shift the risk toward their publishers by negotiating advances that cover production costs and a reasonable profit margin.

The publishers, on the other hand, have no one else on whom to offload their risks. Thus, their strategy becomes one of cost reduction (limiting the losses on any individual title by reducing advances to a minimum) and risk balancing (by publishing as many different games as possible to increase the odds of a hit).


Selling to Retailers

As explained by [Schoback02], gaining wide and deep access to the retailers' shelves is the determining factor in a game's commercial success. Securing good shelf space is therefore the game publisher's most important job.

A Concentrated Business

In North America, a small number of major national retail chains accounts for the overwhelming majority of the game industry's total sales. For publishers, this makes relationships with these retailers especially crucial: if Wal-Mart refuses to stock a game, many potential buyers will not see it on the shelves—and if another major retailer notices the refusal, there is a chance it might reconsider its own decision to buy the game.

The largest brand-name publishers, like Electronic Arts and Sony, can usually assume that anything they publish will be stocked in every retail store. For smaller companies that can't supply stores with a steady stream of sure-fire novelties every month, the situation is much more difficult: store buyers will decide on a case-by-case basis, and they have very limited shelf space to allocate. Even then, an effective strategy can yield success: Case Study 1.3.1 describes how a small development house with a single product line has achieved success self-publishing in its national market.

Case Study 1.3.1: Self-Publishing
Start example

Kutoka Interactive, a small developer of children's edutainment titles starring a mouse named Mia, chose an unusual approach: they publish their games themselves in their home country (Canada) and sell licenses to publishers elsewhere on a country-by-country basis.

"We felt that establishing partnerships with multiple companies was less risky than to rely on a single, big company to market our game every-where," explains Tanya Claessens, Kutoka's vice president. The strategy has paid off: today, the Mia series is distributed in 42 countries and in 14 languages. Moreover, finding the partners was easier than most people would expect: "When we first introduced Mia at MILIA, we received 43 proposals before the show was even over!"

Like many other companies in the field, Kutoka started out as a contract development house and used the income generated by this work to fund development of its own intellectual property. Mia's success on the trade show floor led to great press coverage, which in turn helped Kutoka secure precious shelf space for the games in Canada. "Thanks to the media's enthusiasm, we were able to get our first title into stores in December, which is almost unheard of." Since distributors could not handle the game at this late date, Kutoka's employees had to assemble the boxes in the office at night and ship the games directly to retailers themselves. And despite the positive press, even the retailers who ordered the game remained skeptical: "All we got at first were trial periods of two to four weeks. The game had to sell by then, or it would have been taken off the shelves."

Fortunately, Mia did sell, and today the 25-person company is expanding to a second line of original games and will soon begin publishing third-party software. "We're glad we're not starting out today, though," Tanya Claessens concludes. "With fewer and fewer major retailers in the market, it is becoming more difficult to win 'mindshare' and to sell original properties."

End example

The Publisher's Headaches

Convincing retailers to put a game on their shelves is unfortunately not nearly enough to ensure a game's financial success. This is because games are sold as consignment items: the retailer will only pay the publisher for copies of the game that consumers actually buy—the rest will be returned, often at the publisher's expense.

Therefore, not only must publishers convince retailers to order the game, they must also entice them to put it on the best shelf space, at the right time, and for as long as possible. Retailers will therefore study the publisher's marketing plan, sell the right to advertise the game in their store fliers, demand preferential pricing to convince consumers to buy the game in their stores instead of the competitors', and so on.

And sometimes, a relationship with a retailer will be so important that the publisher will be forced to accept the retailer's demand for a temporary exclusivity, or even to change the game's content to satisfy the retailer's standards.

The Channel-to-Market Throttle

Compared to other popular forms of entertainment such as music CDs and movies on DVD, games suffer from three serious disadvantages in the retail market:

  • Retailers don't stock many titles. The major specialty music stores routinely offer tens of thousands of different recordings. Game shops rarely if ever have more than a few hundred games in stock. And the large surface discounters often propose 10 to 100 times more movies and music CDs than games.

  • Games are perishable. A weak-selling game will be taken off the shelves in six to eight weeks—there is no second chance. A success story like that of the Austin Powers movie franchise, which was revitalized in home video after the first film drew poorly at the box office, would be impossible in our medium. Even moderate hits rarely last more than a year in the marketplace.

  • Platforms are perishable. When music lovers were forced to switch from vinyl to cassette tapes and then to CDs—two platform changes in 50 years—the public rose into an uproar. Game players have been through six generations of consoles, from the Pong machines to the Atari VCS to the 8-bit Nintendo to the 16-bit Sega Genesis to the 32-bit PlayStation to the Xbox, in half that time. And unlike the music of the Beatles, the overwhelming majority of the classic games of the DOS and 8-bit era have never been re-released commercially. While players can still enjoy many of these games (despite publishers' best legal efforts to the contrary) thanks to emulators and the so-called salvage community, this sort of non-commercial effort generates no income for the developers who created the games in the first place.

The Developer's Headaches

Suppose that a developer sells a game to a publisher for an advance of $2,000,000 that matches its development cost exactly, plus a royalty of $10 per copy. The developer will earn royalty checks and turn a profit only if the game sells more than 200,000 units.

Now, if the publisher invests $400,000 in the game's manufacturing and marketing and sells it to retailers at a gross price of $30, it will have earned back its own investment as soon as the game sells (2,400,000 / 30) = 80,000 units. Therefore, if the game's sales begin to decline after 100,000 units, the project has already achieved profitability from the publisher's point of view. Consequently, the publisher might not be highly motivated to stimulate sales any more, because such an effort will quickly run into diminishing returns. Meanwhile, the developer hasn't received one dollar in royalties.

Of course, if the advance paid to the developer didn't even cover the cost of developing the game, this phenomenon can lead to profits for the publisher and disaster for the developer. For this reason, smart developers will negotiate the largest possible advance, even at the expense of a modest royalty rate.


On the Shelves

Different outlets might sell the same game at different prices for reasons of strategy: for example, some retailers will choose to sell a high-profile game at a discount for a short time to draw customers. However, publishers will also change their suggested retail prices with time, lowering them when demand decreases ([Laramée03]). What happens to developer royalties at that time?

If the royalty rate has been set as a fixed percentage of the publisher's sale price, for example 20%, the royalty amount decreases proportionally with the price. One consequence of this fact is that, if the game has not yet earned back its advance at the time of a price drop, the developer might have to wait until unit sales reach much higher levels than expected before he receives a check.

The other royalty model, in which the developer receives a fixed dollar amount per copy of the game sold no matter what the publisher's sale price might be, would therefore seem more attractive. Unfortunately, this model has a serious flaw of its own: as the publisher's price drops, the fixed royalty accounts for an ever-increasing share of the publisher's revenue, until it becomes economically preferable for the publisher to stop marketing the game even if there is still a demand for it.

From the developer's point of view, the optimal agreement ought to generate royalty income as soon as possible and keep the game on the shelves as long as possible. One way to build this strategy into a contractual clause would be to:

  • Set a ceiling to the unit sales that can be used to recoup the advance. For example, an advance of $1,800,000 at a royalty rate of $9 per unit corresponds to 200,000 units sold at full price. The contract might therefore specify that the developer is entitled to receive royalties as soon as unit sales reach 250,000 copies, even if the advance has not yet been recouped due to price cuts.

  • Set an escalating royalty percentage once the advance has been earned back. For example, the royalty on the first 100,000 units might be 20% of the publisher's price, the rate on the next 100,000 might be 25%, and so on. This way, the developer shares in the success of a hit, but since the royalty remains bound to the publisher's price as a reasonable percentage, there will never be any incentive for the publisher to drop the game as long as demand stays strong, since both parties earn money on each unit sold. After all, by the time the higher royalty rate comes into effect, the game is already profitable for both parties.


When Do Royalty Checks Arrive?

Finally, most publishers pay royalties on a quarterly basis, and only on copies that retailers have paid them for (because they have been sold to consumers). This means that it takes some time for money to flow back into developers' pockets: if a game reaches the target sales numbers required to generate royalties on October 21, the fact will be reflected on the publisher's fourth-quarter report, which might only be completed in February—and accounting might not print the developer's check until March.

Case Study 1.3.2: Royalties versus Guarantees
Start example

Sarbakan, a developer of online games based in Quebec City, is most notorious for its mystery serial Arcane and its action series SteppenWolf, both published by Warner Bros. Online. Sarbakan's business model relies on a balance between original intellectual property (whether sold outright, work-for-hire style, or licensed to distributors according to non-exclusive agreements) and service deals.

"We want to maintain a 50–50 split between creating our own projects and providing our services to other intellectual property owners," says Richard Vallerand, Sarbakan's vice president for creative affairs and production. "These are very different businesses, but they complement each other very well."

In SteppenWolf 's case, Sarbakan sold all rights to the property to Warner Bros. The publisher provided a budget sufficient to insure profitability, and Sarbakan retained a share of future earnings tied to the property. "This way, we gained access to Warner's tremendous marketing machine. This allowed us to gain more players faster than we could have on our own. And since they own the rights, our partners will be more interested in migrating the property toward other media; television, for example. Obviously, they are in a much better position to do so than we are."

By selling the rights to SteppenWolf to Warner Bros., Sarbakan accepted a smaller share of the property's revenue. However, with the power of the conglomerate behind SteppenWolf, this small share might actually amount to more, in the long run, than what Sarbakan might have been able to generate on its own.

"Plus, Warner has allowed us to retain a great deal of creative control over the characters and storylines. This is not the case when we work on someone else's intellectual property: when we do so, the decision process always involves a lot of back and forth."

End example


Conclusion

Not very many games ever earn anything beyond the initial advance for their developers. Even in the best case, it will take months for the game to start earning royalties, and a few more months for the money to reach the developer. As a result, smart companies now base their budgets on the advances alone—and they try to build a healthy profit margin into them. Thus, the "cost and margin" pricing model becomes more prevalent, in fact if not in intention.

The retail market for games is difficult for developers, and not much easier for most publishers. Retailers wield enormous power over our livelihoods: they stock few products, don't keep them on the shelves for very long, and reap much of the income the games generate. Yet, alternative distribution schemes (e.g., online sales) have not risen above marginality, because of download sizes and fears over channel conflicts. Learning how the retail market for games works will help developers thrive in this competitive environment.


References

[Laramée03] Laramée, F. D., "A Publishing Project: From Concept to Launch and Beyond," in Secrets of the Game Business, Charles River Media, 2003.

[Schoback03] Schoback, K., "The Role of Each Entity in Game Publishing," in Secrets of the Game Business, Charles River Media, 2003.


Chapter 1.4: A Publishing Project: From Concept to Launch and Beyond

Overview

François Dominic Laramée

<francoislaramee@videotron.ca>

Unfortunately treated by many game developers as a necessary evil, publishers are in fact the developer's greatest allies. Not only can publishers open the door to the retail market (and to profitability), but their resources can also shield the developers from many sources of conflicts and mistakes, and thus help them make better games.

This article outlines the work that the publishing company performs at various stages of the production and marketing process.


Selecting a Project

Even the largest publishing house only has the wherewithal to market a tiny fraction of the games submitted to it. Therefore, the process through which publishers select the projects they will invest their precious resources in is extremely crucial.

Publishers evaluate projects with a "profits and losses statement" like the one presented in Case Study 1.4.1; let us examine the factors that influence this calculation.

Case Study 1.4.1: Estimating a Project's Profitability
Start example

Here are examples of profits and losses spreadsheets for a mid-range PC game and a franchise console title.

PC Game

 | Early Adopter | Peak | Budget | Total
Gross unit price | $40 | $30 | $15 |
Expected units | 0 | 80,000 | 40,000 | 120,000
Gross revenue | $0 | $2,400,000 | $600,000 | $3,000,000
Cost of goods | $0 | $120,000 | $60,000 |
Advance/R&D | $1,500,000 |  |  |
Marketing | $200,000 | 6.7% of sales |  |
Direct (total) expenses | $1,880,000 |  |  |
Breakeven | 62,667 |  |  |
Profitability ratio | 1.6 |  |  |

Franchise Console Game

 | Early Adopter | Peak | Budget | Total
Gross unit price | $40 | $30 | $10 |
Expected units | 350,000 | 500,000 | 150,000 | 1,000,000
Gross revenue | $14,000,000 | $15,000,000 | $1,500,000 | $30,500,000
Cost of goods | $2,450,000 | $3,500,000 | $600,000 |
Advance/R&D | $3,500,000 |  |  |
Marketing | $2,500,000 | 8.2% of sales |  |
Direct (total) expenses | $12,550,000 |  |  |
Breakeven | 313,750 |  |  |
Profitability ratio | 2.4 |  |  |

Let's define the line items in this spreadsheet:

  • Gross unit price: The price at which the publisher sells to retailers. This is usually 50 to 70% of the retail price paid by consumers.

  • Expected units: Target sales numbers.

  • Gross revenue: Gross unit price multiplied by expected number of units sold.

  • Cost of goods: The cost of printing game media, manuals, packaging, and shipping and handling. For console games, this includes the unit royalty paid to the platform owner; for example, $3 to $8 depending on the retail price and the platform.

  • Advance/R&D: The non-refundable sums paid to a third-party developer, or the money invested in developing the game internally.

  • Marketing: The sums devoted to advertising the game in print, online, and on TV, plus in-store marketing and promotion. For most projects, this is roughly 8 to 10% of gross revenue, but some publishers will invest much more.

  • Direct expenses: Advance/R&D plus marketing.

  • Breakeven: Number of units that must be sold to cover the game's direct expenses.

  • Profitability ratio: Gross revenue divided by total direct expenses.

Note that indirect costs, including trade show expenses and publisher staff salaries, are not accounted for in the profitability ratio calculation. Neither are profit margins. The actual ratio that the project must generate to justify investment depends on publisher overhead and profit objectives; for a small publisher with limited staff, a ratio of 1.5 might be sufficient, while giant companies traded on the stock market might need a ratio of 3.0 or more.

End example

The Two Risks

Sadly, game development studios are inherently unstable. For every company that achieves long-term success, many close their doors after releasing only one or two games, and even more never manage to ship a single title. Furthermore, the game market is highly hit-driven; according to numbers quoted by [Laramée00], only 3% of PC games and 15% of console games sell more than 100,000 units in any given year—and 100,000 copies is rarely enough to make a high-budget release profitable. For a publisher investing time and money in a project, these facts translate into a pair of major risk factors:

  • The risk of cancellation: That the project will never yield a product, because it will be cancelled along the way.

  • The risk of commercial failure: That the finished product won't find success in the marketplace.

The publisher's decision process must balance these risks against the product's inherent appeal, to determine whether its potential payoff warrants the investment.

Reducing the Risk of Cancellation

Most game project cancellations derive from excessive delays and/or poor quality. Thus, well-established teams with proven track records of success stand the best chance of securing publishing deals. When Sid Meier created Firaxis, the press reported contract signings involving the new company within weeks.

For the typical startup, the situation is more complicated. Some publishers will demand to see a 25 to 75% complete version of the game as a proof of the developers' credibility before they invest. Others will sign a contract based on a fully functional demo, but for a modest advance only. In both cases, the new team will have to find alternative sources of funding (debt, capital, or sweat equity) for part of the development process.

Reducing the Risk of Commercial Failure

With thousands of games released every year, and room for but a fraction of those on retailers' shelves, publishers will favor projects with built-in target audiences. For example:

  • A sequel to a current best-seller. If Zombie Rodent Disco Kings sold 3 million copies, retailers and consumers will clamor for Zombie Rodent Disco Kings II.

  • A game that fits the general parameters of a popular genre. It is easy to assess the potential sales figures for a war game, a shooter, or a golf simulator.

  • A game based on a popular license. When deciding between two games to buy, the typical consumer will tend to choose the one featuring Star Trek or Sesame Street characters.

While these "franchise games" by no means guarantee success, they are perceived as more likely to make an impact in the retail market than their wholly original or off-beat competitors.

Making the Decision

A variety of strategies are available to publishers seeking further risk reduction:

  • Cross-collateralization: This is an accounting process that ties together the earnings of several games (or of the same game on multiple platforms) so that the profits made by one have to recoup the losses of the others before royalties are paid to the developer.

  • Budget games: If a game can turn a profit on sales of 5,000 units, the risk is minimal.

  • Hedging the bets: Larger publishers might play the odds by acquiring the rights to many high-profile games and hoping that one of them will turn into such a hit that it will more than make up for any losses on the others.

  • Affiliate label status: Some small and mid-sized publishers will delegate the massive sales and distribution effort to a larger company to reduce their costs. Strategy First, a PC game publisher profiled in Case Study 1.4.4, is an affiliate of Infogrames.

However, the most important factor in the decision remains the individual game's odds of making it to market and being successful there.


Guiding Development

Funding is not the only benefit that a good publisher provides during development. Others include help fine-tuning the game design for maximum market impact, securing approved developer status from console manufacturers, equipment loans (those console development kits are expensive), better exposure in the press, and any number of morale-boosting fringe benefits such as free games and invitations to exclusive parties at industry trade shows.

Perhaps most important of all, the publisher will assign an internal producer to your project [McGilvray03]. This person's job is to make it as easy as possible for you to complete the project on time; the producer might provide services such as getting the publisher to pay for an external testing studio, obtaining extra equipment, organizing special training, or applying a little pressure to get your game certified by a console manufacturer in time for a November release. The best internal producers will even shield you from sources of stress emanating from their own companies!

Case Study 1.4.2: How a Publisher Selects a Team for Contract Development
Start example

For NewKidCo, a small publisher of console and handheld games based on licenses that appeal to children 4 to 12 years old, choosing a development partner involves considerations of technology, expertise, and cost.

"Since we're small, we have limited financial resources," says Seth Rosenfeld, a producer at NewKidCo. "We also try to match games to developers based on their capabilities. For example, if we want a platform game based on a cartoon license, we will approach a company with strong animation skills and an appropriate 2D or 3D engine."

It is also crucial that developers deliver products carefully tailored to the specific development cycles. "Often, developers make promises that they are unable to fulfill due to schedule or budget restrictions. Tight schedule management, including bi-weekly or even weekly build reviews, will insure that any slippage will be noticed immediately. Developers should be candid with their publishers with regard to risk, so that potential problems can be dealt with at the earliest opportunity."

End example


Preparing for Launch

Some games catch the public eye years before release—sometimes on purpose, sometimes because of schedule slips. However, in most cases, publishers begin to work on a launch campaign approximately six months before release. In the United States, much of this activity happens at the Electronic Entertainment Expo (E3), which takes place almost six months to the day before the most important shopping weekend of the year, Thanksgiving.

Selling to Retailers

At E3, publishers meet buyers from all of the retail chains and show them the games of the Christmas season in almost-finished form. (Demos of the next year's releases are also shown, often behind closed doors.) The publishers' goal is to guarantee that their games will be available in as many outlets as possible, in sufficient quantities, and on the best shelf space. Therefore, they spare no expense; the high-tech booths and hundreds of thousands of square feet of floor space that publishing giants buy at E3 cost them millions of dollars for the three-day event.

[Laramée03] discusses the retail market in more detail.

Selling to the Press

At the same time, game magazine reporters receive previews and interview the games' developers.

Most print magazines have lead times (e.g., delays between writing and publishing of articles) of about two to three months. Therefore, E3 previews appear in print in August or September—just in time to condition consumers for Christmas shopping. Full reviews follow a few months later, to coordinate their appearance in print with the game's release.

Marketing Campaigns

It is no secret that magazines tend to give better and more favorable coverage to publishers who fund their business through advertising purchases. Retailers also want to know how much advertising a publisher will buy to support a game, when it will appear, and in which publications.

A print advertising campaign for a typical game will cost about $150,000 to $350,000. That amount will buy full-page and two-page ads in several major magazines for three to six months. Television ad support is usually reserved to flagship titles and brands (e.g., Tomb Raider or EA Sports) and can easily cost 10 to 20 times as much.

Other major marketing expenses include:

  • Store promotions. These include preferential pricing and rebates granted to a specific retail chain, in-store displays, and advertising in a store's fliers.

  • Online marketing. Publisher staff members discuss upcoming games with consumers in chat rooms, on Web sites, and so forth. Once marginal, this labor-intensive practice now sometimes accounts for half of a game's marketing budget.

The Final Countdown

Once the game is complete, the publisher runs final testing, manufactures copies of the game and packaging (sometimes in-house, usually through subcontractors), stores the boxes in its warehouse, and ships orders to retailers.

For a PC game, this sequence takes approximately one month. For console games, it often takes three times as long, for two reasons:

  • Since it is impossible (for now) to release a patch for a console game, the platform owner must certify that the game is bug-free. This makes the final testing and approval period much longer.

  • Platform owners usually retain the exclusive right to print copies of game media, using special formats and processes to minimize the risk of piracy. If the platform owner has limited manufacturing capacity, which is typical during a console's first year on the market, it might take a while for them to fulfill orders.

Case Study 1.4.3: Self-Publishing (Continued)
Start example

Kutoka Interactive, the publisher of children's games profiled in Case Study 1.3.1, relies on effective press relations to offset their competitors' larger advertising budgets. "When a magazine like MacHome writes that our animation is as good as Pixar's and better than Disney's, consumers notice," says Kutoka vice president Tanya Claessens.

Aggressive brand promotion also helps ensure market penetration. "We have bundled the games with plush dolls, created a complete line of ancillary products such as backpacks, puzzles, and action figures, and we are going to expand the license into children's books and television as well."

But ultimately, it all comes down to sales. "Stores only stock best-sellers, so we have to move more units than the competing product that could replace us on the shelves."

End example
Case Study 1.4.4: A Publisher Profile
Start example

One of the world's leading publishers of strategy games for the PC, Strategy First has marketed such titles as the Disciples and Europa Universalis series. When evaluating a game proposal, the company adopts an iterative approach.

"Anyone in the company can submit a design treatment," says Chuck Kroegel, Strategy First's vice president for product development. "If it is approved by our executives, the project advances to the proof of concept phase, during which a brief design document and a playable demo are created. After another review, a promising project is assigned to a team of six or seven people who develop a prototype, a technical design, and better gameplay specifications. Only if there is a strong hook in the prototype will the game progress to full-scale development."

As a result of this iterative review, about 50% of the projects that pass the proof of concept stage eventually reach store shelves. "I have seen hundreds of games in my career," says Kroegel, "and many get waylaid because they lose their core vision. We work hard in the early stages of our projects to avoid the mistakes that lead to cancellations."

Third-party developers seeking a publishing agreement with Strategy First go through the same process, but they have to create the proof of concept on their own. "We usually act as a publishing partner, paying more in royalties than in advances, although we plan on funding more development in the future."

As an affiliate of Infogrames in North America, Strategy First handles advertising and online marketing for its games, while Infogrames takes care of sales, distribution, manufacturing, and store promotions. The company begins a game's pre-launch campaign three to six months before the planned release date. "War games are one of our specialties, and they don't require much advance warning. We know who and where the consumers are, so reaching them is straightforward." For this type of niche product, online promotion is key, and accounts for 50% of the marketing budget and 70% of the labor.

Thanks to its low overhead, Strategy First can turn a profit on games that bigger publishers must decline. Kroegel concludes: "We can often break even on sales of 50,000 units and earn significant profits if we reach 100,000. That makes us an attractive outlet for developers whose games target smaller but well-established niches."

End example


Beyond the Launch Campaign

The publisher's job isn't done when the game ships. To maximize earnings, the publisher must extend the title's life cycle.

Support

First, the buying public must receive the support they need to enjoy their purchase. For classic retail games, support involves little more than a Web site, an e-mail address, a telephone number, and possibly a few patches to correct the bugs that have slipped through the quality assurance process. However, massively multiplayer online game customer support [Perkins03] requires dozens or even hundreds of people monitoring the happenings in the game world around the clock to foil hackers, stifle aberrant player behavior, and solve transient bugs.

Price Reductions

Highly anticipated games are released at premium prices ($60 or $70), so that the publisher will generate as much income as possible from early adopters. This is standard marketing strategy: DVD players, microwave ovens, and a host of other devices cost much more when they were introduced than they do now that they have reached mass market acceptance.

Unfortunately for publishers, early adopters account for only 20% of the population. Therefore, premium sales drop off within a few weeks or months of release. At that point, the publisher will stimulate demand by lowering the price to $50. (Games that do not justify premium release prices start at that level, or even lower.)

The price reduction process will be repeated periodically, as long as reports show that the drop causes an increase in sales. A highly successful game's retail price can go from $60 to $50 to $40 to $30 to $20 over a period of 12 to 18 months, before remaining stock is liquidated at $5 to $10 once demand has all but vanished. If the game fails to find an audience, retailer pressure might drive the price down to budget or liquidation levels within 6 to 12 weeks.

Add-Ons

For many types of games, an expansion pack containing new quests, new levels, or new units is a quick and relatively inexpensive way to generate additional income from the existing user base.

In the future, some games might be sold with minimal content included, and additional "episodes" be distributed online by weekly or monthly subscription. This way, publishers will be able to exploit a successful franchise for several years, much like the creators of a hit television series do now. (A potentially even more appealing benefit is that they will be able to cancel unpopular games before millions of dollars are sunk into development.)

Bundles

Once a game reaches the end of its retail life cycle, the publisher can entice additional consumers by bundling the game and several add-ons into a single budget-priced package. By adding special features to the bundle (e.g., a metal box, cloth map, action figure, music CD, etc.), the publisher might even turn it into a "lifestyle purchase" that consumers who already own the game might want to buy or receive as a present, much in the style of "greatest hits" music compilations.

Finally, once a game is completely out of the retail channel, the publisher might want to bundle it with hardware, books, or even include it in cereal boxes. Revenue generated from such bundling agreements is minimal (often less than $0.25 per unit), but volume and/or visibility might be sufficient to justify the deal.

Sequels

And of course, a successful game creates a built-in audience for a sequel, which might be easier to sell to retailers and consumers than a brand new product. In fact, it might be easier to make money on a sequel, even at lower sales volumes, because the sequel costs less to market—and possibly to develop as well, if assets can be reused, although the rapid evolution of game technology has made this unusual to say the least.


Conclusion

Game publishing is a high-risk, high-yield business. Most games lose money. The hits are expected to compensate; therefore, small publishers (who can't afford to release many titles) struggle, and big ones hedge their bets through mergers and acquisitions.

For developers, concentration of the publishing business is unwelcome: fewer outlets for games means less favorable deals. However, until online self-publishing becomes a viable option for high-budget games, the trend is likely to continue unabated.


References

[Laramée00] Laramée, F. D., "How I Spent My Spring Break: A Report on the 2000 Game Developers Conference," available online at www.gamedev.net/reference/articles/article959.asp, March 15th, 2000.

[Laramée03] Laramée, F. D., "How Developers Get Paid: The Retail Market for Games," in Secrets of the Game Business, Charles River Media, 2003.

[McGilvray03] McGilvray, M., "The Producer: Friend or Foe?" in Secrets of the Game Business, Charles River Media, 2003.

[Perkins03] Perkins, T., "Customer Support in Massively Multiplayer Online Games and Elsewhere," in Secrets of the Game Business, Charles River Media, 2003.

[Sloper02] Sloper, T., "Following Up after the Game is Released: It's Not Over When It's Over," in Game Design Perspectives, Charles River Media, 2002.


Chapter 1.5: The Producer, Friend or Foe?

Overview

Mitzi McGilvray

<mitzi@slamdunkproductions.com>

The role of the producer varies depending on whether the producer works for a publisher or a developer. This article deals specifically with those producers who are employed by publishers.


Step 1: Establish a Relationship with Your Producer

By establishing a positive relationship with a producer, you are taking the first important step toward a successful relationship with a game publisher. Prior to having a deal with a publisher, a producer can:

  • Recommend you for a project he has. When a producer has an upcoming project, he will be on the lookout for a good development team. He will typically have two to three developers in mind whom he will contact to get proposals.

  • Recommend you to other producers within his company. The producer will know which projects are getting funded and are in need of a developer. If you are on good terms with him, he might recommend you to other producers.

  • Help you prepare for a successful pitch to the publisher. The producer can provide you with document templates and sample information to help you prepare the most effective pitch possible.

  • Help you with key introductions within his company. By introducing you to key decision makers within his organization, he can help you extend your network throughout that company. Those relationships might even outlive the producer's employment with that publisher.

  • Alert you to opportunities for contracts or product proposals. The proper timing can significantly increase your odds of obtaining a contract with a publisher. Knowing when a publisher is looking for developers and what types of titles they are looking to publish will help you focus your presentation or pitch.

Once you have inked a deal with a publisher, the producer assigned to you can help you with the following:

  • Put together the perfect project plan. Most publishers have approved examples of technical designs, game designs, schedules, and budgets. Having these available prior to starting your work on these deliverables will help ensure a quick approval and a happy publisher. If a producer does not offer these documents, ask for them.

  • Proactively keep you on good terms with the publisher. If you succeed, he succeeds. He will review your progress, alerting you to any potential issues in terms of milestone approvals, direction, or impending changes with the publisher.

  • Get you a quick sign-off and prompt payment for your milestones. Assuming you meet your milestone, most producers can expedite approvals and check deliveries. Remember however, that getting you an expedited payment is extra work for a producer.

  • Gain support for your product from other divisions. A good producer knows how to get the most from the various other organizations within his company. This can translate to increased marketing, public relations, and sales support.

  • Recommend you for future work. Do a good job and maintain a positive working relationship, and he will recommend you for additional work.

Unfortunately, not developing a positive working relationship with a producer will affect both your short- and long-term business goals. A negative relationship with a producer might:

  • Make it difficult or impossible for you to ever work for that publisher or even perhaps other publishers as long as he is employed there. This situation can cost you additional work with that publisher and any future publisher for whom he might work.

  • Critique every milestone approval to the point that it is impossible for you to successfully complete your project. A producer can make a developer's life miserable if he so chooses. Having very well-defined milestones and a solid, approved project plan can help prevent this.

  • Get your project canceled. A disenchanted producer can get your contract cancelled in the hope that a different developer can do a better job.

  • Speak poorly of your company to his peers. The producer network is very tight. Most producers have worked for several publishers and have a solid network of peers. Obviously, it is important to always maintain a positive relationship with your producer. This is especially important when things go wrong, as the producer can help you stay in good graces with the publisher. This might enable you to work with that company again in the future.


Step 2: Plan for Checks and Balances

It is important to note that the producer is probably not the final decision-maker within his organization. Therefore, you should view him as the guardian for all that relates to his projects. Many larger companies have a series of checks and balances in place. The producer must work within this system in order for his projects to run smoothly. These checks and balances typically include:

  • Technical directors. These individuals will help ensure that a developer is technically able to undertake a specific project.

  • Sales and marketing. This team will evaluate whether a product is marketable. Although, it goes without saying that a game must look great and play well, there are a host of other factors that sales and marketing must consider when evaluating the marketability of a game. Some of these factors include market condition, competition, and timing to market.

  • The Executive staff. This group will make sure the product is consistent with the overall goals and guidelines of the company.

  • Legal/business affairs. This organization will check to see that the deal meets corporate standards, and approve any contracts prior to signing them or beginning work.


Step 3: Know Your Producer

A producer is typically someone who likes to get involved in all aspects of the game development process. Recent information from Melanie Cambron (a.k.a. Game Recruiting Goddess) shows that 87% of all producers in the United States are male (Figure 1.5.1a). There are numerous debates as to why there are not more female producers in the business; however, please note that this article is written by one of those few women who have chosen game production as a career.

Click To expand
Figure 1.5.1a: Percentage of male and female producers.

As you can see in Figure 1.5.1b, the average, experienced California-based producer earns nearly $100,000 a year. To put this in perspective, this compensation is about equal to what an entry-level attorney would make in the same region.

Click To expand
Figure 1.5.1b: Producer compensation.


The Production Hierarchy

Understanding the hierarchy of the various production roles will help you decide where to invest your efforts in terms of networking, relationship building, making product pitches, and such. It will do you no good to invest time and effort in building a business relationship with someone who cannot influence decisions. It is important to keep in mind that the roles of a producer vary greatly by publisher. In some organizations, the producer is entrusted with a great deal of power and authority. In other companies, that level of power might only be available to the executive producer or vice president of development. Typically, the level of responsibility is directly related to the salary the producer earns. Do not let the title fool you, as each game company uses the "producer" title differently. Examples might be seen in a smaller game company where the title of executive producer is assigned. Those individuals might have responsibilities matching that of a producer at a larger publisher. Regardless of title, the producer is ultimately the person responsible for a title coming in on time and on budget. He will receive either the blame or credit for these accomplishments.

The organization chart shown in Figure 1.5.2 is an example of a typical production hierarchy. Expect this to vary by publisher.

Click To expand
Figure 1.5.2: Production hierarchy.


The Five Types of Producers

Producers can be categorized into five distinct personality types. You can expect some overlap; however, these generalizations should help you in choosing the best way to deal with producers.

The five types of producers are the micro manager, the macro manager, the team leader, the creative producer, and the game designer.

The Micro Manager

You will find this producer to have excellent project management skills. He is very detail-oriented and has a keen understanding of the processes involved in game production. The micro manager is sometimes better at identifying problems than at solving them, but given the proper authority and pre-production time, he will typically plan for contingencies and properly assess risk, thus saving you from unexpected problems later on.

To make the most of your relationship with this producer you must use his passion for organization by involving him early in the planning stages. This producer is the master of follow-up and follow-through. He will read, digest, question, and reread every document you submit to him, especially schedules and plans. Therefore, have him provide templates and additional assistance in preparing these documents throughout the production process.

The Macro Manager

This individual is all about the big picture. He is a visionary, a franchise builder who might begin planning for a sequel long before the first title is completed, and is typically quite adept at problem-solving. This is because he constantly has his eye on the prize.

The macro manager has a solid understanding of all aspects of the videogame business and will be a valuable asset in navigating the publisher's organization. In working with this producer, you will obtain the best results by keeping your own focus on the details and letting him take care of the long-term plans. Remember that you must make that first game a hit before anything else matters.

The Team Leader

This producer typically gains the trust and respect of the development team by rolling up his sleeves and providing value wherever he is capable. He chooses to lead by example and strives to be liked by everyone on the team. The team producer can be easily spotted, as he can be found testing code for programmers at midnight, having coffee with the execs at 8 a.m. in an attempt to gain more budget money, and taking the art team to lunch. All of this is, of course, in addition to his regular producer job.

In working with the team producer, remember that it is important for him to constantly feel as if he is providing "added value." Therefore, take advantage of his desire to help and use his (often considerable) expertise wherever appropriate.

The Creative Producer

The title says it all. This individual comes from a creative background. He quite likely has very strong game design or graphic design skills. He thrives on the creative aspects of game production and does his job because of his love for games.

You will find that the creative producer provides invaluable contributions in terms of driving the vision of the product. Harness this energy early and you can have a solid foundation for building a winning product.

The Extreme Producer

Sadly, almost everyone has encountered this producer type, and his presence at a potential publishing partner can have long-lasting effects on your business.

Everyone knows how to spot the extreme producer, by the trail of battered and abused developers with nothing to show but cancelled games. Unfortunately, you might not have a choice about working with this producer. If you do encounter the extreme producer, you can get the best results by using an approach of consistency, respect, and thorough documentation.


Case Studies

In order to gain a practical perspective about the varying roles of a producer, we interviewed two veteran producers whose experience includes working for publishers such as 3DO, Activision, Eidos, Electronic Arts, and Midway. The individuals interviewed are Bill Hindorff and Mike Kawahara. Both of these producers have been in the business since the early days, and have in excess of 40 years of game production experience between them.

Quality, Not Quantity

A producer is typically in charge of three to five projects at any given time. A project can be defined as a unique title for a specific platform. If a project is small in scope or duration, the producer might have responsibility for even more, or, depending on the publisher he works for, he might have as many as 10 to 20 titles under his domain.


A Producer's Day

As you can see in Figure 1.5.3, a producer's day is typically spent making sure his projects are progressing according to plan. Topping the list of activities in his day is most definitely communication. These communications vary greatly depending on the status of the product and might include:

  • Bug list reviews. This typically happens first thing in the morning to understand the state of products in the alpha or beta phase.

  • Milestone schedule review. In order to keep on top of project status, a regular review of the milestone status is conducted by the producer with the developer.

  • Marketing plan updates. Keeping abreast of the status of marketing efforts and keeping the marketing group informed of how the game is coming along will help ensure the product gets the proper attention when it ships.

  • Product pitches. The product pitch process seems never ending to most producers. It is a constant cycle of creating and pitching project plans. Many of these pitches are built with the help of the targeted developer.

  • Negotiations. Negotiations are a large part of the producer's day. This might include negotiating additional features for his game, a multi-million dollar development deal, or convincing the test department to close a particular bug.

  • Product review. There is a constant stream of meetings designed to update all stakeholders within a producer's organization on the status of his titles. The product review meetings are most important because each product and its status are discussed.

Click To expand
Figure 1.5.3: A producer's day.

Communication Is Key

It is important to note that the more effective producers will put communication with the developer and testers at the top of their priority list. Each producer interviewed told stories of inheriting troubled projects in which the developer was months behind. These projects were turned around in every instance because more effective communication was made a priority. Developers cannot succeed if they do not know how to meet the objectives of their publishers. Further, developers also need to feel that the project they are working on has visibility with their publisher and that their efforts will be rewarded at the end by effective marketing and sales programs.

The rest of the producer's day is split between reviewing schedules, seeking out and solving problems and, of course, playing games. Each producer interviewed acknowledged that playing theirs and competitive products was always something they wished they had more time to do, but that this typically gets pushed aside because more immediate problems or priorities demand their attention.

A Producer's Dream

In addition to their technical expertise, there are several other attributes that a producer will look for in a development team.

  • Communication. Effective communication was most definitely at the top of the list. Being able to know when and how to communicate are essential traits in a developer.

  • Passion for making games. If you do not love what you are doing, do something else.

  • Willingness to take and act on feedback. Everyone needs to be able to take criticism: it's what makes good games better.

  • Objectivity. Know when to escalate issues such as when a product is in trouble, an individual is not meshing with the rest of the team, or a key milestone date is not achievable. When you lose objectivity, things can quickly get off track. For example, one story shared during the interview detailed how a development team was falling apart. Milestones were being missed, the team members were at odds with each other, and the lead developer had put in his resignation notice. Why? Because one of the key contributors on the development team was not capable of doing his job. Eventually, that producer and the programmer in question were fired. The project had already missed too many key dates and was ultimately cancelled.

Words of Wisdom

When asked to share their best advice with the development community, they had some excellent words of wisdom to keep in mind:

  • Say what you are going to say. Say it. Say what you said. This is a lesson taught in every communication class, but cannot be reiterated enough when you are dealing with game development. Communication, follow-through, and follow-up are essential in a successful producer/developer relationship.

  • Plan for everything to fall apart. Create a solid plan in advance; plan for it to change and plan for everything around it to go wrong. Producers are keen risk assessors. If they do not feel like you have planned for all contingencies, they will not believe you are capable of succeeding. As you see the need for change, raise the flag high detailing exactly what the costs of this change might be to the schedule, budget, and team. Plan to do this early and often.

  • It is more work to make a bad game than a good game. Once the plans are set in motion, each time a producer feels he needs to tune, tweak, and polish the design, art, or gameplay, the bigger the opportunity for disaster. With the proper team in place, much of this polishing will occur seamlessly with only the occasional redirect. If a producer gets into a pattern of constantly changing or redirecting resources, the budget and schedule (and typically the game quality) will quickly get out of control.

  • Throwing more resources at a problem will not always fix it. There is a critical path for everything. Do not shift resources from one project to something else (that you deem higher priority) and expect to make up that time later. These antics drive producers absolutely crazy.

  • Never throw good money after bad money. Some games should never make it to market. This determination might not be accessible until a significant investment has been made in the development process. Cancelling those games as soon as this fact is obvious is not only prudent for the publisher, but also very healthy for the development team as they can focus on more positive work. Every producer can tell stories of how they witness millions of dollars being thrown at a project that will obviously either never make it to market, or will never succeed in the market.

  • Success has many parents, failure is an orphan. If you have a successful project, people will come out of the woodwork to take credit. But if your project fails, only the truest friends will stand by your side.


Conclusion

If you are trying to get your game produced by a publisher, get to know one or two of the producers at each of your target publishers. Stay in regular contact with them so they know your availability and projects. Frequent communication keeps you at the forefront when they are making a list of potential developers for their projects.

Once you have your product placed at a publisher, establish and maintain a positive relationship with your producer. Getting to know him will help you get the most out of that relationship.

Finally, as you are nearing the completion of your project with that publisher, make sure the producer knows you are ready to take on more work.


Chapter 1.6: The European Challenge in Videogame Software: The " French Touch " and the " Britsoft Paradox "

Team LiB

Chapter 1.6: The European Challenge in Videogame Software: The "French Touch" and the "Britsoft Paradox"

Overview

Philippe Larrue, William Lazonick, and Mary O'Sullivan

INSEAD (The European Institute of Business Administration)

Corresponding author: <william.lazonick@insead.edu>

In the year 2001, the French publisher, Titus Interactive, acquired a controlling share in the U.S.-based company Interplay. At the time of the acquisition, Interplay was one of the best-known PC games developers and publishers, with 1998 sales of over $115 million, a solid game development base of five in-house studios, and about 50 titles in the pipeline for the year 1999/2000. Titus was about the same size as Interplay at the time of the acquisition and the fourth-largest publisher in France.

During the 1996 to 2001 industry cycle, a number of French publishers experienced rapid growth, both internal and through acquisitions, that permitted the French industry to take third place in global revenues after Japan and the United States. Pushed back to fourth place was the British industry, notwithstanding the facts that the British have a larger home market for videogames than the French and a much more extensive and successful developer base.

In a recently released report on "creative industries," the UK Department of Media, Culture and Art has acknowledged the existence of what is now being called the "Britsoft paradox" [UKMedia01]. In an industry in which "everything comes down to games," why didn't the "Britsoft" advantage translate into the rapid growth that the French achieved? And how sustainable is the French competitive advantage in publishing? Our ongoing research on the European videogame industry will hopefully provide some robust answers to these questions as the next cycle of the industry unfolds. As a prelude, in this short article, we survey the competitive strategies of some of the major British and French players in the last cycle.


The European Challenge

The emergence of a number of strong European videogame publishers over the past few years represents a significant change in international competition in an industry that previously had been dominated by companies based in the United States and Japan. Indeed, in many accounts of the evolution of the videogame industry, one gets the impression that European capability in supplying the videogame market is nonexistent. For example, Steven L. Kent's The First Quarter: A 25-Year History of Videogames [Kent00] contains virtually no references to European individuals or companies—a somewhat ironic omission in view of the fact that the preface to the U.S. edition of the book is written by Peter Molyneux, a well-known videogame developer based in Britain.

The Competitive Landscape

As shown in Table 1.6.1, in 2001, of the top 15 independent (i.e., non-console producing) videogame publishers ranked by revenues, six were American, four were Japanese, four were French (Infogrames, Ubi Soft, Titus Interactive, Vivendi Universal Publishing), and one was British (Eidos) [Saigol00].

Table 1.6.1: Top 15 Independent Videogame Publishers of 2001 Information adapted from the Financial Report 2000/2001 of UbiSoft.
# | Publisher |  | Game Sales ($m) | Game Sales in Group | Main Games
1 | Electronic Arts | USA | 1,760 | 100% | FIFA, Sims, Madden, NBA, NHL, Medal of Honor
2 | Konami | Japan | 1,181 | 65% | Metal Gear Solid, Silent Hill, ISS
3 | Infogrames | France | 889 | 100% | Driver, Looney Tunes, Alone in the Dark, V Rally
4 | Square | Japan | 760 | 99% | Final Fantasy, The Bouncer, Parasite Eve
5 | Activision | USA | 594 | 100% | Toy Story, Tony Hawk's Pro Skater, Spiderman, Quake
6 | Capcom | Japan | 483 | 70% | Devil May Cry, Street Fighter, Resident Evil, Onimusha
7 | VUP | France | 470 | N.A. | Warcraft, Diablo, Starcraft, Crash Bandicoot, Spiro
8 | Take 2 | USA | 385 | 100% | Oni, Austin Power, GTA, Midnight Club, Spec Ops
9 | THQ | USA | 374 | 100% | Simpsons, Evil Dead, WWF, Ring Rats, Red Faction,
10 | Ubi Soft | France | 351 | 100% | Rayman, Tom Clancy's Rainbow Six, The Settlers
11 | Eidos | UK | 285 | 100% | Tomb Raider, Commandos, Soul Reaver
12 | Namco | Japan | 256 | 30% | Tekken, Ridge Racer, Soul Calibur, Pac Man
13 | Acclaim | USA | 242 | 100% | South Park, Dave Mirra Bmx, NFL Quarterback Club
14 | Midway | USA | 207 | N.A. | Ready to Rumble, SpyHunter, NFL Blitz, Gauntlet
15 | Titus Interactive | France | 164 | 100% | Baldur's Gate, Giants, Icewind Dale, Top Gun
Source: [UbiSoft01]

This competitive configuration is new: although most of the leading French publishers have been in business since the 1980s, British companies such as Ocean and Centre Gold dominated the European videogame industry at the beginning of the 1990s. In 1993, the French Minister of Culture, Jack Lang, cited videogames as an example of an industry in which French companies were in danger of being gobbled up by foreigners [DeGasquet93a]. As late as 1997, there were still no French companies among the top 15 independent publishers, with Infogrames ranking 16th, Ubi Soft 20th, and Titus Interactive 27th[Barnu98]. Neither Cryo nor Vivendi Universal Publishing (at that time Havas Interactive, which was only involved in edutainment) could be found among the top 30 publishers. In 1997, Eidos held 11th position as a result of its acquisition of a number of British companies, including its 1996 purchase of the largest listed British company, Centre Gold, which was in the process of developing Tomb Raider.

If French companies have now surpassed their European rivals as publishers, the British still remain leaders in videogame development. In 1999, at the peak of the last industry cycle, there were about 250 development studios in Britain compared to about 60 in France. British studios developed one in four games sold in Europe and one in eight sold in the United States [ELSPA99]. Within Europe, British developers accounted for 30% of the games sales on the French market [ELSPA99], while French developers could claim only 5% of the sales of the top 100 games in the UK [Screendigest00]. Of the "top 100 games of all time" for PCs compiled by PC Gamer, 53 were of U.S. origin and 32 came from Britain [Jenkins99].

Risk and Reward

As the financiers of game development and commercialization, publishers bear most of the risks in the industry, but also stand to reap the most profits. There are no solid data currently available to calculate the distribution of revenues between publishers and developers in the videogame industry [Sanghera01]. Simon Cook, a former industry participant, asserted that the products of the British game development sector generated sales of $6.5 billion in 1999, of which only $500 million flowed back to the creative community in Britain [Barrie99].

When in 2000, even Eidos was having severe financial difficulties, the British Culture Minister, Janet Anderson, challenged the City to get involved in the British videogame industry by arguing that, with financial backing, the nation's strong capabilities could be translated into profits [M2Comm00]. This purported failure of British financial interests to invest in small but creative firms has long been bemoaned in British policy circles. And, as we shall see, in the last half of the 1990s at least, it would appear that bullish financial markets provided much more support for the growth of French videogame companies than they did for their British counterparts.


Leading French Companies

The following are a few of the leading French publishers in the videogame market.

Infogrames

Leading the French challenge has been Infogrames, a company whose origins in the early 1980s were, in retrospect, atypical of the European industry more generally. The founders of most early European firms were programming prodigies who were devoted to gaming, and who produced their first games in their bedrooms or family garages. In contrast, Bruno Bonnell and Christian Sapet created Infogrames as a business in 1983 with the idea of developing and commercializing games for the mass market, not for hardcore gamers [Doward99]. In 1993, Infogrames, still struggling to survive with its 100 employees, received financial backing from Pathé Interactive (a joint venture of Philips and Chargeurs) and a French venture capital company. Supported by its new partners, Infogrames floated an IPO in December 1993 that broke existing Second Marché records; offering just 10% of the company's shares, the Infogrames IPO was oversubscribed 530 times [DeGasquet93b].

Cryo Interactive

Philippe Ulrich was a self-made programmer who was part of a development team hired by Virgin to work on a game based on the Dune license. After many delays, in late 1991 the game became a major success. Using the proceeds from the Dune sales, Ulrich, in partnership with a former Virgin executive, Jean-Martial Lefranc, created Cryo in early 1992. Over the next three years, Cryo grew rapidly as a developer, and in 1995 the company decided to make the costly and risky transition to publishing, with Financière Lagache (part of LVMH) taking a 20% stake. Cryo published its first games in 1996, and in 1998 listed on the Nouveau Marché, with its offering being oversubscribed 46 times. In 2000, the online gaming subsidiary that Cryo had created in 1997 also went public on the Nouveau Marché.

Ubi Soft

Founded by the five Guillemot brothers, Ubi Soft entered the videogame industry in 1986 as a French third-party distributor for games developed abroad. Through its control of distribution networks, Ubi Soft began publishing games developed by external studios, and in 1994 founded its own development studios. Thus, while the growth trajectory of most of its competitors was from development to publishing, Ubi Soft expanded in the opposite direction. Its 1994 blockbuster, Rayman, provided resources for Ubi Soft's further expansion, which included high levels of investment in R&D for development tools. In 1996, Ubi Soft was listed on the Second Marché, with its shares being oversubscribed 282 times, second only in demand for shares to the Infogrames IPO of 1993.

Titus Interactive

Titus Interactive was founded in 1985 by brothers Eric and Hervé Caen. The following year, Titus developed its first PC game, and in 1989 became one of the first European companies to embark on console game development, becoming a licensee for Sega (1989), Nintendo (1990), and Sony (1994). In 1996, Titus listed on the Marché Libre (the over-the-counter market), but in 1997 transferred its listing to the Nouveau Marché. The acquisition of Interplay and Virgin Interactive in 1999 transformed Titus into a full-scale publisher, with its release schedule of 50 games per year placing it third among the French videogame companies. The Caen brothers remain Titus's dominant shareholders and retain top management positions. Such is also the case at Infogrames (Bonnell and Sapet), Ubi Soft (the Guillemot brothers), and Cryo—at least until its bankruptcy in July 2002.


Leading British Companies

Eidos

Eidos was founded in 1990 as a video compression R&D company. In 1995, Eidos received a cash infusion from an outsider to the videogame industry, Charles Cornwall, a 30-year-old South African who left his job in the City to run Eidos. In 1995, Eidos acquired Domark, Europe's fifth largest developer/publisher, as well as two studios, Simis and Big Red, which developed games for Domark. With the Domark acquisition, Ian Livingstone, a veteran in British game development (including books and board games), joined Eidos, and served as the company's chairman for several years. In 1996, Eidos acquired Center Gold, Britain's largest listed computer games company, along with its two development teams, Core Design and US Gold, and became the owner of Tomb Raider, at that time a title among others, still in development at Core Design. Tomb Raider, published in November 1996 on PlayStation and PC, was an immediate success and triggered a series of lucrative sequels that provided the financial foundation for Eidos' growth in the late 1990s.

Argonaut Software

In 1982, Jez San, then 16 years old, founded Argonaut as a software consultancy firm. During the last half of the 1980s and first half of the 1990s, Argonaut financed itself internally, with funds generated from successful games (e.g., Croc) or from Argonaut's very lucrative technology arm (a subsidiary that had in 1993 produced the powerful "SuperFX" chip for SNES Nintendo console's games). From 1996 to 2000, the company received around £8 million from external partners, two venture capital firms, New Media Investors and Apax Partners, and the Japanese videogame publisher Koei. In 2000, the company was floated on the London Stock Exchange, raising £20 million. San remains the CEO and principal shareholder of the company he founded two decades ago.

Rage Software

In 1991, 11 people from Liverpool formerly with the videogame company, Ocean, pooled their redundancy pay to develop a 3D soccer game called Striker. They formed Rage Software to market the game, and Paul Finnegan, an Ocean co-founder who had worked for other software companies for several years, came on board to manage Rage. Striker was a smash hit, selling 1 million copies in two years. In 1994, Rage was acquired by BCE (Bristol Coin Equipment), a quoted leisure company with interests in amusement arcades and snooker equipment listed on the Unlisted Stock Market (USM). As the focus of BCE's business shifted to computer games, the group took back its name "Rage Software" in 1996. Finnegan still remains the managing director of Rage.

SCi

In 1988 Jane Cavanagh, a former British Telecom employee, founded SCi as a developer and publisher. For six years, the company remained small, employing between 20 and 30 people and publishing a few titles for PCs in Europe. In the mid 1990s, SCi's management recognized that the increased cost of developing videogames and the intense competition to commercialize them meant that it could no longer remain a small publisher. With a profitable track record, SCi became the 200th company listed on the Alternative Investment Market (AIM), the London Stock Exchange's market for smaller, growing companies.


The " French Touch? "

Team LiB

The "French Touch?"

Although they had already grown substantially since their inception, the scale of activities of the top four French companies—Infogrames, Ubi Soft, Titus, and Cryo— took off once they went public. With their shares highly valued, these companies were able to grow through acquisitions. Such was especially the case of Infogrames, which acquired Ocean (UK) in 1996, Gremlin (UK), GT Interactive (US) and Accolade (US) in 1999, and Hasbro Interactive in 2000, along with many development studios (e.g., Paradigm, Beam, DID) and videogame distribution arms (e.g., Philips Media). The very high valuation of Infogrames' stock provided the company with an acquisition currency, using either shares directly to make the acquisitions, or cash that was raised on the stock market or through the issue of convertible bonds. From €54 million in sales and 194 employees in 1995, Infogrames grew more than tenfold to €674 million in sales and 2150 employees in 2000. Many financial analysts gave high marks to Infogrames' management for its expertise in negotiating, integrating, and restructuring acquisitions.

While Titus Interactive has not grown as much as Infogrames, it concluded a number of acquisitions in 1999 and 2000, including two large videogame companies, Virgin Interactive (Britain) and Interplay (USA), paying for both companies in shares, and a number of small developers abroad, including Digital Integration (Britain), Blue Sky (USA), and Black Cat (Britain). Largely through these acquisitions, Titus grew from 124 employees in 1999 to 691 in 2000.

Ubi Soft followed a different strategy, mainly relying on organic growth rather than acquisitions. The company devoted large portions of its resources to expand its development capacity through hiring, with its development staff increasing from 23 employees in 1994 to 268 in 1996 and about 1100 in 1999. Since 1999, however, its growth has been augmented by the acquisition of several development studios, including Sinister Games (USA), Red Storm (USA), and TLC (USA). In 2000, Ubi Soft's development staff reached 1300 people. Ubi Soft raised considerable amounts of funds from the stock market to finance its internal growth and has also used its stock as an acquisition currency to cover most of the value of its acquisitions.

Cryo also acquired a few small developers, publishers, and distributors—for example, Dreamcatcher (Canada) and Dark Horse Interactive (USA)—and used funds raised on the stock market to finance these acquisitions and its online spinoff, CryoNetworks.


The " Britsoft Paradox? "

Team LiB

The "Britsoft Paradox?"

In Britain, as in France or in the United States, it became obvious in the mid 1990s that the ability to raise funds on financial markets was essential to compete in a context of accelerating consolidation. In clear contrast with French publishers, however, the leading British publishers did not implement an aggressive external growth strategy. They performed few significant acquisitions and raised much less capital than the French publishers. As a result, in 2000, the revenues, profits, and head counts of the leading British companies were much smaller than those of their French counter-parts (Table 1.6.2).

Table 1.6.2: Revenues, Net Profits, and Employees of Leading French and British Videogame Companies, in millions. Information adapted from Thomson Analytics database [Thomson].
 | Revenues (€m) |  |  |  |  | Net Profits (€m) |  |  |  |  | Employees
 | 1996 | 1997 | 1998 | 1999 | 2000 | 1996 | 1997 | 1998 | 1999 | 2000 | 1996 | 1997 | 1998 | 1999 | 2000
Infogrames | 57.02 | 100.38 | 223.76 | 306.13 | 521.59 | 3.12 | 5.95 | 12.76 | 20.28 | -24.60 | 485 | 503 | 583 | 1186 | 2150
Ubi Soft | 37.43 | 52.33 | 96.48 | 132.58 | 186.50 | 1.32 | 2.40 | 4.43 | 6.26 | 10.94 | 393 | 573 | 933 | 1474 | 1625
Cryo | 8.31 | 14.84 | 23.72 | 36.43 | 50.09 | -0.10 | -0.95 | 0.87 | 1.92 | 10.62 | - | 180 | 193 | 236 | 455
Titus | 6.64 | 21.24 | 7.94 | 26.54 | 142.81 | 0.12 | 1.43 | -2.94 | 1.36 | -27.57 | - | - | - | 124 | 691
Kalisto | n.a. | 7.13 | 8.24 | 16.48 | 2.86 | 0.50 | 1.20 | 0.29 | 1.70 | -28.10 | 46 | 136 | 176 | 240 | 270
Eidos | 3.48 | 105.96 | 216.98 | 338.34 | 324.72 | -1.83 | 8.66 | 17.18 | 32.26 | 42.01 | - | - | - | 458 | 485
Rage | 11.54 | 9.98 | 5.05 | 13.52 | 6.66 | -3.64 | -22.61 | 1.32 | 4.06 | -4.15 | - | 185 | 99 | 103 | 165
SCi | 1.29 | 7.60 | .30 | 12.30 | 5.28 | -4.93 | 1.81 | 4.65 | 2.58 | -4.15 | - | 79 | - | 38 | 38
Empire | - | 13.30 | 17.40 | 11.80 | 17.40 | - | 0.20 | 0.20 | 0.30 | -2.80 | - | 66 | 75 | 71 | 75
Argonaut | - | 7.70 | 8.90 | 3.80 | 7.00 | - | -1.00 | -1.30 | -4.10 | -1.00 | - | - | - | 109 | 141
Warthog | - | - | 0.50 | 1.50 | 4.00 | - | - | 0.00 | 0.50 | 0.30 | - | - | - | - | 170

In the case of Eidos, the leading British publisher, the company did not perform significant acquisitions apart from the seminal ones through which it transformed itself into a videogame company in 1996. Subsequently, it implemented a strategy of "cherry-picking" industry talent by taking minority stakes in many small development companies; for example, Innerloop (Norway, 25%), Clockwork (Britain, 25%), Pure (Britain, 26%), Elixir Studios (UK, 5%), Pyro (Spain, 25%). Typically, these investments were connected to a publishing deal, sometimes on an exclusive basis. This arrangement gave small developers the benefit of Eidos' financial support for game development while enabling them to remain independent. For Eidos, the arrangement helped to ensure that the development team would remain intact and motivated, outcomes that would not necessarily be forthcoming when the autonomy of the team was challenged in a full acquisition. At the same time, Eidos thought that minority investments would give them greater control over the studios than a regular advance on royalties; a notion that the company subsequently determined to be ill-founded. Since 1999, Eidos has not been involved in any acquisition activity, in part because the strategy of minority acquisitions has not lived up to expectations, and in part because Eidos has faced severe financial problems. Indeed, since 1999, Eidos has been more an acquisition target for other companies—particularly the French—than a potential acquirer itself [Paquette02].

Apart from Eidos' minority stakes in developers, British publishers made only a few small acquisitions in the last cycle, usually of companies within the broad British development base. Argonaut acquired three development studios: LTStudios (Britain), Just Add Monsters (Britain), and Particle Systems (Britain). Gremlin took over three development studios as well: Dream Weavers (Britain), DMA (Britain), and Mainstream Interactive (Australia). SCi took minority stakes in two developers, Stainless Software (Britain, 25%) and Pivotal Games (Britain, 10%) and acquired one small publisher, Actualize (Britain). Finally, Rage, as part of its strategy to make the transition to publishing, has increased its development capacity by acquiring or taking minority stakes in about eight studios, among them Splinter (Britain), DID (Britain), Wayward Design (Britain), and Denki (Britain, 20%).

As a result, while the French publishers were climbing the ranks of the world's top independent publishers, the British publishers saw only modest growth. After losing €5.4 million on sales of €4.6 million in 1998, SCi implemented a radical change in strategy towards "pure publishing," cutting its total employment to 38 by shedding its internal development capacity. Rage is still struggling to achieve its transition to publishing; in recent years it has vacillated between being an external development studio and an independent publisher. Argonaut is one of the world largest independent developers, but does not intend to switch to publishing.


The Role of National Stock Markets

In a given industry at a given time, many factors can limit the growth of any particular company relative to its competitors. Growth is always a risky process, and the management of some companies might purposefully avoid it. In the French videogame industry, for example, Delphine Software, a highly regarded development studio, has remained small with about 35 employees over the past decade, easily finding publishers and getting favorable terms for the two games it produces each year. Delphine's strategy can be contrasted with that of Kalisto, which increased employment from 46 in 1996 to 270 in 2000 before going bankrupt the following year. For companies that do pursue a growth strategy, success or failure will ultimately depend on the investment strategy and organizational structure of the particular company.

Nevertheless, the British-French comparison over the last cycles suggests that the national context can make a difference. It is clear that the British had a superior developer base, yet it was the French-based companies that grew. In both countries, the leading firms had long-established roots, at least given the young age of the industry in question. There is no compelling evidence that the French were better managers than the British. In the case of the videogame industry, what the French had that the British lacked was an ebullient stock market that bestowed far higher price-earnings ratios on the French listed companies than on the British [Schroders01], enabling the leading French companies to raise huge amounts of capital through share issues or convertible bond issues without too much dilution, as shown in Table 1.6.3. As a result, these companies could engage in a much more aggressive acquisition strategy than their British competitors, paying with the cash raised or directly in highly-valued shares.

Table 1.6.3: Cash Raised Through Share Issues and Long-Term Debt Issues by Leading French and British Videogame Companies, in €millions. Information adapted from Thomson Analytics database [Thomson].
 | 1994 | 1995 | 1996 | 1997 | 1998 | 1999 | 2000 | 2001
Infogrames | 12.17 | 2.10 | 100.82 | 70.48 | 17.51 | 333.54 | 334.00 | 52.2
Ubi Soft | n.a. | n.a. | 3.57 | 13.95 | 29.88 | 73.05 | 60.42 | 0.10
Cryo | n.a. | n.a. | n.a. | n.a. | 24.43 | 19.00 | 40.21 | 0.00
Titus | n.a. | n.a. | n.a. | n.a. | n.a. | n.a. | 165.66 | 0.00
Total | 12.17 | 2.10 | 104.39 | 84.43 | 102.25 | 425.59 | 600.29 | 52.3
Eidos | 0.69 | n.a. | 6.53 | 58.62 | 49.05 | 1.25 | 6.61 | 1.28
Rage | 0 | 16.27 | 2.8 | 0 | 0 | 0.02 | 21.59 | 0.10
SCi | n.a. | n.a. | n.a. | 6.4 | 1.65 | 0 | 33.58 | 0.00
Empire | n.a. | n.a. | n.a. | n.a. | n.a. | n.a. | 9.76 | 6.05
Total | 0.69 | 16.27 | 9.33 | 65.02 | 50.70 | 1.27 | 71.54 | 7.43

Within Britain, this disadvantage is recognized, and is attributed to an aversion of "investors" to the videogame industry, or even to high-tech industry in general, especially when it is based on small-scale enterprise. For example, Peter Molyneux, a famous British developer and CEO of Lionhead, argued in The Financial Times that he "would love Britain to be at the forefront of the games sector. There is no doubt of the impact of British designers. Our problem is shortage of investors" [Grande01]. One of the very few City analysts to follow the game industry, Nick Gibson from Durlacher, expressed similar views: "There is no doubt that British investors are more conservative than their continental and U.S. counterparts and it could be argued that this has much to do with their lack of understanding about how the games industry and games companies work" [Gibson00]. In the previously mentioned "creative industries" report, the British Department of Culture, Media and Arts stated: "British innovation in interactive leisure software development has not been matched by a British willingness to invest. The fact is, the London Stock Exchange is not prepared to back 'Britsoft' with the same vigor as do NASDAQ, the Nikkei, or the Bourse de Paris for their respective industries" [UKMedia01].


Conclusion

Within France, videogame stocks performed better during the last cycle than other French high-tech/IT stocks. For example, a mutual fund dedicated to videogame companies during that period ("Ifuel Equity Fund") was the most profitable European media and telecom private equity investment fund in 2001 [Morningstar02]. Yet in 2001 and 2002, the subsequent decline of French videogame stocks and the financial difficulties of some of the leading French companies, including Infogrames, raise questions about the sustainability of the French challenge, including whether the French companies have access to the committed sources of finance needed to remain world-class publishers. Speculative finance is not committed finance. It might well be that, for reasons that had little if anything to with the videogame industry, investors on the French financial markets were simply more speculative than their British counterparts. The experience of the French stock markets was in line with what is now seen as a worldwide bubble in technology stocks that coincided with the last videogame cycle. The British stock markets were not immune to this speculative fever, but they never became as "exuberant" as the French. There is much more research to be done on the European challenge in the videogame industry, and the rise of the French companies in the 1996 to 2001 cycle. However, our research thus far suggests that one should not reject the hypothesis that the substance—and sensitivity—of the "French touch" in videogames was a greater French propensity to stock-market speculation.


References

[Barnu98] Barnu F., "Le jeu vidéo pèse autant que Hollywood," L'Usine Nouvelle, June 11, 1998.

[Barrie99] Barrie C., "UK: how the British lost the game," The Guardian, May 27, 1999.

[DeGasquet93a] de Gasquet P., "Face au boom des jeux vidéo—Jack Lang veut favoriser la pénétration des supports interactifs," Les Echos, January 22, 1993.

[DeGasquet93b] de Gasquet P., "Introduction le 16 décembre, Infogrames mise sur l'explosion du 'loisir interactif'," Les Echos, December 8, 1993.

[Doward99] Doward J., "Games never over for the video visionary," The Observer, October 10, 1999.

[ELSPA99] European Leisure Software Publishers Association, "UK market reaches new high," Press release, December 14, 1999.

[Gibson00] Gibson N., "France 3, England 0," available online at www.gamesinvestor.co.uk/Thinkpieces/thinkpieces.html, November 2000.

[Grande01] Grande C., "Game developers keep the Britsoft bandwagon rolling," Financial Times, January 10, 2001.

[Jenkins99] Jenkins D., "A Flurry of Euro-Stats," available online at www.gamasutra.com/newswire/eurospeak/19990521.htm, May 21, 1999.

[Kent00] Kent S. L., The First Quarter: A 25-year History of Video Games, BWD Press, 2000.

[M2Comm00] M2 Communications, UK Government, "Culture Minister challenges City to play the game . . .," M2 Presswire, July 11, 2000.

[Morningstar02] Morningstar, "Palmares 2001 Morningstar" available online at www.morningstar.fr/aboutus/press.asp, January 2002.

[Paquette02] Paquette E., "Ubi Soft sees Eidos as takeover target," Financial Times, May 13, 2002.

[RedHerring00] Red Herring, "Game publishers have stock stuffer appeal," December 20, 2000.

[Saigol00] Saigol L.,Larson P., "Infogrames presses on with Pounds 700m Eidos deal," Financial Times, July 10, 2000.

[Sanghera01] Sanghera S., "EU: survey—creative business—tracking the performance of creative sectors," Financial Times, March 13, 2001.

[Schroders01] Schroder Salomon Smith Barney, Video games—Game On!, Industry Report, February 2001.

[ScreenDigest00] Screen Digest, Interactive Leisure software: new platforms, new opportunities, Preview of Screen Digest/ELSPA research for ECTS, 2000.

[Thomson] Thomson Analytics database, http://analytics.thomsonib.com/

[UbiSoft01] Ubi Soft, FinancialReport 2000/2001, 2001.

[UKMedia01] UK Department of Media, Culture and Art, "Creative Documents: mapping industry," available online at www.culture.gov.uk/creative/mapping.html, 2001.


Section 2: Game Development Startups

Chapter List

Chapter 2.0: Introduction
Chapter 2.1: Development Misery and How to Avoid It
Chapter 2.2: Writing a Business Plan for a Game Development Startup
Chapter 2.3: Strategies for Staffing a Startup
Chapter 2.4: Financing from the Buyer's Side: Evaluating and Acquiring a Game Company
Chapter 2.5: Financing Projects and Startups
Chapter 2.6: Wireless Business Models
Chapter 2.7: Online Business Models: Using the Net for Profit
Chapter 2.8: Creating a Successful Freelance Game Development Business


Chapter 2.0: Introduction

The game development market is overcrowded. Of the thousands of games released every year, only a few hundred ever receive wide distribution, and a mere fraction of those earn significant profits. But by far the most common cause of failure of new studios (and of new businesses in any field, for that matter) is insufficient preparation.

Time and time again, successful programmers, designers, and artists have left their jobs to create high-profile studios, only to see their new companies fizzle for lack of business acumen. For those who create startups with little or no prior industry experience, the odds of success are even slimmer. If you decide to start your own company, make sure that you have access to the right management, sales, and legal resources—preferably among the shareholders. Then, prepare a solid business plan, identifying an opportunity that you and your team are uniquely qualified to profit from, and you will be on your way.

The articles in this section describe ways to improve your chances of starting a company that will beat the odds and achieve long-term success:

  • Freelance designer Sean Timarco Baggaley examines several of the common mistakes made by new developers and explains how to avoid them.

  • Freelance consultant François Dominic Laramée describes how to write a successful business plan.

  • Game industry recruiter Grant Stanton explains techniques for optimal personnel selection.

  • Veteran producer Tom Sloper explains the tricks and pitfalls of acquiring an existing game development company.

  • Independent studio owner Thomas Djafari describes the financing alternatives available to startups.

  • OpenPath Products CEO Johanna Wilson explains how to build a successful business in wireless game development.

  • Game writer and Grammy-nominated music video director Sande Chen describes the pros and cons of using the Internet as a distribution channel and a sales tool, based on the experiences of several companies.

  • And finally, François Dominic Laramée explains how to prepare for a career as a game development consultant and sustain your new business' success in the long term.


Chapter 2.1: Development Misery and How to Avoid It

Overview

Sean Timarco Baggaley

<stimarco@bangbangclick.com>

It is common to hear of the great successes in our industry: the celebrities who have made millions from games and produced strings of hits. Yet, success is often not a good teacher. Many early game developers were successful as much through blind luck and serendipity as through judgment and management skill. In the 8-bit days, when development teams could be as small as one person, "management" was a dirty word, and formal business practices, aside from hiring an accountant, were rare.

Today, the industry has changed beyond recognition. Even the smallest of mainstream games can cost millions of dollars, and a developer wishing to go it alone is embarking on a dangerous path.

Success is well advertised, but failure hires no PR companies. This is a shame as many of the mistakes made in our industry—and others—get forgotten in a rosetinted haze of hype. Yet, without being aware of the mistakes, it is difficult to learn from them.

The statistics—only one in five new businesses, regardless of industry or market, succeeds—speak for themselves. The games industry today is already a risk; going it alone adds even more.

And yet many people still do it for the same reason why people play national lotteries: the rewards might be rare, but when you win, you can really win.

Success speaks for itself, so this article highlights the mistakes, the traps, and pitfalls that can beset the unwary.


Doing It Yourself

Managing any business is very hard work and is not for everyone, and there's no shame in deciding against setting up on your own if you feel that it is not for you.

If you've decided to forge ahead, you must first look at the basic rules of business management that apply to all businesses. Surprisingly, many managers have never run a business before. There has to be a first time for everyone, but this is not an excuse to just dive in at the deep end to see if you know how to swim.

Do Your Homework

If you want to run a business, or even if you've been asked to do so, it is your responsibility to learn how to do it. This isn't as onerous as you might think: contrary to popular belief, there's no real mystery to being a good manager. (Being a great manager takes talent, certainly, but "manager" is a very broad job description. Great managers tend to specialize.) As with most jobs, the craft can be learned. Most adult education institutes offer courses in this area. If you have little or no formal training in the subject, a course in management and business studies is well worth the investment.

You should also take a class in basic book-keeping and accounting. Although you will want to hire a dedicated accountant, it does help if you can understand what he's doing for you. (This ties in with the Golden Rule of Management, which we'll come to shortly.)

After you have done your research and studied the craft, you will have a far better grasp of what you're getting yourself into. The theory behind good management practices is easy to learn, but it can take a lifetime to master fully.

Make no mistake, running your own codeshop is a massive responsibility. Your own livelihood depends on your abilities, and so do any employees you hire.


Knowledge Is Power

Discounting the obvious issue of luck, about which little can be done, it is simple ignorance that causes most new—and even some venerable—businesses to fail.

Ignorance does not mean "stupidity," although it is often mistaken for it. Ignorance means "lack of knowledge." It is clearly impossible to know everything about everything, but it is your duty as a manager to know what you need to know. Of course, finding out what you need to know is your first task, and many a startup has collapsed because of a failure to perform even basic research into your industry's market status.


The Golden Rule of Management

Management is primarily about herding people. In reality, most people are generally nice, but they will often have their own agendas and desires that might not always match up with yours. It's your duty to understand how this behavior will affect your business.

The key to this is also the key to mastering management in any industry:

Learn enough about all aspects of your chosen field of management to be able to recognize when something's not right. This is the First Golden Rule of Management, and it means you never stop learning.

Now, it might seem like you need to be an expert in everything related to computer games, but this is not necessarily the case. A good manager knows when and how to delegate: only rarely will the CEO of a company also wear the lead programmer and game designer hats. Instead, your job will be to hire people who can take care of the details for you, leaving you free to work on the big picture.

Case Study 2.1.1: A Brief History of MS-DOS
Start example

When IBM came to Digital Research's door, looking for someone to write an operating system for their new "IBM Personal Computer," they were turned away. It was to Microsoft to whom IBM turned; a software company that, until then, had no experience with building operating systems whatsoever.

From that moment on, Digital Research's days as a colossus of the IT industry were numbered, whereas Microsoft, then just a tiny company in Seattle making versions of BASIC for home computers, has become the behemoth of the personal computer world.

But the moral of the story is not "Digital Research's managers were stupid." They might have been ignorant, certainly—but they weren't "stupid."

No. The strangest act was to follow when IBM effectively signed away their crown jewels to Microsoft, agreeing to MS's request—and it was only a request at the time—that MS be allowed to license their own version of MS-DOS to other companies. IBM's use of off-the-shelf products to build their "Personal Computer" made the likelihood of clones appearing on the market very high. If IBM's lawyers had understood more about the IT industry, they would have tried the patent route, but they didn't. Along came the clones ... and the rest is history.

Bill Gates wasn't being nasty or even immoral: Microsoft was a very small fish at the time and most likely didn't expect IBM to be quite so shortsighted. However, when someone hands you an entire market on a silver platter ...

Microsoft's success didn't just make Gates rich: many of the developers at Microsoft at the time became millionaires as a result of Bill Gates' astute management decisions.

End example

If you're setting up a large development studio with multiple projects, you will probably be dealing not with leads, but with producers who are in charge of those leads. In a small-scale venture, you might have to wear the producer hat as well as your manager hat. In each case, you will certainly need to have a firm understanding of exactly what is involved in game design and development.

In the games industry, this rule is applied by understanding what those programmers, artists, musicians, testers, and game designers actually do for a living. You don't have to be an expert in these fields, but you do need to know enough to manage the Second Golden Rule:

Communication! Communication! Communication!


Interfaces

As soon as two or more people have to work together, the problem of communication arises. A major aspect of effective management is managing the lines of communication within your business.

In very small development teams, it's usually possible to just turn to your colleague and ask him a question directly. As teams get larger, this becomes less workable: too many people talking to each other make for a very noisy and distracting environment. A lead designer can't design if he's being constantly assailed by department heads to discuss this or that trifling detail.

Viewing a business structure in terms of interfaces is a useful analogy.

The interfaces in your business are the lines of communication between employees, as well as those to the outside world and other businesses. Managing and maintaining your business' interfaces are your responsibility. Get these wrong and faulty lines of communication will introduce "noise" into the system. Noise is interference of some form—just like in a TV or radio signal. This can be concrete interference or abstract interference.

Concrete Interference

Concrete interference is usually visible and tangible. It represents the more obvious communications problems, such as people having to shout across an office because there is no internal messaging system.

Another example is environmental obstacles: an office that's too hot (or cold) to work in comfortably will affect performance and morale.

Abstract Interference

This type of interference is usually not clearly visible. It manifests itself in the form of effects with no obvious cause. For example, morale might be gradually dropping for no visible reason. Chances are that there's an unsubstantiated rumor about the company going around the office. This type of interference can have an insidious effect on productivity, but can usually be countered by improving the flow of information between management and the people at the front lines. (Of course, if the company's stated plans make no sense to your employees, this can also have a detrimental effect. This is why good communication skills are required of all managers.)

Interference of any kind will cause disruption. Your job is to eliminate all interference—all noise—from your business processes. The more transparent the communication, the easier it is for everyone to see what's going on. People are naturally wary of information-hiding or obfuscation. If you're deliberately interfering with your employees' jobs, they won't thank you for it. Morale will fall. Good people will leave. More naïve people will stay a little longer, but ultimately, no one will stay to the bitter end.

Ultimately, all business management can be boiled down to interface design—or more specifically, communication. You have to know how to communicate with your own colleagues and employees. Your business needs to communicate with its customers—both game players and publishers. Your business needs to communicate with marketing people, magazine reviewers, Web site-building fans, new job applicants, and so on. If you're not good at talking to people, run, don't walk, away from any and all management roles: you won't enjoy them. Even famous musicians hire PR people and agents when they can't face talking to people themselves.


Reputations: Part 1

Word-of-mouth marketing—also known as "viral" or "memetic" marketing in some circles—is the most powerful form of publicity available to you. The technique has the huge advantage of inherent trust: people lay a lot of store by their friends' recommendations, so if you can get those friends to recommend your game, you're onto a winner. You might not necessarily see first-week sales records smashed, but you can certainly ensure that your game maintains long-term interest. This makes word-of-mouth publicity particularly suitable for games with long shelf lives. This covers any game that doesn't rely primarily on cutting-edge technology to make it attractive to players: shareware card games and puzzle games are a classic case in point.

Of course, this form of marketing requires that you have a good game to sell. People simply won't recommend a lemon to their friends. (If your game is truly dire, they might not even recommend it to their own worst enemies.)

Another problem this form of marketing poses is that it requires building a critical mass of support before you can see its effects. It takes a while after the initial release of your game for the recommendations to build up any noticeable momentum. Exceptions to this occur when someone with many useful contacts—and the means and desire to communicate with them—gets wind of your game. Many games developers will have been told about two of the most original games designed in recent years, Balasz Rozsa's Elast-O-Mania and Chronic Logic's Pontifex, through their own contacts. Neither was advertised in the traditional way, but relied on word of mouth to build up that critical mass of support. It is often argued that this type of sales technique might be the future of many independent developers.

The power of the Internet has made this type of marketing by far the most effective for smaller developers. Hotmail, for example, grew from zero to several million accounts solely by attaching its "free email" offer to all e-mails sent from its users. For larger developers, who are more concerned with making a big splash, the problem lies not with games players, but with the fact that you can't sell hot air: the games mentioned in the last paragraph were essentially self-funded, which is fine if the game is small in scale, but far harder to do if you're working on a multi-million dollar project.

There is also a lot to be said for starting small and working your way up the scale. id Software did this in their shareware days: Doom simply wouldn't have been possible if they hadn't had the income from their earlier games to fund it.


Reputations: Part 2

The games industry is a small world in which to work. It's fair to say that pretty much everyone worth knowing knows everyone else worth knowing. Word gets around the industry grapevine very quickly, so you need to make sure that the words that concern you and your business are good ones. This means that word-of-mouth marketing also applies in your business-to-business relationships. If you build up a solid reputation for your company, you will attract more attention from traditionally conservative publishers.

If you plan to play with the major players, rather than start with smaller, cheaper games, you'll need to look to publishers or other major sources of funding. This has the unfortunate side effects of (a) making them your customers, and (b) giving the funders a huge chunk of control over your business.

Giving away control is not always a bad thing, but as with most options in life, it needs to be analyzed in context. If you have absolutely no way of getting your game off the ground without funding, you will simply have to bite the bullet and sign. However, if you can recruit a board of directors full of savvy financial executives who know your business, they might be of great help to you—especially if this is your first attempt to run a business.


Covering Your Assets

A certain amount of "paranoia" is healthy in any successful endeavor, meaning that while you are basking in the glow of your success, others might be viewing your business with jealous eyes.

In the games industry, as with most other storytelling media, the concept of intellectual property (IP) plays a huge part in your company's success. Your company's value is measured as much by its IP as by its physical assets. Peter Molyneux and Les Edgar became millionaires because of the IP that Bullfrog owned. IP is valuable, but its value can be diluted. In Bullfrog's case, the IP was as much in the branding. At its peak, a Bullfrog game was almost guaranteed high sales solely through the power of the name.

As Bullfrog became increasingly successful, producing a string of hits, Electronic Arts became more interested in the company. Eventually, they bought it lock, stock, and barrel. They paid the original owners and key personnel a lot of money to stay with the company, yet it was clear almost from the beginning that the magic had gone. From the point of view of Bullfrog's IP, the buyout was a failure, since the end result was the end of Bullfrog and the gradual erosion of the brand's value as IP. Soon, the name "Bullfrog" on a game no longer had the cachet it once did.

While the managers did well from the deal financially, they were clearly uncomfortable with what Bullfrog became after the buyout. Consequently, very few of the original members of the company remain there today, yet the original management team is still in the business, having set up new companies.


Top Three Ways to Get It Wrong

Hindsight is a great teacher. It is easy to point fingers and laugh after the event, but it is unfair to those who at least tried. They made the effort, and that takes a lot of courage. The following is a short list of common mistakes that bring down most businesses, and not just those in the games industry.

Item 1: Don't Do Any Research

It's amazing how often people will take this type of risk. Failing to prepare adequately kills your business' credibility if the people you deal with see through your bluffing. Sure, talent and luck might get you through the tough times, but you will regret the mistakes that could have easily been avoided, the wasted money, and the bridges you will have burned.

Item 2: Place All of Your Eggs in One Basket

This is actually more subtle than it first appears. For example, many developers have made the mistake of focusing all their efforts on just one project. The problems occur when your publisher—who is likely funding your project—suddenly pulls out, gets bought up, or simply collapses into a mess of suspect accounting practices. Without some type of insurance, such as a second concurrent project with another publisher, your company is in deep trouble.

However, the single-project risk isn't the only application of this cliché. Many developers have been badly stung by the practice of placing great portions of a project in the hands of one or two people. Lose those key personnel and you lose your project.

A good rule of thumb for analyzing this problem is the "hit-by-a-bus" question: "If this person should be run over by a bus tomorrow, how will it affect the project?" If the answer is "We're doomed!" then you need to remedy the problem now. Remember, these people don't have to be run over; they could resign, join your competitors, or even change careers tomorrow if they're unhappy.

Item 3: Hire the Wrong People

"Manager" is a meaningless term without context. For example, a "project manager" and an "office manager" need very different skills. No one can possess all of the talents and abilities required to manage every possible mission.

A huge proportion of the games industry's managers come from non-management backgrounds—often they are either ex-programmers or ex-designers. Neither role is particularly good at preparing you for management, yet the number of developers who have left one game development company to set up their own with little preparation is surprising. Some are successful, but they are exceptions, not the rule.

Similarly, many companies make the mistake of hiring a manager proven in one industry and expect them to be able to pick up all the nuances and quirks of another with little or no training. Managing a chain of grocery stores is not the same as managing a chain of development teams. There are similarities, certainly, but without that key understanding of how the industry works, it is all too easy to miss something that would be obvious to an experienced hand.


Conclusion

Starting your own game development company is hard work. It requires a massive commitment in blood, sweat, and tears. And forget about getting home at a decent hour: good managers are usually the last to leave.

  • It's not about playing golf.

  • It's not about fast cars.

  • It's not about swimming in money.

  • It's about making a living. If you get seriously rich, great! However, you will have to do a lot of hard work first. Most businesses don't even survive the first three years of life. If you do survive for a while, you still can't afford to be complacent: Atari collapsed because of this attitude; and even the mighty IBM was brought to its knees in the late 1980s and nearly collapsed.

If, after all this, you still want to go ahead: good luck!


Chapter 2.2: Writing a Business Plan for a Game Development Startup

Overview

François Dominic Laramée

<francoislaramee@videotron.ca>

Preparing a business plan might well be the single most important action taken during a game development company's startup phase. Not only will the business plan help secure financing, but the research process leading to it will strengthen the promoters' knowledge of the market, solidify their business strategy, and establish their credibility with clients and partners.

Multiple business plan formats, sharing much in content and structure, have been published over the years. [Gumpert96], [Touchie98], and especially [Bangs98] present several alternatives. The model described in this article is a hybrid modulated to the needs of game developers. The author has used variations of this model to write business plans for several successful clients since 1998.


The Many Purposes of the Business Plan

Your studio's business plan will come into play during all phases of the company's operation, in a variety of roles:

  • Strengthening your own convictions. The research leading to a business plan will help you determine whether the opportunity you identified really exists. If you want to start a motion-capture studio, and 8 out of 10 local studios you poll say they would use the service, you're on your way to success.

  • Identifying business opportunities. Sometimes, the research process itself will reveal ancillary sources of business you might not have thought about. For example, while asking local publishers about their interest in full-service game development, they might tell you that their existing stable of developers is in dire need of extra 3D animation help; adding a 3D team for hire to your studio's assets could therefore increase profits.

  • Guiding your strategy. Once you have identified key opportunities, the business plan will help you pursue them effectively—and avoid distractions.

  • Establishing partnerships. A credible business plan will help you recruit key employees, secure publishing contracts, obtain a favorable lease, negotiate credit, and so forth.

  • Securing debt and equity financing. Since the safety of (and return on) their money is paramount to them, bankers and investors will base their funding decisions on the viability of the business plan.

  • Selling the company. Finally, if you ever want to sell your studio, a business plan showing a viable long-term strategy will be your most important asset, especially if the buyer is not intimately involved in the interactive entertainment industry himself.

Therefore, the business plan should be created before the studio's launch and updated on a regular basis (at least twice a year) as long as the company is in operation.


The Business Plan's Contents

A business plan is an organic document. It can and must be tailored to the needs of the person or organization to which it is being presented. For example, if your business is applying for a bank loan, the banker will be far more interested in seeing how you will generate a regular positive cash flow (and therefore be able to repay the loan on time) than in your long-term growth process, while an angel investor will focus on the exact opposite.

That being said, most business plans need to include:

  • Front materials: A cover page, executive summary, and table of contents.

  • Market information: A general description of the state of the industry, the niche you want to carve for yourself, and the clients who will buy your products and services.

  • A description of your company: Your own track record, key members of the team, your staffing plans, and the outside resources to which you have access.

  • Your development plan: Growth objectives, research and development, other markets you wish to expand into, and risk management.

  • Your financial plan: How much money you need (and when), your cash flow and earnings previsions, and your capital structure.

  • Assorted supporting documents: Personal résumés, letters of intent, and so forth.

Length

The complete business plan should not exceed 50 pages (preferably 30), starting with a 2-page executive summary and including 10 to 15 pages of financial statements and supporting documents. This is often insufficient to discuss everything that you feel is relevant; however, not every reader needs to see every piece of information, so you can assemble the 30-page document you submit on a given occasion from substantially more material. Case Study 2.2.1 discusses ways to do this effectively.

Case Study 2.2.1: Modulating the Business Plan
Start example

Once you have written all of the material that belongs in your business plan, you can assemble different versions of the document for different purposes. For example:

  • To secure a work-for-hire contract with a publisher: Emphasize the team and any staffing growth plans (publishers like to establish long-term relationships), leave out the intellectual property except technology, and skim over financial predictions.

  • To secure a bank loan: Include extensive personal information, make sure that your cash flow forecasts minimize fluctuations, and expand the section on risk management. De-emphasize long-term development.

  • To define internal strategy: Prepare extensive market research, alternative financial forecasts based on different development scenarios, and leave out team info.

  • To obtain equity investment: Insist on development plans and on how you will retain your key employees. In your market analysis, insist on emerging trends with long-term sustainability.

  • To obtain venture capital: Identify a critical shortage in the market. Show enormous earnings growth potential within two to three years. De-emphasize risk management, except where it concerns very short-term cash flow.

  • To recruit key employees: Leave out most of the market description (unless hiring outside the industry) and the financial data, and emphasize the company profile and the development plan.

End example


The Market, and How You Fit into It

This section of the business plan might be the most important, because it shows why your business should exist in the first place. Avoid the temptation to skimp on it to save pages for the financial forecasts: in the eyes of the shrewd investor, cash flow statements without a credible market opportunity are worthless.

Your Products and Services

First, describe what your company will do, and how it will distinguish itself from the competition. Examples of unique distinguishing characteristics might include:

  • Exceptional talent. Do your partners and yourself have marketable industry credentials, advanced degrees, or unusual backgrounds?

  • Unique intellectual property. Have you developed characters that focus groups have identified as the next Pokémon? Or have you secured an exclusive license to an upcoming film franchise's gaming rights?

  • Financial advantages. Will you be able to develop better games for less money than the competition? Why? Is the cost of living very low in your state or country? Is your national government subsidizing high-tech companies?

  • Geographic specificities. Is your studio located in a high-density game development area, with plenty of competent talent available to be hired? Or are you the only game company in an area teeming with exceptional 3D artists?

Current Market Conditions

Telling the reader that the game industry's total sales have experienced double-digit growth every year since 1980 is not enough: you must also demonstrate knowledge of the specific segment(s) you are attacking. Who are your customers? Are they used to buying what you propose to sell? If so, is there room for additional suppliers? If not, how will you convince them of the benefits of leaving their current partners to do business with you?

The best way to do this is to identify an obvious need in the marketplace. For example, if you want to start a game programming school, ask local companies how long it takes to fill an opening, how many technical positions they have available, and how many more art and production jobs they would be able to create if there were enough qualified programmers to fill the team. (In some countries, the answer to that last question might help you secure funding from government agencies.)

You must also identify trends that support your approach. If you want to develop games for publishers on a work-for-hire basis, show that licensed properties account for an ever-increasing percentage of the best-sellers list on your platform of choice. If you prefer to create your own characters, show that the market for intellectual property of their kind is large, growing, and/or underserved. Be precise, and aim where the competition isn't too strong: while there is a seemingly inexhaustible demand for fantasy, the teenage-wizard-at-boarding-school-in-England sub-genre is probably saturated until at least 2010.

Your Marketing Strategy

Finally, demonstrate how you will carve your own niche in the difficult game development market. Have you secured the services of a reputed agent? Will you begin by developing a low-cost, low-risk title that can be played on personal digital assistants (PDAs), and use it as a calling card? Will you focus on a narrow segment and establish yourself as an unquestioned leader—like id Software for first-person shooters and Maxis for simulations—or will you develop an entire line of complementary sports games and distribute them on all major consoles?


Your Company

Having identified an opportunity in the marketplace, you must now prove that you and your partners/employees are qualified to turn that opportunity into a profitable business. This section will establish your credibility in this regard.

Promoters

Identify the partners who will be involved in day-to-day operations by name, and describe the skills they bring to the company.

Insist on expertise in three major areas: management, sales, and game development, in that order. [Bangs98] states that 92% of all business failures in any industry are caused by managerial incompetence or lack of industry knowledge. Bankers and investors are understandably wary of funding companies that they perceive as deficient in these areas. Also remember that most of the people who will read the business plan know nothing about the game industry, except what they might have read in the mainstream press—and that coverage is rarely flattering. Thus, to maximize your odds of securing capital, your core team should include:

  • A proven business manager, preferably with a finance background.

  • An experienced salesperson with solid industry contacts.

  • A game designer or producer with multiple titles to his credit.

  • A lead programmer, also with multiple industry credits.

Of course, it is possible to rely on the support structure described in the next section to fill a gap in your expertise, but this is the optimal combination, because investors love it when people who hold long-term stakes in the company occupy the key positions.

Support Structure

Few startups, if any, can count on promoters with all of the skills necessary to succeed. The "Support Structure" section of the business plan lists the employees and external resources that will complement the promoters' knowledge, including:

  • One or more senior software engineers.

  • A lead artist, if he is not among the promoters himself.

  • A law firm and/or agency with entertainment industry experience to represent you in contract negotiations.

  • Members of the board of directors and/or advisory committee.

  • Auditors and other consultants.

  • Local schools and research institutes.

  • Chambers of commerce and other business associations.

  • Laws and regulations that favor the game industry in your local jurisdiction.

Staffing

Then, describe your initial team in these terms:

  • How many people will you hire?

  • What will their jobs be, and to whom will they report?

  • What salaries and benefits will you offer? Are you going to pay above or below the industry average in your area? Will you implement a stock ownership plan to minimize employee turnover?

  • Can the local market provide you with enough qualified talent? If not, what type of training will you have to invest in?

Production Plan

Finally, describe how you will organize the studio's operations. Will you have a single unified team? Multiple projects based on the same engine? Three independent product lines?

Remember that generating positive cash flow early and regularly is important for investors. When seen in that light, a single group working on the same AAA game for three years is not very attractive. You might have an easier time securing capital for a larger company that can release two handheld games every quarter and a major console title every Christmas season.


Development Plan

The development plan describes how you envision your company's evolution over the next few years. In traditional businesses, the development plan usually covers five years; for a game studio, it is very hard to make predictions more than two to three years in the future with any credibility, so a two-year plan will usually be sufficient.

Research and Development

Explain your company's technological strategy. Will you develop in-house engines, license technology developed elsewhere, or take advantage of industry standards such as Macromedia Flash? Do you plan on using technology as your competitive advantage? If so, will that competitive advantage lie in visual quality, character behavior, or faster development? If not, where will you put the emphasis: art, design, or writing?

An aggressive but sound research and development plan is a high-risk, high-reward strategy. While success might bring enormous profits, there is always the chance that you will find yourself, years into a new engine's development, with technology that fails to bring the expected competitive advantage. Therefore, such a strategy will attract venture capitalists, but scare loan officers away.

Growth Targets

Is your goal to keep your company small and easily manageable, or do you want to turn it into an industry powerhouse? Do you want to concentrate on a single platform or develop for all major consoles at the same time? Do you want to become your own publisher? Handle your own distribution? Exclusively online, or in retail stores as well? Or do you intend to take the intellectual property you develop for your games and turn it into a TV, comic book, and merchandising franchise?

Again, an aggressive growth strategy is attractive to equity investors, but perceived as risky by lenders.

Risk Management

The best business plans demonstrate knowledge of the common sources of failures in the industry, and explain how the company will maximize its odds of defeating them. For example:

  • Many experienced game developers leave the industry because they can make more money and work shorter hours elsewhere. How will you retain your key staff?

  • A small number of hit games earn enormous profits, while most projects lose money. How will you minimize your financial risk?

  • The industry suffers from a high employee turnover rate, especially in active areas like California and Texas. How will you keep your teams intact throughout long projects?

  • As the industry grows ever more concentrated, the number of potential publishers for your games shrinks every year. How will you get your games to market?

  • The average AAA game budget reaches millions of dollars. How will you minimize your costs and still have a chance to compete for consumers?

Convincing answers to these questions will show that you are ready to face the challenges of the marketplace.

Also note that local circumstances might influence your vulnerability to these risks, or even spawn others. Study your state or country's tax code (especially the provisions on tax incentives for R&D and investment in technological ventures) and job market thoroughly.

Case Study 2.2.2: Creative Risk Management
Start example

Nothing impresses investors quite as much as a proactive, original approach to minimizing the risk of failure. Here are a few examples of strategies that can increase your odds of success:

  • Send employees to teach at local colleges and universities, where they can recruit the best students.

  • Participate in work-study programs.

  • Implement a profit-sharing plan; this retains key employees more effectively than stock options, because few game companies ever make it to the stock market.

  • Pool resources and/or trade services with other companies to eliminate the costs associated with the hiring/layoff cycle.

  • Enforce a strict upper limit to the duration of the work week to maintain morale and avoid employee exhaustion.

  • Establish strong relationships with the local mainstream and business press to gain notoriety in the financial market and attract quality employees.

  • Mix and match project types and durations to generate regular cash flow.

  • Involve employees in every project, if only for a couple of weeks, to create a sense of unity.

End example


Financial Planning

Most companies write business plans to obtain financing. Others do it to secure contracts and partnerships. In both cases, a sound money management plan is of the utmost importance.

Types of Financing Deals

If your studio needs funding, you must determine which type of financial arrangement between you and your backers will be most appropriate. There are three general categories of funding you might solicit:

  • Debt. This category includes credit margins, "bridge loans" allowing you to cover cash flow shortages until a milestone payment arrives, bonds, and mortgages. Lenders avoid risk, and they want to get their money back (with interest) on a precise schedule. Therefore, debt funding is easier to obtain if you already hold a letter of intent or work-for-hire contract from a publisher, or if you are willing to offer significant collateral (e.g., a house) to secure the loan.

  • Equity. Family, friends, financial angels, and some investment funds might be interested in providing a studio with long-term capital in exchange for a percentage of ownership—and thus a share of future profits. Equity investors might be willing to accept a higher risk factor than lenders, but mavericks beware: while any business failure is painful, one that destroys your relationship with loved ones will be much worse. As a rule, investors will expect to earn back their seed money within two to three years and receive a 25 to 40% return thereafter.

  • Venture capital. Some investors specialize in high-risk, high-payoff companies. A typical VC contract involves the studio selling a percentage of its stock to the investor at a certain price and buying it back later at a higher price so that the venture capitalist will be out of the picture within 3 to 10 years. Usually, VC is only available to companies with extremely high potential—for example, those that hold the rights to a breakthrough technology or show immediate stock market perspectives. At the height of the dot-com bubble, VC firms expected 100 to 500% rates of return on their investments within one year.

Depending on your company's business model, some of these types of financing will be easier to obtain than others: venture capitalists have little interest in stable, low-growth companies, while banks will not risk large sums unless the loans are secured by contracts with well-defined milestone payments.

Pro Forma Financial Statements

To convince potential investors and partners of your company's potential, you must demonstrate financial viability. To do so, you must provide the following statements:

  • Cash flow statement. This document lists cash receipts and expenditures, demonstrates your company's liquidity, and shows how much external funding you will need at any given time. Table 2.2.1 shows a simple cash flow statement. Don't forget to take trade show expenses and representation into consideration!

    Table 2.2.1: Simple Cash Flow Statement (Simple Studios Inc.)

    Receipts

    Q1 2003

    Q2 2003

    Q3 2003

    Q4 2003

    Q1 2004

    Q2 2004

    Q3 2004

    Q4 2004

    Equity funding

    $250,000.00

    $0.00

    $0.00

    $0.00

    $0.00

    $0.00

    $0.00

    $0.00

    Milestone payments

    $0.00

    $100,000.00

    $100,000.00

    $200,000.00

    $100,000.00

    $100,000.00

    $200,000.00

    $0.00

    Royalties

    $0.00

    $0.00

    $0.00

    $0.00

    $0.00

    $150,000.00

    $150,000.00

    $150,000.00

    Tax credits

    $0.00

    $20,000.00

    $20,000.00

    $20,000.00

    $20,000.00

    $40,000.00

    $40,000.00

    $40,000.00

    Govt subsidies

    $100,000.00

    $0.00

    $0.00

    $0.00

    $150,000.00

    $0.00

    $0.00

    $0.00

    Total

    $350,000.00

    $120,000.00

    $120,000.00

    $220,000.00

    $270,000.00

    $290,000.00

    $390,000.00

    $190,000.00

    Expenses

    Rent and suppliers

    $8,000.00

    $8,000.00

    $8,000.00

    $8,000.00

    $10,000.00

    $10,000.00

    $10,000.00

    $10,000.00

    Capital expenses

    $100,000.00

    $0.00

    $0.00

    $0.00

    $100,000.00

    $0.00

    $0.00

    $0.00

    Salaries (burn rate)

    $120,000.00

    $120,000.00

    $120,000.00

    $120,000.00

    $240,000.00

    $240,000.00

    $240,000.00

    $240,000.00

    Income tax

    $0.00

    $0.00

    $0.00

    $100,000.00

    $0.00

    $0.00

    $0.00

    $0.00

    Total

    $228,000.00

    $128,000.00

    $128,000.00

    $228,000.00

    $350,000.00

    $250,000.00

    $250,000.00

    $250,000.00

    Quarterly variation

    $122,000.00

    -$ 8,000.00

    -$ 8,000.00

    -$ 8,000.00

    -$ 80,000.00

    $40,000.00

    $140,000.00

    -$ 60,000.00

    Cumulative

    $122,000.00

    $114,000.00

    $106,000.00

    $98,000.00

    $18,000.00

    $58,000.00

    $198,000.00

    $138,000.00

  • Earnings statement. This document summarizes sales, costs, and profitability. It differs from the cash flow statement in several important ways; for example, sales are "earned" as soon as they are closed, but accounted for in the cash flow statement only when the invoice is paid. Table 2.2.2 shows a simple earnings statement.

    Table 2.2.2: Simple Earnings Statement (Simple Studios Inc.)

    Q1 2005

    Q2 2005

    Q3 2005

    Q4 2005

    Total 2005

    Milestones and royalties

    $400,000

    $250,000

    $200,000

    $1,200,000

    $2,050,000

    Development costs

    $350,000

    $350,000

    $350,000

    $350,000

    $1,400,000

    Gross margin

    $50,000

    ($100,000)

    ($150,000)

    $850,000

    $650,000

    Overhead

    $100,000

    $100,000

    $100,000

    $100,000

    $400,000

    Gross profit

    ($50,000)

    ($200,000)

    ($250,000)

    $750,000

    $250,000

    Income tax

    ($7,500)

    ($30,000)

    ($37,500)

    $112,500

    $37,500

    Net profit

    ($42,500)

    ($170,000)

    ($212,500)

    $637,500

    $212,500

  • Balance sheet. This document summarizes a company's assets, liabilities, and book value. Since game studios rarely own many assets except quickly depreciated computers and software, this statement is less important for you than for a traditional business such as a manufacturing plant, but lenders in particular will still want to see it, because they can seize assets if you default on your payments. A 1:1 ratio of cash and accounts receivable to short-term (one-year) liabilities is considered comfortable.

The business plan should include monthly statements for the first year, and quarterly statements for the next two years.

Your Financing Proposition

Having prepared your cash flow statement, you know how much external funding you will require to support your operations. It is now time to propose a deal to your prospective financial partners. Do you ask for a single equity investment in the entire amount, or are you willing to bring in multiple partners? What percentage of your stock are you willing to offer in exchange? If you prefer a loan, venture capital, or a combination of both, what interest rate are you willing to pay?

As a general rule (with many exceptions), angels and funds don't like to provide a disproportionate share of a company's money: they are more comfortable if the principals and/or a number of other institutions participate as well. On the other hand, venture capitalists often demand a high percentage of the stock, or provisions that let them increase their ownership (and ultimately wrest control from the promoters) if the company fails to meet the expected buyout schedule.

Capital Structure

List current owners and debtors, their stakes in the company, and their roles in its management, if any. A second table showing the situation after the proposed funding must also be provided.

In addition to the principals' investments in the company, you might also want to declare the salaries they will be receiving until the company releases a title or signs a publishing contract. Investors tend to frown upon promoters who pay themselves generously at this stage, so you might have to prove your commitment to the company by taking much less than you could be making as an employee elsewhere; your payoff is supposed to come later.

Case Study 2.2.3: Minimizing the Cost of Money
Start example

An overly aggressive venture capital buyout can cripple a company. So can deteriorating relationships between dissatisfied shareholders. Common sense dictates that game studios should cap the potential negative impacts of outside capital influxes, by minimizing the amount of money they have to bring in and/or by cutting on the premiums they have to pay for it. Here are a few ways to do so:

  • Select venture capital partners who are accredited by fiscal authorities. In some jurisdictions, VC firms receive tax credits on risky investments; if this is the case in your state or country, you will not have to guarantee as high a rate of return to secure an investment.

  • Find alternative suppliers. If you can bear the risks associated with a non-standard 3D animation package or programming environment, their suppliers might be willing to sell them at a substantial discount to gain a foothold in the game industry.

  • Lease instead of buying. In some jurisdictions, lease payments are 100% tax deductible, while purchased equipment must be depreciated over several years even if they are paid in advance. Computers, office furniture, and some software packages can be acquired this way.

  • Consider a second mortgage. If you are going to have to put your home up as collateral on a business loan anyway, why not get a mortgage and invest the money in the company? Mortgage rates are often lower than those granted on business loans.

  • Cross-subsidize. Accept work-for-hire deals, subcontract your workforce to other companies during downtime, and use the income to pay for your own original development projects.

  • Sweat equity. Some employees might be willing to work for less money at startup in exchange for a share of the company's stock. Unfortunately, this mechanism is often abused; several projects advertised on industry Web sites in 2002 asked for several months of unpaid work (in one case, as much as three and a half years) in exchange for vague promises of regular employment—no stock—in the future. Remember that you always get what you pay for.

End example


Supporting Documents

Finally, append any document that could help sway the reader's decision in your favor: personal résumés, personal balance sheets, letters of intent and contracts from publishers, leases, awards received, a description of the company's intellectual property, and so forth.


Conclusion

A well-crafted business plan is a management tool, a calling card for the company in negotiations with publishers, and the single most important factor in obtaining financing for your projects. Do not underestimate its impact.

Above all, remember that your business plan must capture your company's unique personality: write it in a lively, attractive style that shows that you belong in the entertainment industry. Best of luck!


References

[Bangs98] Bangs Jr., D. H., The Business Planning Guide, 8th edition, Upstart Publishing Company, 1998.

[Gumpert96] Gumpert, D. E., How to Really Create a Successful Business Plan, 3rd edition, Inc. Magazine Publishing, 1996.

[Touchie98] Touchie, R. D., Preparing a Successful Business Plan, 3rd edition, Self-Counsel Press, 1998.


Chapter 2.3: Strategies for Staffing a Startup

Overview

Grant Stanton

<grant@TSCsearch.com>

Perhaps in no other industry short of motion pictures is there such a direct correlation between the success of the product and the staff involved. There is a vital creative element involved in games development that sets it apart from other software products, and being successful in this young and volatile industry requires brilliant and fanatically dedicated staff. The most promising game concept or license can fail as a product in the hands of a lackluster studio.

As recently as the early 1990s, the industry was witness to successful startups born at home by a few young entrepreneurial spirits that created games like Castle Wolfenstein and Myst. In recent years, rocketing development costs and the size of the teams required to create a sophisticated competitive product have created a substantial barrier to entry for this form of venture. Most often, today's startup falls into one of two broad categories.

The most common genesis of a developer is when a few key employees depart from an established studio to form their own company. In this case, they typically capitalize on their contribution to a successful title to secure funding and contracts. The most common error made by the first type is that they don't take the management responsibilities seriously enough. They just created a hit game, how hard could managing a studio be?

The other less common origin for a studio is when a company well established in a similar field—like motion pictures or software application development—decides to expand into games development. The latter type usually puts too much faith in the management techniques that have served them well in other industries.

In staffing a new venture, your candidate pool (available applicants to choose from) will consist chiefly of two groups: active candidates, people who are unemployed or actively looking for a new job, and passive candidates, candidates who aren't actively looking to change jobs but are still interested in opportunities to advance or improve their careers.

In this article we discuss strategies for sourcing, screening, interviewing, and hiring both types, as well as how to avoid some of the common staffing pitfalls that young studios face.


Creating Job Descriptions

This crucial first step in the hiring process is often not given the full attention it requires and when not thoroughly implemented, is the primary cause of a hiring process going awry. Without a clear, complete, and detailed job description to reference, the hiring decision is often made on an emotional level, based on whether someone likes or feels good about a candidate rather than determining who is best qualified according to the needs and requirements of the position.

The following is a summary of the five fundamental steps to creating a job description.

  1. Determine the hiring manager. Who is going to make the actual decision to extend an offer? Ideally there should be just one person responsible for making the final hiring decision. If this is not practical, then it is important to restrict the number of people involved to as few as possible. You can certainly use the entire team in the interview process and consider the resulting input, but the actual decision of whom to hire is critically important and should not be put to a "team vote" any more than other important management decisions. Imagine taking your entire family and extended family along to buy your next car and allowing everyone to have veto power in the decision. Do you believe you would end up with the best car for your needs or just a car that everyone agreed on? It is the team leader or manager who has the best perspective and understanding of what the needs are that this new hire will address. In business, only the people most qualified to make a particular decision should be empowered to do so.

  2. Determine what the needs are. What are the specific needs that this position will address? Make sure that everyone involved is in agreement as to these needs.

  3. Position responsibilities. What responsibilities will this person have? What will this person be expected to accomplish? What specific tasks will this person perform on a daily and weekly basis? What management or leadership responsibilities will this person have?

  4. Required skills and bonus skills. Clearly define the necessary skill-set to succeed in the position. Also determine what skills would be an additional benefit, but are not a necessity.

  5. Personality. Are you looking for a strong leader? A team player? Someone who works independently? Someone adept at resolving conflict? Determine what personality traits or attributes would have the most bearing on a candidate succeeding in this position as well as the company as a whole. Now is the time to determine what type of individual you are looking for and what type of individual works best in your company culture.

Your completed job opening document should include job title, who this position reports to and who would be reporting to them, hiring authority, responsibilities—this includes both duties that would be performed on a daily basis and longer-term objectives for this position, skills required, skills that would be beneficial, a brief sentence or two about beneficial personality attributes desired, and finally, a salary range.

Make sure that you have created a job description that can be done by one person. Sometimes managers amalgamate several distinct positions' needs into one. Care should be taken that a job description doesn't become a wish list that no one candidate could fill. When the document is completed, revisit the hiring authority(s) to make sure everyone is in agreement. This is a very important step. Everybody might agree that you need a technical director, but there might be several different opinions as to what exactly a technical director does and is responsible for.


Strategies for Finding the Candidates

The videogames industry is in a growth cycle and the best development talent is in constant demand. The worth of a studio is in a large part determined by the caliber of its development staff. In an industry with such a high demand for talent, a new studio should not rely exclusively on advertising and should be both creative and aggressive in their recruiting efforts.

  • Advertising. This is the most obvious method. There are numerous avenues to consider with advertising, from print to the Internet. There are trade magazines published specifically for the game development community as well as the computer graphic arts community. On the Web there are game developer forums and Web sites to consider as well as a few private sites in the developer community that will post job ads free of cost to developers that they trust. While simple advertising will likely produce the largest quantity of applicants and the occasional diamond in the rough, it should be mentioned that often the majority of the respondents are either inexperienced or looking to break into the games industry rather than experienced veterans.

  • Networking and trade shows. Talk to friends and employees, ask who they know. Attend trade shows like E3 and the CGDC and let people know about the exciting projects you are working on.

  • College recruiting and internships. Today's colleges are producing some brilliant young engineers and artists. Many a startup owes their success in part to their proximity to a college campus; Raven—University of Wisconsin, Volition—University of Illinois, Redstorm—University of North Carolina, Turbine—MIT, and so forth. As the games industry matures, more and more colleges are developing curriculum with games development in mind and then there are schools that specialize in games development like Digipen and Fullsail. Many of these students actually have exposure to console development before they graduate. An enthusiastic student intern or recent graduate with the essential skill-set and a fanaticism for games can be a terrific addition to your team.

  • A Professional recruiter. Using a professional recruiter seasoned in the industry is the most efficient and direct method of sourcing the entire applicant pool, not just the candidates that are actively looking. A good recruiter will champion your studio in the games community and aggressively pursue the passive candidates. Passive candidates are not unemployed, not unhappy, not reading the want ads, and represent the majority of development talent. If your studio has something exciting to offer, it is the professional recruiter who will be pro-active and make sure the right people know about it. Some recruiters in the games industry even offer special fee arrangements to startups. The recruiter that you select should know the industry top to bottom; have an extensive network of contacts, and have a good reputation within the games community.

  • Reputation. This is an often overlooked facet of recruiting in the games industry. The games development community is very closely knit. As a consequence, news travels fast. Good development staff is in high demand, so a good candidate has many choices. The caliber of talent that you attract will have a great deal to do with how your studio is perceived in the games community. Your reputation will, in part, be based on the founders' reputations, the quality of game you are producing, your studio's work environment and studio culture. This can be both an advantage and a disadvantage when creating a startup. It is difficult to repair a poor reputation. Take special care with your burgeoning reputation in the community and treat all applicants graciously.


Screening and Qualifying Applicants

Sorting through large quantities of mostly unqualified applicants can be daunting. These days the résumés will arrive primarily via e-mail. For the sake of organization, dedicate an e-mail address just for applicants (e.g., Jobs@Newstudio.com). Set up an auto response that is sent to every e-mail received at that address thanking them for applying and letting them know their résumé will be reviewed and thoroughly considered for open positions.

Discipline yourself not to make judgments about a candidate based on résumé format or composition. Remember, you are not hiring someone for their résumé writing skills. The résumé is not the candidate. If the résumé is difficult to understand or leaves you with more questions than answers, but the candidate looks like a possibility, then a telephone screen is warranted to find out more.


The Telephone Screen

The telephone screen is not an interview and shouldn't be confused with one. It should be used to clarify information on the résumé and the qualification of a potential interview. A telephone screen is a friendly, brief, fact-finding conversation designed to determine whether someone is qualified to do the job. A face-to-face interview is for determining whether this is the actual person you want to hire.

Key Questions

There are questions that are appropriate for a telephone screen and questions that are best left for a face-to-face interview. How do you distinguish between the two? Here are some examples.

  • Phone screen question: What is your current salary situation?

  • Interview question: What are you looking to earn?

    • This question should be left until the end of the interview process. Asking a candidate to commit himself to a number before he has been fully briefed on what your company has to offer and the specifics of the position doesn't benefit you or the potential hire. You want a chance to sell them on the position and your company before asking what salary they are looking for.

  • Phone screen question: I see that you used C++ at your last employer. How many years have you programmed in C++? How would your rate your skill level with C++?

    • The candidate can answer this type of concise question with just a few words. The answer speaks directly to whether the individual is qualified to perform the essential duties of the position.

  • Interview question: Where do you see yourself in five years?

    • This question pre-supposes that the candidate has the necessary skills for the position and is probing big-picture considerations such as ambition and motivation. These traits are difficult to detect over the telephone and are best gauged in a face to face setting.

  • Phone screen question: How many people do you currently have reporting to you? Or what is the most number of direct reports you have had?

    • The answer to this question can be as brief as one word and still give insight and context to management skills described on the resume.

  • Interview question: Describe your typical workday or workweek.

    • Asking this question during a personal interview allows the interviewer to watch for changes in the candidate's enthusiasm level and demeanor while he describes different daily tasks. This can tell you which tasks he enjoys or feels confident at and which he doesn't.


Verifying Candidates' Skills

Okay, so you find a candidate with the right skills on his or her résumé. How do you confirm these skills? References are one way, but if the candidate is currently employed it might be difficult to check references without compromising his situation. If you can speak with references, due to legal concerns, most references offer very few specifics beyond dates of employment and title.

How can you be sure the candidates are as skilled as they claim to be on their résumé? The games industry has evolved some analytical methods of assessing skills.

  • Code samples: Samples can tell you a great deal about someone's coding style. Does this programmer just make the code work, or is the code "concise," "creative," and optimized. Be specific about what type of samples you are interested in seeing. The drawback here is that sometimes a programmer cannot share his best work because of intellectual property and non-disclosure agreements (NDAs). If the programmer doesn't feel that he has samples available that he can share that meet your specifications, then a code test can help.

  • Code tests: Code tests can be given in place of or in addition to code samples. Before a code test is devised, careful thought should be given as to what skills should be tested. Remember, the type of candidate you are looking for is a games enthusiast, dedicated to his or her project and is most likely working ridiculous hours. The test should consume the least amount of time as possible while still being able to gauge the necessary skills, or lack there of, that you are screening for.

  • Math tests: Math skills are crucial to a programmer creating game worlds/environments and the virtual physics that govern them. Math tests are not as common as code tests, but there are studios that feel they are a very useful screening tool for certain engineering positions

  • Demo reels: Demo reels have taken on such importance for artists in the video-game industry that virtually all development studios will not even consider an artist without one. Reels and portfolios come in various forms, ranging from VHS tape to CD-ROM. Unfortunately, some artists have difficulty assembling their best work without violating agreements with past and current employers. Avoid misjudgments by asking potential art hires to include a brief guide to their demo reel explaining what tools were used and a description of precisely what they were responsible for in the demo.

  • Art tests: Art tests can be designed to ascertain artists' general skills. They can also gauge aptitude with a particular graphics package. While not yet industry wide, art tests are gaining in popularity.


Interviewing

It has been said that interviewing is more of an art than a science. It is a wonderful professional skill to develop, allowing you to elicit important information about someone without making him feel "handled" or uncomfortable. Before the interview, thoroughly review the candidate's résumé and compose a list of questions germane to the job being interviewed for. The interviewing process can be a stressful one for both the interviewer and the interviewee. The more relaxed and unguarded both you and the candidate feel, the more you will learn. Show the candidate around the studio. Ask how the drive was. Make small talk for the first few minutes before getting down to business.

Preparing for the Interview

If more than one person will be meeting with a candidate, talk with everybody prior to the interview and come to an agreement as to who will cover what areas. Otherwise, you risk having an individual having to answer the same questions, possibly with some fairly involved answers, four or five times in one day. This can frustrate a candidate and make your company appear disorganized.

Some people will come prepared with a list of questions about your company. It's acceptable to offer brief answers to applicants' questions during the interview but if the applicants ask a question that warrants a lengthy answer, make note of it and explain that due to time constraints you will answer their question toward the end of the interview. The goal is to learn as much about the applicants as possible. You want to keep the focus on them and keep them talking.

Selecting Interview Questions

Avoid obviously illegal questions about ethnicity or family situation. Several books have been written based simply on compilations of hundreds of interview questions. Prepare a list of questions before the interview and give some thought as to how you want to phrase the questions in order to get the specific information you are looking for. Beyond the position-specific questions, technical and otherwise, here are a few staple questions to consider asking:

  • "Why did you leave your last employer?" Or, if the candidate is currently employed, "Why are you looking elsewhere?" Keep in mind that if a recruiter was responsible for sourcing the candidate, the candidate might be there for no other reason than the recruiter has convinced him that it was an opportunity not to be missed.

  • "Describe your typical workday? Your typical week?"

  • "What was the biggest professional challenge you have faced? How did you go about tackling it?"

  • "What do you feel it takes to be successful as a (position title)?"

  • "In what type of environment or culture are you most productive?"

  • "What type of environment or culture do you not work well in?"

  • "What kind of games do you like to play? What is your favorite game and why?"

  • "Professionally, where do you feel you could use the most improvement?"

  • "What is your greatest professional strength?"

In addition, don't hesitate to ask a few "Why . . ." oriented questions. These questions speak to what motivates someone and offer an insight into their reasoning processes. For example:

  • "Why did you take the job at your current/last employer?"

  • "What made you choose to use (Maya, RenderWare, etc.) on your last game?"

When you have gotten the answers to your questions, revisit any questions the applicant might have had during the interview and offer him a chance to ask more.

Finally, keep 5 to 10 minutes at the end of the interview to sell your company. This is crucial, even if you don't intend to hire the candidate. You want everyone who interviews with your company to leave with a positive impression of the interviewing process and your studio as a whole. If the candidates believe that your company is a great place to work, they will encourage friends in the industry to interview with you as well. If the candidates have a negative impression of your studio, then they will discourage friends and colleagues from applying. Think about what makes your new studio special and how you want to communicate it.

After the Interview

Immediately following the interview, while the candidate's answers are still fresh in your mind, take a few minutes to write down your impressions of the candidate and flesh out any notes that you didn't have time for during the interview.

Making an Offer

If you are confident that you have found the right person, move as quickly as possible to offer the job. If you are just working out the details of the offer, then let him know an offer will be coming. This will help reduce the risk of the applicant committing to another company before you have a chance to conclude the deal.

Extend the offer by telephone first. Once the candidate has committed to a verbal acceptance, have other employees whom he met with call or e-mail to congratulate and welcome him aboard. It is important that the new hire feels good about the decision - and fully committed to your company. Otherwise, there is a risk he might accept a counter-offer, especially one coming from his current employer; after all, no organization likes to lose a good talent. The bottom line: don't simply register the acceptance and then wait for the new employee to show up a few weeks later. Stay in touch; make him feel like a member of the team as quickly as possible.

Offer letters vary, but should contain:

  • The position title and to whom it reports

  • Salary and bonus, royalties or option details

  • An explanation of what benefits the employee will be eligible for, such as insurance, health, dental, profit sharing, 401k, and any other notable benefits

  • A tentative start date and a summary of what conditions the offer is contingent upon (e.g., physical, drug test, reference checks)

Include an expiration date by which the candidate must accept the offer. Giving the candidate two to five days to think about it is usually sufficient; extend the deadline only at his request.

Finally, send the offer sheet in two copies (one for the applicant to return, and one for his own personal files) and a signature line for the human resources manager and the new hire.


Conclusion

In this industry, a love of games, intelligence, and enthusiasm are the most important qualities that you should look for in a prospective hire. An intelligent and enthusiastic candidate learns rapidly, invests himself in his work, and will pay for himself several times over in a short period of time.

The competition for top talent in the games industry is fierce. When you find a good candidate, be aggressive. Move the process along as quickly as possible. Whom you hire is the most important decision you can make in starting a new company. When you are successful in choosing people that share your vision and enthusiasm about what kind of company you are creating, you have gone a long way toward assuring success.


Chapter 2.4: Financing from the Buyer's Side: Evaluating and Acquiring a Game Company

Overview

Tom Sloper

<tomster@sloperama.com>

The information in this article is based on the steps taken in evaluating a potential acquisition that did not come to fruition. By reading this article, you will learn about the various processes involved in evaluating and eventually acquiring a company.


The Target Company and You

The process begins when you find a company you think you would like to buy (or when the company's current owner thinks he would like to sell it to you). A preliminary conversation sets things in motion. You and the company's owner discuss whether a deal can occur, including a range for the acquisition price. In our case, the business' owner initiated negotiations. An initial meeting revealed that the seller's target price was twice what the buyer had in mind, but the parties did agree that they would probably be able to negotiate a deal in that range.


The Emotion Factor

The first thing to keep in mind as you begin the acquisition process is that emotions play an important role in acquiring a business, both for the buyer and for the seller. The buyer is buying a job, a new career, almost a new persona. The seller is selling the product of many years' hard work, and he wants to see the business go to someone who will work equally hard at keeping it successful.

It's important, though, that you not allow your emotions to win over your better judgment. If the deal is going to cost too much or otherwise turn problematic, you need to be prepared to walk away from it.


The Business Plan

The first step once you've decided to acquire a company is to work on your business plan. As explained in Article 4.2, "Managing the Development Process," you have to make a plan.

The business plan is not only a document that you will use to define what you will do with the company. It is also a plan used to get capital for acquiring the business. Your business plan also helps you set priorities and define, in concrete terms, the reasons for (or against) acquiring this particular business.

Without a solid plan, life usually conspires to prevent you from getting where you are trying to go. The very act of planning, though, lays the groundwork for a flexible approach to a process. Almost assuredly, things will work out somewhat differently from your well-laid plan, but you absolutely must have a solid plan before proceeding. The process of developing the initial plan helps later on, when the plan has to be adapted to deal with changing circumstances.


Outlining the Plan

In the first section of the plan you should describe your plan for the business itself.

  • Describe the company, its products and services, its focus.

  • Accomplishments of the company under the current ownership.

  • Growth opportunities under your ownership after acquisition.

  • Marketing aspects:

    • Who the company's customers or clients are.

    • Your plan to step in and take over those relationships—how you will keep them and strengthen them.

    • What steps you will take to get more clients.

    • How you will maintain the balance, not taking on more than you can handle.

  • The competition:

    • What other companies are doing what this company does.

    • Strengths and weaknesses of the competition. What lessons can be learned from those competitive operations.

    • Your plan to make your company successful and unique in that competitive environment.

    • Analyze current trends, and their implications for your venture.

  • Operating procedures:

    • Location: Where you will operate the business, and why.

    • Space: What kind of space the business needs.

    • Accessibility: For employees, for clients, for courier services, etc.

    • Hours of operation.

    • Building security.

  • Personnel and staffing:

    • Job descriptions and job titles: Number of employees in each. Name the employees if possible.

    • Salaries, benefits.

    • Staffing schedule.

    • What is the "business personality?"

  • Transition plan: When the acquisition occurs, will you be suddenly replacing the current president, or will there be a gradual transition?

  • Goals and objectives.

  • Future opportunities.

  • Risks: You have to be brutally honest in considering what kinds of things could go wrong, the likelihood of them happening, and what some contingency plans might be in case they do happen.

The preceding is a very brief description of what goes into Part I of your business plan. It is recommended that you get a good book on business plans; see this article's References section for suggestions.


Financial Data

Part I is written in prose style, but Part II of your business plan is presented in spreadsheets, charts, and graphs. Here you get into the real nuts and bolts: how much it costs to run the business, and how much money is to be made.

First, analyze and show the financial history of the company under current ownership. Banks want to see at least three years' history, and they want to see a pattern of profitability. If the company has not been profitable, then they'll see it as a bad risk. If you have a plan for turning that around, it had better be a really good one—and very convincing. You'll have to overcome skepticism and (worse) entrenched bank policies.

Analyze what it costs to run the business per month, per quarter, and per year.

  • Personnel costs: Salaries, benefits, raises

    • Office rent or building purchase payments

  • Utilities and ongoing expenses: Electricity, gas, water, trash removal, cleaning service, telephone, internet access, Web hosting

  • Capital expenses:

    • Computers, printers, scanners

    • Telephones, faxes, answering machines

    • Teleconferencing equipment, projectors for presentations

    • Desks, chairs, filing cabinets, credenzas

    • Conference tables, chairs

    • Coffeemaker, refrigerator, microwave, toaster

  • Supplies:

    • Printer ink, printer paper

    • Pens, pencils, erasers, staples

    • Batteries

    • Coffee, sweetener, creamer, filters

    • Cleaning supplies

  • Analyze where the money comes from: development milestone payments, royalties, direct sales

    • How much

    • How often

  • Break-even

  • Desired profit margin

  • Profit & Loss analysis

    • Year One—per month

    • Year Two—per quarter

    • Year Three—per quarter


Evaluating the Company

A company evaluation might or might not be part of the business plan document itself, but you need to evaluate the business. This can be a difficult part of the process, because no two companies are alike, and standard guidelines you might find won't necessarily apply. Each bank uses its own valuation methods, and nobody wants to tell you what his or her method is.

In this case, three different valuation methods were used and then averaged together. The three methods were as follows:

  • Thirty percent of annual sales (Source: [BizStats02]).

  • Five times EBIT (Earnings Before Interest and Taxes). (Source: [Robb95])

  • Earnings (EBIT) times two, plus inventory. (Source: [SCORE02])

The desired and maximum purchase prices were set based on the average of the valuations yielded by these three different methods.

Adapting Valuation

The target company is a retail game business, so the valuation methods that were used were based on factors such as sales and inventory. Different valuation methods should be used for a game development company.

The concept of EBIT (Earnings Before Interest and Taxes) applies to any business. Put succinctly, EBIT represents all profits (income minus deductible expenses) before interest and income taxes are deducted.

You will also need an asset breakdown: what exactly are you buying, and how much is every piece of that puzzle worth. A little creativity might be needed here, because it is likely that some of the price that will be paid will be above and beyond the tangible assets. That "above and beyond" money is usually called "goodwill." However, if your loan goes through the U.S. Small Business Administration (SBA), there cannot be any goodwill built into the purchase price. Therefore, you have to find other reasonable assets and assign them value. An example of such a valuable but intangible asset is a Non Compete Agreement, which states that the current owner or president cannot start a new game company (taking the most valuable employees with him) and compete against your new enterprise for at least two or three years. Determine how much such an agreement might be worth, and add that to the asset breakdown. Or perhaps the current owner will agree to consult exclusively for you for the first two years after the acquisition.

Figure out your capital spending plan. How much money do you need to buy furniture, equipment, business licenses, office lease deposits?

What is your "startup nut?" How much money do you need to buy the business and run it until you're past the transition period and the company is making a profit?

These figures tell you how much of a loan you need. You will be expected to inject some of your own capital into the acquisition. Expect this to be at least 25 to maybe 30% or more, depending on bank policy.

Figure in the loan payments into your Profits & Losses and Cash Flow statements. The interest payments go into the P&L, while the principal payments go into the Cash Flow.

Completing the Picture

Part III of your business plan is all about the current owner and you. The business plan needs to paint a complete picture of both parties of the deal—the buyer and the seller—and why the banks should want to loan the money for the deal to happen.

The banks want to see that you are stable, capable, reliable, and responsible. You have to have an up-to-date credit report and FICO score. A FICO score is a number that rates the individual's likelihood to repay a loan. A high number means you are a good credit risk. Use myfico.com, equifax.com or one of several other Web sites to obtain this data. Each bank will also have its own Personal Financial Statement forms they'll want you to fill out. They're taking a big risk on you, and they want to feel comfortable about taking that risk.

Other supporting documents that will need to be attached to the business plan are your résumé and the company résumé of the acquisition target. Specifically, you will need to include the past three years' corporate tax returns for the acquisition target, as well as your own personal tax returns.


Putting the Plan to Work

Your business plan is finally done. It's a masterpiece, and it was hard work to write. Still, in the end, the business plan is just a tool. Once you have written the plan, it's not like everything else will fall into place. However, completing the plan is an extremely important step in the process, and you should give it your best effort.


Getting the Loan

There are various sources for obtaining business loans, including the Small Business Development Center (SBDC) and your local bank. The SBDC program is administered by the U.S. SBA. Their mission is to provide management help to small business owners (those who currently own or are working to own small businesses). However, going through the SBA is usually very slow, and it seems that the program is geared primarily to aid minorities and veterans.

As mentioned before, one of the major documents required by the banks is tax returns for the company you are purchasing. Companies need to have at least three years' worth of tax returns in order to be considered stable, and our target company only had two years of returns. You need to check with your bank or financial institution to determine exactly what paperwork they require, but keep in mind that it's a long process that requires a lot of follow-up.

Contracts and Due Diligence

Another major part of the purchasing process is the contract and due diligence review. There must be a Buy-Sell Agreement between the buyer and seller. This agreement should cover all the rights and obligations of both parties, including delivery of intangible assets covered in the Asset Breakdown as mentioned previously. It's a truism that the seller is the one who controls the price, but it's the buyer who controls the terms. Although a particular business is offered for sale, there won't be a sale if the buyer doesn't come up with the seller's desired price. Once the seller agrees to an offer, though, it's the buyer who holds the position of strength; the money won't be changing hands if the seller doesn't agree to the buyer's terms.

"Due diligence" means that the buyer has accountants and other experts in the area review all business documents to ensure that they are factual and reflect the actual costs and revenues of the company. If anything is found to be false during this phase, the deal can be canceled, or the seller might be given time to remedy the problem. Do not underestimate its importance; many high-profile corporate mergers collapse at this point.

Advisors

Typically, you should have a CPA, a lawyer, and a businessperson as your advisors.

You should seek a CPA who is familiar with business acquisitions. The same goes for your lawyer. You probably don't need the lawyer until you are ready to write the contract, but you should at least get him lined up in advance. The CPA you will want even earlier in the process—you'll want his feedback on your business plan, before sending it out to banks.

SCORE stands for "Service Corps Of Retired Executives." These are folks who have learned a lot about business and volunteer their time to help neophytes in any way they can. A SCORE counselor can help you evaluate the target business, for example.

Good advisors are tremendously important. When the result of an action comes back, you have to make a decision, and quickly. The thinking of others will be extremely valuable in this process. Each advisor adds his perspective on the matter. These different points of view will help you arrive at a better-informed decision than if you just proceed based on your gut reaction. In our case, although the buyer very much wanted to buy this business, there was group consensus that this deal was not going well. Intellect wound up winning over heart.


Conclusion

Buying a business is a good way to become a business owner. However, emotions can get in the way of making the best decisions, both for the seller and for the buyer. As with any important venture, planning is vital. You'll need money to buy a company, and if you're not a minority or a veteran, perhaps the conventional bank business loan might be better than trying to go through the SBA.


References

[McKeever99] McKeever, Mike, How To Write A Business Plan, Nolo Press, 1999.

[Bischof&Pucket96] Bischoff, William R. and Pucket, G. Douglas, Guide To Buying And Selling A Business, Practitioners Publishing Co., 1996.

[Yegge96] Yegge, Wilbur M., A Basic Guide For Buying And Selling A Company, John Wiley & Sons, 1996.

[Robb95] Robb, Russell, Buying Your Own Business, Adams Media Corporation, 1995.

[BizStats02] BizStats.com, "Rules Of Thumb For Valuing Small Businesses," available online at www.bizstats.com/rulesofthumb.htm, 2002.

[SCORE02] Service Corps of Retired Executives, available online at www.score.org, 2002.


Chapter 2.5: Financing Projects and Startups

Overview

Thomas Djafari

<tdjafari@activision.com>

With every year, games become increasingly expensive to develop, the amount of work to handle becomes larger and larger, and while good planning and a well-controlled production will save you money, you still need lots of cash.

Ironically, it turns out that keeping the team together throughout the project and actually turning a profit might be harder than getting the initial funds.

The goal of this article is to illustrate the various sources of financing you can use for your project, how they work, and what the people who will decide whether to fund your team are looking for when evaluating your project.


Risks versus Returns

This is the single most important consideration, and one of the cornerstones of any business. The higher the risk, the higher the expected return must be; the larger the investment, the more important it is to keep risk low, or at least manageable.

All investors will need to evaluate the risks associated with your project. Provide them with the right information to allow them to evaluate the potential risks versus the potential returns of your venture.

In general, videogames are considered a risky investment. Compared to some other domains, they carry a relatively low cost in equipment and a very high cost in human resources, which is what investors tend to shy away from. While it is possible to recover assets from a failed project and re-use them or re-sell them, the money gone in salaries is a loss; when making videogames it represents the largest chunk of the budget.

Another concern is that many games lose money. A good product is not enough: you also need good marketing, because companies are competing for shelf space in retail stores. Generating expectation from the customers, as the movie industry has done for years, has become indispensable. From an investor's point of view, there are many ways that this process could go wrong.


What Matters

You have a game concept, and possibly a team. Investors have money and questions.

A financing deal has to be built on a win-win agreement. Building a product with someone else's money requires a strong and honest relationship between the parties. Answering each other's questions is the key to a good start.

Risks Are Everywhere

Software development is very hard to plan. Unexpected problems—hardware failures, employee turnover, and so forth—keep cropping up at the most inopportune moment. Not only should your design be structured in such a way that it minimizes risk, but you must also prove to investors that you have taken all of the steps necessary to do so.

It is very important to be completely open and honest at this stage. All parties involved need to know what parts of the development carry the risks, how to handle them, and so forth. For example, the technology to be used has to be discussed in detail; using pre-existing engines or building on a previous game carries much less risk than rewriting code from scratch, even if it means more work.

Fallback Plans

Plans fail. Seemingly perfect ideas sometimes turn out to be wrong. And things sometimes just don't happen as expected.

Nobody is expecting you to deliver a problem-free project. However, investors need to know that you're ready to handle the problems as they arise. Take the right steps to minimize the risks, and prepare multiple fallback strategies to account for the possibility that part of your design might be cancelled, that you might lose a part of the team, suffer technical or planning problems, or that an unannounced competing title might change your own game's market conditions.

Experience and Knowledge of the Industry

Dealing with a company familiar with the game business is definitely easier for everyone involved. If your investor is not also your publisher, relationships can become slightly more complicated, especially if the funding company has no prior game industry experience. If that is your case, question the investors about their motivations for entering the game market and try to understand their culture and goals.

Commitment

All projects go through hard times. For an investor, it is sometimes easy to bail out, leaving you with very little recourse, no matter what the contract says. Keep in mind that contracts are not much more than what arguments revolve around in courts if things go wrong, and that the investor has more money to fight legal battles than you do.

In practice, completing the project successfully will require you and the investor to be more flexible than what is specified in the contract. As long as both parties are committed and on good terms, this is the way every project goes. Therefore, before signing with an investor, make sure that they are as committed as you are. Ask the tough questions: Are they going to concentrate on a couple of projects, or do they run a myriad of them at the same time? If your game is just 1 out of 100 projects for them, it probably won't hurt them much to cancel it for any reason they please. Ask them to demonstrate a strong interest in your project and team.

Flexibility

Don't be afraid to ask the prospective investor about their plans if the game slips, and if they'd be open to prototype some ideas that might change the nature of the product. While the answers to these questions will need to be detailed in the contract, it is a good idea to understand the intent of what the other party is looking for as early as possible. Do they want a specific game to fill a niche, or just any good game with a chance to compete in the marketplace? Learn from other developers who worked with that investor.

How Solid Is the Company?

Even a good deal is not worth much if the company disappears in the middle of your project. It is important to do your homework and then question them. You'll have to get involved with their politics and listen to their employees as well as other developers before you can determine if you want to do business with them. Remember that a single replacement on the board of directors can make the difference between saving and canceling your project, and that this type of situation is out of your control. And don't forget that the financial situation of the investing company's subsidiaries, parent company, or other branches might also affect you.


Publisher Funding

So far, we have covered all the essential points that will need to be discussed with a source of financing. But where do you go now? Whom should you talk to? The most common option is to sign with a game publisher, but it is not the only one. Here are some of the issues that might arise when negotiating publisher funding.

Control

The publisher will want to assume the role of producer ([McGilvray03]). This is usually a good idea because their knowledge of the market is probably better and more current than yours is. The producers working for large companies are usually very knowledgeable and can help you make your product appealing to a larger audience, help with game play tuning, and so forth. However, the contract must set boundaries delineating what can be changed by the publisher; otherwise, the number of features might double in a month, and your project plan quickly become obsolete.

Manage relationships with the publisher well. The team will lose some power over their own game; make sure that they know it is for the project's greater good.

Ownership

Ownership is a very important and controversial topic. Typically, the publisher will want to own the technology used in the game, which will allow them to legally reuse it without paying you extra sums. If your game is almost ready and you have other opportunities elsewhere, the publisher will be the one making concessions in this area; otherwise, you might have to give up ownership of the software. At the very least, make sure you get a percentage of the profits they earn from re-using your work.

Protecting Your Team

Get a minimum number of units sold guaranteed in writing. A publisher buying a product that competes with their franchise title and never releasing it, in order to protect their sales, is a nightmare scenario that rarely happens but one that you must be protected against. Make sure your contract guarantees a release in stores and a minimum marketing budget, and negotiate a "kill fee" to protect yourself in case of cancellation.

And, of course, make sure that the milestone payment schedule is structured in such a way that you will never experience cash flow shortages. Since checks won't be mailed until the publisher has approved a milestone delivery, build the delay into your plan.


Going Through a Venture Capital Company

Foregoing publisher funding to sign with a venture capital company is a radically different experience, with higher risks for you—but also higher potential rewards.

While working with a publisher is pretty much like working for a publisher, dealing with a VC company is like having a partner—but one that doesn't share your priorities.

In addition to a good team and a good game idea, you need a solid business plan to obtain capital. Capital investors are buying a share in your company, not just in one project; they must be confident in your long-term plans before they open their checkbooks. Preparing a business plan requires significant work; hiring a professional to write yours might be money well spent. See [Laramée03] for details.

Selecting a VC Partner

Most VC companies are not interested in videogames. Unfortunately, game projects are too expensive for very small funds, and not large enough for most companies that deal in the stock market. Moreover, since a game might take two or three years to yield revenues, it is hard to reconcile investment in games with the typically very short-term horizon of venture capitalists.

If a VC company initiates a dialog with you, it will be extremely different from what you get with the publishers. Since you will be asking for "seed money" to create a demo, or maybe even for enough money to develop the entire product, they will question your ability to deliver the game, how you plan to sell, it and what they can get back if everything fails. Since they are not from the game industry, they might rely on publishers you choose with them to evaluate the product itself, and they might get involved in negotiating the publishing deal. For example, the VC might pay you to develop the game and receive the milestone payments from the publisher; this protects you from cash flow fluctuations, but at the cost of an extra middle man. They will also control expenses very closely, thus forcing you to stick to the plan instead of doing research—to a VC company, a decent title delivered on time is preferable to a better product that costs more than expected and therefore reduces the calculated return on investment.


Going Private

Individual investors might also be interested in putting their own money into ventures like yours. And they may not be as difficult to find as you might think. For example, owners of small to medium-sized businesses might be willing to diversify their portfolio and risk small amounts of money in projects such as videogames.

In practice, individual investors will rarely provide more than what is needed to build a prototype, which brings you back to the original problem: finding a publisher. Funding a complete project from beginning to end is out of reach for most individuals. Therefore, this is a quick method to get started on a game, but it is not suitable for large projects.

A word of warning: since individual investors are usually not very familiar with the industry, they might not be prepared to deal with the types of problems that every project encounters, such as delays when developing the demo, finding the publisher, signing a contract, and so forth. Make sure there are no misconceptions, or the relationship can quickly sour.


Banks

Banks lend money to people who have money. It is easier to get $500,000 from a bank if you bring another $500,000 as collateral than it is to ask for just $50,000 empty handed. Therefore, banks cannot be realistically considered a stand-alone funding resource; instead, you should use bank loans as a complement to your core funding.

For example, it is possible to secure an advance from a publisher and finance the rest of your development with a bank. This can be very useful, as the lower publisher advance might allow you to negotiate better royalty rates.

The bank can also provide a credit margin to use as a buffer when the schedule slips or milestone payments don't arrive in time. A good credit margin also comes in handy when beginning the next project while awaiting royalties.


Conclusion

Getting funding for a project is not nearly as difficult as getting the project done. It is, however, very time consuming, and the process can take anywhere from three months to a year.

Getting professionals to help can be invaluable. Involve a lawyer who is familiar with intellectual property laws when discussing your contracts. Agents can also help represent your team; meeting people and shopping around for a publisher is a tough job, not to be taken lightly, and a good agent with the right contacts and knowledge of all the pitfalls can make the difference between success and failure.

One word about ethics: there is nothing wrong with getting publishers and funding companies in competition with each other—it is actually the best way to go—but commitments are not to be taken lightly. Verbal agreements are binding. Do not promise something you can't deliver.

It is difficult for developers who are passionate about their product to change their focus from making the best game to making the most profitable game. However, remember: it is what investors expect of you.


References

[Laramée03] Laramée, F. D., "Writing a Business Plan for a Game Development Startup," Secrets of the Game Business, Charles River Media, 2003.


Chapter 2.6: Wireless Business Models

Overview

Johanna Wilson

<johanna@openpathproducts.com>

The wireless gaming market is an industry that is rapidly changing. This change is due in part to the rapidly changing wireless technologies as well as the adaptation of wireless technologies and how services built on these technologies can be billed. These factors influence the business model for wireless games. Therefore, an overview of the most common wireless technologies is necessary to understand wireless business models. Equally important is the sales model associated with these various technologies, as it impacts how you can derive revenue.

Current wireless gaming technologies include Short Message Service (SMS), Wireless Application Protocol (WAP), J2ME as well as others such as the Palm PQA and BREW. Each technology has its strengths and has various amounts of usage associated with it. This article concentrates on the first three of the technologies mentioned as they are commonly available and well suited to wireless gaming. An overview is provided for each technology, followed by technical and revenue considerations for each.


Sales Models

Three distinct sales models are presented for each technology within this article:

  • Carrier Sales

  • Aggregator Sales

  • Direct Consumer Sales

Figure 2.6.1 illustrates these models. In the Carrier Sales model, the developer sells product or services directly to the carrier. The carrier offers these services to subscribers, bills the subscribers, and pays the developer. With the Aggregator Sales model, the carrier interacts with an aggregator for access to multiple products from multiple developers. The aggregator will typically provide billing and technical services to bridge the gap between developer and carrier. Finally, the Direct Sales model requires the developer to market and sell services directly to the subscriber. The subscriber must pay both the carrier and the developer to receive the developer's unique offering.

Click To expand
Figure 2.6.1: Sales models.

The case studies throughout this article profile companies actively involved in supporting developers with generating wireless gaming revenues. They each provide different methods of marketing and selling wireless applications.


SMS: Short Message Service

Short Message Service, or SMS, is a text-based service for exchanging one- and two-way text messages. If you have ever received a message notifying you that you have a voice mail message on your mobile phone, then you have seen text messaging in action. One-way SMS messages have been available for years and were initially used to provide messages to telephone subscribers alerting them to the fact that they had received a voice mail. Later, news alerts, sports scores, and traffic messages were provided to mobile users as well. Two-way SMS messaging allows messages to be sent to the mobile phone as well as from the mobile phone to other mobile phones, e-mail addresses, or to servers that manage services such as games. Messages sent to the mobile phone are commonly referred to as "mobile terminated," while messages sent from the phone are referred to as "mobile originated." With the advent of two-way messaging, a whole new host of functionality became available. Mobile phone users could use text messaging in an interactive fashion, interacting with others or with servers capable of responding to SMS requests.

Another factor in making SMS messaging more prevalent was inter-carrier messaging. Initially, two-way SMS messaging allowed messages to be sent to or from mobile phones from within the same carrier or to an e-mail address or server capable of responding to SMS requests. Inter-carrier messaging allowed messages originated from a mobile phone on one carrier's network to be sent to a mobile phone on another carrier's network. This was a watershed event, as it prompted tremendous growth in SMS traffic.

SMS Technology

SMS Messages are exchanged with consumers via the carrier's Short Message Service Center (SMSC). The SMSC is the bridge between the TCP/IP and the wireless Signaling System Seven (SS7) protocols. In an ideal world, SMS applications would be able to directly interface with the SMSC so that the application can be technically "as close to the consumer" as possible. Direct SMSC access enables the developer to guarantee message delivery, send enhanced binary content such as bitmaps and ring tones, and receive mobile-originated messages in a timely fashion.

Unfortunately, the carrier's SMSC is typically not available for direct access by application developers. Some carriers will provide direct access to third-party SMS delivery agents that in turn will resell access to other application providers. This is a valid "second choice" for developers if direct SMSC access is not possible.

Most carriers also provide publicly accessible Internet gateways that relay Web (HTTP) and e-mail (SMTP) messages to the SMSC. Some carriers also provide mobile-originated e-mail gateways that enable subscribers to send Internet e-mail via SMS. These gateways can serve as a "last resort" for SMS application developers that require one- and two-way SMS access to the carrier. This is the least-preferred technique, as it is difficult to guarantee SMS message delivery, delivery is not always immediate, and there is no support for direct billing to the consumer.

Figure 2.6.2 illustrates the various SMS connectivity options. The carrier's SMSC is typically available only to select third parties. The carrier's Internet gateway provides public access to basic SMS capabilities. The aggregator can offer connectivity and billing services.

Click To expand
Figure 2.6.2: SMS connectivity options.


SMS Carrier Sales

Case Study 2.6.1: Pinpoint Networks Inc.
Start example

Pinpoint Networks, Inc. is an aggregator that provides wireless game developers a method for distributing, supporting, and generating revenue from their applications. Developers can join the Pinpoint Fuel Developer Program and register their applications. Pinpoint offers these applications to mobile operators seeking to provide fee-based applications to their subscribers. Developers define the method for pricing their applications such as on a per-download basis, subscription basis, and so forth. The developer also provides a suggested price for the applications. The Fuel platform is integrated into carriers' billing systems so that subscribers are charged for the applications they use. The subscriber remits payment to the carrier, which in turn remits payment to Pinpoint who pays the developer. The Fuel program provides a simple path for developers to derive revenue from their applications. The Fuel program supports SMS and WAP technologies.

Special Pinpoint developer tip: when developing mobile games, it is very important to provide intuitive functionality. It must be easy to play from any wireless device. Keep in mind that since the subscriber is paying for entertainment, there must be a compelling reason for the subscriber to want to play and continue to play over and over again!

Information on Pinpoint Networks, Inc. can be obtained at www.pinpoint.com , 1.800.746.7646 or <devprogram@pinpoint.com>.

End example

In an ideal world, all SMS applications are sold directly to and through the carrier. The carrier has a vested interest in promoting SMS technology and has a consumer billing system in place. The application could be sold via a one-time fee to the carrier and the carrier would recoup its costs by charging subscribers on a perusage/per-message basis. The application must typically be custom-configured to inter-operate with the carrier's SMSC and underlying billing system.

The amount of network traffic that a carrier experiences is important, as carriers typically bill their users based on it. Specifically, most carriers bill their users for each SMS message that they send or receive. Increasing this type of traffic per user is important to the carrier as it can increase revenue. Carrier revenue is typically benchmarked in the wireless telecommunications industry as Average Revenue Per User, or ARPU. Carriers are always looking for ways to increase their ARPU. One way of enticing users to use more SMS messages is to provide enhanced services based on SMS such as games. Users can play SMS-based games against other opponents or a game server. The carrier might then bill the user for the number of SMS messages that were used to play these games.

Each carrier has its own way of billing for the SMS messages. The game developer who has developed an SMS-based game can earn revenue from this game by one of two methods through the carrier channel.

  • The carrier can elect to purchase the game outright, providing a fixed one-time fee to the developer, or to license it for a fixed amount of time.

  • The carrier can share the fees charged to the subscriber with the developer.

Use of your game should increase the amount of SMS traffic used by the subscribers. Generally, your best bet will be to target carriers who can recognize revenue from increased traffic and will enter into a revenue split relationship with you.

Content Aggregators

Although many wireless carriers are actively looking for enhanced services such as wireless games, carriers for the most part are large organizations, and finding the right contact to pitch your wireless game to can be time consuming and difficult. Further, some carriers prefer to enter into a relationship where they can obtain many games at once rather than negotiating for one or two games at a time with individual developers.

Service aggregators address these issues by facilitating business and technical relationships between the developer and carrier. Service aggregators are companies that represent many different types of enhanced services, including games. These aggregators often provide services that are of benefit to both the carrier and the developer. For example, they might provide safe but reliable access to the carrier's SMSC. This eliminates the need for the SMS developer to use the carrier's public SMS Internet gateways or third-party SMS distribution companies in order to send or receive messages. The aggregator also typically provides a consistent billing mechanism for developers and integrates into a carrier's billing platform. Billing is frequently performed on a per-message basis.

Some aggregators also provide certification for a game to ensure that it can be used with multiple mobile phones and will work under high use conditions, or provide a hosting service for the game with a guaranteed level of support for the server. Carriers are notoriously concerned with ensuring that the subscribers can receive service whenever they request it. Typically, this means that service must be available more than 99% of the time. To ensure this level of up-time requires redundant servers, as well as redundant connectivity to the carrier's network. Some game developers might have relationships with hosting providers that can ensure this level of support; others might opt to allow an aggregator to provide this service for them for a share of the revenue associated with the game. Aggregators also often provide marketing of the game, targeting it to providers to which they already have existing relationships. Whether you choose to use an aggregator or not will depend on the strength of your business development with respect to carriers as well as your service level agreement with your hosting firm.

Direct Sales

The final distribution option is to sell directly to the consumer. This is potentially the most lucrative in that developer revenue is typically not shared with the carrier or application aggregator. However, this technique also requires direct consumer marketing and sales efforts. The developer must also have a means for billing the customer, typically with credit cards. If the SMS service transmits a large quantity of SMS messages, then it might be necessary to broker a carrier or message distributor agreement to avoid having the carrier block your content as "spam." It also might be necessary to use a third-party SMS delivery agent to send SMS binary content. In this scenario, it is almost always required that the subscriber separately sign up for SMS service with the carrier. One drawback to this model is that consumers might feel that they are paying twice for a service, since they must pay the carrier for the SMS message and the application provider for the SMS application. Another drawback is that mobile-originated requests must typically be performed using mobile-originated SMS/e-mail services that are implemented differently across carriers. Consequently, the consumer experience is not consistent and can be difficult for the developer to support.

In summary, the SMS market can be serviced at both ends of the technical and business spectrums. On one extreme, a game developer can directly bill consumers for services that are provided through the carrier's public SMS e-mail gateway. On the other, a developer can write advanced SMS services that are sold to the carrier, which handles all subscriber billing. Service aggregators help to fill in the middle of this spectrum.


Wireless Application Protocol

The Wireless Application Protocol (WAP) constitutes a set of protocols that collectively enable mobile phones to browse specially constructed documents located on the Internet. WAP features a browser application that is stored on the mobile phone and queries external WAP-compliant documents. The user requires both a mobile phone that supports WAP as well as the WAP service from the wireless carrier. WAP access is typically menu driven and is primarily text based with rudimentary pictures. Wireless carriers typically bill their subscribers for each minute of WAP access used. Providing services that would encourage their subscribers to increase their WAP usage is therefore of interest to them.

WAP was initially released by carriers with much fanfare and high expectations. WAP technology has been somewhat of a disappointment to the industry because the expectations were so high. Consumers expected the experience to more closely resemble that of their Web browsers. The primitive mobile phone browser interface, coupled with slow data rates, has created a negative consumer and industry impression. Nevertheless, WAP technology provides greater interactivity options than SMS and has been used to create a number of wireless services, including games. With the advent of larger screens, more sophisticated browser capabilities (such as XHTML browsers), and faster network access, the WAP experience should continue to improve for consumers.

WAP Technology

Mobile phone browsers interact with Internet-hosted content via the carrier's WAP gateway. The WAP gateway converts between WAP requests and the Hypertext Transfer Protocol (HTTP). The actual content (i.e., your game) is hosted on a standard Internet-accessible Web server.

Unlike SMS, the protocols for publishing WAP content are consistently used across carriers and products. Therefore, the barrier to entry in publishing WAP content is fairly low. Only a properly configured Internet Web server is required along with programming knowledge of WML and/or XHTML.

Unfortunately for independent content providers, some carriers will not allow their subscribers to "travel off the beaten path" in order to access sites that are not sponsored by the carrier. Even if subscribers are allowed to access external WAP sites, it is often a difficult process to enter custom URLs into the mobile phone. Finally, even if the subscriber is able to navigate to a custom WAP site, the independent content provider will typically not be able to automatically retrieve information about the subscriber such as a unique identifier, mobile phone number, and so forth. For subscription-based services, the user might therefore be required to endure a login process each time the service is requested.

Figure 2.6.3 illustrates the WAP browser model. The carrier provides a WAP gateway enabling the mobile phone to request Internet content. If permitted by the carrier, a subscriber can directly access independent content hosted by the developer. An aggregator can facilitate access and billing for developer content.

Click To expand
Figure 2.6.3: WAP connectivity options.
Case Study 2.6.2: Pixo
Start example

Pixo provides wireless infrastructure software that allows wireless carriers to manage the complexity of delivering wireless applications to their subscribers. Pixo provides an alliance program at no charge to wireless application developers. This program allows developers to list their applications in a warehouse of applications that are shown to wireless carriers. Pixo considers content to be key and a driving force in the wireless data business model; thus, applications to provide this content are important.

While Pixo provides developers exposure to carriers, it does not resell the applications. Rather, the developer and carrier directly negotiate. Pixo provides a formal working process that includes trials to showcase the technology and engage the carrier in making a decision. Supported technologies include J2ME, SMS, and MMS. Typical developers in this program are small to mid-sized firms. Developers can use this program to obtain a larger partner who can assist with the sales and marketing of their applications. The alliance program can be cost effective for developers, as they can gain market exposure without having to do the footwork of creating initial contacts that can be difficult to obtain in the carrier space.

Pixo recommends that developers consider developing J2ME applications. This technology eases the job of wireless carriers by abstracting the application from the handset architecture and providing a secure application layer.

Special Pixo developer tip: The developer should provide a clearly defined message to the wireless carrier. This message should include their application, the technology used, and how the carrier can use their application to generate revenue. Provide specific examples of how the carrier can bill the application.

Information on the Pixo program can be obtained by contacting Mark Grandcolas, VP of Strategic Alliances, at <mgrand@pixo.com>.

End example

WAP Sales Models

Selling WAP content directly to the carrier is an ideal solution for the developer because it addresses a number of business and technical difficulties. The revenue model for the developer is simplest if the carrier offers a flat fee to the developer for use of the WAP application. If the carrier elects to host the application, then the developer only needs to worry about maintenance and support. The carrier can then configure the WAP gateway to pass along any information, such as mobile phone number, that the WAP application might require.

A carrier arrangement is still highly preferable even if the developer hosts the applications and revenue-shares with the carrier on the profits. This is because a convenient consumer billing mechanism is being provided and the carrier can configure the WAP gateway to pass along required subscriber information to the application.

Perhaps the most important benefit of selling directly to the carrier is that the application will likely receive prominent placement on the mobile phone's WAP Start Deck. The application is most likely to be used if it can be seen and easily accessed by the subscriber. Without Start Deck placement, it is very difficult to obtain high traffic volumes on a WAP site.

WAP Aggregators

Unfortunately, carriers do not typically have the resources or inclination to work with individual application developers. Configuring billing services, WAP gateway rules, and updating its Start Deck for every new WAP Application is not a reasonable model for the carrier. Although many carriers are implementing developer programs to support developers, it can still be a time-consuming process to "get in with the carrier."

Service aggregators can help to place your applications with multiple carriers while hurdling the business and technical challenges associated with each carrier. Aggregators can help to make an application accessible from each provider's Start Deck. They can also integrate with the carrier's billing system so that consumers are directly billed for your services. Some aggregators might even host your application to help ensure the high-availability expected by the carrier. Of course, the aggregator might expect a portion of the revenues obtained by your service.

Direct WAP Sales

The final option for an application developer is to market and sell a WAP application directly to the consumer. This is perhaps the easiest way to get started, but the most difficult way to generate revenue. It requires direct billing of a consumer who is already paying monthly fees to the carrier. It also requires the consumer to access a WAP site via a custom bookmark that can be tedious to assign on the mobile phone.


Java 2 Micro Edition

In the Java 2 Micro Edition (J2ME) model, an application is stored and executed locally on the mobile phone. Network access is not required, although the application can optionally retrieve data from the Internet if it has been designed to do so. The application can support graphics, animation, local data storage, network access, and extensive program logic. Therefore, J2ME is a highly appealing technology for game developers.

The economic advantage of J2ME is that it supports a product-based billing model that is familiar to every consumer. Just like buying software for a personal computer, the consumer pays a fee for the software, installs it on the mobile phone, and then executes it as desired. Of course, other billing options, such as subscription-based fees, can be used depending on the functionality of the billing system in place. However, since J2ME is fundamentally a product-based model, it is easier to sell to the consumer than SMS or WAP services.

J2ME Technology

Although Sun has standardized the J2ME Mobile Information Device Profile (MIDP) APIs, the handsets are highly varied in their screen, memory, and performance capabilities. Even mobile phones built by the same manufacturer for the same carrier are highly varied in their capabilities. From a business perspective, the developer should support as many devices as possible in order to realize greater market penetration. However, more sophisticated handsets should not suffer from the "lowest common denominator" syndrome for the sake of supporting low-end devices. This dilemma is left to the developers to resolve.

Figure 2.6.4 illustrates the J2ME technology model. The carrier typically provides a mechanism for subscribers to download J2ME applications over the air. The carrier also provides a mechanism, via the same or different server, for the applications to access Internet content servers. An aggregator can facilitate the distribution and billing of applications and content on behalf of the developer.

Click To expand
Figure 2.6.4: J2ME connectivity options.
Case Study 2.6.3: WirelessDeveloper
Start example

WirelessDeveloper serves the Wireless industry with a number of unique services. Through their Developer Program Management service, they help large companies establish and manage relationships with wireless software developers. Developer Programs allow wireless carriers and platform providers to offer their customers many more wireless applications than they could develop on their own, and provides new channels to market for developers.

WirelessDeveloper also provides an Agent service to wireless software developers who are looking for a mechanism for generating revenue based on their applications. They will act as an Agent for wireless game and other wireless application developers. In this role, they assist developers with marketing and direct sales for their applications throughout the world. WirelessDeveloper complements this by coaching the application developer on how to capitalize on their strengths.

WirelessDeveloper provides a PartnerMatch service. This service provides potential clients and strategic partners to wireless software developers. Since making the appropriate wireless contacts are often difficult and time consuming to obtain, this can be a cost-effective mechanism for wireless application developers seeking clients or wireless partners. The wireless software developer specifies the type of contacts that they would like to obtain, and WirelessDeveloper in turn facilitates these.

Finally, technical staff can use the WirelessDeveloper training services as a resource to become familiar and certified with WAP, GPRS, J2ME, CDPD, and other wireless technologies, and build a unique online résumé to promote their capabilities on the Web.

Special WirelessDeveloper tip: Taking your wireless games to market and deriving revenue from them is often called "monetizing your application." Ensure that you have a method for billing gameplay in a variety of ways when you design the game.

Information on WirelessDeveloper can be obtained by contacting Susan Leuth at <Susan@WirelessDeveloper.com> or by referencing www.wirelessdeveloper.com.

End example

J2ME Sales Models

The decision to sell through the carrier will be driven largely by the carrier's role in the application distribution model. It will be necessary to pursue this model if applications can only be sold through the carrier. A carrier will typically take this position in order to guarantee application quality, protect its wireless network, and provide a consistent experience to the subscriber. The carrier must approve the application concept, might require application certification, and finally make the application available to its subscriber base. The advantage to the developer is that this model provides a simple subscriber marketing, sales, and distribution mechanism. The disadvantage to the developer is that the process can take several months and the developer might have to pay for certification. Considering that the typical price for a J2ME application is less than $10, it can take a while to recoup the initial expenses.

J2ME Aggregators

Aggregators can help developers to place J2ME applications with the carriers and directly with consumers. Some aggregators provide their own certification process and will market games and other applications to carriers. These aggregators provide an alternative path to placing applications with carriers that only allow subscribers access to authorized J2ME software.

Other aggregators sell applications directly to consumers. These companies provide a single directory of applications providing consumers with a "one-stop shop" for J2ME applications. The advantage is that these companies can provide billing services.

Direct J2ME Sales

Finally, the application developer can elect to sell J2ME applications directly to the consumer. The advantage to this approach is that the developer can retain all revenues. The disadvantage is that the developer must provide all marketing, sales, and distribution services such as billing.

In conclusion, J2ME technology is expected to have great consumer appeal and offers many technical and business advantages over SMS and WAP. Distribution models will initially be varied, but ultimately consumer demand will drive the market.


Conclusion

While the wireless technology is constantly evolving, SMS, WAP, and J2ME technologies are commonly available and can be used to develop games. Games developed using these technologies can be billed to the customer directly, via an aggregator, or via a carrier. Developers should determine the types of wireless technology best suited for their particular games. Developers should also consider their company's strengths and decide whether it is in their best interest to use partners to assist with the sales and marketing of their games or to directly market their games to consumers or carriers. Leverage the technology and your distribution methods to extract optimum revenue, but remember to have fun and make the games fun!


Chapter 2.7: Online Business Models: Using the Net for Profit

Overview

Sande Chen

<Sande.Chen@alumni.usc.com>

With estimated revenue of $635 million to be earned in 2003, online gaming has emerged as a likely powerhouse in the industry's future. Consulting firm DFC Intelligence reports that 2001's top online games each cashed in over $100 million in revenue and predicts that by 2006, 114 million people worldwide will be playing games online. Other analyst groups support the high projections: IT researcher IDC forecasts $1.8 billion in U.S. revenue for 2005, while Jupiter Media Metrix predicts $2.55 billion in 2006. Game companies, from Microsoft to small independents, are eager to develop online business models capable of capturing this lucrative market.

Online gaming, while wildly popular, is just one of the ways to capitalize on the Internet's potential. Web-savvy companies can sell directly to customers, serve as intermediaries, or employ a combination of online strategies. This article by no means intends to discuss the myriad possibilities. Instead, relevant examples will be examined using the structure of atomic business models explained in [Weill and Vitale01].


Bypassing the Traditional Retail Model

Since the Web's inception, e-tailers have learned to harness the power of the Internet to reach thousands of would-be customers. The direct-to-customer business model bypasses intermediaries and ideally offers consumers a better value, better customer service, and increased convenience. The e-tailers, in exchange, might gain higher profit margins through cost reduction, product placement fees, and the sale of advertising space or customer data. The direct-to-customer business model can be extremely profitable, but its success depends on several key factors.

As [Weill and Vitale01] details, a successful direct-to-customer business must first capture customer awareness and then maintain interest through marketing or good press. The business must woo repeat customers by understanding their needs and by ensuring that transaction processing, fulfillment, and payment are conducted in a secure and efficient way. In addition, the product must be unique enough to deter price competition.

To the independent game developer, self-publishing and self-distribution via the Internet might be an appealing proposition because the game developer retains control over the product. However, the experiences of independent developers CogniToy and Digital Tome indicate that both retail and direct-to-customer markets can be difficult for self-publishers.

Traditional Retail Model

The traditional retail model, which is discussed fully in Articles 1.2 and 1.3, is a proven method to generate revenues. As shown in Figure 2.7.1, the publisher, the distributor, and the retailer all act as intermediaries between the developer and the customer.

Click To expand
Figure 2.7.1: In the traditional retail model, the publisher owns and controls the rights to the game. The developer supplies the game to the publisher, who then negotiates with distributors and retailers to reach the customer.

Each of these middlemen decreases profits for the developer. Even though the consumer might pay $50 at the store, the developer tends to receive little or none of that purchase price. Moreover, since the advance payment by the publisher is recoupable, the developer will not receive any royalties until the game's development costs have been fully repaid. From the standpoint of the game developer, this model tends to be more favorable to publishers.

CogniToy: Web and Retail Sales

Independent developer CogniToy chose to use the direct-to-customer approach and later expanded to traditional retail channels. Located in Acton, Massachusetts, CogniToy was founded in March 1997 to make "intelligent toys for intelligent minds." Its award-winning robot simulation game, Mind Rover: The Europa Project, was released in November 1999 and at that time, only available through CogniToy's Web site. Like other small companies on the Web, CogniToy used a third-party credit card validation service to facilitate sales.

Despite scanty advertising, Mind Rover sold pretty well via the Web site. Reviewers raved about CogniToy's first product. Within months, Mind Rover was available for purchase on Amazon, EBWorld, The Robot Store, and several other online sites. It sold so well at EBWorld, Electronics Boutique's online home, that the retail giant asked CogniToy to consider selling the game at its regular stores.

However, CogniToy soon found traditional retailing quite difficult. It lacked the marketing resources and the clout of the big software publishers to get in-house advertising or retail shelf placement. The company needed to package Mind Rover in a glossy four-color box for the retail version. Originally, Mind Rover had sold as a CD and manual only. To keep its cost per unit constant, CogniToy cut the 250-page manual down to 64 pages.

Moreover, since game retailers sell on consignment, a company only gets paid if the product sells. If it doesn't sell, the company pays to ship the unsold merchandise back. CogniToy found itself waiting months to get paid, if at all. While traditional retailing might have increased CogniToy's exposure, it yielded significantly less profit per copy than the Web site sale.

CogniToy's CTO Kent Quirk advises, "I would not recommend that small companies attempt to crack the retail market without knowing exactly what they're doing."

CogniToy's retail experience resembles that of Figure 2.7.1 while its online business model corresponds to Figure 2.7.2. Like other companies that sell direct-to-customer and also use intermediaries, there are potential channel conflicts. For example, the Web site sales might destabilize a relationship with the retailers. Instead, CogniToy could have pursued another revenue stream through the licensing of its technology. Indeed, it now sells a downloadable development kit to owners of the Lego RCX robot. In hindsight, Quirk admits that retailing might have been a bad decision for CogniToy. If there's a next time, CogniToy intends to leave retailing to a publisher.

Click To expand
Figure 2.7.2: CogniToy's self-published game, Mind Rover, was sold direct-to-customer via its Web site and through intermediaries. EBWorld, like its parent company, sells on consignment.

Digital Tome: Episodic Digital Distribution

Like CogniToy, Houston-based Digital Tome opted for a direct-to-customer model but with episodic downloads. Co-founders Van Collins and Jim Shiflett planned to digitally distribute what would be equivalent to a traditional retail CD. In 2000, Siege of Avalon, a single-player RPG in six chapters, was released over the course of several months. Three chapters were central to the story's plot while the other three were expansion chapters designed to give further opportunities to explore the fictional world. Players could purchase each chapter separately or all six in a bundle. This business model, depicted in Figure 2.7.3, had never been tested before.

Click To expand
Figure 2.7.3: Digital's Tome game, Siege of Avalon, was sold to consumers through a subscription or a la carte. Digital Tome paid Digital River, a third-party transaction company, a percentage of the sales.

Digital Tome soon ran into problems with customer expectations. Even in a downloadable format, gamers expected premium quality cinematics, voice actors, music files, and sound effects, all of which would necessitate huge file downloads. Without widespread access to broadband Internet access, such a huge download led to long and often costly download times.

Digital Tome also ran into high fixed costs for distribution. Digital River, a third-party transaction company, handled transactions and hosted the downloads. Since each chapter was larger than the download limit, penalties were assessed for each downloaded purchase.

Other potential customers resisted paying online for a downloadable product. They wanted a physical object in a box. In September 2001, Digital Tome released an anthology CD with a manual and additional content. This immediately caused a channel conflict, which led to the suspension of online subscriptions. Earlier U.S. customers had paid $35 for the 500MB download, while the retail product was selling in stores for $20. Consumers outside the United States complained that the cost of the subscription after exchange rates and download charges were about three times more expensive than the box.

In 2002, Digital Tome ceased new product development and the co-founders launched Expedition Games. Despite the difficulties, Shiflett still believes in the future viability of digital distribution. Certainly, digital distribution, if it's convenient, secure, and profitable, has the potential to overtake the traditional retail market. However, even in 2002, broadband penetration rates in the United States are lower than expected, and according to the International Intellectual Property Alliance, billions of dollars are lost through software piracy each year.


Online Gaming and Virtual Communities

A vibrant virtual community is absolutely critical to the success of online gaming businesses. Unlike Digital Tome and CogniToy's games, which do not require an active Internet connection to play, online games are usually played with friends. Because of the tight-knit communities that develop online, gaming sites are known to be among the "stickiest" sites on the Web. Portal sites, like Lycos and Yahoo!, routinely use their gaming zones to place interstitial advertising and to cross-promote other offerings.

Generally, online games are geared toward two target customers: hardcore or casual gamers. Of the approximately 50 million online players, hardcore gamers are a small minority but they are the least price-sensitive. Hardcore gamers, predominately young males, are attracted to massively multiplayer or multiplayer games, often spending over 20 hours per month online. Casual gamers are more interested in little "coffee break" browser-based games which run about 10 to 15 minutes. Casual gamers, older and predominately female, are the fastest growing audience for online games.

Opportunities exist for the independent developer, as the experiences of Samu Games and Tams11 Software indicate, but the high costs of developing and maintaining a massively multiplayer online games will need the support of publishers.

Massively Multiplayer Online Role-Playing Worlds

Currently, the top massively multiplayer online role-playing games, or MMORPGs, each have between 200,000 to 400,000 paying subscribers. Games are sold at retail stores and after the free month of play, the purchaser can opt to continue the subscription for a monthly fee. Thus, the retail model follows that of Figure 2.7.1.

The development costs for a MMORPG can range well over $10 million, but because the games reach so many people, there can be economies of scale. The sheer volume of ongoing subscriptions, combined with the sale of the retail box, add up to a significant sum. However, with new entrants competing for the same hardcore players, there might be market saturation, or a limit to future revenues.

Samu Games: Multiplayer Arena

A dedicated fan base has proven to be invaluable to independent developers like Samu Games of Tulsa, Oklahoma. Formed in 1999 by brothers David and Douglas Michael, Samu Games released the multiplayer war game Artifact in October 1999 and its sequel in November 2000. The real-time strategy game is freely available to anyone to download, but there are benefits to paying for Citizenship, as Samu Games terms it.

At any given time, there might be about 33 war games running simultaneously. Each active game runs continuously until one side emerges as the victor, and the game might last anywhere from two days to a couple weeks.

Samu Games offers a mixture of payment options based on access. The Freeman level, designated for free accounts, is limited to three hours of gameplay per day. For a one-time payment, players are allowed to play a greater number of hours daily in more games according to a five-tier structure. The premium level, Full Access, which allows the player to play all day, every day, in as many as 12 games, is offered as a monthly subscription.

Approximately 3,000 players download the game each month. Typically, 1.5% of the newbie players become Citizens. Samu Games' sole revenue comes directly from subscriptions and a good percentage is from repeat customers, who continually upgrade their access level. One third of the new players come from player referrals. The company refuses to have advertising because it would annoy players.

The active community on Artifact generates most of the content for the monthly newsletter, and fan volunteers serve as in-game administrators. The game itself was designed to support a virtual community, and players use the chatrooms and note systems extensively. The team-oriented nature of the game promotes community building since teamwork is essential to playing the game well.

Samu Games releases periodic bug fixes to Artifact, but other than that, there are no changes made to the game. However, to the player, each active game is different given the variables of players and skills. Samu Games hasn't given up the idea of a publisher or possibly licensing Artifact, but for the time being, it is committed to providing hardcore players with quality entertainment.

Samu Games successfully combines the direct-to-customer model with a virtual community, as shown in Figure 2.7.4. For a two-person company with volunteer staff, this is quite an accomplishment. It proves that when a company caters to its audience, fans are more than willing to devote time to improving and contributing to the community.

Click To expand
Figure 2.7.4: Samu Games' self-published game, Artifact, is free to play, but access time is sold direct-to-customer via the Web site. The company relies on referrals and low-cost word-of-mouth advertising from its virtual community to increase its subscription rate.

Tams11: Gaming Community

The Tams11 Gaming Lobby which started up in January 2002, is maintained and run by Tamera Shaw-McGuire. A one-woman workforce, she programs all of the card, word, or puzzle games herself. The games appeal mostly to women, who appreciate Shaw-McGuire's personal commitment. The community started to take off in March 2002, mostly through word of mouth, and the site received the Gaming Friends Multiplayer Excellence Award for the 3rd Quarter 2002.

Shaw-McGuire envisioned a gaming community that would be different from the larger, well-known sites. A casual gamer since 1999, she found that she disliked having to deal with the advertising on sites like Pogo and Yahoo!. Her biggest complaint was that those sites were cold and commercialized. She didn't want a "play to win" site, but a place where players could feel more involved with a community. Therefore, she says, "I wanted to make the players feel more at home at my site, knowing that I will try and be there to help whenever I can."

Tams11 members often converse with Shaw-McGuire, pointing out bugs and suggesting new games. Aware of her own penchant to chat online, she created a central lobby where any member can chat with another even if the other person isn't playing the same game. She also put up a tournament lobby that allows members to set up their own tournaments. The games offered are her unique creations but are similar to deleted games from other sites.

Shaw-McGuire's direct-to-customer business model resembles that of Figure 2.7.4. All of the games are free to play offline, but a subscription is required to continue playing online with friends after 30 days. Offline, the games are not very challenging and not much fun. The computer opponent usually loses.

So far, the hobby turned business has enough subscription revenue to cover costs, and Shaw-McGuire is pleasantly surprised that her startup is doing so well. As the community grows, she hopes that her level of personal service can stay constant.


Intermediaries and Combined Models

While the direct-to-customer model trumpets disintermediation, other companies have found success as intermediaries. Sites like Real's RealOne Arcade, MSN's Zone.com, and GameSpy attract a large audience of gamers by offering content, matchmaking services, and a large number of free casual games. At first glance, these sites might appear to be direct competitors, but in some instances, they are also partners. These larger sites employ a combination of online models and can provide valuable insights to independent developers.

Combined models can cause potential conflicts or synergies. Almost all gaming sites have forums or chatrooms because a loyal virtual community generally leads to repeat business and a good direct-to-customer relationship. On the other hand, a game reviewer site that also sells games has a clear conflict of interest: it might be tempted to give glowing reviews to its own products.

RealOne Arcade

In 2001, Real launched its games division called RealOne Arcade. As shown in Figure 2.7.5, RealOne Arcade is essentially an aggregator that collects comparable products for display in one site. For customers, it concentrates information about offered products, which lowers search and decision costs. For developers and publishers, it profiles their products with editorial content and user reviews. Registered users have access to forums and lobbies for multiplayer matchmaking. Thus, RealOne Arcade serves as a content provider, a virtual community, a direct-to-customer business, and an intermediary.

Click To expand
Figure 2.7.5: RealOne Arcade aggregates games from publishers and independent developers. Advertisers are eager to reach consumers of the high profile site.

For the independent developer, Real offers the RealOne Arcade Developer Service. An independent developer can submit a game in any format and Real performs many of the duties of a publisher, such as quality assurance, marketing, distribution, and transaction processing. Developers have a choice of exclusive or non-exclusive agreements. If the developer has an exclusive agreement with Real, then the game stays on the site for a window of time in exchange for better promotion and a better royalty rate. If non-exclusive, such as with CogniToy's 5 Card Dash, then the developer is free to sell the game elsewhere.

Real also works with established publishers to sell known games like Centipede. Both publishers and developers use Real as a value-added distribution channel. All the parties benefit from these arrangements. For RealOne Arcade, the presence of diverse games helps to spur its virtual community, which in turn justifies its advertising rates.

Of the games on RealOne Arcade, many are free Web-based games supported by advertising. The higher-quality, downloadable games are available at different price levels. Consumers can buy games on transaction or through a subscription service called GamePass. Real's proprietary anti-piracy software ensures that the distribution is secure.

Unlike Digital Tome's offering, all of RealOne Arcade's games are small "coffee break" games intended for casual gamers. Most are single-player and can even be downloaded to PDAs. According to Andrew Wright, general manager of the company's game division, traditional retail distribution remains the best channel to reach hardcore gamers but the situation is completely different for casual gamers. He says, "For the casual audience, they can't walk into retail to find games that are relevant. They need ease of use. Digital delivery provides a level of convenience that the retail brick-and-mortar crew can't compete with."

Zone.com

MSN's gaming channel Zone.com, as depicted in Figure 2.7.6, also uses a combination of the content provider, virtual community, direct-to-customer, and intermediary models. However, unlike RealOne Arcade, its goal as an aggregator is not to sell games but to provide multiplayer support for a variety of games. Zone.com has over 100 games available for retail matchmaking, while RealOne Arcade offers only a handful of games with multiplayer play. From its onset, Zone.com has focused on both hardcore and casual players.

Click To expand
Figure 2.7.6: Zone.com aggregates games from different publishers for retail matchmaking. Advertisers promote products to consumers through sponsored games.

Hardcore gamers rely on matchmaking services to find teammates and challengers. Microsoft does have its own games up on Zone.com, but other game publishers are represented as well. This would appear to be a direct conflict, but Zone.com has no incentive to drive players toward one game or the other. The retail games supported on the Zone have been sold already, and publishers tend to view multiplayer play as a value-added service. Zone.com's group product manager Chris Di Cesare says, "We benefit from the advantage of the increased traffic that we get through the players on the Zone and [the other publishers] get the advantage of the service and support that we provide through having the site." The other publishers do not pay Zone.com to host their games.

Zone.com is also the exclusive gateway to Microsoft's MMORPG Asheron's Call, which is subscription-based. The virtual community from Asheron's Call does not tend to spill over to other parts of Zone.com. Instead, Zone.com provides its own chatrooms and a chat service called Zone Friends. To generate interest in its games, it regularly holds tournaments and allows players to organize their own tournaments.

Advertising and sponsorship constitutes about 72% of Zone.com revenues. Zone.com pioneered what it calls "adver-gaming." "Adver-gaming" would include the 3D racing game Toyota Adrenaline, which featured a Toyota Tundra truck in the game-play and coincided with a six-month long Toyota sales promotion. Other sponsorship opportunities exist with the trivia game OutSmart. Launched in 2001, OutSmart pits a celebrity against players to answer questions about the celebrity's work. Players compete for prizes donated by the sponsor. Various TV shows, music publishers, and movie studios have paid Zone.com to host a celebrity on OutSmart in order to reach MSN's large Internet audience. Episodes are archived in the OutSmart gallery. In addition, some tournaments, such as the Bourne Identity Trivia Challenge, are sponsored.

Games like OutSmart appeal to casual gamers, and Di Cesare feels that this segment of the online market is becoming more and more important. For this reason, Zone.com has begun to offer higher-quality downloadable games for casual gamers. Casual gamers can also play Zone.com's free Web-based games.

GameSpy

As indicated in Figure 2.7.7, GameSpy has a lot of revenue streams. As CEO Mark Surfas says, "In a really uncertain environment, we found it would be best to try to capture as many revenue streams as we could." This strategy has worked well for GameSpy because some revenue streams have surged while others have receded.

Click To expand
Figure 2.7.7: GameSpy business model.

GameSpy is a vortal, meant to be "Gaming's Homepage" and the #1 destination for people to read, try, buy, and play games. GameSpy is a content provider, the largest creator of editorial content with GameSpy Daily ("24-hour gaming news coverage from the inside") and over 55 player-run Web sites. Each hosted Web site aims to be the information source for a specific game with forums, content, chat, and an active community. In addition, GameSpy runs its own forums and aggregates all available forums on ForumPlanet. Capitalizing on its virtual community, GameSpy sells advertising.

Like RealOne Arcade, GameSpy Arcade has a large number of free and pay-to-play casual games. Like Zone.com, GameSpy Arcade supports retail matchmatching for hardcore gamers. Another application, GameSpy 3D, is for players who do not want chat, forums, Web browsing, and events. GameSpy's audience is nearly 97% male and 80% are using broadband.

Besides advertising, GameSpy has other significant revenue streams. GameSpy licenses technology for anti-piracy systems, in-game matchmaking, in-game voice chat, and other software tools. It has worked with almost every large publisher in the industry. In fact, RealOne Arcade is a customer of GameSpy in this way.

For consumers, GameSpy offers a variety of services and subscriptions. In File-Planet, gamers can pay to have high priority to GameSpy's extensive library of cheats, files, and guides. On GameSpy Arcade, players can pay a one-time fee to turn off the ads that would run on the free service. In addition, GameSpy sells its voice chat software Roger Wilco directly to consumers.

GameSpy also acts as an intelligent price-comparing agent for buyers. GameSpy receives a commission for sending leads to online retailers. According to Surfas, this way, GameSpy works with all of the retailers and can have a relationship with all of them. Surfas tends to view other gaming businesses as potential partners rather than competitors. It's a viewpoint that has helped GameSpy to grow and succeed.

While he does not believe that digital distribution will ever replace the traditional retail market, Surfas is betting that digital distribution will become more important and is devoting energy to develop technologies to download top-tier games. In the future, GameSpy On-Demand will allow players to rent or buy games.


Conclusion

The continued trend of online gaming has the potential to transform the economics of the industry. Whether it's due to streamlined digital distribution, licensing opportunities, or a shift from banner advertising to subscriptions, online business models will continue to evolve accordingly. Undoubtedly, informed independent developers will play an important role in this future.


References

[Costikyan and Mulligan02] Costikyan, Greg and Mulligan, Jessica, The Themis Report on Online and Wireless Gaming, The Themis Group, 2002.

[Hunt02] Hunt, Ben, "War on piracy is being lost in 100 countries," Financial Times (August 7, 2002): IT Review, p. 4.

[IGDA02] IGDA Online Games Committee, "IGDA Online Games White Paper," available online at www.igda.org/Endeavors/Research/Online/online.htm, March 2002.

[Kary02] Kary, Tiffany, "Study: Sixfold Growth for Online Games," available online at http://news.com.com/2100-1040-933295.html, June 6, 2002.

[Weill and Vitale01] Weill, Peter and Vitale, Michael R., Place to Space: Migrating to e-Business Models, Harvard Business School Press, 2001.


Chapter 2.8: Creating a Successful Freelance Game Development Business

Overview

François Dominic Laramée

<francoislaramee@videotron.ca>

Long hours, interminable projects, bad bosses, and layoffs are but a handful of the reasons why some game developers forego the relative security of regular paychecks and create their own freelance businesses. The rewards of self-employment are such that most of them never go back to regular jobs, except under extreme financial duress. However, going into business is a risky proposition, and one not suited to everyone.

This article summarizes the techniques developed by the author, over a period of five years, to minimize the risks associated with a freelance business. Valuable insight gathered from the Freelancer's Roundtable at the GDC in 2001 [Laramée01] and 2002 [Laramée02] is also presented.


Should You Make the Switch?

Before you invest in a home office, ask yourself whether freelancing would be good for you:

  • Will you develop an ulcer if you go three months without receiving a check?

  • Will insecurity cause friction between you and your spouse?

  • Do you love chatting with co-workers over lunch or coffee every day?

  • Do you have nightmares before important meetings and presentations?

  • Do you enjoy being able to delegate responsibility?

  • Do you have trouble handling rejection?

  • Are you afraid you'll procrastinate and spend all day watching soap operas?

  • Are you too timid to call a client, repeatedly, until he pays what he owes you?

If you have answered "yes" to most of these questions, freelancing might not be your best choice. Perhaps you should consider going into business with partners, or merely changing jobs.


What Kind of Business Do You Want?

Some choose freelancing as their main career path, while others do it part-time while holding a regular job, or on an intermittent basis to fulfill specific goals, like saving for a vacation or a down payment on a house. Whatever your situation, you must know the skills you can sell, and the companies likely to buy them.

Generalists

Generalist freelancers take on a variety of roles, often at a moment's notice, and routinely handle multiple projects of wildly different durations in parallel.

For example, in the past year, this author has received assignments in game design, translation, artificial intelligence, business consulting, book and magazine writing, Web design, press relations, teaching, and comedy writing. Some lasted 30 minutes and had to be completed within 24 hours; the longest took about 200 hours over a period of three months.

Generalists fare well in most environments. They can often rely on a small stable of regular clients to provide most of their income, particularly in geographical areas where few experienced developers live.

Content Specialists

3D artists, audio specialists, some programmers, scriptwriters, and other professionals who provide well-defined, isolated game components fall into this category. They can literally set up shop anywhere; well-designed character models, for example, can be plugged into an engine with a minimum of back and forth between freelancer and client, so it doesn't matter if the two are next door neighbors or if they live on different continents.

The amount of repeat business that a content specialist will receive varies a lot; an artist can work on a project for years, while a piece of code might be paid for once and used in several products. If your perspectives are weak in this regard, do not hesitate to take advantage of geographic freedom and market yourself far and wide.

Process Specialists

Producers, lead designers, and project salvage specialists are intricately involved in the corporate process. That makes it difficult for them to become freelancers; the ones I know are very senior people whose tremendous credentials overwhelm clients' natural reluctance to risk so much of their projects on external resources. Even then, process specialists must spend significant amounts of time in their clients' offices, interacting with the rest of the team. Thus, they tend to live in high-density game development areas, like California or Texas, or travel extensively.


Setting Your Priorities

Before you start your freelance business, you must define the criteria by which you will judge its success. Do you want to work fewer hours, and have more time to spend with your family? Choose your projects? Make more money? Work from home, and move to the mountains? Acquire prestige within the game development community? Make games that the usual studio structure can't develop profitably?

Be honest with yourself. You can't be satisfied unless you aim for goals you really care about. And once you set your priorities, stick to them: judging your own success by someone else's standards will get you nowhere. If you want to work three days a week and use the rest to take care of your children, to write a novel, or to volunteer at the Red Cross, who cares if you earn less than you could as a studio executive?

Business Priorities

However, within the boundaries of your work, your priorities must be:

  • Completing projects on deadline

  • Generating new and repeat business

  • Maintaining your skills

  • Managing your money

Nothing else matters. If your office is a little messy, clean it up—but only after you return that new client's telephone call.


The Freelancer's Finances

In any business, the ultimate key to success lies in making sensible financial decisions. For freelancers, this means selling services at optimal prices, and managing cash flow effectively.

Your Target Income

First, you must determine how much revenue you have to generate every year to meet your goals and obligations. Again, depending on why you want to freelance, this might be significantly more or significantly less than what you earn right now. Don't lose sight of your goals, even when money is involved.

At the very least, the amounts you invoice to customers must cover the following:

  • Living expenses. How much must you contribute to your household every month? What do you need to be happy? Make a reasonable budget, and include everything you need and want: rent/mortgage payments, transportation, insurance, clothing, vacation, petty cash, groceries, cable TV, savings, and so forth.

  • Income tax. Fill out a tax return in reverse, starting with the after-tax income you need for your household budget, and determine the required pre-tax, after-expenses income.

  • Business expenses. You will need a new computer every two to three years, software, office furniture, books, Internet access (don't forget anti-virus and firewall software), postage, trips to trade shows, training, transportation, professional services, and various supplies. Talk to a tax specialist to see what you can write off, what you must amortize over several years, and how you can use your home office as a deduction. Typical expenses amount to about 20% of sales every year, give or take 5%. Yours might be higher, especially if you need to lease office space or hire an assistant, but tax authorities frown upon anything in excess of 50%.

Case Study 2.8.1 includes a simple target income calculation.

Case Study 2.8.1: Financial Planning
Start example

Here is a sample grid to help you plan your business' finances:

Sales Objectives | Value | Formula | Result
Monthly household needs | $2,500 | × 12 | $30,000
Average tax rate | 30% | $30,000 / 70% | $42,800
Expenses | $10,000 | $42,000 + $10,000 | $52,800
Working Hours | Value | Result
52 weeks ¥ 5 days | 260 days | 260
Minus: Vacation | 20 days | 240
Minus: Holidays | 10 days | 230
Minus: Sick days | 5 days | 225
Minus: Trade shows | 15 days | 210
Total, at 7 hours per working day: |  | 1,470 hours
Billable Hours | Value | Result
Working Hours | 1,470 hours | 1,470
Minus: Training | 200 hours | 1,270
Minus: Banking and invoicing | 30 hours | 1,240
Minus: Shopping for supplies | 20 hours | 1,220
Minus: Marketing and promotion | 150 hours | 1,070
Minus: Office maintenance | 25 hours | 1,025
Minus: Various contingencies | 25 hours | 1,000

Hourly Rate

Basic average rate:$52,800 / 1,000 hrs = $52,80 per hour

"Rule of 800" target rate:$52,800 / (80% ¥ 1,000 hrs) = $66 per hour
End example

The Rule of 800: Calculating Your Billable Hours

Next, you must determine how many of your working hours you will be able to bill to clients. Again, refer to Case Study 2.8.1 for an example.

First, find out how many hours a year you will spend working. Take into account the length of your normal workweek, vacation, holidays, sick days, and travel time going back and forth from your home to trade shows and clients' premises.

Then, subtract time spent on tasks not directly related to client assignments, like marketing your services, banking, shopping for supplies, invoicing, training, cleaning up the office, installing software upgrades, and handling of all the other chores someone else would be taking care of in an ordinary company.

For most full-time freelancers, this computation will result in about 1,000 billable hours a year. However, you may want to cut that number by 20%, to about 800, to account for slow periods (which you can't always spend training) and for bad payers.

Your Target Hourly Rate

To determine your hourly rate, divide target income by billable hours. This is an average; on occasion, you will have to accept a lower rate because a client has limited resources or a project is just too interesting to pass up. This is another reason to apply the Rule of 800: having a higher base rate will give you a margin with which to work.

In most cases, the calculations in Case Study 2.8.1 will yield a rate that is about twice an employee's hourly salary for similar work. This is perfectly normal; the client expects a higher fee because he does not have to pay office space, benefits, vacation time, and so forth.

Financial Safety Margins

[Laurance88] suggests setting aside the equivalent of 3 months' living expenses and 3 months' business expenses before you launch your business. This is enough to bridge the gap between your last paycheck and the first payments you will receive from clients, 30 to 60 days after you have delivered the work.

Then, to assure your business' long-term viability, gather an emergency fund twice as large—and restore it as fast as possible after drawing funds from it. Otherwise, a few months without assignments or a big client going out of business while he owes you money will leave you in financial difficulty.

Other Considerations

The pricing method outlined previously will work in most cases, but be wary of the extremes:

  • Even if you need little money, do not undersell your services. Clients often assume that "cheap" equals "shoddy."

  • If you determine that you need $100 an hour for work that full-time employees do for $30,000 a year, your business is unsustainable. Change your assumptions.

  • If you constantly find yourself turning down business because you're too busy, you might be able to raise your prices at no risk.

  • If you're in a bind, you might have to take assignments at discount prices. The shorter the better in this case, because you don't want to tie up time that you could sell at premium rates later on.


Marketing Freelance Services

Now comes the most delicate part of the operation: securing enough assignments to make your business self-sufficient. This requires excellent knowledge of your market and a significant promotional effort.

Who Will Retain You?

Companies hire when they have needs, and only if the service fulfilling the need can be acquired at an economically sensible price. Of course, "economically sensible" is a relative term:

  • In some jurisdictions, game companies receive government subsidies when they create full-time jobs, but not when they subcontract. Thus, it becomes almost impossible to convince them to hire freelancers for anything that could be done by employees.

  • The greater and more urgent the need, the higher the fees that the company will be willing to pay.

  • An artist who lives in Montana will be able to charge more for the same work if she sells it to a California company than to one based in Kentucky, because the price of an employee is higher on the West Coast.

  • Freelancers living in countries where the cost of living is low will have an easier time underselling their foreign competition.

In general, you will have to prove that giving you a freelance assignment will result in better, cheaper, and/or more convenient work for the company. This is not as difficult as it might seem, because the cost of a regular employee is much higher than his or her salary: hiring costs, office space, computer equipment, benefits, social charges, management overhead, vacation, paid holidays, and layoff costs all have to be taken into account. Examples of situations in which hiring an employee at $30 an hour might end up costlier and less practical than hiring a freelancer at two to three times the rate include:

  • Frequent but small assignments. Sound effect design, translation, press releases, and second opinion on management decisions.

  • Very specialized knowledge. Music composition, screenwriting.

  • Seasonal overflows. Beta testing, trade shows.

  • Unusual tasks. Business plan writing, staffing, employee training.

  • Disaster recovery. Project salvage, critical bug fixes, filling the gap between an employee's departure and a new hire.

  • Shortage of experienced people in a specialty. Senior programmers, game design.

  • A volatile job market. Why go to the expense of a formal hiring process when the employee is likely to quit within three to six months?

Your Marketing Targets

That being said, it is always easier to secure freelance assignments from people who already know and trust you. Talk to former co-workers and employers first, and once you complete an assignment with a company, keep asking them for more (unless the first project went horribly wrong). You can expect repeat business to account for 80% or more of your income after a couple of years.

That's the good news. The bad news is that existing relationships are the only reliable source of assignments. Finding work in any other way will require time, effort, and the stoic handling of many rejections.

Thus, you should spend your promotion effort on the following, in decreasing order of importance:

  • Repeat business. Call your current clients a month after completing a project, and every three months thereafter.

  • Former clients/co-workers who change companies. Producers, in particular, know when a project team needs assistance, and they often recommend the freelancers to hire.

  • Referrals. Make contacts at local institutions where people with limited knowledge of the industry are likely to call for information. Good relationships with schools and chambers of commerce might be especially helpful.

  • Visibility. Build a Web site advertising your credentials and current projects. Write for magazines and books like this one. Teach at a local college. Get involved in the IGDA. People who have seen your name before are likely to think of you when they have a project to assign.

  • Companies you can meet in person. If you can visit a client's offices during off-peak periods or set up a meeting at an IGDA chapter event, do so. Face time is valuable.

  • Trade shows. You can meet many people at E3 or the GDC, but they will have limited time for you. Make sure to book key meetings at least four to six weeks in advance.

  • Direct marketing. When you call, write, or e-mail potential clients, concentrate on those not actively looking for full-time staff; they will have more time to look at your proposals.

One final word: never stop marketing yourself. Companies go out of business all the time. A regular client might grow until it becomes cheaper for him to hire a fulltime employee to take over your duties. Or a new manager with her own stable of freelancers might replace your key contact. As a rule of thumb, you shouldn't let one client account for more than a third of your income on a consistent basis, because if this client ever disappears, you will be in trouble.

Handling Bad Debts

Speaking of trouble, what should you do if a client refuses to pay you?

Unfortunately, your options are limited. [Laurance88] says that law firms won't get involved unless a debt of $10,000 to $25,000 has been outstanding for at least six months. Collection agencies might present an alternative, but they will cost you 20 to 50% of the amount they recover, and in case of failure, you are still going to have to get a court order and have it executed by bailiffs—at your own expense.

Indeed, the best way to deal with bad debts is to not let them happen in the first place. Protect your interests:

  • Keep the first assignment small. This way, if the client shows bad faith, you have limited your losses.

  • Initiation of Service fee. When dealing with a new client, or starting any large project, ask for 20 to 50% of the assignment's value up front. This establishes good faith on both parts.

  • Split large assignments into several milestones. [Onder02] also recommends making payments part of the project schedule: inscribe payment due dates in the contract, and put in a clause stating that any delay will push back all further milestone deliveries accordingly.

  • Avoid making the final payment too large. Once you have delivered all of the work, a bad client has no further incentive to pay you.

  • Apply these rules to everyone, even people you know and like. A former co-worker and friend still owes this author thousands of dollars, four years after a project's completion.

  • Be careful if you spread the word about the bad client. It is all too easy to acquire a reputation as a troublemaker—and a libel lawsuit can ruin your life, whether you win or lose in court.

Case Study 2.8.2: Mark Barrett, Prairie Arts
Start example

Mark Barrett went directly from college to being a freelance screenwriter, and he wouldn't have it any other way.

"Freelancing affords me two main benefits: I get to move from project to project, which keeps my interest high, and whenever I'm not employed I get blocks of time to pursue my own initiatives, some of which also generate income. Plus, since most of my freelancing is done via telecommute, I'm able to live where I want."

Since Mark's family has never seen him work any other way, obtaining their support for his freelance venture was not an issue. "While a steady paycheck might provide us greater liquidity—primarily because we wouldn't have to keep reserves on hand for the lean months—I think that would be the only direct benefit of being an employee. Having said that, if the lean months ever turned into lean years, the level of support I am currently receiving would probably drop precipitously."

Mark receives most of his assignments through word of mouth. "I am almost always contacted by people who know my work and my reputation from a trusted third party, rather than because of claims I have made about myself. Since it can be difficult for a company to get over the fear associated with hiring outside workers, particularly offsite ones, first contacts usually happen when the prospective client is in trouble: the original writer or designer failed, and there is little time in which to correct the damage and finish the job."

For Mark, the most important quality freelancers must possess is discipline. "If you are not comfortable working alone and being alone, and if you do not have a history of initiating and completing your own projects, freelancing is not for you."

End example


Managing Your Schedule

Freelancers sell time. It is imperative that you learn to assess workloads accurately, and that you always know how much of your time is already sold.

Figure 2.8.1 is based on the author's actual yearly schedule. (The numbers are fictitious.) Several columns indicate the number of hours spent and future time allocated to various projects. The most important columns, however, are the one indicating the time left in each upcoming week, and the one indicating the percentage of the year's expected income generated to date. With a tool like this, if a client calls on July 15th to offer a 25-hour assignment, it is obvious that delivery can be promised by August 9th (or a little later if some time must be set aside for other expected assignments). It is also good to know whether you are slightly ahead on your financial objectives.

Click To expand
Figure 2.8.1: Sample schedule.

Scheduling Flexibility

In addition, you should maintain a detailed two-week schedule in electronic form on your computer. (Paper won't do, because you will have to update it frequently.) The reason for this is that when a client calls, odds are he'll want to schedule a meeting or hand you a short assignment immediately; the two-week schedule lets you determine if and when that will be possible.

Vacation

Don't be afraid to go away if you want to. Most jobs can wait: in four years, this author has lost only about 10 hours' worth of assignments because of vacation-related unavailability. The period between December 15 and January 15 is always a good choice, as clients who shut down for the holidays won't assign anything urgent immediately before or after. Summertime might be a different matter: companies that must ship titles for Christmas might need a lot of help.


Conclusion

With each passing year, more opportunities for freelancers arise in the game industry. With proper marketing and financial management, a freelance business can be extremely rewarding. The tricks and techniques explained in this article will help the self-employed maximize their odds of success.


References

[Laramée01] Laramée, F. D., "Tales From The Loneliest Frontier: GDC 2001 Freelancers' Roundtable Moderator's Report," available online at www.gamedev.net/reference/business/features/freelancer/

[Laramée02] Laramée, F. D., "GDC 2002 Moderator's Report: The Freelancers' Roundtable," available online at www.gamedev.net/reference/articles/article1816.asp

[Laurance88] Laurance, R., Going Freelance: A Guide for Professionals, John Wiley & Sons, 1988.

[Onder02] Onder, B., "Negotiating a Freelance Game Design Contract," in Game Design Perspectives, Charles River Media, 2002.


Section 3: Taking a Game to Market

Chapter List

Chapter 3.0: Introduction
Chapter 3.1: Public Relations: Making the Most of the Gaming Press
Chapter 3.2: Securing a Development Contract: The Art of Pitching
Chapter 3.3: The Whys and Wherefores of Game Agents
Chapter 3.4: Effective Development Contracts
Chapter 3.5: Pros and Cons of Worldwide and Country-by-Country Deals
Chapter 3.6: Techniques to Increase Upsell for Online Games


Chapter 3.0: Introduction

You have built a solid company, with an impressive business plan that has seduced investors and allowed you to secure enough private financing to develop your first game? Or maybe you have created a spectacular demo and are ready to show it to publishers? Or have you completed a project and decided to sell it online yourselves? Good; you have taken the first step toward success. Now comes the most difficult part of the operation: taking the game to market.

The game publishing market is highly concentrated, with only a few dozen large publishers accounting for the overwhelming majority of sales, and getting more so every year. Retailers have limited shelf space, and will only open it to games they perceive to have reasonable expectations of success. Players get bombarded with information about new games every day; how will you make sure that yours is the one they remember?

Most developers' marketing effort is essentially limited to what is needed to obtain a publishing contract. For self-publishers, the job expands to public relations, customer service, and maybe even direct sales. How do you go about ensuring that your company signs with a publisher at advantageous terms, or that your downloadable game emerges from the masses of its competitors to become a cash cow for years to come? The articles in this section of the book describe how to optimize your marketing effort, whatever the strategy you choose:

  • Beverly Cambron, president of game public relations firm Rocco Media, explains how to build good relations with the gaming press and use them to improve your title's notoriety.

  • Ed Bartlett, director of development at UK-based developer The Bitmap Brothers, describes how to secure a contract with a publisher.

  • Borut Pfeifer, co-founder of independent developer White Knuckle Games, explains the pros and cons of hiring an agent to represent your company in negotiations with publishers.

  • Game industry attorney and independent developer Thomas Buscaglia examines the clauses found in typical development contracts, and explains how to negotiate deals that protect your interests.

  • Game agent Jay Powell studies the respective advantages of global and territorial publishing deals.

  • And finally, Mason McCuskey, president of independent developer Spin Studios, explains how self-publishers can optimize the online sales of their own games.


Chapter 3.1: Public Relations: Making the Most of the Gaming Press

Overview

Beverly Cambron

<beverly@roccomedia.com>

Why do some names consistently appear in the gaming press, while others languish in virtual anonymity? Effective public relations is key to getting your name, product, and reputation out of the shadows. If you're a developer looking for a publishing deal, the publishers need to hear about you. If you're a publisher hawking a game, consumers need to hear about it. Or, perhaps, you're just ready to raise your personal profile in the industry. If any of these scenarios fit you, then it's time you implemented an effective public relations campaign.


What Are Public Relations?

Practically speaking, the first line of relations in public relations, or PR, is with the news and reviews editors at the media outlets who get your news to the public. Editors are the people who decide what news is published, who is interviewed, and which games are reviewed. Effective public relations include a host of activities, including press releases and media kits, online interviews, and television and radio appearances. However, to get those interviews and appearances, and to get those games reviewed, you need to begin your PR efforts with the press release.

"Public relations for games is really community relations," says Travis Cannell, business development manager for Gnostic Labs. "All effort should be to interact with this community, keep it happy, and grow it as quickly as possible. Press releases are your primary tool to meet those ends."

Ever see an article about one of your competitors in the industry press and wonder why they didn't write about you and your great company? Odds are that you're reading about your competitor because they send out press releases—effective press releases.


Writing an Effective Press Release

Press releases are one of the most cost-efficient and effective means of spreading the word about you and your business, if done properly. News articles about your company are premium forms of advertising. Unless you have more business than you can handle, or you're engaged in illegal activities, there really is no reason not to use press releases as an integral part of your public relation strategy.

Further, in the age of e-mail, getting out a press release is pretty simple; you just need a story hook, a flair for concise, effective writing, and a database of relevant press contacts. If you don't have any of those items or abilities, there are plenty of PR professionals who do. Look for more on outsourcing your public relations work at the conclusion of this article.


The Hook

A story's "hook" is what makes your press release newsworthy. It needs to be more than "Hey, we're game developers with a cool new game! Check out our Web site for more cool stuff!" That is not a hook. There are hundreds of game developers who all believe their game is cool and should be checked out. Not only is that not a newsworthy story, it doesn't provide the news editor reading your e-mail with enough information to even care about learning your story.

To find your hook, think about what makes your company unique. If you're a new game developer, what is it about your game or the team behind your game that makes your story newsworthy? Perhaps the team left a particularly well-known company to develop your game? Maybe you're developing a game that has an innovative aspect—or at least an aspect you can make sound innovative.

The hook can also be something as simple as the release of the game's demo, the fact that the game has "gone gold," or that a certain band will be contributing to the game soundtrack. The point is that there is a point to the story, not just a general "check us out."


The Style and Format

Getting your hook is half the battle, but the war is not yet won. Your press release must be professional and well written. You need to stay focused. Pick your hook and stick with it. You can always send out another press release with another hook. Richard Aihoshi, editor-in-chief of IGN Vault Network finds that simple, straightforward writing that gets to the point and doesn't try to do too much makes for a good press release. "The press releases I consider best are short and contain only one central message, which means they don't risk diluting the central message by trying to convey secondary ones at the same time," says Aihoshi.

Gamespot PC Platform's editor, Andrew Park, wants to know a game's developer, publisher, release date, plus a brief summary of what the game is about, including any distinguishing features such as noteworthy licenses or brands, "as well as some sort of brand new or updated information on the product itself." What he doesn't want is "repeated bombardment" of press releases that simply reiterate what has already been revealed in a previous press release. "The best press releases have a good deal of information and don't necessarily have to come out every week," says Park. "Some of the worst ones have barely any new information and come out every week, or even worse, multiple times a week. These should be avoided at all cost."

The Top-Down Approach

So, you have your hook and it's fresh. Now, it's time to put finger to keyboard and start putting it together. As you're doing this, you need to remember to work "top down." That is, place the bulk of your facts in the first couple of paragraphs of the release and then use the remainder of your release to elaborate. Don't make the news editor search for the facts and the story. A press release should be written in such a manner that a publication could remove everything but the first couple of paragraphs and still have a complete story.

The 400-Word Rule

Be clear and concise in your writing. Your press release should be in the 400-word range. You should be able to hit the high points of your story and include a short "bio" on your company and still be comfortably in that range. The 400-word range certainly isn't a hard-and-fast rule, but it's a good one to follow. If you ultimately distribute your press release via services such as PRNewswire or Businesswire, you will typically find that their fees increase when the press release exceeds 400 words.

Quotes

As you tell your story, make sure it reads like a story. Take a look at a business article in your morning paper. You'll probably see at least one quote from a relevant party. Put a quote or two in your press release. Who at your company would be appropriate to comment on the subject of your story? Quote that person saying something interesting about the game or the event. At the risk of widespread disillusionment, most quotes in press releases are fabrications of the PR people. Just make certain the person you're quoting approves the quote.

Simplicity

Be sure to simplify the technical language in your press release. Keep in mind that the person reading the press release is most likely not a programmer. Yes, you might have a completely new way of compressing bounding volume data for arbitrary polygon meshes, dramatically reducing memory footprint compared with traditional bounding volume approaches without sacrificing any runtime performance, and enabling you to create worlds of a greater size and scope than was previously possible. However, unless you're press release is for hyper technical journals, you're going to only succeed in putting the news editors to sleep.

There is no need to write in a condescending manner; just keep it smartly simple and always entertaining. Rather than expounding on the technical minutiae, focus on the ultimate point: the technical advances incorporated in your game make its worlds more detailed and robust than any other game on the market. Leave the dramatically reduced memory footprint and compressed bounding volume data for "water cooler" chatter and GDC or E3 sessions.

Finally, as you wrap up your release, be sure to include a short "About Your Company" paragraph. Spend some time creating a two to three sentence summary of your company, including who you are and what you do. You can use this brief bio at the end of every press release.

Proofread. Proofread. Proofread.

Now that you've written your release, it's time to proofread. And then proofread again. And then have someone else proofread. Yes, even simple grammatical errors are noticed. While some of these gamer sites are run by kids just trying to get free games, most are run by professionals, and sloppy press releases connote sloppy, unprofessional people. No one wants to follow up with a sloppy, unprofessional person. Although good grammar and proper spelling seem to have become a lost art, and even though you and your buddies communicate just fine, the news editors might have gone to school when proper grammar still meant something. They might be well aware of the difference between "your" and "you're," possessives and plurals, and, whether it makes any sense or not, "tough" is not spelled "tuff."

Make Sure You've Written for Your Audience.

Additionally, as you're proofreading, keep your audience in mind. Does the press release appeal to your audience? While your ultimate audience is the person reading the news, your first audience is the gaming press. Who are these people? Well, they're males—mostly. When asked about the male/female ratio of game reviewers at Gamespot, Andrew Park noted that, "currently it's infinity, which is what you get when you divide by zero." While the age range of the gaming press is typically viewed as very young, Park reports the average age of Gamespot reviewers as mid-20s to early 30s. Aishoshi of IGN sees an age range of 16 to mid-50s. He also notes the male to female ratio as "about five males to one female over the course of our existence." Take a glance down the editor photos in a PC Gamer and you'll see a row of seven white, male faces and, at least at the time this article was written, one female face.

So, what does all that mean in terms of your press release? Not to say that these guys aren't in touch with their feminine side, but your best bet will be to focus on the "dude!" elements of your story. How many levels? How many Mechs? How many weapons? Any intense bands on the soundtrack? While the number of female gamers appears to be growing, like it or not, until more women join the ranks of the gaming media, you should probably focus on the guy-appealing aspects of your game.

Accompanying Materials

Gaming news editors also want to see screenshots—lots of them. Make sure you take plenty of screenshots and make them high resolution while you're at it. You can always compress them later for e-mailing purposes. If you're sending out a press release, send out a new round of screenshots as well. They also like demos and trailers. Keep in mind that they need you as much as you need them. They need content that will attract an audience.


Releasing the Release

You've written. You've proofread. And proofread again. You're almost ready to release. However, before doing so, make sure you have a catchy and concise headline that makes clear the point of your story.

Be very certain to include basic information in your release, including a contact name and, at a minimum, contact e-mail. Make sure this is a contact who will actually be available for contact after sending out the press release. Don't send out a press release and then be unable to return e-mail or telephone calls for a week. Hedge your bets and include two different contact people.

As mentioned earlier, e-mail has made sending out press releases a relative breeze. If you are sending the press release out yourself, and have not already compiled a database of contacts, you need to do so. As Cannell of Gnostic Lab says, "this is the biggest weapon in your arsenal." There are easily more than 100 gaming press outlets and they're all relatively easy to find with a quick Google search. Further, many of the online sites pick up news items from other sites, so you should be able to compile a wealth of data fairly quickly. While some are bigger in terms of audience size, you never know who is reading, so include them all. Generally speaking, you're looking for the "news" contact address.

When sending out a press release by e-mail, include the text of your press release in the body of your e-mail, versus as an attached Word document. You're just adding another step and everyone is increasingly virus wary of attachments. And please don't just put a link to your press release posted on your Web site. Again, don't create additional steps to get to your news. In addition, while most people have HTML-friendly e-mail, the best way to go is simple text format. If you absolutely must do HTML, keep your background white and your text black. This is news, not a "prettiest e-mail" contest.

If you use an outsourced PR firm, they will know how to get it out for you. They maintain their own press databases and have established relationships with the media. Using a professional PR firm saves you the time of compiling your own database and allows you the advantage of an already established relationship.

Press release distribution can also be facilitated through the use of "wire" services such as Businesswire or PRNewswire. If you want to release via one of these services, just be aware that the services are not free, and prices typically range anywhere from a couple of hundred dollars to a thousand, depending on the number of news outlets receiving the release.

If you're also releasing screenshots, a demo, or a trailer in conjunction with your press release, don't e-mail some monster file. Zip files when you can, and if the file is still over 1MB, upload it to your Web site and provide a link where the files can be easily downloaded. While you might have a screaming-fast Internet connection, many e-mail servers reject large files, so play it safe.

Finally, be as specific as possible in the subject line of the e-mail. "Press Release" just doesn't cut it. Journalists and editors are inundated with press releases. Don't make them jump through hoops just to get to the basis of your story.


After the Release

If someone does bite on your press release and asks for more information, answer the questions specifically and in detail. Don't just give them a link to information found on your Web site. It's lazy, unprofessional, and could be the end of the story. Andrew Park of Gamespot finds it particularly irritating to deal with PR representatives who aren't communicative or who ignore repeated e-mails and telephone calls. On the other hand, Park says that Gamespot "loves" PR folks who send games and supporting materials out on time, if not early, "and who keep in constant communication about important developments."

And, of course, say "thank you!" If a publication picks up your press release or publishes something nice about your company, show your appreciation. A simple e-mail is all it takes and it will be remembered. The larger publications don't have time to let you know they've written about you, so it's up to you to keep up with the media. There are also companies that provide "clipping services" that do the looking for you for a price. If a news outlet has followed up wanting additional information, say "thank you." And if they let you know they've published something about your company, say "thank you."

Of course, in the event they've written something negative, it might be hard to say "thank you" and not even necessary. However, this is also not the time to lose your temper. Either just bear it and walk away, or have a rational conversation, however irrational you might find their review of your beloved game. Don't burn any bridges.


Beyond the Press Release

Press releases are the first stone on the path to industry fame and glory. Press releases lead to interviews, game previews, and reviews. If you want a media outlet to demo or review your product, you need to make the process as simple as possible. One of the biggest gripes from game reviewers is the lack of support material accompanying review copies of games. Even if your manual hasn't been laid out just yet by the designer, send just a plain bound copy of the text. Send a walkthrough, too. With preview CDs, include some game art, screenshots, game logo, and company logo.

For game reviews, have a "press pack" ready to roll, including a box shot (front of the box in a high-resolution format), game logo, company logo, and at least a dozen high-resolution screenshots. In addition, in terms of releasing a game for review, keep in mind that the gaming press typically like to receive games in advance of their release to the public.

You should also have physical prepared media kits ready to go at a given notice. Have some folders printed with your company logo and, in an organized fashion, put together a nice packet of information about your company, including company history, previous press clippings, game "sell sheets," and archived press releases. You might also include a CD "sampler," which could include product images, demos, contact information, and more.

Case Study 3.1.1: Game Reviewer Perks and Playola
Start example

In addition to copies of the game, most game reviewers receive accompanying accouterment from game publishers. These typically include t-shirts, caps, backpacks, and other assorted company and game branded items. However, when these perks become over-the-top, such as free trips to Japan and Europe, transportation by limousine, and movie premiers, some critics call this "playola." As noted in an April 2002 article in the Los Angeles Times [Cambron 01], while many publications have specific policies forbidding writers from accepting free trips and accommodations, or gifts worth more than $25 to $100, practically speaking, these policies are often unenforceable or inapplicable to freelancers. According to the article, although there is no evidence that the junkets generate more positive reviews, and no writer would admit to being swayed by the extravaganzas, they do, says the author, produce more publicity for some middle-of-the-road games that might otherwise draw little attention.

End example
Case Study 3.1.2: A Sample Press Release
Start example

The following is a press release sample announcing a publishing deal:

For Immediate Release

GAME PUBLISHER TO PUBLISH GAME DEVELOPER'S MASSIVELY MULTIPLAYER ONLINE GAME "MOG"

Weston, CT—July 15, 2002—Game Publisher and Game Developer today announced a publishing agreement for "Mog," a massively multiplayer online strategy game that puts the player in command of a massive flying saucer. The retail version will incorporate new levels of game play, as well as offer a one-month free trial subscription.

The arrangement between Game Developer and Game Publisher was negotiated by Los Angeles based AndWeHelped, a boutique firm specializing in interactive entertainment consulting.

John Doe, vice president of third-party broker AndWeHelped, was instrumental in putting the deal together. "Joe Smith, president of Game Developer, and his team wanted a publisher who would really get behind and support the game," said Doe. "Game Publisher has exhibited tremendous commitment to all its titles, so we felt this would be a great match."

Mog takes place in a universe splintered by intergalactic war. Humanity has split into two hostile factions, while a new hostile alien race advances into human space. In the midst of turmoil and civil unrest, players start as flying saucer ensigns, piloting smaller saucers, eventually working their way up to saucer fleet admiral, controlling a massive flying saucer and plotting strategic maneuvers in one of the three initial factions.

The Mog universe is alive with many new different subplots. Humans are the dominant species of each beginning scenario, but more advanced scenarios will feature diverse alien races and advanced technologies. Numerous players will focus on their own agendas in this seemingly crowded galaxy, and the player will be forced to deal with circumstances that this creates.

"We are excited to be entering the massively multiplayer world with what we believe to be a particularly well-crafted and well-run game," said Game Publisher president, Peter Leader. "The Game Developer team keeps the game fresh and evolving, which was key to our publishing decision."

About Game Publisher

Game Publisher is a publisher of games for PC and other platforms. Founded by entertainment industry veterans with over 15 years of experience, Game Publisher is committed to bringing to market quality games offering exceptional entertainment. Learn more about Game Publisher at www.GamePublisher.com.

PRESS CONTACT:
Beverly R. Cambron
Rocco Media, LLC
For Game Publisher
<beverly@roccomedia.com>

End example


Conclusion

One press release does not a PR strategy make. You need to make public relations a consistent and prioritized part of your company's business strategy, whether developer, publisher, or other game industry folk. Recall the question of a tree falling in the woods and no one is around to hear it, does it really make a sound? If you make a game and no one hears about it, have you really made a game? Well, yes, but you've also wasted a considerable amount of time and money. And if you don't have the staff, the time, the writing ability, or the personality to maintain good press relations, then hire someone who does. There are public relations firms, such as Rocco Media, devoted to the game industry. They know the people and they understand the process. Rates vary depending on the expertise of the firm, but whether you're budgeting your own time, or budgeting actual dollars, make public relations an integral part of your business, and you will make the most of the gaming press.


References

[Pham02] Pham, A., "Gamers' Perks, or 'Playola'," Los Angeles Times (April 8, 2002).


Chapter 3.2: Securing a Development Contract: The Art of Pitching

Overview

Ed Bartlett, business development director, The Bitmap Brothers

<ed@bitmap-brothers.co.uk>

<bartlett_ed@hotmail.com>

Gone are the days when it was possible to sign a development deal from a handful of buzzwords shouted during a post-E3 party. With team sizes, development schedules and product budgets on a seemingly unstoppable upward trend, and a noticeable bias toward what publishers consider "safe" product such as sequels and licenses, pitching new product to publishers is becoming increasingly unpredictable, complex, and frustrating, particularly for smaller, lesser-known teams.

This article looks at the pitching process in detail and explains the rudimentary criteria that should be fulfilled in order to maximize the impact of your pitch and help streamline the signing process.


What Is Pitching?

pitch1 (pĭch)

v. pitched, pitch·ing, pitch·es

v. tr.

  1. A form of words used to persuade.

  2. To attempt to promote or sell, often in a high-pressure manner.

  3. Set or aim at a particular level, target or audience.

Almost every industry has to pitch for work in some way, shape, or form, and this applies particularly to creative industries, in which companies compete against others in their sector for key accounts and contracts.

Pitching is the established way for a client to evaluate exactly what an individual, team, or company can offer them in terms of services and skills by allowing them to prepare a highly specific presentation containing not only details of any relevant products, but also important peripheral aspects such as background and company history, staff profiles, and previous work samples.

In the case of videogames, publishers have limited budgets and resources allocated for each quarter, so even if their game concepts are different, developers are still competing for a slice of the same pie as well as regularly pitching directly against each other for "work for hire" deals, usually based around publisher-owned intellectual properties (IPs) or licenses.

Numerous pitch types take place within the videogame industry, ranging from middleware vendors touting tools and technology, to publishers selling in their latest lineup to retail, but in this article we will concentrate on the most nebulous of pitch type: developer deals.


Deal and Product Types

Before touting your development skills, it is important to understand the different deal and product types on offer.

Deal Types

  • Work for hire. The most straightforward of contracts, this "cash for content" deal generally sees developers pitching for the right to work on one of the publishers own IPs or acquired licenses. Publishers are looking for emphasis on professional production techniques, stability, and a proven team or track record. "Work for hire" teams rarely secure more than a basic royalty rate, although many such deals involve working on franchised or licensed products, which tend to have a greater potential of realizing royalties for the developer.

  • Prototyping deal. As publishers look to minimize their long-term development risks, many are starting to offer prototyping deals. Here, the publisher pays the developers' costs, or "burn rate" for a short period of time (usually three to six months) to allow them to produce a more detailed "proof of concept" demo to evaluate before making the final decision on a product. Some publishers also use external development teams to create prototypes of games they intend to develop internally rather than tie up their own teams, in which case the developer will factor a larger percentage profit margin into their burn rate.

  • Development deal. The most common deal type, where the publisher funds a new product through a royalty advance, a set number of milestone payments to cover development overheads, and an agreed royalty rate once the publisher has recouped the advance.

  • Publishing deal. Effectively a marketing and distribution deal, here the developer approaches the publisher with a finished or near-finished product, negating the publishers' risk as much as possible and maximizing the opportunity for the developer to negotiate a substantial advance and higher-than-average royalty rates. With the massive budgets and protracted development cycles of modern AAA titles (publishers grade products internally according to its quality and sales potential, with AAA at the top of the scale), the straight publishing deal is now the Holy Grail for all but the biggest and best developers.

Product Types

It is important to consider that the parameters of any potential deal will also be dictated to an extent by the type of product in question.

  • Original IP. A developer approaching a publisher with a totally new, untested IP needs the sharpest of pitches in order to convince publishers of its merits. Publishers regard new IPs as the biggest risk, as they are an untested and therefore unknown quantity. The risk factor is exacerbated if the product is devoid of a compelling character, environment, storyline, or gameplay "hook" for the marketing department to work with, which is why it is increasingly important for developers to consider such factors from inception.

  • Third-party IP. Usually a work for hire deal using one of the publishers own IPs, the developer must be able to deliver a quality product according to rigid schedule and budget guidelines.

  • Third-party license. Licenses are still very hit and miss within the games industry, and the pitching process for licensed products generally reflects that, as the developer often has to please both the publisher and the licensor. The majority of licensors also have little or no knowledge of the game industry or development process. Therefore, where some licensors will require a creative solution, requiring the developer to re-work the subject matter for a gaming audience, others will demand that the IP remains untouched. Many simply don't know what they want. Fortunately, most publishers are now securing more control over licenses before commissioning them for games, and some licensors are even securing a developer and creative brief before approaching the publishers.


The Fundamentals of Pitch Preparation

While there are a number of different types of pitch, they share the same core structure needed to provide the publisher with a well-rounded overview of any potential product or deal. The following section outlines the main stages in detail, giving hints and pointers along the way.


Researching Your Concept

When developing any new product, research plays a fundamental part, and videogames are no exception. It's one thing to have a great game idea, but the sooner you gather hard facts on potential competitor products, consumer demographics, and platform statistics, the easier it will be for you to create a concise pitch that will convince the publisher that your product is more than just a good idea.

Start by looking at products that are broadly similar to your "high concept" and then compare and contrast your unique selling points (USPs). Look at which publishers tend to favor that genre of game and get your hands on platform- and territory-specific sales figures, marketing information, and any relevant press coverage for competitor titles.

It's important even at this early stage to consider how you will differentiate your product from similar titles, and if it's highly original, how will you make the most of its features and establish it as a unique brand in an overly saturated market. A frightening number of developers never consider marketability, positioning, and brand development, and are all too happy to leave such important details to the publisher, even after a deal is clinched.


Preparing Documentation

It is very likely at pre-pitch stage that you will have a short, concise document outlining the fundamental elements of your concept. Until fairly recently this was all that was required when pitching new products. Nowadays, however, publishers are keen to read more deeply into your game mechanics and theory.

Feature-creep has cost publishers countless millions in the past, so the more concrete a design they can see in place from the beginning, the better. A good idea is to create two separate documents: a marketing/concept overview document and a design bible.

Marketing/Concept Overview Document

This document is for people who do not have the time or necessity to digest every ounce of your game design, but rather need a concentrated "shot."

It should ideally weigh in at less than 20 pages, starting with a concise, accurate, and informative overview of your concept including positioning, and subsequently detailing in a similarly concise manner elements such as:

  • Storyline

  • Setting

  • Characters

  • Key features

  • Competitor analysis

  • Bullet-pointed USPs

The concept document should also be fairly graphical. Avoid filling entire pages with text; instead, try interspersing text with attractive concept and early game art.

Design Document

The nature of a design document tends to vary from game to game, designer to designer, and company to company. At the pitching stage, the advice would be to focus your designers' time on documenting, explaining, and illustrating only the key functionality, including:

  • Control features

  • Game and level progression

  • Graphical themes

  • Core game systems

  • Any unique, unusual, or important functionality

Unlike the concept/marketing document, the design document needs only to be graphical when illustrating gameplay features.


Creating a Demo

The "proof of concept" demo has fast become the most important aspect of pitching to publishers. Demos themselves have evolved from simple technology prototypes through to impressively feature-complete previews of what the final game will offer.

With development costs escalating as they are, assigning even a small team to a demo for just a few months can cost developers dearly, especially as there are no absolute guarantees that their game will get signed, regardless of its quality. Indeed, many a developer has gone out of business during the crucial pitching process. For these reasons, it is essential that you plan carefully and extract the most value for money or "bang for buck" from your demo.

Planning

As with a full product, it is vital when creating a demo that you plan in advance the time and cost factors. This involves working out exactly which features you intend to implement, and not necessarily what you think should be in the demo but rather what the publisher will want to see.

At demo stage, publishers nowadays are rarely moved by amazing graphical routines. What they really want to see is proof that your core game systems—particularly those that are new or different, or that feature strongly in the USP list—work as planned.

Consider the first presentation of your demo and if at any point you would have to say to the publisher "now imagine . . .," then you need to do more work. Never take for granted that other people will have the same vision of your concept as you do.

Once you have an understanding of what is required for your demo, you should sit down with your department heads to prepare a schedule. Again, be realistic. Always remember there are no guarantees that you will ever sell your game or recoup the cost of creating the demo, so while an increased content and quality level within the demo presents a stronger case to publishers, if you still fail to secure a deal your financial loss will be even greater. Pitching is a very delicate balancing act.

Choosing a Platform

Another key consideration when preparing a demo is the target platform. As the vast majority of development work is done via the PC, this is for many the obvious choice, but not always the best one. Presuming that you have researched your concept, you will have a fair idea as to the platform(s) that best suit it. If your primary shelf keeping unit (SKU—i.e., version) is console-based, however, most publishers will want to see the demo running on that platform before committing, both to show that you are a registered developer and are capable of creating content for that platform, and that the key features you are including are possible within the fixed limits of the target hardware.

If you are already in possession of the necessary equipment, then this is less of a problem. However, for startups and PC-only developers, both the time and cost of obtaining hardware and finding experienced staff must be taken into consideration. If for any reason it is not possible to develop your demo on target hardware, then consider options such as keeping your PC content in line with console specs, show demo footage running on a TV, and develop your control system using one of the many console joypad adapters on the market so that at least the publisher can feel as though they are playing it on the relevant system.

Using Middleware

Middleware is one of the biggest stories in recent development history and has in a short space of time evolved from simple component software such as video codices to complete game engines at the bleeding edge of technology.

Middleware can greatly enhance your development process—RenderWare Studio, for example, can be used to develop simultaneously for PC, PlayStation 2, Xbox, and GameCube. Moreover, such software is especially useful when developing your demo, as they already contain much of the core functionality you will require, thus allowing you to concentrate your limited time and resources on implementing the key features.

Bear in mind, however, that middleware is not a magic cure for all game development issues, nor is it suitable for all developers and all games, and time saved at the demo stage might be lost later in development. Unlike proprietary technology, when using middleware, you are never 100% in control, and middleware vendors work to different ideals and deadlines than your team and product do.

Although many publishers are warming to middleware solutions thanks in part to the success of games such as Grand Theft Auto 3, some still favor developers with proprietary technology, and others even have exclusive deals with certain vendors or buy licenses in bulk. This also needs to be taken into consideration when deciding on your technical solution.


Schedule and Budget

Although a detailed schedule and budget analysis are rarely required until after the initial pitching stage, you will obviously be required to give the publisher some indication of the cost of the product, and at the very least an estimate of which quarter of the year you will deliver it in.

Diligent developers will create accurate breakdowns as early as possible using spreadsheets specifically designed to allow fast and accurate assessment of project budgets using predetermined hardware, software, and overhead figures. It is also useful to develop two different breakdowns detailing the game features you can deliver on varying budgets. This shows that you are flexible, and can save a lot of time at the negotiating stage. Most publishers will naturally try to knock down your price, so always go in slightly higher than necessary without pricing yourself out of the market.

Case Study 3.2.1: Team 17
Start example

The pitching process has changed dramatically since the early days of the industry. We asked veteran Team 17 Creative Director, Martyn Brown, how they have adapted over the years.

Q:

How has the pitching process changed for developers over the years?

Q:

What types of materials do you prepare before approaching publishers?

`We prepare many items, from the obvious game design overview and concept materials to a business plan, sales forecasts, and marketing ideas. This can differ from publisher to publisher depending on their individual approach and prior requests.`

Q:

How many publishers do you approach initially, and what do you look for?

Q:

Do you tailor your pitches to the individual publishers?

Q:

What do you think is the most important thing a developer can offer a publisher?

Answers

A:

"The most apparent change is the risk assessment and due-diligence carried out by publishers nowadays. A few years ago, pitches were relatively simple, brief, and to the point. The industry has matured; no matter how good the developer, you need a commercial or business manager to help with the pitching process."

A:

"We prepare many items, from the obvious game design overview and concept materials to a business plan, sales forecasts, and marketing ideas. This can differ from publisher to publisher depending on their individual approach and prior requests."

A:

"I think in the current marketplace there are only a handful of publishers that are capable of doing justice to our titles, so we approach only the major players, most of whom are U.S. based. In terms of publishing, we look for security, presence in the marketplace, distribution capability, and how we can fit into their 'machine'."

A:

"We produce a main core of generic presentation materials that the majority of publishers will see. We have produced publisher-specific content where it is applicable or it has been requested. However, I think it's important to have a well-covered, well-rehearsed pitch in terms of consistent content."

A:

"There are a number of things that are vital to a successful pitch, and I would personally think that the ability, organization, resources, and reputation of the developer are first and foremost.

"A prototype that reassures publishers on technical implementation (upon the core platform where possible) is also extremely useful since few, if any, original pitches are made on concept ideas these days. In all cases, developers need to identify areas of publishing risk and allay those fears."
End example


Product Presentation

Before making contact with publishers, you should create a digital presentation using software such as Microsoft PowerPoint. This presentation should be used as the first point of contact for anybody evaluating your game. Its purpose is to educate newcomers to your product in the most concise and attractive way possible, leaving little of your ideas for the game open to interpretation, but without going into design-doc-size detail.

The basic structure of the presentation should be fairly similar to that of your cut-down concept/marketing document, but with bullet point summaries replacing paragraphs of text.

Using no more than a single slide per heading, and following a similar order, key content should include:

  • Introduction. The first few pages should include an attractive title page and suitable game-related imagery and company logo branding; an introductory paragraph outlining your new concept focusing on the storyline, game genre, target audience, and platforms; the top two or three features that make the game stand out; and a page detailing your perception and research on the market for such a game and why you believe your particular title will be successful. Be wary of making any overly assertive assumptions at this stage.

  • Sales figures. If your product is part of an illustrious franchise and boasts fantastic sales figures, be sure to insert them early on to get the publisher's attention. If you can break them down per SKU and per territory, all the better.

  • Game features and USPs. The next several pages should cover all key game features in a purely bullet-pointed fashion, starting with engine and technology details, focusing primarily on the core gameplay and single-player features, and ending with an overview of any multiplayer features, if applicable.

  • Visuals. At this point in the document, you should break the monotony of pages of text by showing off two to three pages of concept art, game models, screenshots, and videos, depending on what you have available. Line them up neatly as thumbnails within the presentation and link them to full-size versions on the CD so they can be experienced in their full glory.

  • Press coverage. Developers are increasingly using the specialist press as a tool to help secure deals by releasing details of the game almost from inception. If you have any positive press coverage, it's good to include links and details to help marketing teams gauge potential press and public opinion.

  • Competitive analysis. The worthiness of a competitive analysis depends largely on how far away from completion your product is. If you are at the start of an 18-month development cycle, it is unlikely you will have an accurate picture of the games with which your product will eventually compete. However, at the very least it is worth listing key titles in the same genre, and briefly comparing and contrasting key features and USPs.

  • Demo. If you are including playable code with the presentation, you should link the appropriate file into the presentation to ensure that the publisher is aware of that fact, and allow them to install the program before continuing with the presentation. If you are not including playable code, you should at least attempt to supply a crisply edited video clip of your game or technology in action to whet the appetite.

  • Company profile. At the end of the document, you should include a brief company profile, including softography and any relevant links, allowing the publisher to find out more about you without having to ask.

Thanks to its digital nature, this simple presentation can be duplicated onto numbered CDs, at which point your art team can create a realistic mockup of a box cover, CD label, and insert that can be printed on photo-quality paper and slipped into blank DVD boxes to look like retail product.

You might also see fit to include any other relevant info on the CD, such as design documentation and schedule breakdown, all of which can again be hyperlinked into the main presentation to ensure that they are not overlooked on the disc. Be sure to include any necessary software needed to allow the end user to view the presentation, and a "read me" file containing detailed instructions. Before duplicating a CD, get someone to test it as an end user to ensure that everything is clear and works as it should.

If executed well, you can be sure that such a package will garner attention and interest when it hits the publishers' in-box. It is also a good idea to send several copies to each publisher that you are courting, allowing them to instantly forward copies to other territories, and thus speed up feedback response times.


Choosing a Publisher

Once all of the key components of your pitch are in place, the next step is getting publishers interested. It is a dramatically different story approaching a publisher with a new product as an established developer compared with, say, an untried startup team. However, most publishers will be happy to explore every product they are offered lest they overlook the next Tetris or Tomb Raider.

Once you get this opportunity, it is up to you to grab their attention and hammer out a deal.

Publisher Pitch Expectations

Although different publishers will place emphasis on different features, the main requirements are universal:

  • A marketable concept with even a hint of originality, preferably with at least rudimentary multiplayer elements.

  • A solvent, trading company, preferably with a relevant track record.

  • Design documentation.

  • A team, or at least key team members.

  • Playable demo.

  • Schedule and budget estimates.

Publishers are becoming increasingly adverse to risk, so your pitch has to convince them that your product merits the time and financial investment that you are seeking as well as allay any fears that the game might not be completed successfully within the specified timescale and budget. You might have the best new game idea on the planet, but if you only have half a team and a wildly ambitious schedule you cannot hope to find a deal.

Choosing Publishers

Pitching new products can be a long and arduous process, and you can often spend a number of months in negotiations with a publisher only to fall at the final hurdle and find yourself back at square one. As such, it is important to pitch to more than one publisher simultaneously. Of course, the extreme example of this is pitching to every publisher at once. However, this too can be fraught with problems—not to mention incredibly time-consuming, tiring, and confusing!

Many developers will already have relationships with one or more publishers, either from current or previous products, and some might even have "first refusal" clauses on new products in their active contracts. However, this is by no means a guarantee of interest, so you should continue to court other publishers as well, providing you are not bound by a non-disclosure agreement (NDA).

The best path when pitching a new product is to put your ear to the ground and find out which publishers are currently on the hunt for new products, and (obviously) who has money to spend. It is also worthwhile to compile a list of publishers who tend to favor your game genre when deciding whom to approach.

Making Contact

Once you have decided which publishers to target, the next step is making contact. Contacts are an invaluable part of game development, and you should seek to build them as quickly as possible. Make a point of visiting industry trade shows and parties, exchange as many business cards as possible, and spend time cataloguing the names and addresses of publishers throughout the territories to save time. This information can often be found in trade magazines such as Develop and Game Developer, and where there are blanks, feel free to call the publisher directly and establish who their contact is for new product.

Cross-Territory Pitching

When dealing with publishers whose primary operations take place on another continent, you will need to consider whether to pitch in your territory or directly to the heart of the company.

Again, there are no hard-and-fast rules to this—some publishers will specify that you contact their representative in your territory, whereas others will happily work with you directly.

While the obvious downsides are different timelines and the logistics of setting up meetings, the ultimate decision on new products often comes from the publisher's global headquarters. Therefore, by taking the direct approach in many cases you can effectively cut out the "middleman," saving yourself yet more time, effort, and money.

Once you are ready to make contact, open with a polite telephone call to introduce you, your company, and your product, and ascertain whether they are interested in opening dialogue. If the results are positive, you should then arrange delivery of your presentation to allow evaluation by the publisher, and a suitably timed follow-up meeting. If you do not already have them at this stage, try to get hold of all relevant contact details, including e-mail, direct line and mobile phone numbers. You will see why this is particularly useful later.

Follow each telephone call immediately with an e-mail thanking them for their time and confirming any arrangements discussed. If you have arranged a meeting, make an effort to offer information such as studio location rather than waiting to be asked for the directions, and never double-book appointments. Different publishers will want to spend varying amounts of time with you when visiting your studio, so wherever possible, set aside at least half a day per meeting.


Making a Pitch

When pitch day arrives, again, preparation is the key. If you do not appear confident, organized, and in control of something as simple as a meeting, how can you expect a publisher to trust you with a complex, lengthy development process?

Publishers like to see clean, well-organized offices, but anything overtly flash will trigger alarm bells about your overheads and how much of your burn rate is actually spent directly on development.

It is fairly common within the industry for staff to work flexible hours, but when you are expecting a publisher visit it is vital that all staff are present, particularly the key staff members who will usually be required to say a few words during the studio walkabout.

Ensure the day prior to the pitch that all documentation is printed and bound, and any demos, presentations, and machinery are updated and running smoothly in the required location.

Meeting rooms should be kept cool, so that your visitors won't feel sleepy. Any unrelated materials and whiteboard markings should be covered or removed from the room.

Just before the representatives are due to arrive, grab a handful of business cards and ensure that all mobile phones are switched off and external calls are diverted.

First Impressions

Remember:

  • Make a mental note of representatives' names beforehand and be sure to use them correctly.

  • Offer a firm handshake, a smile, lots of eye contact, and a selection of beverages.

  • Don't jump straight to business; try to connect on a personal level first.

  • Remain confident at all times. Remember, this is your product and it is your job to set the pace.

  • Avoid appearing overly somber and business-like, but conversely don't attempt your latest stand-up routine.

  • Avoid making negative comments about past or present projects or partners.

Order of Play

Creative meetings are at their best when organic in nature, but where business is involved it is important to have at least a basic order of play. Expect the natural progression of such meetings to be as follows:

  • Show and tell. Start with a mutual exchange of company-related information such as studio locations, staffing, head count, current products and performance, and future plans.

  • Presentation. Go through your presentation with the publisher. Now that you have their undivided attention, feel free to expand verbally on each point— within reason! If you have playable code, end the presentation by showing them the game in action and allow them to try it.

  • Studio walkabout. Before discussing the finer points such as deal terms, take a break and show the publisher around the studio, allowing them to gauge how you work. Obviously, for bigger studios it's not feasible to meet every staff member individually, but be sure to stop and talk with key staff, and where possible, show work in progress on both the game you are pitching and any other products in development.

  • Fine print. Upon returning to the meeting room, you should now broach the subjects of schedules, budget, and any important contractual terms. At this stage, most publishers will simply require a cash figure and delivery date, but some might want to go into more detail—so be prepared!

  • Winding up. It is incredibly rare that a publisher will commit, even verbally, to a product at this stage. If you're lucky enough to have in attendance someone with the authority to do so, he or she will usually still need time to discuss matters internally, especially if any new issues arose during the meeting. All you can do now is thank them for their time, ensure that they have all the necessary information, and show them

Case Study 3.2.2: Acclaim
Start example

As the complexity, costs, and gestation periods of new titles increase, publishers demand to see more of games and their developers before signing deals. However, are they asking too much? Jeremy Chubb, Acclaim's product development manager, international, reveals his expectations.

Q:

First impressions are important, so how should developers best approach you?

Q:

What are the different stages of the evaluation process, and what is required of the developer?

Q:

Do you have a preference for people using their own tech or using middleware solutions?

Q:

What would be your definition of the perfect pitch?

Q:

What are the most common mistakes developers make when pitching?

Q:

What is the single most important thing a developer can bring to the table?

`Experience. There's no substitute for a proven track record in the chosen genre.`

Answers

A:

"It really shouldn't make any difference, although arriving on a packed and noisy stand at E3 brandishing design documents and business cards probably isn't the best approach. Most publishers are bombarded by requests for meetings a couple of months before trade shows, and schedules tend to be packed by the time the show starts.

"An e-mail with some basic assets introducing the pitch/studio is an ideal start, and a call to make sure the e-mail got through to the right person is recommended."

A:

"This depends on how far along the project is. Concepts reviewed can range from single-page designs from unknown startups to complete games from the greatest developers in the world, and the process is different for each.

"A general approach for a new developer with an unknown game on new technology might look something like this:

  • First contact. A telephone call or e-mail just to quickly outline the proposed project, exchange contact details, and arrange a follow-up visit. Inquiries should target product development/new business development staff or producers.

  • Pitch. A follow-up visit to the publisher to pitch the game comes next. Here, the developer needs to get the game across as imaginatively and efficiently as possible. Aim for a 40-minute presentation.

  • Evaluation. The pitch, including available assets, is internally presented to a brand/marketing group for initial feedback. Issues relating to market potential, projected marketing costs, brand opportunities, licensing, and competitive analysis are investigated.

  • Studio visit. Based on initial interest, producers will visit the studio to assess the developer's technology and management of the project.

  • Feedback. Feedback from acquisition, producer, and brand manager are presented to senior executives.

  • Final pitch. Presentation of the game to senior executives. This is the final pitch to the top brass. Make or break on the project.

"It's very rare for this to actually be the case, though. An experienced developer with a recent hit and a great concept can expect to walk straight into a senior executive meeting. Similarly, a near-final game can be appraised very quickly. Many games are developed based on an existing relationship with a studio and publisher. Z-Axis' Aggressive Inline was signed based on the studio's success with Dave Mirra BMX 2, and Criterion signed Burnout 2: Point of Impact based on the huge success of their excellent first game."

A:

"There's no real preference. Burnout 2 and GTA3 are great examples of middleware generating great sales.

"The benefit of using middleware is that it allows developers to get playable demos up and running quickly and cheaply, particularly on new hardware. Publishers warm to proof of concept like nothing else, and particularly for smaller developers, this can be the best approach."

A:

"I recently saw the perfect pitch. The developer had worked hard to create assets for everyone concerned and had taken advantage of early feedback on the design, cost, and timelines. The result was a final meeting to pitch to senior executives at the publisher. They arrived an hour before the meeting to set up the room and ensure that all the equipment worked on cue. It was a 45-minute pitch detailing the following:

For senior executives:

A PowerPoint presentation of the concept and overview document containing:

  • Company background and team experience, including brief demos of previous, relevant games

  • Concept competitive analysis

  • USPs

  • Key gameplay elements

  • Example level walkthroughs

  • Basic scheduling and cost breakdown

  • Concept art and renders

  • MPEG video combining in-game and FMV (full motion video) footage to illustrate the overall feel of the concept

  • Two-level playable demo illustrating key elements in action

  • Mockup screenshots estimating the final quality of the game graphics

For producers:

  • Complete design documentation

  • Detailed scheduling and milestone information

  • Exact cost breakdown

A:

"Too many developers pitch an approximation of a concept, rather than a clearly defined game. Knowing that the publisher will want creative input, developers are often overly cautious in developing their ideas.

"It's no use answering questions like 'how much will it cost?' with 'how much do you want to spend?' or 'what's the play-through time?' with 'as long as you want.'

"Publishers are most attracted to groups with a clear vision and total understanding of cost and schedule details."

A:

"Experience. There's no substitute for a proven track record in the chosen genre."
End example


The Waiting Game

It is notoriously difficult to gauge how successful a pitch has been. Some publisher representatives will talk candidly and excitedly about your product, often expressing how delighted they would be to sign it. However, this generally indicates that they aren't personally in a position to do so, and therefore their excitement should not be misconstrued as acceptance.

Equally, other publishers might leave stony faced having hardly said a word, but this too should not be misconstrued as rejection. It can take time—sometimes months—for publishers to make a decision on a product. Many people in numerous territories are involved in the process, so don't expect an immediate answer.

You should follow up your meeting with a courteous e-mail thanking the representatives for visiting and that you looking forward to their feedback. Do not worry if you don't get a response; like developers, publishers are extremely busy people, and in the same way developers hate to be hassled by vendors, publishers don't take kindly to persistent pressure.

If you have pitched to multiple publishers simultaneously, the wait for responses won't be quite as intense, and if you start getting further interest you can use this as gentle leverage with the remaining publishers.

Unfortunately, some publishers are known for simply not responding, and in this case remember that a telephone call is far harder to ignore than an e-mail. Here lies the importance of noting your correspondents' direct line or mobile number during the contact phase.


Conclusion

As you can see, pitching has become a long, drawn out, and complex process and should never be taken lightly. Rather than being part of the overall development process, think of it as a development process in its own right.

Planning is absolutely essential, especially because development at this stage comes straight off your top line, so any time and effort wasted merely increases your overheads and adds to the already prevalent risks.

While following these guidelines gives no guarantee of success, at the very least it will help you to maximize the effectiveness of your pitching process and minimize the time wasted both internally and when awaiting feedback... And as we all know, when it comes to game development, time really is money.


Chapter 3.3: The Whys and Wherefores of Game Agents

Overview

Borut Pfeifer

<borut@whiteknucklegames.com>

Much has been written about developer-publisher contracts ([Rogers02], [Powell02]), and rightly so—for a new game development studio, their first game contract can have a profound effect on the success of their business. However, while agents similar to those employed by writers, musicians, and actors are growing in popularity in the game industry, there is little documentation on contracts between a developer and an agent, and how to go about selecting one. Should a new studio decide to sign with an agent, this might be the first legal contract they will ever enter into. This article describes some of the pros and cons of selecting an agent, to help a studio decide whether an agent is right for them, and some of the clauses in typical agent contracts.


Is an Agent Right for You?

Let's look at the services that an agency provides to a developer, and at the corresponding costs.

Pros

  • Location and travel. For a team that is not located in California, it can be difficult to work with publishers who want frequent contact with their developers, at least in the initial stages of the relationship. An agent located where the major publishers are located expedites this process for the developer. Even agents who are not located in California can still help the developer in this manner, since they will still save the developer from having to travel as frequently to see the publisher, letting them focus on what drives them: making games.

  • Knowledge of publisher needs. We would all like to think that exceptionally fun gameplay can sell a demo, but publishers often look for key, hot features, depending on the current state of the market. A good agent will be aware of what features publishers are looking for. They will also know what types of games a publisher is looking for at any particular time, and will therefore be able to tailor the search to the publishers that are looking for your type of game.

  • Contacts in the industry. A good agent has strong relationships with the right people at the major publishers.

  • Negotiation. An agent is usually a skilled and practiced negotiator; this will come in handy not just during the initial contract negotiation, but also during the development cycle if some monetary dispute arises between the developer and publisher.

  • Business knowledge. For an inexperienced team, an agent can bring general business development knowledge to the table.

Cons

  • Commission. The agent takes a percentage of all income you receive from the publisher, as well as income from sequels or derivative works, and also potentially from the purchase of your studio.

  • Negative publisher image. Publishers might think that a development contract is going to have an artificially inflated price if there is an agent involved, to account for their commission. They still tend to deal with agents, however, since it is a convenient way to find new teams.

  • Potential loss of control. Typically, an agent does not interfere very much with the studio and its work. However, if the studio wants to control every aspect of development, including publisher relationships, then the presence of an agent might prove incompatible with the studio's objectives.

What to Look for in a Particular Agent

The ideal agent is strong in most (if not all) of the service areas listed in the preceding section. In addition, consider these factors:

  • Attitude. Do you feel the agent is trustworthy? Can you easily get along with him? Remember that you will have to work in close partnership with this person, possibly for a long time.

  • Experience. Many agents come from other parts of the industry. Some are former publisher or developer employees. The more experience, from as many diverse sources in the industry, the better the agent will be at helping you in general.

  • Representation. How much time and how many people will the agency use to represent you to the fullest?

Analysis

Now that we've gone through some of the pros and cons, let's consider the situations where it would be most and least desirable to use an agent.

For an inexperienced team, one located far away from industry centers, or one without any significant expertise and/or interest in performing the work required by a sustained sales effort, it's probably worth the cost of going with an agent. Obviously, this is not to say that this team would have no chance to succeed without one, but the benefits of agent representation would likely outweigh the costs.

On the other hand, if the team is heavily experienced, it might be able to get a contract based solely on that experience. A good agent could still give this team feedback about the game and thus prevent the negative impressions that might arise from approaching a desirable publisher with an unpolished demo.

It is also worthwhile to study the monetary implications of the agent's presence, and whether they seem reasonable or not. Suppose that an agent secures a $2 million, two-year development contract for you, over the course of a nine-month negotiation process. (It can easily take up to six months to finalize a contract, in addition to the time required to prepare the pitch, visit publishers, and obtain a letter of intent.) If the agent's commission is 10% of the contract's value, you're paying them $200,000 for those nine months of work, but you're also paying for their contacts, the time you didn't have to spend traveling, and for that wonderful benefit, the part about not having to do the sales pitch yourself.

Further, you should consider how many people the agency will assign to your case: is it one person full time, or multiple specialists? Do not make the mistake of simply computing an hourly rate. Keep in mind the qualitative factors mentioned earlier before you use the cost analysis to make your final decision.


Contract Details

If you've decided to go with an agent, it will be useful to know some of the typical clauses you'd see in an agent contract.

Agent's Responsibilities

Agents must try to obtain the best possible offers and contracts for your team. They must be required to keep you informed about all such submissions, rejections, and offers of your game to publishers. The agent might also want to review royalty statements from your publisher to ensure that you (and they) are getting the correct amount of royalties. Most agents will also serve as intermediaries throughout the course of the contract, in the case disputes arise between the developer and the publisher; for example, if the publisher is unduly delaying milestone acceptance.

Developer's Responsibilities

The developer's main responsibility is to send anyone interested in purchasing their titles to the agent, so that the agent can manage all dealings effectively. Providing the agent with past business information (e.g., prior contracts) will also help him to better understand the developer's current business situation.

Commission

The agent is paid by commission. The commission is usually set as a percentage of the developer's gross revenues from various sources of income:

  • Any regular game development deal you sign with a publisher.

  • Subsidiary rights—sequels, add-ons, ports, etc.

  • Derivative works—translations to other media, movies, TV, action figures, etc.

  • Purchase of your company by another.

Each of these categories might have a different commission rate attached to it, in general somewhere between 5 and 10%. Note that when considering derivative works, you should keep the commission to a minimum: migration of a game's intellectual property to other media might be a rare occurrence, but if it does happen, you'll probably have to hire another agency to represent you in these other media—and therefore pay another commission.

Terminating the Contract

Termination of the contract is typically allowed by either party, with some period of notice to wrap up any existing business. However, several contractual clauses still apply after termination. Specifically, the agent's right to perceive commissions on the developer's earnings will expire a specific amount of time after the contract is terminated. For example, if, within 24 months of terminating a contract with an agent, the studio develops a sequel to a game for which the agent negotiated a contract, the agent will still receive his commission for that sequel.

Agents will also want you to be prohibited from dealing with publishers they put you in touch with and/or negotiated a deal between the two of you. For a publisher they have closed a contract with you, they will typically want the length of one development cycle, to discourage developers from terminating the contract with the agent and immediately closing a deal with one of these publishers (thereby avoiding the agent's commission). They will also want to prohibit you from dealing with any publisher to whom they have presented your work, but not closed a contract; since the relationship is less advanced, the limit on this is typically shorter.

Indemnification

In most contracts of any type, there is typically a clause or clauses that indemnify each party from a wrongdoing by the other side. Simply, if the other party in the contract breaks the law without you knowing about it, you can't be sued for their wrongdoing. This includes being sued and any financial obligations due to a suit.

Competition

Since agents typically represent multiple developers, you might be worried about an agent working with a client who is a direct competitor of yours (e.g., based on the genre of the game you're working on). You should be able to request their list of clients to ensure to your satisfaction that they are appropriately handling any conflicts of interest. However, don't expect more information on other clients than that, since the agent will typically be bound by confidentiality agreements with regard to clients' projects, technology, and other property.

Payment Procedures

The agent might want to take funds the publisher is to pay to you and have them place it in a trust instead. This way, they can deduct their commission before the money gets to you. This practice delays your receipt of payment by a few days. Normally, this is isn't an issue, but in tight situations, this delay could mean the difference between paying your team's salaries on time, paying them a week late, or, in the absolute worst case, even going out of business. For this reason, you might want the representation contract to specify that the publisher will send you the money, and that you will then have a short period of time to pay the agent his commission. In this case, you must also give the agent any records of publisher payments upon request, so he can be sure you're paying him the correct amount.

Non-Game Related Work

If you're a small studio, chances are you might occasionally pay the bills with contract work of various sorts. This might include contracting out your art staff to do graphic design for a magazine, or having programmers consult on a networking company's software development projects. If so, it should be clear in the contract that the agent does not receive income from this type of work (unless, of course, they obtain it for you), and that you are not required to fulfill the responsibilities described previously to the agent with regard to this work.


Conclusion

Signing with an agent can help small developers looking to break into the industry to get an edge over the competition. The popularity of game agents has increased to the point where publishers have grown to expect their presence. However, agent representation might not be suited to every team. Study the pros and cons; an agency's services might be what your team needs to increase its odds of success.


References

[Rogers02] Rogers, D. and Summers, M., "Publishers Speak 2002," Game Developer's Conference 2002 Proceedings.

[Powell02] Powell, J., "Negotiating Contracts that Protect Your Title and Team," Game Developer's Conference 2002 Proceedings.


Chapter 3.4: Effective Development Contracts

Overview

Thomas H. Buscaglia, Esquire

<thombusc@intelaw.com>

The development contract is a written agreement between a developer and a publisher that establishes the rights, duties, and obligations of the publisher and developer to each other. Development contracts cover the various issues involved in the developer/publisher relationship, including the funding, production, marketing, distribution, ownership, and ongoing obligations of the parties. This article looks at the many clauses of the usual development agreement and examines in detail some of the more important provisions in these contracts. We conclude by discussing strategies that might help a developer get the most they can out of a contract, based on their relative bargaining power.


How It Works

Publishers, those in the business of selling games, have no interest in ideas. They want teams that have what it takes to turn those ideas into reality. Once a publisher has sufficient confidence in the developer's ability to deliver a profitable game, the publisher will fund the development process and share the fruits of the commercial release, after their investment is recovered in accordance with the contract.

The method used to accomplish this is a combination of advances and royalties. The development budget and royalty rate are essential parts of every developer contract.

Payment Schedule

The total advances under the contract are divided into a series of payments. The publisher advances money to the developer throughout the development period based on a series of production milestones. This system of milestones is established to allow a publisher to protect their interest by requiring the developer to deliver ongoing builds of the game for evaluation and approval during the course of development, while the advance payments allow the developer to work in relative financial security. The failure of a developer to satisfactorily meet their milestones can result in a termination of the contract and the end of any further payments by the publisher to the developer.

Royalties

Royalty rates are calculated from the net proceeds of game sales, after the publisher's costs related to the production, manufacture, and distribution of the game have been deducted. The developer's portion of royalties is first applied to "recoup" the advances the publisher made to the developer. After all advances have been repaid from the developer portion of the net receipts as defined in the contract, royalties begin to flow through to the developer.


How It Starts

In order to convince a publisher to fund a project, a developer must prove not only that the game has commercial merit, but also that the developer has what it takes to deliver the game on time and in acceptable form. The developer prepares a comprehensive demo of the game that adequately displays the environments, characters, technology of the game, and game playability. In addition to the demo, a project document or "game bible" that sets out in detail all the elements of the game is also presented. These elements include the back story, characters, level shots, graphics and design elements, and any other content necessary to the game, especially those that are in addition to the ones included in the demo.

The Letter of Intent

Once the publisher (or publishers) decides to try to sign your game, the negotiation of the basic terms begins. If negotiations are successful, they might result in the execution of a letter of intent. This is a temporary agreement outlining only the most basic terms (e.g., advance, royalty structure, and delivery date) and stating that the parties intend to negotiate a full-length contract in good faith.

At this point, the publisher will probably prepare and deliver their "standard" developer agreement. Don't let the term "standard" fool you. Many of this fill-in-the-blanks contract's terms are negotiable, depending on the relative bargaining power of the parties. While you might be inclined to just sign the contract and get on with what you love to do, which is make your game, some patience and tenacity can have a substantial positive impact on the final terms of the agreement.

The Importance of the Contract

Game development contracts range in length from 8 to 30 pages. These are important documents and should not be treated lightly. Ultimately, the quality of your developer contract is essential to the success of the project and the long-term viability of your entire career as a developer. Therefore, the negotiation of the contract's terms should be treated with the same care you treat your code or artwork. Even if your team has an agent that has been assisting you in negotiating the terms of the contract, entering into an agreement like this without having a qualified attorney review and assist in the negotiation of the details can result in serious problems later.

As we discuss in detail later in this article, development agreements cover a broad range of issues. In addition to the milestones and payments, the development agreement describes the submission and approval process in detail, and, more important, specifies any transfer of ownership of the elements that comprise the game. For example, publishers require most new developers to relinquish all of the intellectual property in the game to the publisher. In this context, "intellectual property" usually includes the game code, game name, concept, images, characters, backgrounds, textures, and all other marketable assets that go into the game. It might also include any tools created by the developer in the process of making the game. When and how this property transfer occurs should be well delineated and set out in detail in the contract.

Of course, in some cases much of the intellectual property used in the game might already be owned by the publisher or licensed to the publisher by a third party. For example, games derived from movies, expansion packs, or second or third releases of games already published might already be owned or licensed by the publisher. In these cases, the development agreement will instead delineate the scope of the developer's right to exploit the property. In addition, if any third-party software such as game engines, software development kits, or middleware is involved in the development of the game, the contract terms will spell out who is responsible for acquiring the rights to this software, as well as who retains the right to use them during the development period and upon completion of the game.

Finally, just like any other business contract, development contracts contain numerous general provisions that lay out in detail what will occur if any specific contingency occurs. These contract provisions deal with more mundane issues such as who is responsible for quality assurance and testing, localization of the game, publicity and marketing, rights to proceeds from ancillary products such as dolls and lunch boxes, areas of distribution, insurance requirements, confidentiality and non-disclosure agreements, non-solicitation agreements, notices, assignments, waivers, and even what will occur if one or the other of the parties files for bankruptcy or is forced into bankruptcy. And of course, the contract will specify where and how any disputes that might arise will be resolved.


The Standard Sections

Let's look at the sections usually included in development agreements.

Preamble or Recitals

This is where the identity of the publisher and the developer as well as the effective date of the agreement are set out.

Definitions

The first formal section of the contract is usually the "Definitions" section. This section identifies the specific way in which certain terms are used throughout the remaining text of the contract. These terms are then capitalized throughout the contract so that the readers can identify them as being specifically defined terms.

Term

The term of the agreement sets the length of time during which the development agreement is effective. It might also include other specific responsibilities concerning events that occur within that time period.

Territory

This section identifies the different countries or geographic areas covered by the sale and distribution obligations of the publisher under the agreement. It is not uncommon to have agreements with several companies in different territories to facilitate worldwide distribution of a game.

Ownership and Licenses

This important part of the agreement will establish ownership of the game content and of related intellectual properties. In addition to actual game content, this section will typically resolve ownership of any trademarks associated with the game, such as the game's name, logo, character names, fictional locations, or any other unique matters essential to the game.

The Obligations of the Parties

Usually, the developer's obligations are set out in one section and the publisher's obligation set out in another. However, these obligations might be included in a single section of the contract. Either way, this section of the contract sets out in detail the responsibilities of developer and publishers to each other. The developer's duties under the agreement generally include specific details regarding the dates and content of each milestone. The duties of the publisher concern advance payments, royalty payments, testing, promotion, and distribution and sale of the game; in some cases, the contract will even specify the promotion and advertising budget that the publisher will spend on the game's marketing.

Finally, provisions concerning any rights regarding sequels and ancillary products might also be set out in this section.

Notices and Credits

Everyone involved in the game wants to be recognized. This section sets out in detail exactly how the identity of the developer and publisher, as well as distributors or licensees, will be displayed in the game and on game advertisements and packaging.

Warranties

Warranties are the legal guarantees and assurances that each party sets out in the contract. These include the absolute rights that each party has in whatever they are contributing to the project. For example, the developer must warrant that it owns or has an appropriate license to use all of the content in the game that is being delivered to the publisher. Similarly, the publisher must warrant that it has all rights to any materials or content that it is providing for inclusion in the game or the game packaging.

Indemnification

Indemnification is the obligation of one party to a contract to cover the losses of another party incurred as a result of any acts or omission by the first party. For example, if the developer did not actually secure ownership of all of the intellectual property contained in a game, then the developer would be responsible for any loses incurred by the publisher as a result of that failure in ownership. Similarly, if the publisher did not own a trademark that was to be associated with the game and it resulted in a loss or a lawsuit the publisher would be required to defend a lawsuit and cover any losses incurred by the developer.

Confidentiality

Confidentially provisions assure that the confidential information conveyed between the parties, as well as the terms of the agreement itself, are keep confidential both throughout the term of the agreement and for a reasonable period thereafter.

Non-Solicitation

Many development contracts prohibit either party from soliciting employees from the other. This prevents a publisher from "poaching" talented employees from the developer either during the course of development or after the completion of the game. Such provisions can be very important for developers wanting to maintain development team integrity.

Termination

This important section identifies and details the situations in which one party can terminate the contract, and the procedures to follow to do so. Termination clauses typically include failure of either party to meet their specific obligations under the agreement, matters beyond their control (acts of God and war), and even financial matters such as the bankruptcy of one or the other parties. Many of these provisions contain a time limit within which the breaching party can cure the breach without the contact being terminated.

General Provisions

General provisions, often referred to by lawyers as the "boiler plate," are the general terms of the contract regarding everything from the assignment rights, notice of the parties to each other, effect of the headings, execution of the contract in counterparts, remedies, and provisions regarding arbitration, attorney fees, and to what state's or country's law applies to the enforcement of the obligations under the agreement.

Contract Addenda and Attachments

In addition to the main portion of the contract, for ease of drafting, attachments to the contracts set out the specific terms unique to the deal. Some examples of matters often detailed in these addendum are as follows:

  • Specifications: Setting forth the game title and general specifications.

  • Milestones and payments: Identifying in reasonable detail the time (either a date or number of weeks from execution) for each milestone delivery and payment, what deliverables are included in each milestone, and how much money will be paid upon delivery and acceptance of each milestone.

  • Additional deliverables: Things such as screen shots, promotional demos, downloadable demos, and other promotional materials.

  • Additional agreements: Any secondary contracts regarding conveyance of intellectual properties rights, and specific confidentially agreements to be signed by all of the members of the team.

  • Localization: What specific languages the game will be delivered in and who is responsible for the localization.

  • Personnel: Identifying by name and address all essential team members involved in the development.

  • A signature page: The names and titles of the people who are entitled to sign the contract, along with the date of the contract's execution.

Contract Form and Tone

All contracts are different, but most contain the various sections listed in the preceding section. The details will vary from publisher to publisher. Some developer contracts have a lot of technical legal language. Others are worded in "plain language." Each type has its advantages and disadvantages. Formally written contracts are, at least in principle, more exacting, and therefore they better delineate the duties and responsibilities of the parties. However, they are often difficult for anyone other than lawyers to understand. On the other hand, reader-friendly "plain language" contracts might be easier to understand for a non-lawyer, but harder for a court to enforce due to loose construction. Ultimately, it is the publisher who starts the contract negotiation, so it will be the publisher who decides the basic tone and format of the agreement.


Effective Contracts

Now that we have covered the basic business relationship and different elements that go into a development contract, let's get down to what a developer can do to ensure the success of their development agreement. Of course, the quality of the deal that the developer is able to negotiate is directly proportional to the publisher's desire to obtain the game and the publisher's relative comfort level in the economic success of the game on release. Therefore, if you are id Software or Lionhead Studios, you will probably be able to negotiate extremely favorable terms, retain all IP rights, and get a huge royalty percentage. Similarly, if the development team has a desirable product and a highly qualified team, favorable terms can be reached. On the other hand, if you are trying to negotiate a development contract for a game that the publisher perceives as being high risk, your ability to obtain favorable terms is not good. Let's look at some specific goals to strive for in your developer contract.

Setting the Net

Ultimately, it all comes down to royalties, and royalties come down to royalty rates. Royalties rates can range from below 15% to above 40%, depending on the development team, the publisher, and the game product. However, other issues come into play besides percentages.

Royalties are defined as a share of the "net" profit to the publisher. The contract should set out in detail exactly how this "net" is calculated. These provisions are often complicated, and a close examination is important to make sure that the publisher is not deducting expenses that it should be absorbing into its own cost of doing business. In the end, the definition of the net profit can be even more important that the percentage.

Indeed, the "net" should be the net profit derived from sales of your game after the publisher has deducted costs related to the development of the game. Therefore, deducting costs such as software development kits, licenses, manufacturing costs, discounts, freebies, returns, and distribution expenses is appropriate. However, these deductions should be limited to variable costs directly related to your game. The publisher's costs for advertising and promotion, marketing, inventory storage, internal operations, or what is being spent to promote the publisher itself should not be included.

Royalty Run Up

Escalating royalties are an excellent method to capitalize if your game really hits it big. The nicest thing about escalating royalties is that they only apply once the game's sales have reached a point where the revenue stream is pure profit for everyone. Once the publisher has recovered all of his costs, including those that are not included in the deductions that establish the net, the game becomes extremely profitable for the publisher. And increasing the developer's share of the additional profit is both reasonable and appropriate.

Here is what it looks like. Let's say that the initial royalty rate is 20%. After the initial 150,000 units are sold, that rate increases to 25%. Then, if the sales go up another 150,000 units, the percentage goes to 30%, and so on up to a maximum rate of 50% for sales over 1,050,000—a total that is both phenomenally high and very unlikely. Rarely, some contracts even call for this higher royalty rate to be applied to all sales retroactively, and not just to those above the threshold.

The main point of escalating royalties is that these higher sale numbers signify an exceptional product and a much higher return for the publisher. Therefore, publishers are more likely to share a larger proportion of the sales at that point.

Avoid the Slide

Even the greatest games end up in the discount bin eventually. Publishers sometimes seek to have the developer's royalty percentage decrease as the price of the game goes down.

Avoid this at all costs. Keep in mind that your game has already been paid for and that most if not all of the marketing has already occurred. Consequently, there is no rational basis for the publisher not to share the net profits here at the same percentage as they did at the beginning of the project. After all, they are "net" profits. In fact, there are some good arguments to be made for increasing the developer's royalty percentage on the discounted games, since by then the publisher's costs associated with the game might have already been fully recovered.

Lunch Box Bonus

Ancillary products and product placements can create substantial profits for everyone—and at no additional cost. A savvy developer should demand a higher royalty for these secondary revenues, hopefully at least twice the base royalty rate set for the game itself.

If possible, you should also include a time limit on the exploitation of ancillary products derived from your game. This way, if the publisher does not pursue these ancillary revenue sources within the set period of time, you will be able to do so yourself.

When Things Go South

The termination provisions are, not surprisingly, contract terms that should be examined very carefully. As with all of the important provisions of the contract, make sure that they are mutual, within the boundaries of reason. While your company might be much smaller than the publisher, there is no reason to assume that they are less likely to run into problems. Publishers go bankrupt or sell off their assets all the time.

Try to include provisions in the development agreement that call for the reversion of all of the game's assets and obligations to the developer if the publisher goes into bankruptcy or receivership. Even in contracts where the agreement calls for a conveyance of all your intellectual property rights in the game to the publisher, postpone the transfer of ownership of the game's assets until the final payment. This will help avoid your game being pulled into the publisher's bankruptcy estate, which would make the ultimate completion and distribution of the game beyond your control.

Get It Back

Also make sure that if the publisher drops your game or decides not to market it within a reasonable period of time, all rights revert back to you so you can try publishing your game with another company.

Space It Out

Contract provisions regarding material breaches often allow for a period to cure such breaches. Make sure that this period is as long as possible; if the publisher offers 10 days, ask for 30 or even 60. That way, if you receive notice of a breach, you might have that extra week, or month, you need to save your project.

Stay Loose

Flexibility in milestones is also something that can help when a project starts to get away from you. An overly rigid definition of milestones creates a contract that might not remain viable throughout the project. We often hear publishers complaining about slippage in milestone dates. While slippage in milestone dates hurts the publisher, it hurts the developer even more. As delivery dates slip, the period of time it takes to develop a game lengthens. As a result, fixed costs such as payroll, rent, and so forth continue to accumulate for the developer. Therefore, the extended time between milestone payments can make payroll, rent, and other financial responsibilities of the developer difficult if not impossible to meet.

One good way to insert flexibility in a contract is to have the development schedule and milestone definitions subject to revision at the delivery of each milestone. This can really help when new technologies, market changes, and other unexpected issues come up. Keep in mind that it is in everyone's best interest to have the game delivered in a timely manner and in acceptable form. Therefore, this sort of flexibility is good for both the developer and the publisher.

Keep It Simple

Multi-platform deals are becoming increasingly common. However, as far as contracts go, the more components in the contract, the likelier it is that something will go wrong.

For example, a PC/Xbox deal might look very appealing. However, if 75 to 80% of the work is related to the PC game development, but over 50% of the revenue is tied to the Xbox version, a simple thing like Microsoft either lagging or denying approval of the game could spell disaster for the developer in mid-production.

Make sure that only the appropriate share of the development advances is tied to each platform's SKU. Remember that the purpose of the advance is to fund the creation of the game; the work needed to develop each component should be the basis for the apportionment of advances, not the potential return. Especially in a situation where a third party has the ability to substantially delay or even kill the project and there is nothing the developer or the publisher can do about it.

One at a Time, Please

Publishers also like to tie one game contract to another by cross collateralization when acquiring two or more games from the same developer. What that means is that the set-off costs being accrued on one game for the publisher are applied to the royalties on the other game. This is great for the publisher because they then spread the risk of both games across both games' revenue streams. However, if one game is a bust and the other a hit, the royalty stream from the hit will go to the publisher to defray the costs of the bomb—instead of going to the developer. Of course, if this is taken into account by setting higher royalty percentages for the developer in both games, then fine. However, that rarely (if ever) happens, so avoid these cross collateralization deals, if possible.

Exercise Your Audit Rights

The developer's audit rights need to be considered both in the contract negotiations and after the game is released. Every developer contract should provide the developer with audit rights over the publisher's financial records regarding the total game sales and a detail of what expenses are used to determine the "net" income that forms the basis for royalty payments.

Although audits are usually limited to one time per year, push to have the audits more often—like every six months. Moreover, be wary of clauses that make audit rights "use them or lose them" propositions, where if the developer does not audit within 30 or 60 days of the end of the accounting period, the rights expire. Use your audit rights and do not allow them to expire


Conclusion

Each developer contract contains similar elements, but a contract is ultimately as unique as the game it covers. Just as the publisher is compelled to protect its economic interests, so should the developer. If the developer does not do everything in its power to protect its interests, no on else will.

Keep in mind that negotiations occur throughout the process, from the first contact through the signature of the formal document. More than one developer has suffered from "negotiation fatigue" and missed opportunities to replace detrimental contract provisions. Don't be afraid to ask for what you want in the contract. No one ever lost a deal for asking. It is just good business sense.

You might think of yourself as a programmer, designer, or artist, but if you want to make a living at this business, when you are working on the deal with the publisher, think of yourself as a businessperson. Apply your attention to the contract negations with the same focus and zeal you apply to your game development. Take care and, to the extent possible, surround yourself with competent professionals.


Chapter 3.5: Pros and Cons of Worldwide and Country-by-Country Deals

Overview

Jay Powell

<Jay@Octagon1.com>

A development studio has been working for months on the next greatest game and now it's time to hit the streets and secure a publisher for the game. They're confronted with their first decision: do they want a single publisher, or multiple publishers?

This article gives developers the information they need to decide whether they want one publisher to handle every territory in the world, or whether it would be better for the company to leverage their risk across multiple publishers. Each model has its advantages and pitfalls, but developers need to have a firm grasp on the development status of their game and what their company needs in order to move forward.


The Alternatives

There are two primary models used for publishing or distributing titles. The worldwide model will place a game with one publisher who will handle everything for the developer and take care of all sales around the world. The country-by-country model will involve selling the game to smaller publishers in each major territory, or having one of these publishers handle a group of smaller territories.

Basic Criteria for Each Model

The first step in deciding which model a developer should go with is to evaluate their game and company. The two primary factors for this evaluation are the state of the development and the amount of cash in the bank. When looking at the state of development, the further in development a company is, the more options they will have.

Case Study 3.5.1: Evaluating Intellectual Property
Start example

The following are some of the major points involved in determining whether an intellectual property is marketable as the basis for a game.

Quality of the Property

  • How strong are the characters in terms of depth and popularity?

  • Is it a well-developed book/television series/film/etc.?

  • Is it interesting, could the story add value to a game?

  • Is it a very linear story, or is there a broader "world?"

Value of the Property

  • Popularity

  • Age (has it peaked?)

  • Strength of following

  • Expected longevity

Target Demographics

  • Age

  • Sex

  • Geographic region(s)

Ability to Translate into Game

  • What genres would be appropriate?

  • What platforms could it be adapted for?

  • Can the story be used in a game or is it too linear?

  • Could it be used on an existing game project or to increase sales to an existing line?

Competing Properties

  • What properties are similar?

  • Why is this property superior?

  • If another developer selects a competing property, how will it affect the market?

  • What games would it be similar to?

End example

Worldwide publishers will be able to sign titles on a technology demonstration or design document if your team has a great track record. When developers begin this process, they must realize that as much as three to five months can pass between the initial pitch and the signing of a contract.

When dealing with smaller publishers or country-by-country publishers, this process can take as little as one month. Country-by-country publishers will have to see a working demo of the game, preferably at beta stage. Developers also need a significant base of contacts with these publishers as well as time to contact, follow up, and negotiate contracts with each.

Once a developer understands the position of their company and title they will be in a position to determine which model is best for them. This article takes a deeper look at each business model and how it will affect their game and company both immediately and in the long run.


Advantages of the Worldwide Model

Case Study 3.5.2: What to Include in a Package to a Worldwide Publisher
Start example

Here is a checklist of the materials you should provide to a worldwide publisher:

  • A 10- to 15-page game overview that includes thought out and detailed concept, look and feel, details on gameplay including number of hours, types, and depth of gameplay.

  • A technical design review featuring unique technological aspects, polygon rates, frame rates, and so forth, including how different technological features will affect the budget.

  • Technical requirements of the final product.

  • Pre-production time scales and budgets.

  • Estimates of schedules and budgets for the complete project, including milestones.

  • Video or rendered/interactive demo that shows core gameplay. With a demo, include a detailed walkthrough.

  • Localization overview with an estimate of the localization effort, including approximate number of words, files, bitmaps, different voices, and so forth, and any unique localization issues, such as a proprietary engine limiting ability to subcontract localization.

  • Competitive analysis, including similar products in the same category (with sales results for those products) and strengths and weaknesses compared to those products.

  • Copyright information, including: will specific actors need to be hired? Are there union involvement issues, or specific approvals required?

  • Unique selling points of the game.

End example

When most developers begin to think about getting a publisher for their game, the publishers in this category are the ones that come to mind. What most people do not realize is that there are far more publishers that can handle these deals than they think. Around the globe, there are about 50 with the capital and distribution networks to handle a multimillion-dollar game on a worldwide scale. Many developers will only submit their title to the top 10 or 12 that they see consistently in the press. Here are the advantages of the worldwide model.

Alleviating the Risk Early

For companies that need to have a source of revenue early in the development cycle, this is the best model to use. Companies in this situation that stand a realistic chance of obtaining a contract with a major worldwide publisher are generally new teams with a wealth of experienced individuals and companies that has been in the industry for some time and want to get a second or third team moving on a project. If a team has a solid track record, these publishers will sign based on design documentation, technology demos, and a solid timetable of milestones. This will allow the team to work on the game without worrying about not being paid, and will save the developers from investing time in a project that will never see the store shelves. Provided all the milestones are met, the contract will cover the expenses of the project as long as it is in development.

Access to Professional Testing Facilities

Few developers have the time or the facilities to fully test a game for gameplay balancing, bugs, and compatibility. Choosing a worldwide publisher will completely eliminate this burden. The publisher will be responsible for this testing and for promptly reporting any problems to the developer. The publisher will also have a wealth of experience with games in the genre to help let you know what features and gameplay elements have worked well with retailers and consumers in the past. Many developers might believe that too much of this input destroys the game that they have envisioned, which is true when this feedback gets out of hand. However, when handled correctly, it can make the difference between a poor selling game and a top 10. Keep in mind that selling to retailers can be as important as selling to gamers. If the buyer for a major chain has a problem with the game, a significant portion of the market can vanish from under your feet. Which takes us to our next point...

Better Access to the Retailers and End Users

In today's retail market, being excluded from the shelves of one store can put a severe dent in the sell-through of a game. One retailer deciding not to stock a game can cause a ripple effect down the line. Other retailers will see that it is not being stocked and can turn the game down based on this as well. Worldwide publishers not only have great access to all the retail channels, but they also have the weight and clout to turn a "no" or "maybe" into a "yes." Through the promise of other titles or promotions, a worldwide publisher can get a title onto some store shelves that a smaller publisher would not have the ability to do.

Worldwide publishers also have the experience with similar titles to know what the end users and press liked and disliked. Developers can use this experience to create a better game and consequently a bigger hit.

Name Recognition

Some worldwide publishers will publish titles that sell great despite bad reviews. How does this happen? Gamers often buy products based on the track record of the publisher; they have faith in that company to consistently deliver a quality product. By signing a contract with one of these publishers, a developer gains an instant fan base and potential customers.

This name recognition will also carry over to the next title from a developer. By having one or more titles published on a worldwide scale by one of the larger publishers, the developer will be able to capitalize on the acquired notoriety when approaching other publishers in the future. This is a valuable tool in the process of selling and negotiating future titles.

Marketing

The larger publishers simply have more money to invest in marketing. More money invested here will generally translate into better sales. The best games in the world will not sell if they are not marketed correctly, and sometimes the extra marketing dollars will save a title that is not receiving the great reviews that everyone had planned. Small publishers will finance a few ads and some Web advertising, but the bigger publishers can produce the TV spots and in-store advertising that really push units out the door.

Worldwide publishers can also afford to pay for more and better shelf space for their products. There is a reason why the games from the worldwide publishers are always up front and in the face of the consumers: the publisher pays a premium for this location.

In addition, the more a publisher markets a game, the more name recognition the developer gets for future products. Again, this is a powerful tool for future negotiations and sales.

Relationships

One of the biggest benefits of working with a worldwide publisher is the relationship that a developer will build. Publishers will generally look to teams with which they have had a positive experience in the past to handle contract deals. These deals, which can range from add-ons to ports to the next title in a franchise series, are difficult to obtain without a prior relationship with the publisher, but can be a huge boost to the team.

A good experience with the publisher will also make things much easier the next time a developer needs to pitch a game to them. They'll remember what went right and what went wrong, and reward good teams accordingly. If a developer created a hit for them, the last thing they want to see is that team working on a project for a competitor.


Drawbacks of Worldwide Publishers

Working with the worldwide publishers has a lot to offer if a developer is in a position to move on such a deal. However, these publishers also have their drawbacks.

Time Restraints

When a developer submits a title to one of the worldwide publishers, they should be aware of the time that it will take that publisher to evaluate the title. Most of these companies will have to show the title to multiple offices in North America and Europe to even get the approval process rolling. These offices will evaluate the game based on the gameplay, finances, and marketability. If the game passes these steps, a board will generally have to approve the project. The higher the budget of the game, the more processes a developer can expect to go through. This process can take anywhere from one month to three months in some cases.

Contract Negotiations

Once the title is approved, the contract negotiation begins. Again, this is going to take time, as the publisher will have a large and sometimes exacting legal team reviewing the contract at each step. The developer is now looking at another one to three months in negotiation before a single dollar is transferred to them.

The contracts themselves are much more stringent with the larger worldwide publishers. A developer might find that they are not getting the best deal possible with the contract that they have been presented from the publisher, and swinging the points of the contract in their favor will be a long and arduous process.

Overlooked Territories

Very few worldwide publishers have true distribution across the entire planet. In many cases, some smaller territories with a market for the game will be overlooked. True, these territories generate limited revenues, but when added together they can contribute a nice sum of money. If a worldwide publisher has no presence in South America, Portugal, or Eastern Europe, the developer might end up leaving a lot of money on the table. If the publisher has no plans to support the game in a territory, the developer would be better off selling it on their own in those markets.

Sublicensing

Worldwide publishers who do not have their own worldwide distribution will also sublicense to the territories they cannot cover directly. By sublicensing the game to smaller distributors or publishers, the worldwide publisher can generate revenue of their own with little effort. The drawback to the developer is that in most situations they are receiving a percentage of the percentage their worldwide publisher receives. With a little effort, the developer could make these sales directly and earn much more money.

Lower Royalty Rates

The sublicensing factor is not the only downside to the royalties from a worldwide publisher. Depending on the developer's track record and the profile of the project, the overall royalty rate from a worldwide publisher is generally much smaller as well.

This is because the risk associated with completely or nearly completely funding a project is much higher than that involved in acquiring a nearly complete game. Consequently, the royalty rates will generally be much smaller—from 15 to 25% as a general rule. Other deal structures can generate a much higher backend for the developer.

Less Mind Share

Worldwide publishers handle dozens if not hundreds of titles each year. A developer can rarely count on getting the mind share from a worldwide publisher that they can get from a smaller territorial or country-by-country publisher. Less mind share can translate into less time spent with the producer polishing the game, and less marketing attributed to the game. All of this can easily result in fewer sales, which means smaller royalties for the developer.

High Risk for the Developer

One of the biggest concerns with the worldwide model, given the state of the industry over the last few years, is the risk involved in this type of deal for the developer. By signing full rights to a game over to one publisher, that developer has placed all of their eggs in one basket. Without a solid contract and backup plan, this could spell disaster for the developer if the publisher goes bankrupt, is purchased, or loses interest in the title.

Case Study 3.6.3: What to Include in a Package to a Country-by Country Publisher
Start example

Submitting a project to a national publisher requires very different materials:

Finished Goods

  • Copy of product

  • Sell sheet

  • Localization summary form

  • Product walkthrough

  • Saved games with descriptions for evaluation aid

  • Review and previews

  • Cheat keys, keyboard commands

  • Installation guide

  • Current product competitive analysis

Beta

  • Playable demo/beta

  • Saved games with descriptions for evaluation aid

  • Design overview

  • Gold master date

  • Completed localization summary form

  • Detailed installation guide

  • Summary description of all game levels/missions

  • Printout of keyboard commands and cheat keys

  • Copy of marketing plan

  • Trailer of game

  • Unique selling points

  • Product walkthrough

  • Mock-up of box design (if available)

  • Plan for porting game to other platforms

  • Minimum and recommended system requirements

  • Timeline for localization

  • List of marketing and advertising assets available

  • Copy of manual/documentation

  • Competitive analysis

End example


Pros and Cons of Country-by-Country Deals

Many developers do not consider this type of deal structure when they are looking to get their game to market. However, if a developer can meet the criteria for doing deals in this manner, they will likely see much larger returns in the long run and sometimes on the advance as well. Starting with the higher royalty rates a developer will see, let's look at the advantages of a country-by-country deal.

Royalty Rates

Royalty rates with these publishers are usually much higher from the beginning. By cutting straight to the source and dealing with a country-specific publisher, a developer can see a royalty rate of 30 to 35%. There are fewer middlemen and lesser margins to factor into the net receipts definition of the contract, so this money is passed on to the developer.

Focused Marketing

Where many worldwide publishers will use one marketing strategy for all markets, a country-by-country publisher will use the strategy that best fits their market. These strategies will vary from country to country, and the companies that specialize in one market will know which channels and strategies work best for promoting a title. The amount of revenue spent will be very close to a worldwide publisher, but the effect will be much greater as the effort is always put in the best place.

Wider Variety of Partners

There are almost 1,000 publishers of videogames around the world. Obviously, some of these publishers operate in territories that generate very small deals, but on the average there are anywhere from 10 to 20 publishers and distributors per territory. With this selection available, it is much easier for a developer to select a partner with whom they are comfortable.

Furthermore, developers will always see a greater response from publishers when they are showing a near complete title, and the options for partners that this model provides makes for a better deal for the developer.

Direct Contact with Decision Makers

When dealing with a worldwide publisher, there is a strong chance that the developer will be dealing with a product manager or producer. When a developer establishes a relationship with a country-by-country publisher, they will most likely be working with one of the principals of the company or someone nearly as powerful. This translates into a better relationship for all parties involved and a much quicker period for evaluations and contract negotiation. In many cases, a title can be evaluated and contract signed within one to two months because of the lesser amount of internal red tape from the publisher.

More Mind Share

The final major advantage a developer will see from this model is the amount of mind share the publisher grants to a project. Some of these companies will release fewer than one game per month. With fewer games going to the retailers, each is very important to the publisher. This places the interest of the publisher and developer perfectly in line. Both companies have to work well together to ensure a successful launch. The publisher cannot allow one of their games to fail, as it will have a drastic effect on their income for the year. With this type of dedication, the relationship will work out better for both sides.


Disadvantages of Country-by-Country Deals

Signing a contract with a country-by-country publisher has definite advantages to any developer in the industry. Unfortunately, there several disadvantages to consider and barriers to overcome before someone can adopt this method of publishing or distribution.

Game Should Be Near Completion

One of the major disadvantages to this model is that a game needs to be nearly completed for a country-by-country publisher to invest in the game. In fact, most country-by-country publishers will not evaluate a title unless they can see at least a beta copy. Because they are handling only a handful of titles a year, they are very reluctant to take a risk on a title early in development.

Smaller Advances

As the deals that are being structured in this model only involve one territory at a time, the advances are generally much smaller. Typically, a publisher will guarantee a set amount of units at a fixed royalty rate in dollars, unlike worldwide publishers who set their royalty rates as a percentage. If they don't approach enough country-by-country publishers, a developer might find that their total advance is lower than it would have been with a worldwide publisher. This is usually offset by the royalties on the backend, as country-by-country deals are much more likely to see a sell-through than worldwide deals. Sell-through occurs when a title sells more units than the publisher guaranteed to the developer. This is the point where royalty checks are issued each month and the revenue from these payments can quickly compensate for a lower advance.

Difficulty Landing U.S. and UK Deals

Due to the small number of publishers in the United States and United Kingdom that handle deals for only their market, approaching this model will make it difficult to land a deal in these countries. Most of the publishers based in the United States and the UK only want to acquire titles that they can control on a worldwide basis. These two countries hold smaller numbers of country-by-country publishers than countries such as Germany, France, and Italy, so the deals are harder to find unless the developer truly works hard to acquire them.

Time Investment

This is the biggest disadvantage and hurdle for any developer looking to approach the country-by-country publishing model. Developers will be approaching three to four times as many publishers on average than they would for a worldwide deal. A developer has to take time to build that many more packages, follow up on those packages, and negotiate contracts. In many cases, this is a job for a minimum of two people working only on sales for the company.

Once the deals are secured in all the major markets, the developer then must deal with localization efforts for each of their partners, negotiating each of the individual contracts, handling the press requests, and aiding each publisher with the marketing effort in their country. After the game has been released, the developer must keep in touch with the publishers to continue the press and marketing, and to receive their royalty reports and any money due with each report.


Conclusion

Each model outlined in this article has its advantages and disadvantages. The important thing to remember is that there is no perfect scenario for every deal or developer. Before deciding which route to take, developers should sit down and take an accurate assessment of where they are with their game and finances and where they want to be. Selling a game to publishers is not a secret science by any means; the important things to remember with either model are to always follow up with your leads, never exclude a potential publisher, and be professional with your partners (or potential partners) at all times. In the game industry, one burnt bridge now could easily come back to haunt the company down the road.


Chapter 3.6: Techniques to Increase Upsell for Online Games

Overview

Mason McCuskey

<mason@spin-studios.com>

If you're selling your game online, as shareware, you live and die by the upsell. Simply put, an upsell is when someone pays you money to get more than what he got for free. Depending on your business model, you might refer to this as an order, a registration, a full version, or an upgrade. Regardless of what you call it, it's how you stay in business.

Since making two dollars is better than one, here are some techniques for increasing the number of upsells you get. They're presented in roughly chronological order (from your customer's point of view), and are just waiting for you to put them to use in your own games.


Present a Professional Appearance

If you want people to buy your game, you need to look like (and behave like) a professional business. Customers need assurance that they're not getting ripped off, and a professional Web site and a prompt response to their questions will assuage their fears.

Web Site Don'ts

If your Web site doesn't reflect a business mentality, you're going to miss out on some orders. Here are some things you should definitely not have on a business Web site:

  • Diaries containing personal opinions or rants. Not only is this unprofessional, but also, no one cares, and you run the risk of alienating your customer. "Company News" or development diaries are okay, provided they concentrate on your business.

  • Meaningless marketing hype about your game. When it comes to explaining why your game rocks, your best bet is to provide an accurate list of the things that make your game fun. Avoid phrases like "the best game on the planet" or "guaranteed to be the only game you'll play for a month," because they make you sound like a piece of spam.

  • False or misleading statements about what customers are getting for their money. It's illegal and unethical. Stick to listing features that you actually have. In addition, avoid listing nebulous features such as "a totally redesigned gameplay engine," unless those features really do make a difference in the game. Technobabble rarely impresses; the people who can't understand it don't care about it, and the people who do understand it recognize it as meaningless.

  • Web design gimmicks like mouse trails, animated GIFs, background music, and rainbow text. They make you appear juvenile. The exception to this is Shockwave or Flash-based Web sites, which many game companies use.

  • Broken links. This is an obvious one. Use software to check your site for dead links or buggy code.

Web Site Dos

On the other hand, your Web site should definitely include:

  • Screen shots. A screen shot is worth so much more than a thousand words. Showcase your game's good parts with lots of high-resolution screen shots.

  • Cohesive, easy-to-navigate design. Use a modern design that works on as many browsers as possible.

  • Contact information. Consider setting up generic e-mail accounts for sales, orders, Webmaster, and support, even if they all route to your personal e-mail.

  • A newsletter sign-up. Write newsletters when something happens, and send them out to people who have signed up for them on your site. This not only increases your chances for repeat business, but also keeps your name and products in the forefront of the minds of the people who read the newsletter, which can often result in "word of mouth" sales.

  • A message board. If you can supply the time to moderate and maintain a message board, it can be boon for your business. However, beware—a dusty ghost town forum can make your company look worse, not better.

There are many other techniques that can prove useful; check out what other software companies are doing, and if something looks like it will work for you, try it!


Make It Easy to Order

This seems like an obvious item, but you'd be surprised how many developers make it difficult for people to order their games.

Start by allowing your player to order the full version directly from within the game. At the start and/or end of the game you should display a teaser for the full version, and hyperlink that page to the ordering page on your Web site.

In addition, make sure that customers have options regarding how to order. You should accept major credit cards, as well as checks and money orders mailed to a well-publicized address. Setting up a merchant account for credit card processing takes some investment, but if you can't afford it, there are companies out there who will provide this service to you for a percentage of your sales. Do a search or ask around for names of reputable registration companies.

One way to measure how easy it is for people to order your game is to count the number of clicks that must occur before they get their game. You want to keep this click count as low as possible, ideally requiring just one or two clicks.

In addition, spot check your ordering system, especially if you're using a third-party vendor to handle your credit card validation. Buy software that periodically checks to see if your server is working, and alerts you if it is not. Also check your order pipeline from different systems to make sure that it works equally well in all cases. There's nothing worse than having a whole bunch of people who want to buy your game but can't because they don't have a specific browser or operating system.


Make It Worthwhile

To get the most upsells, you need to achieve a perfect balance between compulsion and boredom. Give your players a large enough demo of your game so that they're compelled to play and get hooked on it—but if you give them too much, they'll get tired of it before they register.

Several different strategies have been employed by games distributed online:

  • Time-lock. Allow the demo version of your game to be played for a certain length of time, and then force players to register to continue playing. This works well for highly addictive puzzle games.

  • Date-lock. Give potential customers a certain number of calendar days (usually 30) to play the game without restriction. If they want to play for more than a month, then they must register. This method works better for applications than for games, since it's very possible that a huge fan of your game will complete it within a month.

  • Tokens. This is a variant on the time-lock method. Allow potential customers to play your game 20, 30, or 40 times before requiring registration.

  • Episodes. In this scenario, your demo allows unrestricted access to the first few levels of the game, and allows the player to purchase more levels. This is the method id Software got very rich on with their shareware games.

  • Donations. When it comes to games distributed online, asking for a donation typically does not work; either use a different method, or just release your game as freeware.

Resist pricing your game too high. Games sold online typically cost half of what a game in the store would; $10 or $15 will work well, since games are impulse buys for many people, especially online. Also remember that most of the people who purchase games online typically would not spend $50 on a videogame, even if it was something they liked.


Follow Through Quickly

One of the easiest ways to irk new customers is to make them wait a long time before they receive what they paid for. For games distributed online, there's no excuse for long order delays—ideally, your customers should receive what they paid for within minutes after paying for it. Of course, to achieve this requires a fully automated order processing system, which makes you vulnerable to bogus registrations and invalid credit card numbers. Work around these problems as much as possible, but not at the expense of your true customers' time.

Be sure to explain your registration process to your customers. Tell them how long it will take, what they should do once their order is processed, and where to send e-mail or call if they feel something is not right.


Use Minimal Copy Protection

For years, developers have debated over how much copy protection a game should have. Today, the standard seems to be to create "light" copy protection—just enough to keep the honest people honest.

Heavy-duty copy protection usually isn't worth it. As you know, no copy protection is unbreakable, and hackers see sophisticated padlocks as challenges. The cracker might not even like your game, but will still crack it just because you've "challenged" him by using sophisticated anti-piracy techniques.

Remember that most of the people who play and buy games online are not technically knowledgeable enough to crack something. They're casual people who enjoy a quick diversion, not hardcore gamers. They don't usually know how to get a crack, much less how to use it.

The most prevalent form of piracy today is called "casual piracy." This is where someone lets a friend copy a game he's bought or got from someone else. Most of the time, if someone copies a CD and the anti-piracy mechanism notices and prevents them from playing the copied game, that person isn't likely to spend time trying to crack the protection. At worst, he might try a few times, enter a few different serial numbers, fail, and either buy the game or move on.

This is great, because it means that you can prevent most of your piracy losses by employing a relatively easy protection scheme. You just need to think about the most common ways a game gets copied, and put a couple of layers of protection on those holes.

For example, Web-validated registration codes work well. The basic idea is that in exchange for their purchase, a customer gets a registration code that he or she types into the game. Then, the game validates the code, either through an internal algorithm (e.g., a checksum), or by "phoning home" to a registration server and query that server to make sure the code is valid. The game either checks the code each time it is run, or it hides a key/value pair in the system's registry that specifies whether the game is registered.

The main problem with an algorithm-based registration code is that it doesn't prevent someone from writing the code on the CD copy and giving that to a friend. Unless your algorithm is based on something unique to the machine the game was originally registered for, your program has no way of knowing if a code has been used before. If someone posts a registration code on the Internet, your only recourse is to release a new version of your software that disallows that code.

The "phone home" method is slightly better than relying on an algorithm, if you don't mind forcing your customers to connect to the Internet. With phone-home protection, whenever someone uses a code, you know about it. It then becomes easy to prevent the same code from being used on multiple computers, and if you see that a registration code has been leaked out to the Internet, you just add it to your "blacklist" database, so that any game that asks if that code is good gets a "no" answer from your server.

The weak spot for the phone-home algorithm is spoofing. To a cracker, it's pretty easy to write a program that pretends to be your registration server, and tricks the game into believing it's talking to the real registration server. You can mitigate this risk by creating your own communications protocol, but then you're off to the races—you can spend months designing a secure method of communication, but there will always be a way around it.

Another issue to keep in mind if you use the phone-home technique is that users expect to be able to re-install their games on their own computer if they're forced to re-install their operating system, if they upgrade to a new hard drive, or otherwise change their system configuration. You need to think about a way they can do this easily, or you'll get a lot of angry e-mails from people who believe their fair-use rights have been trampled.

In summary, you should create some type of copy protection. Most games distributed online use algorithm verification, and/or phone home to a central registration server. Regardless of which method you choose, realize that it's a game of diminishing returns—concede the fact that you'll never stop someone who really wants to crack your game, and concentrate on keeping honest people honest.


Track Where Orders Are Coming From

Companies that distribute games online typically do not have a lot of money to spend on advertising and marketing, so it's important that what you do spend, you spend on the right things. Therefore, it behooves you to track where your page hits and orders are coming from. If 90% of your game's orders come from a shareware download site like download.com, it probably makes sense to spend your advertising money there, perhaps by purchasing an enhanced service plan that makes it easier for your customers to order or download your game from that site. This enhanced service might take the form of a better spot in a search engine, a boldface upgrade, an ad that appears based on user input, and so forth. The possibilities are endless.

In addition, knowing where orders come from helps you design your site better. Make sure that the path most often used to order your game works quickly and reliably.


Keep It Fresh

Games distributed through retail have notoriously short life spans. Consequently, many game companies release expansion packs and add-ons to keep their games fresh. Games distributed online tend to stick around longer than games on the shelf, but there's no reason why you shouldn't also use expansion packs to keep your game fresh and garner repeat business.

Most successful games distributed online have multiple expansions, sometimes called "episodes" or "installments." Usually, these expansions sell for around half the price of the full game, and most companies sell packages that include the original game plus all the expansions, so that newcomers can "catch up."

A big part of keeping a game fresh is fixing bugs. You need to release patches and bug fixes as if you were a large company. Sales for games distributed online usually start slow, then build up over time as word-of-mouth advertising kicks in, so you shoot yourself in the foot by not maintaining your software.


Conclusion

In this article, we hinted at some of the common strategies for increasing upsell. Don't hesitate to keep looking for other tricks, and don't be afraid to talk about your processes with other shareware authors; it's always valuable to share ideas.


Section 4: Managing Game Development

Chapter List

Chapter 4.0: Introduction
Chapter 4.1: The Stages of Game Development
Chapter 4.2: Managing the Development Process
Chapter 4.3: Customer Support in Massively Multiplayer Online Games
Chapter 4.4: Offshore Game Development Outsourcing
Chapter 4.5: Localizations
Chapter 4.6: Leadership: The Making of Effective and Happy Teams
Chapter 4.7: Quality Assurance: Bug Tracking and Test Cases


Chapter 4.0: Introduction

Securing a contract to have your game published is great. Delivering a game you are proud of, and doing so after a smooth and pleasant production, is even better.

Managing a game development business is hard work—much harder than most outsiders realize. It involves herding an ever-larger group of fiercely independent creative types toward a common goal (seemingly forever), resolving cultural conflicts between artists, designers, and programmers, and constantly adjusting the design to the shifting technological and competitive landscape—all the while dealing with financial constraints that would bring most companies in other fields to their knees.

Much has been written about the game industry's idiosyncratic problems: lack of management acumen, leading to developers signing horrible contracts, then to endless unpaid overtime to ship the games anyway, then to burnouts, then to the hiring of a new crop of bright-eyed youngsters so that the cycle can begin all over again. Less has been said about the companies that have managed to break this vicious cycle. The articles in this section of the book attempt to remedy that situation, by looking at the tricks and techniques elaborated by successful developers to make their jobs easier, smoother, and more predictable:

  • Mike Sellers, veteran designer of Meridian 59 and founder of Online Alchemy, describes the stages of development and how to prepare for each.

  • Veteran producer Tom Sloper explains how he has managed his 50+ productions over the years.

  • Anarchy Online's Terri Perkins explores the delicate topic of customer service in the game industry, specifically in the difficult context of anytime, anywhere massively multiplayer online worlds.

  • Javier Otaegui, president of Argentine independent developer Sabarasa Entertainment, looks at the financial and logistical implications of outsourcing parts of the development process to companies in other parts of the world.

  • Heather Maxwell, associate producer at Red Storm Entertainment, discusses ways to make the process of localizing the game for international markets as smooth as possible.

  • Game industry recruiter Melanie Cambron describes why development companies should strive to keep their teams happy, and how successful leaders have achieved this goal.

  • And finally, Chris Campbell, quality assurance lead on such titles as Age of Empires, explains how to implement effective quality control throughout the production process, thus minimizing the need for crunch time at the end of the cycle.


Chapter 4.1: The Stages of Game Development

Overview

Michael Sellers

<mike@onlinealchemy.com>

Games lead all other forms of software in innovation and interactivity. Unfortunately, games also lag behind other forms of software in their development process. At small studios and large companies, game development today is a chaotic process that differs greatly from team to team and game to game. The process might change during the development of a single game, and is often subject to the passing preferences of individual developers, managers, or publishers. This chaos leads to lost time, money, and opportunity. Games are developed without being designed; they might be killed late in the development process (when it is most expensive); or they are released late—sometimes years late—with severe bugs and missing promised features. And sometimes they are completed and released but simply aren't any fun.

The solution to this is a development process that is practical, realistic, flexible, and takes into account the unique aspects of game creation. Applying the stages of game development discussed here to your projects will clarify your process, and increase your chances of successfully developing a fun game that sells.


Stage 1: Concept

The first stage of game development focuses on figuring out what the game is going to be. Unlike other software development, where the users' set of tasks is already known or can be discovered, in game development the first thing you have to do is create these tasks out of thin air. This is the core of game design, and in far too many projects is left until much later in the process. It's important to resolve this as early as possible, so that at every step you know what kinds of things the player will be thinking about and doing and why the game is fun. Losing sight of this, especially during the long haul of production, is a main reason why so many games fail.

Timing and Participants

The conceptualization process should begin long before the project team is assembled, or even before anyone else knows that the project exists. Typically, one or two or three senior people—a designer, producer, and/or publisher representative—get together to hammer out the game concept. The concept might arrive in a flash in the first hour, but more likely it's going to take time to emerge. It's important to allow this kind of time; don't try to schedule inspiration. That's one reason why the concept formation should begin before there's a team waiting around for something to do—you need to be able to take the time needed to explore the concept without a project clock ticking loudly in your ears. That said, it's reasonable to assume that this stage will take one to three months to complete, although it might take much longer.

Process and Deliverables

The conceptual design process is critical to successful game development, and has been detailed in [Onder02]. This is necessarily a highly iterative process where the participants look at their ideas from different angles, searching for the most engaging gameplay experience.

When you're finished with the conceptual phase, you should have a clear (if high-level) understanding of what the game is and why it's so incredibly great that you just have to develop it. The primary deliverable from this stage is a clear, concise statement of what the game is. This doesn't mean that you need to create a hefty design bible. On the contrary, you should be able to boil down the essence of the game into two or three sentences. This statement will be the touchstone for you and your team throughout development, so it's important that it's understandable, memorable, and believable. In addition, a brief design document, as described in [Laramée02] and discussed as the Game Overview Document in [Onder02], serves as the basis for pre-production work. This typically includes several paper and electronic mockups depicting key moments in gameplay to give the feel of the game and the player's interactions.


Stage 2: Pre-Production

With a clear, high-level set of ideas in hand, you're ready to expand the team and start putting meat on the conceptual bones for the game. During pre-production you'll take the overall game concept, iterate on it in more detail to create the design, create an actual playable demo of the game, and prepare for full-scale production in the next stage. The ultimate goal of this stage is twofold: first, to produce a small but playable version of the game that demonstrates the eventual game experience; and second, to provide enough design, art, and technical detail that no huge questions are left hanging at the start of production. Be careful to give this stage the time it deserves. As shown in Figure 4.1.1 you can expect that an effective pre-production stage will take up to 25 to 30% of the overall time allotted for the project, or up to about six or seven months on a two-year project.

Click To expand
Figure 4.1.1: The stages of game development and the approximate duration of each.

Participants

This stage of development is led primarily by the game designer and producer. However, during pre-production you should start adding to the leadership of the team and begin getting contributions from the technical lead, art lead, quality assurance, and in some cases specialized leadership for areas such as sound and music, 3D, database, or server technology. You might also want to add some assistants in areas such as production or design, but be careful to build the team from the top down (or center outward)—you want to encourage bonds between those who will lead the effort for the rest of the development process, and to make sure they understand the game's focus and progress better than anyone else. It's probably going to take time for you to find the right people to add as leaders on the project and for them to come up to speed, but in the meantime, the designer and producer should be working on their pre-production deliverables.

Process

The main point of pre-production is to take the initial concept and build it up. You and your team need to understand what is going to be needed to implement the game, and those outside your team need to understand (and believe in) what you're developing. The first and main part of this is what [Cerny02] calls "macro design." This involves fleshing out the original idea, focusing first on the game systems that will be required, and eventually working down to the details ("micro design") of individual characters, opponents, objects, levels, and player actions. Macro design also includes creating fast, non-functional mockups and working prototypes to demonstrate gameplay, camera, and user interface designs, as well as setting the art and sound style direction. These mockups and prototypes are a great way to try out ideas quickly within the team, report progress to management or publisher, and to get early player feedback (looking for comprehension and interest).

Creating the design, mockups, prototypes, and early art begins a process of convergent iteration that lasts throughout pre-production and production. Convergent iteration is based on the spiral model of software development [Boehm88] and a number of different rapid development models [McConnell96]. As shown in Figure 4.1.2, you're going to iterate on the main ideas in your game during pre-production, defining them, designing them, implementing prototypes, and evaluating them (and having a few players do so). You will start over this time using what you've learned to converge on your goal. The idea in game development is to start with a general concept and hone in on an optimal mix of fun and feasibility. By taking the time to do up-front conceptual and pre-production design work, you cover a lot of ground quickly and cheaply, and spend the rest of the project fine-tuning your solution rather than casting about late in development, hoping to find something in it that's fun.

Click To expand
Figure 4.1.2: The process of convergent iteration shown over the stages of game development. Note that the upward strokes are define—design—implement, while the downward strokes are evaluation phases. The number of phases shown will vary by project, and is not meant to be taken literally.

Convergent iteration also makes it easier to spot design, technology, and process risks. For example, as shown in Figure 4.1.3, without a clear game concept, or with churning external requirements, you can find your project stuck iterating in a cycle, covering the same ground over and over again instead of converging on an optimal gameplay solution. Alternatively, you might rush into production too quickly, and end up exploring the gameplay space later in the process when it is much more expensive and you are already beholden to early ideas that might hobble your game (Figure 4.1.4, page 250).

Click To expand
Figure 4.1.3: In some cases you might find that your project is not converging on a single game. This can happen if you did not start with a clear concept, or if external requirements change throughout the life of the project.
Click To expand
Figure 4.1.4: If you race into production too quickly, you might find your project wandering through the conceptual space in the late (and expensive) stages.

Many projects never leave the concept or pre-production stages—these are a lot of fun, and moving on requires commitment and making difficult decisions. Alternatively, some projects barely touch on the conceptualization and ramp up fast to production. This inevitably leads to having a lot of assets (art, code, sound) on hand that might get used somehow, and bits and pieces that hopefully will fit together to make a fun game. In either case, it's easy to find yourself late in the schedule with all the ingredients of an actual game, but for some reason it isn't coming together.

The best way to avoid this is to be rigorous about these first two stages of development, and avoid the illusion that being "in production" means you know what you're doing. The gate from pre-production to production should be the most stringent of all. If the game isn't going to be fun, you should know it—and admit it—by the end of pre-production, rather than hoping that your earlier vague idea will somehow turn into something worthwhile.

Deliverables

The output of pre-production is a set of documents, prototypes, and in almost all cases a small but working version of the game. This playable demo, often called a "first playable," might present only a sliver of the eventual game, and yet it contains enough to give non-team members (i.e., management, publishers) a solid experience of what the game will be. It should also demonstrate the main aspects of the art style and the UI and interactivity style (that is, whether the game is menu-driven, a click-fest, turn-based, etc.). The ability to produce this working game, and to show that there are no major design, technical, or artistic questions remaining open is a clear signal that the team is ready to move into production.

In addition to producing the pre-production documents and playable game, it's also useful to revisit with the team (by now including more programmers, artists, designers, and others who are ready to dive in) the initial overview statement and high-level product goals. It's crucial that before the team enters the "fog of war" known as production that they all understand clearly what the game is and what it isn't. There should be no misunderstandings, no hidden agendas, and no gaps in the design large enough that there is any difference of opinion as to why the game is fun and for whom. Establishing this early on—and reviewing it periodically during production—will prevent many crises on the team and much lost work in the project.

The pre-production documents are more internally than externally focused, although the producer might need to create a marketing-driven document as well. These documents also act in conjunction with the earlier conceptual documents, which might have to be adjusted to reflect changes that have occurred during pre-production. The main documents describe the game from design, art, and technical perspectives in sufficient detail that they can act as a blueprint for assembling the rest of the team and setting production schedules and milestones. They each also outline any significant risks or unresolved issues that remain when going into production.

The pre-production macro design document treats the game design in more depth than the conceptual overview. It includes the main player interactions and the major gameplay systems (NPC AI, level types, combat, magic, inventory, unit types, etc.), but does not yet dive into the details of the systems that are outlined. While it's likely that you'll have actually done some detail design work within each of the main game systems during pre-production (to prove to yourselves that the systems can work, and to add substance to the "first playable" version), keep these separate from the macro design document. The point here is to answer the question, "what is the game?" or "what are we building and why is it fun?" without getting lost in details.

The technical counterpart to the macro/pre-production design document is written by the lead programmer (or engineering manager, technical director, etc.—the titles vary). This document is often called a "technical design" document, as it mirrors the macro design document for the overall game. It outlines the software architecture that will be built during production, highlights any preexisting software that will be used (homegrown or third-party), and references coding standards and source control standards. Any issues regarding these areas should be worked out during pre-production so that the technical team can start to focus on producing robust code and not on which tools will be used. Like the macro design document, the technical design document does not delve into the minutia of the systems to be implemented; it is enough to understand what pieces are going to be needed, how they need to communicate, and where the major unknowns and risks lie. This is necessarily a technical document, and yet the other project team leaders—the producer, designer, art lead, and so forth—should grasp it at least well enough to understand whether it is going to cause significant problems elsewhere on the project.

The lead artist creates an art design document, and often an audio guidebook that parallels the technical pre-production document. This covers the overall art style for the project, presents both inspirational and technical conceptual art, and discusses issues of color usage, camera use, lighting, the look of the user interface, and so forth. While a full art asset list is not typically possible when entering production, an asset creation, naming, and control policy should be included with the document, along with a list that will grow into the full asset list. This list should include the major environments, characters, objects, opponents, and so forth, based on the macro design document. An on-going task during production will be adding items to this list and maintaining it; keeping this up to date and the art integrated with the code all along the way will avoid many heartaches later in production.

Finally, during pre-production the lead quality assurance (QA) person should create an overall test and integration plan for the project. This is based on the technical and art plans, and will follow them as their schedules become more detailed. It is not a substitute for unit testing by the programmers, but provides a centralized plan for making sure that all bugs are tracked, systems integrated and project builds confirmed, and all art and sound assets are in place. QA plans like this are often one of the first things that project leaders eliminate in a production time crisis, but their absence can become a major source of trouble later on.

Armed with the first-playable version of the game, a clear statement of what the game is, some early player commentary (from both initial mockups and the playable demo), and the design, technical, and art documents, the team is ready to get the final deliverable to move from pre-production to production: the green light from management or the publisher. If any of these items don't stand up, if there are too many issues outstanding, or if the game just doesn't feel fun, then the team should go back and hammer it all out until it does work. Until that happens, sending some part of the team off to start creating art or to start working on the software is more likely to create problems later than anything else—and could just represent expensive, wasted work if the game never quite makes it out of pre-production.


Stage 3: Production

In many game projects, being "in production" is considered to be really working—the game is becoming real. While it's true that it's in this stage of development that code, art, and sound are emerging, if you've handled the concept and pre-production stages appropriately, the game should already be feeling real to the team. Production becomes about implementation that stays true to the concept, macro design, and art direction decided on earlier, and on executing minor course corrections as needed.

The production stage typically takes the lion's share of the project's time—50% or more, or a full year out of a two-year project. Nevertheless, if you've prepared well during the pre-production stage, this stage need not turn into a crisis-filled death march toward an ever-receding goal.

Process

During production, the design, technical, art, and sound teams need to work closely together based on their common vision. There will always be some give and take, problems that must be solved, but as long as this happens within the context of the game concept and design already created, the team and the project will stay on track. During this stage, the focus shifts from design to the technical and artistic implementation. That doesn't mean that design is left with nothing to do—they still have a great deal of detail design work and balancing to take care of as the technical and art teams deliver the software infrastructure and game features.

The technical team's first task, working with the producer, is to lay out a high-level schedule for delivery of program components based on the design document that was delivered as part of pre-production. This schedule typically takes the form of high-level milestones that occur once every four to six weeks—shorter than that and there's not enough time for significant progress, and much longer than that and the team's focus can be lost. During each milestone period, the process of detail design, implementation, integration, and evaluation will take place with one or more major systems or gameplay features. In many cases these overlap, so that one system is in final integration and evaluation at the end of a milestone, while another is scheduled to be done with its first pass of implementation, and another is scheduled to have its detail design complete.

However, a detailed schedule cannot with any degree of certainty be created in advance for the entire duration of the project. Instead, it's best to plan in complete detail for the current and next milestone, and to make one of the current milestone's deliverables a similar list of the contents of the next two. Further out than that, the milestones should have high-level goals based on the design, art, and software needs.

The order of implementation is different on each project. This is something best left to the technical lead to decide, working in conjunction with the producer and other team leaders. One important factor is to ensure that the software architecture is as robust as possible, but without leaving the rest of the team unable to proceed or play the developing game. After the first playable version, the game should never "go dark" or become unplayable. Making separate prototypes and code branches helps preserve the programming team's flexibility while enabling others to make progress in their areas.

While the technical team is creating the main software systems for the game, the art and design teams are revisiting in detail their earlier macro designs. Now each monster, vehicle, object, animation, environment, and attribute must be examined and reduced to numbers for the designers, and models and pixels for the artists. Communication and integration are key, so that the designers do not, for example, create 10 types of alien troops while the artists create models for only three. Each type of object that will appear in the game is designed in complete detail, including what makes its contribution to the gameplay different from any others, what animations it has and commands it responds to, and its specific attributes (or range of attributes) relevant to the game. This should all be included in a descriptive single page per object type, and the necessary model entries should be added to the art and sound asset lists.

As each asset type is designed, it should also be prototyped and tested in game, evaluated for its appearance and effect on gameplay, and changed (via iterative design/implementation) as needed. This iteration will go much faster if the game objects are data-driven; that is, they receive their attributes from a text-based data file that is easily changed by the designers. If instead the designers have to pass each change to the programmers, progress will be much slower. Note too that "tweaking" game-object attributes is an on-going process, not a one-time activity. To make sure the game is balanced, various object attributes will have to be changed, tried in-game, and changed again. This process lasts throughout the production stage.

Milestones

Most complex game projects live by development milestones as mentioned earlier. These are typically set up by the producer in conjunction with the technical, design, and art team leaders, and often with significant pressure from external management. If the concept and pre-production stages have gone well, the main point of these milestones will be to show that the game is developing as planned, that the necessary game elements are being implemented in a timely fashion, and that the team is not drifting off target. It's easy to indulge in late-stage design, to want to include a new nifty feature someone thought of, or even to take the game in a new direction. Each of these is extremely risky, however, so realistic milestones based on the pre-production plans help the team stay focused and reduce or eliminate these risks.

Each milestone should demonstrate a visible new capability, preferably in the gameplay. Even when the main progress is technical or graphical, this should be expressed in terms of making the game more fun—if a new particle effect doesn't make the game more fun, you should question why your team is spending time on it. However, sometimes at a milestone the game will seem less fun than before. This is important to evaluate carefully: is it less fun because a new system isn't fully implemented, because there's a missing part of the user interface, or because some new objects have thrown off the game balance? All of those are easily evaluated and fixed. On the other hand, it might be that the game has become less fun because it's grown too large, tedious, or repetitive. If this seems to be the case, you need to quickly consider where the design or implementation went wrong—you might need to add features or objects, or more likely cut some out.


Stage 4: Post-Production

The end of production is often not as clear as its beginning. The team has worked hard for months, perhaps more than a year, and sometimes it seems the end will never come. But at some point, the project either grinds to a halt under its own weight—not the end you want to see—or it reaches that point when the tasks of producing the necessary software, art, and sound can be called complete—which is not the same as saying the game is finished.

The post-production stage consists of two main milestones that focus on evaluating, fixing, and polishing the game prior to release. This stage can take up to 20 to 30% of the overall project duration, depending on the complexity of the project and on how effective the concept and pre-production stages were. In general, complex multiplayer games need to plan on spending more time in this stage than do more linear single-player games.

Alpha

As development proceeds, the number of unimplemented systems and game features diminishes. There is a milestone, often both loved and feared by the development team, when all the initial features for the game have been created; no art or sounds are missing; and the user interface functionality is complete. This point is sometimes referred to as "feature complete" and is often called the alpha milestone. On a well-designed, well-run project, this point is loved because it means the game is there—even though significant work remains to be done. At the same time, it's feared because inevitably cuts have been made to the original concept (primarily during pre-production) and everyone has a pet feature they would love to see put into the game before it is considered complete. On a poorly conceived, crisis-ridden project, the alpha milestone is dreaded because it often represents a point of maximum anxiety and even denial: the game isn't done because the design has been implemented, it's considered complete because there is no more time in the schedule or money in the budget to actually make the game as originally planned.

While the game might be "feature complete," the team's work is far from over. The gameplay is there, but it is hampered by bugs both serious and superficial, and by a variety of balance issues between in-game units or objects. It is important, however, that after the alpha milestone, during all the testing and bug-fixing to come, that no new features are implemented without significant oversight from the entire team leadership, and often from management outside the team. The temptation to add a new feature can be strong, but this presents a high risk of delaying the game's eventual release. It can also be tempting to only sketch out the functionality required by a feature or software system earlier in the project, and to call the missing functionality a "bug" to be finished after alpha. This type of dissembling action might save the schedule in the short-term, allowing the team to appear to be on schedule at an earlier milestone, but only at the cost of requiring more time and increased risk later in the project, when the costs of failure are higher.

After the alpha milestone, the team should regroup and then begin fixing bugs in order of priority as established by the QA team and their test plans. The design team should focus on gameplay pacing and balance issues, and if necessary on creating additional levels or environments using the existing feature set. This will involve playing the game over and over again, looking for rough spots to be smoothed over via technical, artistic, or design balancing means.

It is during this time that gameplay testing and evaluation using regular players (not team members or members of other teams) should begin in earnest. During pre-production, early mockups and prototypes should have been given exposure to players to look for interest and comprehension—is the game going to be fun and will players understand it? During production, gameplay testing of individual levels, modules, or systems also helps hone the design and keep implementation on track. Now, with the entire game in place, full gameplay testing begins in earnest. This is the best way there is to find surprising bugs, gameplay flaws, obscure in-game goals, misleading art, and so forth. All of the findings from this gameplay testing are fed back into the plan for fixing bugs, art, and design issues.

Once the alpha version of the game has been created, the team will need sufficient time to create and polish any remaining levels or environments out of existing assets, fix up these assets, and fix bugs found during testing. This is typically on the order of half as long as the entire pre-production stage, or about 10 to 15% of the total time needed to complete the project.

Beta

Once all the objects, environments, gameplay systems, and user interface have been completed, evaluated by players, and any problems fixed, the game is finally nearing completion. This is often called "going into beta" or hitting the beta release. During this time, the game is opened up to more players for testing, finding bugs, and game-play evaluation. The entire team should be hunting down and selectively fixing or documenting any bugs found. As time goes on and the game nears its final release, changing any aspect of the code, art, or sound should require increasing oversight to prevent the last-minute creation of a devastating new bug. The design team should be listening to player evaluations and making final tweaks to the gameplay pacing and balance based on their comments.

In addition, the producer and other staff need to be making final preparations for manufacturing, packaging, distribution, and marketing. These activities are typically outside the scope of the game development process itself, but are nonetheless extremely important and time consuming.

In games with a significant online presence, such as massively multiplayer online games, all the aspects of the service side of the game—in many respects as large and complex as the initial game development process—need to be brought up to speed. Typically, there is a "live" team that will maintain and extend the design and game systems once it is up and running. During the alpha and beta periods, this team should be assembled to provide continuity with those members of the original team who are moving on to other projects. There are also significant activities surrounding billing, customer service, in-game help, and other parts of the on-going online service. Each of these presents new challenges that differ from anything seen thus far in the development process.

The time required for an effective beta period will differ from project to project, but it is typically about as long as the alpha period. At a minimum, the beta period needs to be long enough to have players evaluate the game on their own, report back problems, have the team make the necessary fixes, and have the game evaluated again. This is rarely shorter than six to eight weeks, and might last several months.

Gold Master

Finally, the day arrives when all the aspects of the game have been balanced, all the necessary bugs have been fixed, the animations and sounds are timed perfectly—the game is ready to be frozen in the form of a "gold master" CD-ROM for shipment. Alternatively, this day arrives because of the lead time necessary to get the game to magazines for review and through manufacturing, packaging, and distribution in time for the holiday sales rush. Ready or not, the game goes to gold master.

As you can imagine this can be both thrilling and frightening, depending on how many and how severe the known bugs are that remain unfixed. In many cases, the team steams right on past the gold master date, with any additional fixes or changes being put into a post-release patch available from the company's Web site. This, however, is an implicit admission that the project got away from the team, and that what is shipped is not as polished and playable as it should be. Your goal should instead be to be able to have a release party (the true end to the development process) without any overshadowing issues or anxieties about whether the game is complete.


Conclusion

Game development is a complex, difficult, risky undertaking. You can best reduce the complexity and risk at any given point in your project by having a solid team, a clear and compelling concept, and by following an effective development process. The stages discussed in this chapter—concept, pre-production, production, and post-production—should help you understand how a game project progresses and how to allocate your time and activities.

In addition to parceling out your time and focus while developing your game, these stages highlight the reality that in any complex game project there are many different areas of expertise that are required to bring the game to a strong finish—game design, programming, art, sound, QA, and production among them. Convergent iterative development that makes the best use of each of these domains will result in the best, fastest finish for your project.

Another way of saying this is in this formula I wrote up several years ago when trying to explain the different skills needed to complete a game project:

  • An idea is not a design.

  • A design is not a demo.

  • A demo is not a program.

  • A program is not a product.

  • A product is not a business.

  • A business is not profits.

  • And profits are not happiness.

It's tempting to jump from the beginning to the end—from an idea to profits and happiness—in one fell swoop. But the reality is that you have to go through each part of the process, each of the stages of development, to get to the goal at the end.


References

[Boehm88] Boehm, Barry W., "A Spiral Model of Software Development and Enhancement," IEEE Computer (May 1988): pp. 61–72.

[Cerney02] Cerny, Mark, and John, Michael, "Game Development Myth vs. Method," Game Developer (June 2002): pp. 32–36.

[Kelley01] Kelley, Tom, The Art of Innovation, DoubleDay, 2001.

[Laramée02] Laramée, François Dominic, "Writing Effective Design Treatments," Game Design Perspectives, Charles River Media, 2002.

[McConnell96] McConnell, Steve, Rapid Development, Microsoft Press, 1996.

[Onder02] Onder, Bruce, "Writing the Adventure Game," Game Design Perspectives, Charles River Media, 2002.

[Rodgers01] Rodgers, Perry, and Mencher, Marc, "The ABC's of Running a Development Project," available online at www.gignews.com/abcpart1.htm, 2001.

[Tomayko95] Tomayko, James E., "Managing Software Development," available online at www-2.cs.cmu.edu/~SW_Managemnt, 1995.


Chapter 4.2: Managing the Development Process

Overview

Tom Sloper

<tomster@sloperama.com>

The more projects you manage and survive, the more you learn about doing the job well. This article outlines the development processes learned from producing 56 unique titles, and numerous localizations, ports, and other projects.


The Secret, Part I: Plan the Unplannable

The real key to finishing on time should be obvious: you have to start with a realistic schedule. Plan for everything that has to be done, determine which things depend on which other things, and make adjustments to the plan to make sure that the schedule is in fact feasible.

Let's go over the planning for a game project in detail by breaking the project down into three phases: pre-production, production, and post-production.

  • Pre-production is the phase in which the design is written and signed off, and in which the technology decisions are made. This is also when the schedule and budget are determined, and when the producer does the planning for the other two phases.

  • Production is the phase during which the programmers are busily coding, the artists are creating, the music and audio are created, and you go into a studio to record voice talent or to shoot acting talent.

  • Post-production is the phase in which you test and fine-tune the game, and get the box, manual, and other paper materials (customarily referred to as "box and docs") made.


The Snowball

Producing a game is like building a giant snowball, rolling it down a long mountain, and trying to hit a target at the bottom of the mountain with it.

The pre-production phase is fairly easy—you're just making a fairly small snowball, so it's easy to push it toward the target and to control its direction. During the production phase, you jog alongside the snowball as it rolls and grows, and it isn't hard to nudge it now and again if it rolls off course. The post-production phase is the one where trouble can really happen. The snowball is really big and heavy. You're tired from all that jogging to keep up with the snowball, and now you're breathing hard, your legs feel like logs, the ball is going faster than ever, and it's really hard to affect the ball's direction. Any missteps or planning errors you made in the earlier phases are harder to correct in the crucial post-production phase.


Pre-Production

Pre-production sets the tone and the pace for the rest of the project. Any shortcuts you take in this phase will haunt you later. It is vital to plan everything now. The process of planning together with the development team becomes a habit, and makes it easier to change the plan when emergencies arise. In pre-production, the producer must plan every aspect of production, post-production, and beyond.

Design

Before you can do anything else, you have to know what it is you're planning to make. In the film industry, producers start with a script and then develop a storyboard. In our industry, we have to start with a detailed design document. (At least, that's the way it's done in the West; as we will see, Japanese companies work differently.) The design has to describe all the game's features in sufficient detail, so that the technical people and the art director can estimate how long it will take to implement.

However, you can't simply set your designer to work on writing a document, then reach over his shoulder, grab it, and ship it to the technical director and art director. Before getting firm estimates on it, you need to make sure that this design will be acceptable to your marketing people, salespeople, and company executives, and, if it's a console game, your console manufacturer. Consensus is vital in the early stages. Especially, plan on making sure that this design is acceptable to your licensor.

Licensor Issues

Many successful games today are licensed games—games based on an existing intellectual property, be it owned by an external party or by your company. If you are developing a game based on an outside party's property, you have to include that party in the process early on.

The final approval is the most important, of course. It should go smoothly if you've been getting approvals in earlier stages. You don't want to spring a previously unseen, now-finished game on your licensor!

We made the mistake of not involving Columbia Pictures early in the development of Ghostbusters II for the NES in 1989. We just sent our contact the finished game, expecting an automatic signoff. He was not happy, and although he did approve the game, it could have been a disaster.

Another close call: Activision had created the early Alien and Predator games under license from Twentieth Century Fox in the late 1980s. When Dark Horse Comics came out with Aliens vs. Predator, we got the rights to do games based on the combined license.

Activision went through some dramatic changes during the interim, and we inherited the projects long after the license had been acquired; the producers who had started the ball rolling were no longer with the company. We had sublicensed the rights to Japanese publishers, who funded development on the SNES and Game Boy. Then, we would take the finished Japanese version, localize for the United States, and release domestically. The problem was that the Japanese developer (like most game developers in Japan) was not in the habit of writing detailed design documents to begin a project. After repeated requests, they delivered an outline, which was taken to Fox for approval. That wasn't easy, because the document raised more questions than it answered. Eventually, we got approval to get the Japanese versions released. However, when we wanted the American versions approved, there was a whole new battle to fight because the game had changed significantly since the outline was submitted. The games ended up not being very good, and sold well only because of the license.

Throughout this near disaster, the bright spot was Fox's formalized approval process. They developed a standardized form that would be used for each approval submission. The form indicated whether the material being submitted was code, packaging, manual, or advertising materials. The form indicated whether the approval sought was for text, visuals, or functionality. In addition, the form had spaces where the approver could indicate reasons for denial, or comments about changes that were needed for approval to be granted. If your own licensor doesn't use such a formal approval process, you should work one out together.

Internal Licenses

Sometimes the intellectual property belongs to your own company rather than to an external party. In such cases, there might be someone in your company who is the brand assurance person—the keeper of the flame for that intellectual property. Work with this person the same way you would work with an external licensor. Set up an approval process together; plan for the stages at which approvals will be needed, and schedule accordingly.

Technology

You have to trust your technical people and their ability to estimate the time it will take to accomplish the tasks. They have to create a detailed task list, based on your detailed design document, and plan for whatever learning is required to implement the game's features. If you're using acquired technology, have your team look at the documentation and talk to the people providing the technology. Is it well documented? Are their people going to be able to support it adequately for your peoples' needs?

On Shanghai Second Dynasty, we knew that we were going to have to implement online play, but our external developer, Quicksilver, wasn't going to do it—we were going to have in-house staff take care of that portion, because then the technology would be compatible with the rest of our online game servers.

One little problem we didn't anticipate was that the programmer who had created the online technology would be leaving the company before getting to this project. In addition, "online gaming" had become a buzzword, and numerous game-related dotcoms were trying to convince us to put our games on their sites. The hesitations and negotiations cost us a week at the end of the production. A week doesn't sound like much, but because of that week, the game was not on the shelves over the Thanksgiving weekend.

Marketing

Marketing will be crucial to the game's success, so you have to work together with your publisher's marketing staff to get them everything they need. Moreover, they have to be sensitive to the fact that once you have planned the project, any changes they introduce to the plan have to be reasonably small, or else the schedule will change. Develop a good line of communication with your marketing people. Patiently educate them on the process.

Demos

One of the most significant marketing needs is the demo disc.

It's usually desirable to release the demo before (not after) releasing the game itself. Therefore, work out a schedule with the marketing department and the technical director. With marketing, figure out when the demo needs to be ready, and what needs to be in it. With your technical director, make sure that the plan is feasible.

A reminder: we're still talking about pre-production planning here. We're talking about the planning stage, many months before the game itself (or the demo) will be ready.

Marketing folks often don't plan and create on the same type of timetable that we do—their lead times are much shorter and they're not engineers, so they just don't see things the same way production teams do. It sometimes happens that, after agreeing on a demo spec and schedule, someone in marketing requests changes to the demo—invariably, changes that can't be implemented without affecting the schedule.

The best you can do in such a case is to patiently reiterate that the demo will contain what was previously specified and agreed, and that it will be delivered when previously specified and agreed. Any major changes to the specs and the timing of the demo might have serious repercussions for the release date of the game itself. Sometimes a producer has to be a teacher as well as a manager and communicator.

The demo will also have to meet requirements set by magazines and/or by the Webmaster of your publisher's Web site. Find out what those requirements are well in advance. Usually, the demo has to be limited to a certain size, because there will be other demos on the disc, or to keep download times to a minimum, or to fit within server limits. Find out in advance what these requirements are so you won't experience delays—and expect those requirements to change if too much time elapses.

Also keep in mind that demos have to go through quality assurance just like everything else. Work with your QA people to plan for the demo, and then see if you can get the same testers to work on the final game.

Material for Magazine Covers and Previews

You might also have to provide material for magazine previews and even cover art to your marketing team. Cover art has to be very detailed, and will have to allow space for the magazine's title and feature blurbs and insets. When marketing asks you for graphics for cover art, ask them to get a guideline sheet from the target magazines; all magazines have this ready at hand. Specifically, you need to know the image size requirements and the appropriate resolution in dots per inch, so that you won't lose any time redoing the artwork.

Not only do you want your image on the cover, you also want screen shots inside the magazine. You will want covers and pages in other magazines too—and no two magazines will use the same image.

You also need to be prepared to have editors visit your team, watch over their shoulders while they create the game, and interview your programmers and/or artists. You might even have to fly to the magazine's office and demo the game yourself. Demands for this type of thing typically happen at the most inconvenient time. Be ready. Plan for it.

Strategy Guides

If there's going to be a strategy guide for your game, it needs to be on the store shelves on the same day as the game itself—which means, again, the issue will come up exactly when the project can least afford it. Your lead designer and/or writer, and your art director will be needed for this effort. Find out in advance about the lead times for making strategy guides, and plan them into the schedule.

Trade Shows

When preparing your schedule, circle the dates of trade shows like E3 and the ECTS and figure out how advanced your game will be on those dates. It sometimes happens that the game will not yet be showable, or that the company will not need it to be displayed at a particular trade show. However, if the game is going to be showable at E3 time, you need to plan ahead for the team to do whatever work is necessary to prepare an E3 demo.

Voice and Acting Scripts

You need completed scripts before you can even schedule studio time. Recording sessions are expensive, so you must make a solid estimate of how many days you need to spend in the studio.

Thus, you can only plan for this once the game is far enough along that you can be sure you didn't miss any crucial scenes or lines. Consequently, timing the studio session into the schedule is a tricky balance. Do it too early, and you might need pickup sessions later. Do it too late, and your ship date might suffer.

Voice or Acting Talent

Add into the schedule when you want to have your studio session. Then, work it backward—before you can have a studio session, you need the talent lined up. Before this can happen, you need auditions. Figure out how long those will take, and plan them in. Before you can have auditions, you need to know who your characters are and what their lines are. You have to be able to describe the character to the talent agents so they can describe them to the actors.

Studio Sessions

The studio session itself probably won't be very long—a few days, usually. Plan into the schedule when you need to start looking for studios, when you need the studio time, and for your engineers to be there. Your engineers probably won't be doing the actual recording (unless you have your own internal studio facilities), but they need to be there to provide technical guidance on formats and documentation of the recordings made. Then, after the studio session is over, your engineers need to get and process the assets, and deliver them to the production team in the required formats for the main SKU and for any ports you'll be making. Work it all into the schedule.

Executive Greenlight Reviews

Pinpoint the dates in the schedule when the project will hit critical decision points. When the game is at first playable, alpha, and beta, the executives will need to look at it so they can determine if it's on track.

Sometimes, market changes will mandate modifications to the plan. This is what these reviews are for. If you don't plan for them in the schedule, the change requests are likely to come anyway, but at less convenient times. It's better to know in advance.

Console Manufacturer's Approval Cycle

If you're making a game for Xbox, PlayStation 2, GameCube, or Game Boy Advance, then you have a contact at Microsoft, Sony, or Nintendo. That contact is someone with whom you need to develop a relationship. Discuss your plans and generally keep your contact in the communications loop. Get approval for the game's concept early on, in pre-production. In addition, make sure that your technical folks and your QA department have the console manufacturer's technical requirements.

When your game is looking pretty good and robust, ask your contact if he is interested in seeing it. You want the console manufacturer to be enthused about your game.

Don't wait until the last minute to submit your game to the console manufacturer for final approval. Pre-submit if possible. Familiarize yourself with the criteria for approval; check everything you can beforehand.

In final approval, the console manufacturer will nearly always find something for you to change or fix. Figure that you might have to submit three times, and plan accordingly. The manufacturer's representative can probably tell you how long each submission will take—maybe two or three weeks. It's possible that it'll take even longer—talk to your contact, ask about horror stories. You'll hear plenty! Keep your QA lead apprised of your communications in this regard.

The "Box & Docs" Process

Printed materials take longer to manufacture than discs do. It makes a lot of sense to create the box and the manual early in the production phase. However, the creative department usually is under the supervision of someone else, not the producer, and they probably have to get to this at the latest possible date. As for the manual, you might want it written at the last possible minute to incorporate any last-minute changes resulting from QA testing. This, like the studio sessions, is a tricky thing to time. Work with your marketing counterpart to plan this into the project as best you can.

Operations

Work with operations (the folks who get the product manufactured) to make sure that the timing is known. Manufacturing lead times can vary depending on time of year; in September-October, all the game publishers are trying to manufacture at the same time. To make sure that your product gets put on operations' schedule, you'll have to convince them that your schedule is firm.

Shipping lead times have to be taken into account too, if you need the product to hit the shelves by a particular date.

The Quality-Assurance Cycle

Don't short-shrift the QA cycle. If your QA manager says it'll take six weeks, then you must allocate six weeks. Don't forget that QA will also have to approve the box and docs (including the system requirements, for PC games), the demo, the international versions, and the ports. As much as possible, you want the same testers involved on each.

International Versions

Simultaneous shipment worldwide (also known as "sim-ship") is always the goal. It's attainable. Plan it into the pre-production phase. The moment you freeze the script, send it off to be translated—maybe even sooner. Record the localized voices at the same time you do the domestic voices. Prepare the localized title screen graphics or logo as soon as the domestic title screen logo is frozen.

Original Equipment Manufacturer Versions

On Shanghai Dynasty, we received late word that we needed to make an OEM version. The business development person who had made the deal told us it had to be 100MB, with no redbook music, and that it should not require a CD in the drive. He didn't tell us any of the other important details: that it needed to be delivered as a zip file, that the game would be pre-installed on the hard disk, that the zip file would be on a rescue disk, and that it had to be done in two weeks or the deal was off. We found out all of that when we contacted the OEM customer. You can't predict everything. The best you can do when a new situation arises is to gather all the information you can and adapt your plans accordingly. As long as you have developed good planning practices and aren't already running behind, you're in a decent position to deal with new situations.

Ports

Asset packs are important for the porting process. When your art staff is finished creating everything, have them make a graphic asset pack—organized and documented so that the port team can easily make any new versions needed. When your tech staff is finished making the game, have them make a complete backup, with all files and path structures, and detailed instructions about how to make a build. Document all compiler switches, and provide information about what compiler to use. Make it easy for someone to pick up the asset pack and make a build of the finished game. After making the asset pack, unpack it onto a fresh computer and test it.


Production Phase

To this point, we've been discussing the pre-production planning for the production and post-production phases. We're past that now, and work has begun on production.

So, during the production phase, what can you do?

Keep performing reality checks. Talk to the technical people and the art staff frequently to make sure that everything is being done on schedule. When work falls behind, spend time together to figure out what you can do to make up for the delay. "We'll make it up in QA," are the last words you want to hear. Nobody makes up for it in QA and succeeds in the eyes of the customer.

Learn to recognize red flags. Anything that impacts your schedule has to be addressed sooner, not later. When anything crops up that looks like a danger to your schedule, you have to take immediate action. Incorporate it into the adapted plan.

Planning doesn't mean "sit down and think about it." Planning always has to be done in conjunction with the team. Discuss the red flag with your technical director, your art director, with QA and marketing. Keep everyone informed about the danger, and what's being done about it. Then, follow up with an update later. Are we back on schedule? Is the red flag becoming paler?

Don't forget marketing and the schedule for your demo; make sure marketing remembers what the schedule and spec are, and that changes are at the expense of the schedule. Stay on top of the release date with QA and operations. Make sure sales is clear on the ship date.


The Secret, Part II: Adapt, Improvise, and Overcome

During production, the ability to adapt, improvise, and overcome will prove to be of tremendous importance to the producer in his quest to keep the project moving forward—to keep the snowball moving toward the target at the bottom of the mountain.


Post-Production Phase

By the time you get to post-production, it's hard to be pro-active in making significant improvements to a project that has fallen behind schedule. Remember that rolling snowball? It was small and easy to push around at the top of the hill, but now it's a huge heavy object, it's moving really fast, and you're tired from running alongside it all this time.

If you didn't do your planning right in pre-production, and if you didn't keep on track in production, you're going to have a hard time in post-production.


And After Release?

If you think the producer's job is done when the game ships, think again. Following up after release, to make sure that customers are satisfied, is crucial to the project's ultimate success. For more details on effective management of the after-market phase, see [Sloper02].


Conclusion

This article described how to plan the standard game development process. Of course, non-standard events will creep into your projects, from marketing rethinks to design team mutinies and morale dips that impact productivity. However, as long as you maintain full command of the standard process and good lines of communication with all your team leaders, you can handle everything else that comes up.

By planning properly, you can increase your chances of finishing on time. In preproduction, anticipate and schedule everything—even subsequent ports and versions. Schedule approvals early. In production, if any red flags go up, work together with the team leaders to revise the plan.

Your particular project might have other requirements that weren't covered here—anticipate those, and plan for them. If your plan covers unplannable events and contingencies, chances are that your project will be a success.


References

[Sloper02] Sloper, Tom, "Following Up After The Game Is Released: It's Not Over When It's Over," Game Design Perspectives, Charles River Media, 2002.


Chapter 4.3: Customer Support in Massively Multiplayer Online Games

Overview

Terri L. Perkins

<terri67@bellsouth.net>

Customer service in an online game faces challenges that other service industries do not. Not only is the product always changing and "open" for business 24/7, its customers speak a variety of languages, come from extremely diverse demographic backgrounds and knowledge bases, demand top-of-the-line service for a product they are paying an average of less than 50 cents a day to use, and hold the representatives accountable for many things that are not in the game company's control. If you can imagine a large theme park with only a handful of paid employees and thousands of customers demanding changes to the rides, corrections to the weather, a refund for time they spent waiting in line, demanding the annoying person standing next to them be made to disappear, and complaining that something in the park's pavement is making their shoes slower than everyone else's, then you can imagine the challenges that plague online games.

The challenge then: to provide fair, quick, respectful, and consistent service 24 hours a day, 7 days a week in a dynamic world, to thousands of diverse people scattered over the globe, and to do this for a very nominal fee. Customer support, like your game, is not an end product but a process. Ole Schreiner, customer service manager at Funcom Inc., states:

"One of the most important factors in satisfying customers in an online game is to treat all customers with respect and having a customer service team that can fulfill the customers' needs regardless of the experience level the customer might have with on-line games."


Planning to Succeed

If a computer without Internet access is like a car with no fuel, a potential blockbuster online game without well-designed support is like a vehicle that only works in reverse. While no one dares to release a game to the public without painstakingly scrutinizing every artistic shot, line of code, and music score, it is amazing how many will open their doors to the masses completely unprepared to support the players. If one-fifth of the planning that went into the art, design, code, and marketing of online games went toward customer service, the woes that face today's games would be drastically reduced. Early on, during the development planning for the game, plan to implement the coding that will save you time, customers, and countless hours in the long run. Case Study 4.3.1 explains how to do this effectively.

Case Study 4.3.1: Planning Customer Service
Start example

While every game will require unique coding for their specific plans, gamestyle, and design, a few elements are common across the board.

  • Naming: Ability to block offensive names, change names, avoid impostors, and so forth.

  • Disruption: Ability to silence, temporarily ban, and permanently ban disruptive players. Players need a way to block unwanted communications from each other, but not warnings from the support staff.

  • Exploits: Ability to check logs of player actions for traces of hacking.

  • Inventory: Ability to check a player's inventory.

  • Gameplay: Ability to find players, reach their locations easily, and move them within the game world.

  • Tracking: Ability to add comments to a player's file for easy viewing from within the game.

  • Reset: Ability to restore a player character's previous state after a problem.

  • Reward: Ability to grant bonuses to players.

  • Filtered views: Searchable views by rank, profession, time in game, and other criteria.

  • Help system: An easily alterable in-game help file system that can be modified as changes occur.

  • Call: A way for players to request customer service assistance, both ingame and otherwise.

  • Communication: Secure message boards for player/staff exchanges.

  • NPC control: A way to create, resurrect, or remove non-player characters.

  • Reporting: Methods for players to report bugs and submit feedback.

  • Billing and technical assistance: Access to accounting records and a technical problem resolution database.

End example

Make sure you have these functions tested and ready to work on opening day.


Policies and Consistency

For each event, create two policies: one for the players, and one for the customer service staff. Make sure that both staff and players know the policies; this will save an immeasurable amount of time and manpower. Also make sure that the paid staff and volunteers are following the same policies: players will rarely differentiate between the two, and complaints will mount quickly if enforcement is perceived as erratic. This is especially important in multidimensional worlds, as it only takes one person creating his own rules to throw the game off balance and create an uproar. Create and publish policies covering player character names, reimbursement issues, harassment, exploits, player-versus-player violence (so-called "player killing"), and any other issues that are unique to your game.

Case Study 4.3.2: Customer Service Policies
Start example

A Sample Player Policy

"Disruptive behavior that might affect others' enjoyment cannot be tolerated. Disruptive behavior might include, but is not limited to spamming; monopolizing chat lines; use of profane names or language; or interrupting an event organized by another player or a Game Master. Any such behavior might result in your character[s] loss of game privileges for a time, and repeat offenders might be banned from the game permanently."

A Sample Staff Policy

"When you receive a complaint regarding disruption, go invisible, log the incident, and send a private message to the disrupter identifying yourself and asking him to cease the behavior. If the player continues the disruption, silence him for five minutes, warn him verbally and in writing, and note the incident in the player's history file. For extreme cases, notify a senior volunteer or Game Master and ask for a suspension of the player involved."

End example


Choosing Customer Support Staff

When it comes to the heart of the customer service program, you have four basic options: a small paid staff, a large paid staff, outsourcing, and volunteers.

Paid Staff

Hiring only a few paid staff and hoping for the best is generally not a valid option for the massive multiplayer games, because of the workload involved.

However, Ultima Online and Asheron's Call chose this approach after using volunteers for many months, citing legal concerns as the main reason. U.S. Labor law, quite simply, does not recognize such a thing as a volunteer in a for-profit business, and several lawsuits have been filed against companies that use them. See Case Study 4.3.3 for more information on this topic.

Case Study 4.3.3: Volunteers, Games, and the Law
Start example

More on volunteers in the legal system can be found at www.dol.gov/esa/regs/compliance/whd/whdfs13.htm

For more information on the lawsuits relating to volunteers and online services, see:

  • www.salon.com/tech/feature/1999/04/16/aol_community/index1.html

  • http://dir.salon.com/tech/log/2000/09/21/ultima_volunteers/index.html

  • www.e3dnews.com/e3d/Issues/200102-Feb/lead.html

  • www.wired.com/news/print/0,1294,41821,00.html

As of August 2002, none of the lawsuits have resulted in settlements against a gaming company, but the issues are of significant concern and warrant attention.

End example

Unfortunately, the only way to pay for a large staff is to charge considerably more than the average game can reasonably expect from its players.

Simutronics' games have long offered "premium services" where players can opt to pay considerably more for preferential customer service, and this model works extremely well for them. However, the games in question are text-based, with considerably less overhead than their graphical counterparts, and still allow a large number of volunteers to assist. Everquest introduced "Legends" premium service in 2002, but no data is currently available on its success or lack thereof. Finally, while several thirdparty companies, including Zreality and the Themis Group, offer online gaming customer service assistance, the effectiveness and costs involved must be carefully evaluated before choosing this option.

Volunteers

Despite the threat of litigation, the volunteer approach was chosen by most online games and has worked quite well, although its effectiveness varies due to management issues, willingness to trust the volunteers with commands that have the potential for abuse, and available tools.

As the volunteer service model is the most prominent, it is going to be the focus of the rest of this article.


Why Volunteers?

Cost reductions, although substantial, are not the only reason why game companies create volunteer programs. Often, the players themselves demand it. Most interviews with the developers of future online games feature the question, "Will you have a way for volunteers to work with the game?" [Strand00] states: "I am convinced that online gaming would not be what it is today if it hadn't been for the volunteers."

Volunteers can improve the community aspects of the game world and provide much more game experience and dedication than a temporary agency employee working for near minimum wage. Furthermore, those who excel as volunteers in the industry often hold degrees and lucrative jobs and would not be interested in fulltime employment even if the companies could afford them. A large number work with the games for enjoyment and to be a part of the special behind-the-scenes community. Most volunteers are "hardcore" gamers with years of experience as players and the vast majority are at least part-time students in college.

The downside of volunteer programs is twofold: there is a risk of litigation, and managing volunteers is very time consuming. If your staff is comprised of volunteers who average as little as five hours of work a week, you will need eight times as many volunteers as you would full-time employees to offer the same coverage. Worse: in reality, you might end up needing 30 times more volunteers than you would paid staff, because you must account for the fact that you cannot force a volunteer to adhere to a specific, regular schedule.

Asheron's Call, Ultima Online, EverQuest, DragonRealms, and Anarchy-Online all began life with the devotion and caring of hundreds of volunteers. Asheron's Call later disbanded their volunteer customer support staff and Ultima Online removed their volunteers in the North American and European game worlds due to concerns of legality.

Case Study 4.3.4: Comparison of Games and Support Models
Start example

Table 4.3.1 lists several popular games and their service models.

Table 4.3.1: Customer Service Models
Game | Producer | Player Base | Type of Game | Customer Service
Everquest | Sony/Verant | Very large | MMORPG | Mostly volunteers with limited powers
DragonRealms | Simutronics | Large | Pay to Play Mud | Paid/volunteer mix
[*]Asherons Call | Microsoft | Very large | MMOG | Paid staff only
[*]Ultima Online | Origin | Very large | MMOG | Paid staff only
Anarchy-Online | Funcom Inc. | Large | MMOG | Mostly volunteer
[*]Both games started off with large volunteer staff groups and discontinued due to fear of legal complications.

End example


How Many Customer Support People Do I Need?

A good rule of thumb is to take your player base and multiply by 1% to arrive at a minimum number of support personnel needed. Note that this can greatly vary depending on whether your game has one "dimension" (i.e., copy of the game world) or many, how advanced your customer service tools are, how complex the game is, how much support you want to provide, whether you plan on an all paid staff or the use of volunteers, and how much power you are willing to place in the hands of your volunteers. The 1% rule is followed primarily by medium to large games with more than one dimension that use a combination of paid staff and volunteers.

For example, a game with 50,000 players providing 24/7 support might be able to survive adequately with four paid staff on at all times, but will most likely be better off planning to have one paid staff on at all times and 10 volunteers on at any given time. However, what many games fail to plan for is the number of staff needed to administer the volunteer program itself. As of 2002, the most successful volunteer programs have required one to three paid staff managing the volunteers. However, it is vital to note that these programs empower several of the volunteers with extended abilities and allow for approximately 10% of their volunteers to work in supervisory and administrative capacities.

Case Study 4.3.5: Staffing a Volunteer Program
Start example

Demographics for FunCom's program ARK (Advisors of Rubi-Ka) show the average volunteer to be a college student with one to five years of gaming experience. Polls of their volunteers showed over 60% to be in the 21 to 30 age group, approximately 15% in the 18 to 21 range, and 15% in the 30 to 40 range. The majority of volunteers are male, which is also reflective of the player base for the game. Eighteen months after the program began, 7% of the volunteers had been in the program for over one year, and another 10% had volunteered for six consecutive months.

End example

Types of Volunteers

Typically you can expect to get three types of volunteers:

  • Desirable: Those who have the time, energy, and knowledge to effectively improve the customer service program for the company. Many volunteers in this category have college degrees and lucrative careers but simply enjoy the challenges and friendships that come with such a venture. A large number in this category are also college students seeking a "foot in the door" of the game industry.

  • Temps: Those who just want to see what they can learn or get by being a volunteer, or who genuinely want to try it out and find that it's too much like work. Temps drain time and energy, and usually give up within 45 days.

  • Problems waiting to happen: Volunteers who join to find information to abuse game mechanics, share with other companies, or to get an inside edge to assist friends.

Proper recruiting, training, and monitoring will keep the latter two categories to a minimum.

Turnover

Turnover in volunteer programs is normally very high, and is directly affected by the ability of the volunteers to receive satisfaction from helping players, the manner in which the company treats the help, and the "family" feel to the program. Programs that do poorly in these areas can expect a 25% turnover ratio per week. Even the best managed programs will still see a turnover of 3 to 7% depending on the season. One measure of a volunteer program is how long the volunteers remain active, as well as their level of activity. As in any business, happy people stay longer and produce better results.

In short, the secrets to a successful volunteer program are responsible empowerment, good management, correct tools, and the right people:

  • Ensure that volunteers sign a well-written non-disclosure agreement (NDA), that rules for volunteers are clearly posted, and that you pursue violations.

  • Verify that the volunteer is of legal age. This extra step can save you in child labor laws and NDA violations.

  • When recruiting representatives, ensure that they can write proficiently if they will be dealing with customers online and that they have a friendly "online presence."

  • Provide training. Some programs give a help file to volunteers and let them go. Some programs train, mentor, and teach tools and customer service basics. The latter cannot be stressed enough. Customer service does not come naturally to all. Training your representatives in diffusing difficult situations, how to escalate problems, and how to use positive statements along with the game mechanics will pay for itself when your staff is on the front line.

  • Make the volunteers feel respected by the company. Developer chats, meetings with paid staff, informal discussions, and occasional telephone calls can go a long way toward building relationships. As Ørjan Mathis Tvedt, volunteer program manager for Anarchy Online, states: "The most important thing with a volunteer program that I have found is that it's just like any relationship. You get out of it what you put into it, you have to treat others like you want to be treated, and there has to be room for give and take."

  • Empower volunteers to do what needs to be done. The number-one complaint of volunteers is invariably, "I don't have the tools or permissions to help the players when they have a legitimate need." If your volunteers can only answer players with "I'm sorry I can't help you", or "Let me refer you to (fill in the blank)," no one is benefiting. If your company cannot excel at internal customer service, there is no hope of them excelling with the external customers.

  • Have the tools to monitor and deal with staff problems immediately. Make sure you can catch abuse of power or poor customer service and that you deal with these issues appropriately when they arise.

  • Get good management and treat them well. Consider money spent on customer service an investment for the future rather than a expense. Strong leadership and personable people in both the paid and volunteer programs of customer service will save you time, money, and customers.

  • Provide rewards and recognition for the volunteers. Thank people, publicly recognize them, and provide tangible benefits when possible.

Case Study 4.3.6: Rewarding Customer Service Staff
Start example

Here are a handful of ways in which effective service representatives can be rewarded for their work, and therefore retained longer:

  • Unique items for their characters

  • Renaming items in the game after employees/volunteers

  • Letters of recommendation, awards, and parties

  • Increased responsibility, ranks, and titles based on longevity

  • Recognition on public Web sites, boards, and in the game itself

  • Rewards of game points that can be used to purchase items or skills

  • Preferential employment opportunities

  • Invitation to participate in developer chats

  • Beta testing of other company games

  • Trips to gaming conventions

End example


Monitoring the Progress of a Customer Support Program

To make sure that your support program is performing appropriately, follow these simple steps:

  • From time to time, perform a simple Web search on "customer service" and "your game." See where people are discussing your support program, and what their concerns are.

  • Monitor the fan sites and message boards daily. Take this information to heart and plan to have staff respond on these forums.

  • Periodically review a sample of the feedback. Make sure you know what the top issues are and what's being done about them.

  • Consider surveys or a customer service audit by an independent firm. While most businesses employ some method to follow up on customer satisfaction, this is an area the gaming industry as a whole has not given a great deal of attention. Very few games today seem confident enough to employ this technique.

  • Track statistics on wait times. Set goals and plan for emergency situations to keep your customers from spending an undue amount of time waiting for assistance.

  • Create a quality control team to check on customer service. Test your staff. Take a walk in the customers' shoes and see what the view is.

Customer service surveys for Anarchy Online taught the company two important lessons:

  • The quicker customers received assistance, the higher they rated the overall customer service of the game.

  • When customer service staff were given survey results that pertained to them, the same staff rated a full point higher on the next round in over 90 % of the cases.


Conclusion

Customer service is an ongoing commitment to provide quality assistance and build customer loyalty. The best game can lose money by failing to focus on quality service. As a study done by the Rockefeller Foundation and quoted in [Griffin97] shows, almost 7 out of 10 customers who leave a regular service provider go to the competition because of poor customer service. Quality customer service requires good planning, effective policies, smart management, effective tools, relevant training, and dedicated people. By taking control of these measures in your game, you are taking control of your customers' satisfaction.

Using volunteers in a massive multiplayer game can be a very effective tool, but it is not without costs in time, energy, resources, and management. While many game companies have recently shied away from the volunteer customer service model due to legal concerns, no legal action has been successful yet. The top MMOGs in terms of customer service are continuing to recruit volunteers and do so not only for monetary reasons, but because it's what the customers have asked for.


References

[Griffin97] Griffin, K., "Customer Loyalty: How to Earn It, How to Keep It," Lexington Books, 1997.

[Strand00] Strand, T., "Anarchy Online Developer Journal," available online at http://aovault.ign.com/features/journal/100500.shtml, October 5, 2000.


Chapter 4.4: Offshore Game Development Outsourcing

Overview

Javier F. Otaegui—Sabarasa Entertainment

<javier@sabarasa.com>

The classical definition of outsourcing applies when a company transfers one or more recurring processes to another organization under a contractual agreement. Outsourcing is different from subcontracting and other similar business practices in that it focuses on recurring processes instead of one-time projects [Kelly01].

In the game development community, outsourcing and subcontracting mean the same thing: a game company hiring another company to handle a task such as programming, 2D art, modeling, texturing, audio design, music, scripting, levels, research, testing, or even complete development.

Offshore outsourcing occurs when a company located in another country (usually outside of North America and Western Europe) is hired. The main justification for this growing phenomenon is monetary: offshore game development professionals can be hired for a fractional part of what U.S. or European game developers earn [Yourdon96]. This can imply savings of up to 50% for the entire project budget, a significant and important figure to take into account for your new game development projects.


Why Should You Outsource?

Experts believe that outsourcing is essential to prosper in the twenty-first century. According to [Berger02], companies that outsource are then able to focus on their core competencies. For example, some game development companies could focus on game design and production (their core competency) and outsource the non-core activities of programming, artwork, testing, and so forth.

Beyond this reason, perhaps the most important and decisive factor for many companies is the significant cost reduction that offshore outsourcing implies. Outsourcing to Asian and Eastern European countries for this reason has been a common practice for several years, and recently new countries (e.g., Argentina and Brazil) have entered this worldwide market, due to devaluation processes, with interesting advantages that we will now examine.


Additional Benefits of Offshore Outsourcing

Additional benefits of offshore outsourcing can be summarized as follows:

  • On-budget delivery. Contracts for outsourcing are commonly milestone driven, with set payments for specific work, so you can rest assured that the project will respect the original budget.

  • Reduced operating costs. You can hire outsourcing solutions on an as-needed basis, instead of paying full-time staff during downtimes.

  • Access to specialized skills. You don't need to train your team with a specific technology or methodology; you can simply hire a specialized team that can do the work.

  • Access to preexisting code, tools, and libraries. Your development time will be shorter because you will gain access to the contracted developer's in-house tools and libraries, with the additional benefit that the programmers will already be familiar with them.


Myths about Offshore Outsourcing

Deciding to outsource is rarely easy, and it is almost certain that the transition will create uncertainty, controversy, and even active resistance [Kelly01].

The fear of losing control is the most typical objection to outsourcing, commonly reflected in thoughts like "if I want it done right, I'd better do it myself." [Kelly01] points out that in fact, outsourcing increases the ability to manage and control vital business processes. Outsourcing is based on contracts, schedules, and milestones that specify key objectives and guarantee performance.

Another common myth about outsourcing is that people usually think of it as being financially uncertain. Concerns about upfront costs and ongoing service fees are commonly present; however, with an appropriately written contract, the financial benefits become clear. Structure the contract by milestones and periodical reviews issuing payments on an approval basis. This eliminates all uncertainty about hidden costs.


How to Outsource

There are three defined stages in the game development outsourcing process. The first stage involves the request for proposal and the proposal, with schedule, work planning, and budget. The second stage is concerned with preparing and signing the contract. The third stage involves the development of the game, and the tracking of milestones and bugs.

The Proposal

The outsourcing process starts when the customer sends the Request For Proposal (RFP), which usually includes the Game Design Document, to the provider for evaluation. This design document should be as complete and accurate as possible, as it will dictate both the estimated schedule and budget. The customer should also indicate if there are strict deadlines, so the provider can assign more people (if possible) to the project. The RFP should also specify the tasks that the provider will assume, whom they will report to, and how the approval process will be structured.

The provider then prepares a proposal for the customer. This proposal must include all the functional requisites of the game, as well as a detailed time schedule for project management. Although this is not compulsory, the provider should also inform the client of how many people will be involved in the game's development, and each individual's specific skills.

The proposal must also include logical divisions of the project in order to specify the milestones. A good rule of thumb is to include a milestone per month. This implies constant supervision and satisfaction from the customer, as well as monthly payments for the provider.

Milestone definitions contain lists of features and content required for approval. Specifying a process by which items can be exchanged between milestones during development can also help deal with unforeseen events. This interchangeability will allow the development process to grow more naturally than with imposed artificial schedules.

Finally, the proposal should include a description of how the work will be done: a context diagram of the most important parts of the program, any tools that also need to be developed, and so forth, and a payment structure for the milestones. The final milestone usually has a bigger payment associated with it.

The Contract

Contracts can be signed for a single project or for a set of related projects. [Paul01] recommends not to become entangled in a long-term contract to maintain the flexibility necessary to deal with changing market conditions. This also allows for more dynamic process allocation to different outsourcing groups.

Contracts must clearly depict each party's responsibility. If you are working with separate groups for programming and artwork, you should clearly specify whose responsibility it is, for example, to convert artwork to final game data files; who is accountable for each component; and how performance will be evaluated. Although programming and artwork might depend on each other, separate milestone threads should be used for each, especially if they are subcontracted to different companies.

One important issue is code ownership. The customer will demand ownership of the final product, as he is the one who is paying for the work, but the framework and generic game libraries should be of shared ownership.

Finally, the contract should include the proposal as an appendix, to describe the job to be done.

The Development Process

Once the contract is signed, the hard work begins. The developer and the customer now enter into a close working relationship that will last until the project is delivered. Thus, contracting an outsourcing studio that shares your corporate culture and vision is crucial to successfully develop the product [Jenkins01].

Communications between the provider and the customer are extremely important to the project's success. E-mails, instant messengers, bug trackers, periodical releases, and reviews form the communications spectrum the game designer must implement when hiring an offshore outsourcing development studio. Constant feedback is a must, especially when artwork is being outsourced.

The bug tracker is an important communications channel. The best solution is to use a Web-based system where you and your testers can post details about every issue requiring attention. The bugs should be closed (i.e., officially declared and accepted as fixed) definitively by the customer, once fixed by the developer.

The instant messenger is effective, but only when both parties are located in countries with similar time zones. A South American team working for a U.S. company will have little trouble coordinating; not so for a team in Russia or Taiwan.

Case Study 4.4.1: The Provider's Side
Start example

We asked Sergei Herashenko, from Frogwares (www.frogwares.com), a Ukrainian company specializing in game development outsourcing services, to describe their experience in offshore outsourcing.

Q:

Can you tell us what makes your company successful?

Q:

How do you manage to make it work despite distance and language issues?

Answers

A:

"We have many clients who are very satisfied with our quality and terms of work, and they are much more than happy when they realize that they pay half of the market price for the work we are doing for them! Key factors of success include quality of work, being serious in every detail (terms, deadlines, etc.), and a personal approach to every client."

A:

"Most of our clients come to Ukraine to see our development branch, to meet project managers and other people they are working with distantly. The company was set up to be able to work for clients who speak different languages and with considerable time differences.

"All of our developers and designers speak at least English, and some speak other foreign languages. It is very easy to work with European clients because the time difference is only a few hours. With America, it is more difficult, but we can always find a solution, such as adjusting our work schedule to the client's needs."
End example


Choosing the Appropriate Outsourcing Provider

There really are no sure-fire recipes for successful game development outsourcing, but there are several minimum guidelines that should help you when hiring an outsourcing company to develop your games.

The most basic issue is language. Both you and the development team should be able to write and speak the same language. (It is not necessary that they both share the same mother tongue, as most communication will be written.) Also make sure that the language used in documentation will also be used in the code and in the comments. The usual option is to adopt English.

As the outsourcing relationship is a long-termed one, it is very wise to find a team that matches your own culture. It must understand your business and goals, and it must share the same values and information [Jenkins01].

It is highly recommended that you hire a team with experience in both game development and outsourcing, with at least one contract project completed. Although hiring an inexperienced team might be tempting because of lower prices, it pays to choose a stable and trustworthy partner [Paul01].

Timing

Some Asian companies depict as positive the 12-hour time shift between the client and them, because they can work on the requirements and bugs found in the last 12 hours. If real-time communication is a crucial factor in your case, you should hire an offshore team that shares time zones with your home country. This makes nations such as Argentina and Brazil excellent candidates for clients in the United States and Europe; their recently devaluated economies can lead to savings of up to 50% in development costs.

Case Study 4.4.2: The Client's Side
Start example

We asked Tenzing Kernan, game designer and producer at Cardoza Entertainment (www.cardozaent.com), for his comments about the outsourcing economy.

"It is not difficult to find a good developer (and lots of not so good ones) by searching on the Internet. However, working with a foreign development team does pose some additional problems, mainly the language barrier, time zone differences, and communications delays. If the language barrier is too great, you must find a new developer. Daily exchange of ideas and feedback is essential. To make sure that the hurdles can be cleared, you should exchange a few practice e-mails with the key people on the project, before committing to the developer.

"You will almost certainly communicate with the developer (especially an overseas one) mostly via the Internet, using both e-mail and chat. Feedback can be slow with e-mail, and even slower if the time zones are incompatible. You should set a time period during the day when an online chat session can happen. While chatting, many issues can be talked about and resolved in a short period of time. When sending e-mails, include lots of details, and spell everything out clearly—or a simple 10-minute fix might take two days.

"Finally, while it is tempting to go with the developer with the lowest price, it is absolutely essential to choose a developer who will complete the job. Many things can derail a project before completion. The experience of the team's members is more important than their formal education. The key members of the team must have completed a project of a similar size and complexity, or you are taking a big risk."

End example


Conclusion

Offshore game development outsourcing is an excellent way to reduce the development costs of your game project, sometimes to half the original budget, or to drastically increase your product's quality by hiring more quality people for the same price.

Recent national economy devaluations in Argentina and Brazil provide an excellent scenario for game development outsourcing: lower costs, overlapping time zones with the United States and Europe, and companies with proven track records.


References

[Berger02] Berger, J., "The Value of Outsourcing," DecisionOne, January 2002, available online at www.decisionone.com/d1m/news/white_papers/white_paper_08.shtml

[Jenkins01] Jenkins, D., "The New Standard for IT Outsourcing: Delivering on accountability will drive the future of all relationships," The Outsourcing Institute, 2001, available online at http://verizonit.com/pdf/oi_brief.pdf

[Kelly01] Kelly, T., "Is Application Outsourcing Right for Your Business?" BlueStar Solutions, December 2001, available online at www.bluestarsolutions.com/industry/Is_Outsourcing_Right_For_You.pdf

[Paul01] Paul, L., "Classic Outsourcing Blunders," Darwin Magazine, August 2001, available online at www.darwinmag.com/read/080101/blunders.html

[Yourdon96] Yourdon, E., et al, "Offshore Outsourcing: The Benefits and Risks," Cutter Consortium Research Reports, November 1996.


Chapter 4.5: Localizations

Heather Maxwell

<hbmaxwell@mindspring.com>

Creating International Content

Localization is often the last thing on people's minds and the last thing that is completed in the game development cycle. If localizations are planned for in advance, they can be completed in a timely fashion and can get the game more exposure in international markets. These days, most publishers localize their games into French, German, Spanish, and Italian. This article mainly concentrates on these languages, but this information can also be applied to localizations for other languages such as Korean, Japanese, and Polish. Determining which languages your game will be localized into at the beginning of the project will save time in the long run, since you can prepare for any problems you are sure to encounter.

Get International Input Early

Think about how the name and content will sell in other countries. Will you be able to sell very many copies of a "Route 66" adventure game in Japan if no one there has any idea what "Route 66" is? How about trying to market a real-time strategy game called "Third World" in Mexico—where connotations of this phrase are completely different than in the United States? Will a baseball game sell very well in Europe?

Create special hooks or exclusive content to appeal to an international market. If making a car-racing game, include a special French car that is available exclusively in the French version. If designing a skateboarding game, include a skate park from the UK or Italy. The same goes for music. If licensing music from well-known American bands, replace one of the tracks with the hottest band in Germany.

Avoid making specific references to American culture and slang, unless it is necessary for game design. For example, avoid references to the Survivor TV show like "You have been voted off." And don't use slang like "Keep it on the DL," and "That is whack!" This will also prevent the setting of your game from appearing too dated.

Usually, the U.S. version is completed and then the localized versions follow. In some cases, the localized versions will need to change or remove some of the assets that were originally intended for the U.S. market. For example:

  • Electronic registration. You don't want to include U.S. electronic registration on international builds, but you might want to include country-specific registration. This might require you to get different registration software for each national version of the game.

  • Subtitles. In lieu of fully localizing the product, you can subtitle the voice-over. If this is the case, subtitling functionality needs to be built into the game engine.

  • Blood. Germany has strict censorship guidelines, particularly in regard to blood and violence. Games released in Germany will need to have the blood completely removed or changed to another color so it does not look like blood. Adhering to Germany's censorship guidelines might require you to make a separate German master, especially if you are not going to alter the violence for release in other countries.

European Ratings Boards

Certification for videogames is not centralized internationally so there are several software rating entities that operate in Europe and other countries. If you are planning to release a game in another country, check if they have a software rating system and what the submission requirements are. You might need to modify your game before it can be released in a particular country. Some of the rating boards that operate in Europe are:

  • United Kingdom: European Leisure Software Publishers Association (ELSPA)

  • Germany: Unterhaltungssoftware SelbstKontrolle (USK)

  • Spain: La Asociación Española de Distribuidores y Editores de Software de Entretenimiento (ADESE)

  • France: Syndicate des Editeurs de Logiciels de Loisirs (SELL)


Determining Costs to Localize

Before you localize, make sure it is financially viable to do so, in terms of time and money. Start by figuring out how many assets need to be localized, how much the translations will cost, and how much development time will be needed. Once you have this information, you can work with sales and marketing to determine if the sales numbers point to a financially viable localization. Traditionally, French, German, Spanish, and Italian are the main European localizations that U.S. game companies create.

Licensing deals are sometimes made to create localizations for other countries such as Brazil, Japan, and Korea. In the case of a licensing deal, a localization kit is delivered to the licensees and they handle all the translation, integration, and testing.

Staggered Release versus Simultaneous Release

Of course, each localized project will have a different schedule, but if localizations are planned for in advance and run according to schedule, you can expect to spend no more then two to three months localizing a game. Some developers prefer to wait until the U.S. version is completely finished before beginning work on localized builds. The advantages to this include:

  • Code is final. If you have already planned for the technical necessities needed for localizations, the code base probably will not change. Therefore, most of the team can be off-loaded to work on other projects. You will only need two to three core people to integrate the assets and create builds. The other advantage is that the QA department will not find as many code-related bugs.

  • U.S. assets are final. If the U.S. assets are final, tracking localized assets will be much easier. You will not need to constantly update the translators with any text or voice-over changes, greatly simplifying the asset tracking, translation, and integration process.

The disadvantage to working on localized versions after the U.S. version is finished is not having a simultaneous worldwide release of the game. Therefore, people who don't live in the U.S. will have to wait two to three months to play the game. In addition, this lag time for international releases gives software pirates more time to get illegal copies of the game into international channels.

Ideally, you want localized versions of the game released simultaneously with the U.S. version, or as close to that as you can get. This is very difficult to do, especially if no advanced planning has been done. The main obstacles to achieving simultaneous code release are not being able to work with final assets and not starting the asset integration process soon enough. You will need to work very closely with designers, artists, and engineers to finalize batches of assets that can be sent off for localization. Once assets have been sent off for translation, restrict access to the U.S. versions so that changes cannot be made without first notifying the person managing the localizations. Often, there are last-minute asset changes before the game code releases, and these changes need to be carried over into the localized assets.

The disadvantage of not working with final code means that the QA department will take longer to test since they will be finding a lot more bugs, and these bugs will be duplicated across all the versions. One last deterrent for trying to localize simultaneously with the U.S. version is the increase in manpower and workload. It is very difficult just getting the U.S. version completed on time, if you add localized versions on top of the U.S. version, your team will need to split their already limited time between the U.S. and localized versions.

Scheduling

Create a rough schedule of all the tasks needed to complete the localization. The duration of the tasks depends on how many assets need to be localized and tested. Table 4.5.1 illustrates an asset overview form that you can use to estimate the number of assets to be translated. Additionally, this form provides valuable information so the translators can determine the translation costs and know the format in which the assets need to be delivered.

Table 4.5.1: Asset Overview Form

Click To expand

When planning your schedule make sure to include time estimates for these major areas:

  • Organizing assets for translations. Make sure that all of the assets are organized so that the text and context are very clear for all the translations you need. This includes such things as creating a glossary, adding time codes to the VO script, and creating a master sheet with all the in-game text.

  • Translations. Get estimates from the translator for how long it will take to have everything translated. If doing voice-over, you need to include time for translating the script, casting actors, recording the voice-over, adding special effects, and converting to the necessary audio format.

  • Integrating translated assets. Schedule time for things such as integrating text files, modifying art files, adding localized VO, and compiling the build.

  • Testing localized builds. This can be one of the most time-consuming aspects of localizations. You have to check all the translations in the game and make sure no bugs were introduced when the localized assets were added. You need to allow for several rounds of testing and bug fixing. The amount of testing time will depend on the size of the game and how much translated text needs to be checked.

Budgeting

Once you have a schedule, and an overview of the assets to be localized, you can get an idea of how much all of this is going to cost. The translator needs to provide translation costs and you need to figure out development and testing costs. Table 4.5.2 is a form to help you determine development and testing costs. You fill in the daily rate of the person doing the work and then multiply it by the amount of time he spends on the project. This is just an estimate and you should track the actual time you spent on the project to see how close you came to your original estimate. You can use this information to estimate future localizations.

Table 4.5.2: Estimate for Development Costs
Translating Resource Name | Task | Daily Rate | Est. Days | Cost
Engineer | Extract text for localization | $0.00 | 0 | $0.00
Associate Producer | Organize assets for translation | $0.00 | 0 | $0.00
Integrating Resource Name | Task | Daily Rate | Est. Days | Cost
Engineer | Asset integration, making builds for 4 languages | $0.00 | 0 | $0.00
2D Artist | Update 2D art (if necessary) | $0.00 | 0 | $0.00
3D Artist | Localize cinematics | $0.00 | 0 | $0.00
Associate Producer | Assist with asset integration for 4 languages | $0.00 | 0 | $0.00
Testing Resource Name | Task | Daily Rate | Est. Days | Cost
QC Manager | Burn final Gold Masters (4 languages) | $0.00 | 0 | $0.00
System Admin | Set up localized machines (4 languages) | $0.00 | 0 | $0.00
Lead QA Analyst | Organize all aspects of testing and write test plan | $0.00 | 0 | $0.00
Tester (German) | Test game (2 rounds of testing, GM certification) | $0.00 | 0 | $0.00
Tester (French) | Test game (2 rounds of testing, GM certification) | $0.00 | 0 | $0.00
Tester (Italian) | Test game (2 rounds of testing, GM certification) | $0.00 | 0 | $0.00
Tester (Spanish) | Test game (2 rounds of testing, GM certification) | $0.00 | 0 | $0.00
Engineer | Fix bugs, make builds | $0.00 | 0 | $0.00
Associate Producer | Fix bugs | $0.00 | 0 | $0.00
 |  | Grand Total | 0 | $0.00

Localization Friendly Development

Sit down with the development team during pre-production to discuss ways they can make the game more localization friendly. This means creating assets that are easy to pull out for localization and easy to integrate after they have been translated. For example, keep the text in a separate layer for art assets. This way, you can easily modify the text without having to use an artist to recreate a localized version of the asset from scratch. The more streamlined you can make the localization process, the less time and resources you need to use.

Staffing

One person, usually the producer or associate producer, should be in charge of managing all aspects of the localization. This person is the main point of contact for all localization issues. If you have too many people involved, it is easy to lose track of things, which can add time and cost to the schedule. In addition, you need at least one engineer to help with integrating assets, creating builds, and debugging code. If there are many art assets to be localized, you need an artist part-time on the project as well. For testing, you will need testers to check both the linguistic and functional aspects of the game. Discuss your testing needs with the QA department and make sure there are enough testers available to get the project done on time.

Determining Which Files to Localize

Avoid hard-coding text into the program. Instead, all text should be easily accessible in a separate file that can be modified with a text editor. Make sure the development team is keeping all the assets that need to be localized in an accessible place in the game. Opening and searching dozens of source files for text strings to be replaced is very time-consuming and error-prone. One method of organizing assets to be localized is to create an English-specific directory that contains all the text and voice-over used in the game. Examples of files that contain language assets include:

  • Text and tool-tip files. For example, text that pops up when you mouse-over a button.

  • Images containing embedded text. For example, billboard signs.

  • Voice-over files. Text spoken by actors, as well as audio help files.

  • Embedded commands. For example, "Do you want to quit?"

  • Control messages. For example, "Please wait," or "Press any key."

  • Fonts. Make sure fonts support special characters and accents.

Technical Considerations

The engine needs to be able to handle both uppercase and lowercase versions of special linguistic characters, such as ä, Õ, and Ç. If you are localizing a title that uses an Asian font, the engine must be double-byte enabled and capable of using bidirectional and right-to-left text.

If allowing the player to use the keyboard for input, for example in typing in a multiplayer name, they need the use of accentuated characters. Double-check this functionality in the test process to make sure that using special characters will not crash the game.

In addition, determine how the keyboard commands will be mapped to the keyboard. If the keyboard commands are mapped by location (e.g., the far left key on the bottom row will reload a weapon), make sure this key functions the same way on all international keyboards. Moreover, the manual writer for each language will want to make a note of the exact key when writing the manual, since the name of the key will be different in each country. If the keyboard commands are mapped directly to the keys (e.g., ~ will switch the weapon the player is using), make sure that all versions of the keyboards have this key available. If not, you will have to pick a different key to map the command to for that language.

If you are working on a console game, you might need to make a PAL version of the game. Contact the console manufacturers to find out what requirements they have.

Game Layout on the CD

Plan for an increase in file size when working with localized assets, since most of them are at least 10 to 15% larger then their U.S. counterparts. Make sure there is enough room on the game CD to accommodate this size increase.

If there is enough room, you might decide to include several languages on one CD. If this is the case, you need to determine how users will get the appropriate language installed—will they have an on-screen option to select a language, or will language be auto-selected based on the users' OS?

Screen Real Estate and User Interfaces

Keep the text size increase in mind when designing user interfaces. Implement scrolling text boxes or scalable buttons to accommodate these increases. This will decrease the amount of overlapping and truncated text you have to fix in the testing phase. In addition, don't have too many buttons crowded onto the screen. When possible, use icons instead of words. For example, use an open door with an arrow pointing through as an exit symbol instead of the word "EXIT." If you did not plan ahead for these increases, you might find that you have to redesign the UI and screen layout for the localized versions. Jeff Matsushita, who has managed localization for Activision, offers these examples:

"For instance, Japanese text cannot be displayed in as small a font as European text. As such, if a very small font is used for the U.S. version, the Japanese version might require a layout change to accommodate the larger text size. Another consideration is the width of German text. German has some very long words that can easily overrun a text box and might either require a new screen layout or a retranslation—neither of which is cheap. At the design phase, the developer should avoid having screens that jam tons of text into small spaces, since the localized text might not fit into those spaces."

Other UI considerations need to be taken into account for console games, since consoles have a lower resolution than PCs. You want to avoid having a cluttered UI screen that will be hard to read when displayed on a TV. Regarding PAL conversions, Jeff states, "Since PAL formats have more lines vertically than NTSC, the screens might have to be laid out again in order to match the larger screen."

Organizing Assets for Translation

You can create a complete localization kit and send it to the translator, or you can send assets as they are finalized. In either case, you need to make sure everything is clear and well organized so the translator can work efficiently. If things are disorganized or the assets aren't finalized, you will spend a lot of time sending different versions of the assets back and forth to the translator. Doing this is a sure way to lose track of the current assets and create additional bugs in the game. Establish a naming convention early on so that you can quickly determine what each file contains and if it has been localized.

If you are going to send a localization kit, it should include:

  • Documentation. This includes a table of contents of what is included in the localization kit, design documents, technical guidelines, instructions on how to use the tools, voice-over casting notes, and any documents that will help the localization house reproduce the look and feel of your game.

  • Tools. If a special text editor is needed to open the text files or a special plug-in is required to open the graphics files, these tools must be included in the kit, along with instructions on how to use them.

  • Assets. Include all the text, audio, art, and cinematics that need to be localized. In some cases, like cinematics, you need to provide raw data that can be translated, since the files will need to be compiled before adding them to the game.

  • Source code. This is all the code and assets the localization house will need to create and compile a completely translated version of the game.

Organizing Documentation

Send game-specific documents to make the context of the game clear to the translators. Having these resources makes it much easier for the translator to translate within the correct context. You should send:

  • Copy of game. Provide an up-to-date version of the game. It is helpful to send a game even before you send assets to be localized. The translator can become familiar with the game and be better prepared to provide exact translations.

  • Design documents. Provide all the design documents so the translator knows exactly what features are included in the game and which areas need special attention from a localization standpoint. These documents can also clarify any questions the translator might have while playing through the game.

  • Cheats/walkthroughs. In order to check the translations quickly in the game, cheats and walkthroughs need to be provided so the translator can quickly jump to different levels, screens, characters, and so forth. They need access to all areas of the game that are going to be localized.

  • Voice-over casting notes. In order to maintain audio quality standards, provide detailed casting notes of the major and minor voice-overs in the game. The translators need information such as gender, voice pitch, character description, and how this character fits into the game. This makes is easier to direct the VO session so that the localized VO files maintain the same overall emotion and context as the English VO files.

  • Glossary. This is useful for describing common and technical terms specific to your game, such as mission names, character names, and slang phrases that appear in the game.

  • Technical overview. This includes detailed information on file delivery formats, video editing requirements, and any post-production or integration work required to create the localized assets. If integrating cinematics, the technical overview should also include information on any compression tools used.

Organizing Text Assets

Organizing the text assets for translation can be very easy or very hard, depending on how the text assets are laid out in the game. If all the text is located in a single text file, you can just drop the text to be translated into a spreadsheet, add notes about context, and send it to be translated. If the text is located in various files throughout the game, you need to track down all text that needs to be localized and organize it into a table that is easy for the translator to work with. Ideally, as seen in Table 4.5.3, this table should list the filename, context, and text to be translated. This can be modified based on your translator's needs.

Table 4.5.3: Spreadsheet for Text Translation
Text Filename | Context | Text to Be Translated | Translation
Prision.rsf | This appears in game when a player tries to access a locked door. | You cannot use this door; find a different path. |
Prision.rsf | Appears in game when your team is in control of the enemy base. | You have captured the enemy base! |

Organizing Art Assets

When creating art for your game, do not embed text in the images. Instead, layer the artwork so that the text is on a separate layer. If you cannot layer the text separately and have to embed it, save a version of the file without the text embedded to include in your localization kit. This will make is easier for the translators to modify the art assets.

When the art assets are ready to be translated, put the text to be translated in a spreadsheet similar to Table 4.5.3. The developer can then import the translated text into the text layer of the image, or the translator can do this if he or she has the technical expertise. If the translator does it, make sure he or she has the necessary software to modify the files, like Adobe Photoshop and any necessary or proprietary plug-ins. Additionally, a full font, with special linguistic characters, should be provided for any text that needs to be altered in an art asset.

Organizing Audio and Cinematic Assets

Organizing audio files is more involved since you have to cast actors and record in a studio. Additionally, you must be very clear about the format you need the localized files delivered in, since there are many technical variations of audio files. The delivery format should be included in the original asset overview (Table 4.5.1) and the technical overview that you gave to the translator.

Include casting notes so parts can be properly cast. Sometimes the tone of the selected voice actor does not go with the game and can pull the player out of the game. As seen in Table 4.5.4, you need to include the filename, name of the character, the context of the line, and the timing of the file if you want lip-syncing.

Table 4.5.4: Spreadsheet for Audio Translation
Audio Filename | Length | Character | Context | Text to Be Translated | Comments
Medic.wav | 1.2 sec | Sammy | A teammate has been wounded and Sammy is calling for medical help. | We need a medic here, stat! | Time sync. Max length = 2 secs

Provide the original English audio files to the translator. This will ensure that the translators, director, and actors have a good reference for the voice-overs and that the localized files correspond to their English equivalents.

If voice-over files are overlaid with sound effects or music, keep these as separate files. Be sure to specify where the music and sound effects are needed. You will also need to maintain uncompressed versions of your cinematics so you can easily integrate the localized voice-over. This information should be detailed in the technical overview.

If the game has lip-syncing, you need to provide additional information such as the length of the voice-over in minutes and seconds. You might also need to provide a time-coded PAL Betacam tape (for live video action), or sections of AVI video playback to ensure accuracy with lip-syncing in the localized versions.

Additional Assets that Need to Be Localized

In addition to the actual in-game assets, there might also be other game-specific content that needs to be localized. Be sure to include these items in your budget and schedule. Examples include:

  • Manuals and box text

  • Screen shots for manual and box

  • Keyboard reference card

  • Customer support information

  • Readme file

  • End user licensing agreement

  • Installer


Integrating Translated Assets

Integrating localized assets is time-consuming work because it involves a lot of file modification and file replacement. Basically, there are two major ways developers can handle this process. One way is for the developers to do the asset integration themselves and rely only on translators to provide the translated text. The benefits of this are that technical difficulties can easily be addressed, the integrity of the assets is maintained so they can easily be placed in the build without introducing any additional crash bugs, and the developer has more control over the time and resources. The drawbacks are that the developer has to spend additional development time and has to rely on translators to provide corrected text to fix some linguistic bugs. Furthermore, the developer often has to rely on a third party (usually international marketing) to approve the final versions. This can be very time-consuming, as the third party might go back and forth on minor bugs and hold up the release of the game.

The other way to integrate localized assets is to contract a localization house to do the translations, asset integration, and testing. The benefit to this is that the developer does not have to spend any additional time creating localized software. The developer just needs to provide a localization kit (discussed earlier in this article). The drawback is that the quality of the game can be compromised because no one is maintaining the same standards of quality for the voice-over actors, translations, and so forth. Moreover, some localization houses might not have the technical expertise to independently localize a game, resulting in the developer getting involved to fix a problem created by a translator's error. If you are going to use external vendors to completely localize your game, make sure they have experience localizing game software and the technical expertise to work with the assets.

After creating the initial set of translated assets, check them into a version control system so you can easily track them during the bug fixing phase. Version control is especially important if you have several people fixing bugs. Additionally, if you are working on multiple languages at one time, you can track each language more closely and avoid having German assets appear in a French version.


Testing Localized Builds

This can be the most time-consuming part of localizations since you have to do both linguistic testing and functionality testing. You can save some testing time by using two teams to do concurrent linguistic and functionality testing. Additionally, many of the QA strategies discussed in [Campbell03] would also apply to testing localized builds.

Linguistic Testing

Linguistic testing is where you check all the assets in the game to make sure that text is not overlapping, truncated, misspelled, or grammatically incorrect, and that all the voice-over files play correctly. Linguistic testing should be done by a native speaker of the language being tested. Translation houses often provide this service. Be sure to include time in your testing schedule for sending CDs to the testers, especially if they are in another country.

For linguistic testers, make sure they are familiar with how to play the game and know where all the translations need to be checked. One way is to have them check the text in the game against the text translation spreadsheet they already completed—just add a column for where to look for the text in the game. You can also send them a test plan for the U.S. version of the game. Make sure to provide cheats and walkthroughs.

Determine how you want linguistic bugs reported. If you do not provide a bug report form, you might not get enough information about how to fix the bug. This is especially true in cases where fixes are being made by people who don't speak the language they are fixing bugs for. In cases where you need to get additional text translated, organize it all and send it back to the translator in the same spreadsheet format you used previously. Table 4.5.5 is a sample bug report template for linguistic bugs. It includes information on where to find the bug, what the current (incorrect) translation is, and what the correct translation should be.

Table 4.5.5: Linguistic Bug Report Template
Bug # | Language | Location in Game | Description/Comment | Original Localized Text | Corrected Text | Status
3 | Italian | Mission 4 - Briefing | Please use lowercase letter. | ... Come forse sapere, il colpo di Stato ad Addis Abeba... | ... Come forse sapere, il colpo di stato ad Addis Abeba... | FIXED
9 | Italian | After Action Screen player) (single | Text not translated. | Originals Only | Solo originali | CLOSED

Functionality Testing

Functionality testing is where you test the general functionality of the localized build. You are checking for any bugs that the localized assets created that require a code change to fix. Normally, you should not get any functionality bugs since you are only swapping assets. However, if you did not plan for special characters or have text field length restrictions, you might find that you need to make code changes to accommodate the localized assets. Functionality testing can be done by the same QA team that did the U.S. version, since they are basically just running through the U.S. test plan. Bugs can be reported they same way they were for the U.S. version. Take special care to check keyboard input of all the special characters and the keyboard commands.

In addition to equipment used for testing the U.S. versions, you will also need to have multiple copies of each language's operating system and the appropriate keyboard for each language. You should include time in the testing schedule to have these machines set up for testing, especially if you are testing multiple languages at one time.


Conclusion

High-quality localizations can give your game a lot of positive exposure in international markets. While localizations can be time consuming, they can go very smoothly and efficiently if they are well thought out beforehand. When planning for localizations, keep the following in mind:

  • Create international content.

  • Determine costs and schedules before you start the localization process.

  • Keep game development "localization friendly."

  • Organize all final assets before sending them to be translated.

  • Carefully plan and execute the asset integration process.

  • Allow enough testing time to find and fix all linguistic and functionality bugs.

Each localization will have different pitfalls, but if you plan the known variables, you will have more time to deal with problems as they come up.


References

[Campbell03] Campbell, C., "Quality Control: Testing Plans and Bug Tracking," Secrets of the Game Business, Charles River Media, 2003.

[Dowling98] Dowling, Patrick, "Localizing for Lands Beyond the Wild Frontier," available online at www.gamasutra.com/features/production/19980828/localization_01.htm, August 28, 1998.

[Kano95] Kano, Nadine, Developing International Software for Windows® 95 and Windows NT™, Microsoft Press, 1995.

[Puha01] Puha, Thomas "Eurospeak: Localizing Games for the European Market," available online at www.gamasutra.com/features/20010403/puha.htm, April 3, 2001.

See the Web sites for the following software rating boards:

European Leisure Software Publishers Association (ELSPA), www.elspa.com

Unterhaltungssoftware SelbstKontrolle (USK), www.usk.de

Syndicate des Editeurs de Logiciels de Loisirs (SELL), www.sell.fr

La Asociación Española de Distribuidores y Editores de Software de Entretenimiento (ADESE), www.proein.com/adese.asp


Chapter 4.6: Leadership: The Making of Effective and Happy Teams

Overview

Melanie Cambron

<melanie@melaniecambron.com>

with Heather Maxwell

<hbmaxwell@mindspring.com>

Rather than spending loads of cash on relocation fees, recruiter fees, immigration fees, and to save valuable production time, companies should focus on keeping their teams happy and productive. European game companies have been particularly successful in this area. Why? They make the effort. There are simple yet effective steps you can take as a leader to create a legendary and legendarily happy team.


Why Is Team Happiness So Important?

The benefits of hiring, managing, and keeping happy team members can be limitless: higher quality of work, milestones met, bonuses paid, projects shipped, additional projects from pleased publisher, good reputation earned. However, if no effort is made to keep developers content, the results can be devastating to the happiness of the individual, the morale of the team, the timeliness of the project and, in some cases, the future of the entire studio. Companies are quick to throw money around to land the perfect game developer, but often do not bother to expend any time, money, thought, or effort to keep this necessary link in the development chain.


There Once Was a Programmer from Scotland: A True Story

Airfare from Scotland to Texas: $1,700

Hotel stay during interview: $200

Immigration attorney: $2,000

Second immigration attorney: $2,000

Relocation allowance: $7,500

Recruiter's fee: $14,000

A well-known game developer and publisher spent nearly $28,000 just to hire this one programmer. Given that sort of cash outlay you would think the company would make an effort to keep the employee happy and on board.

Strike One: His second Monday on the job was the Fourth of July. No one told him it was a holiday and that he did not need to be at the office, and no one invited him to the informal company barbecue. While the programmer would not have celebrated the holiday back home, leaving him out of a company event is questionable— and sending him to work alone, inexcusable.

Strike Two: A couple of months later he is told he needs to work on Sunday. Canceling personal plans, he dutifully works alone from dawn to dusk in a completely empty studio because, apparently, there really was not that much urgency in the project. After this incident, he finally spoke up and asked that he not be asked to worked on holidays or weekends unless it was expected of the entire team.

Strike Three: After six months of flawless performance, and having been described by the vice president of production as the best hire the company had ever made, he is asked to repay the majority of his relocation allowance, because he had not actually moved much furniture or other personal property. However, there were no stipulations, guidelines, regulations, or rules covered in his offer letter stating how the relocation money was to be used. Therefore, when the programmer pointed out that the cost to actually move the contents of his two bedroom flat and his car, around $10,000, to the United States would have been significantly more than what he had spent, the company relented and dropped the issue.

Nevertheless, the programmer never forgot the rather financially stressful episode. While he was committed to completing his project, his heart was no longer with the company. He had worked hard, delivered above and beyond expectations on a million-dollar game, and, yet, the employer chose to create a problem that simply should not have existed. This type of behavior on the part of management affected many members of the team. And after seeing so many of the talented individuals he truly enjoyed working with walk out the door, he soon followed suit.

Why would a company spend approximately $28,000 to hire someone and then treat him as a disposable commodity, especially an employee who had exceeded all expectations. It's difficult to explain or understand, but it happens regularly.


Warning Signs of the Unhappy Team

Employees might give numerous signals to indicate their discontent with the work environment. If you notice any of them in your workplace, you could easily amend the negative situation before losing a valuable team member.

Absence

Do they come to work on time? Do they leave early? Do they frequently miss work? While excessive absences could be related to personal issues at home and might not necessarily mean they are unhappy, they could also be an indication that your employees are actively searching for employment elsewhere. It could also be an indication that they don't feel their contributions to the projects are valued and, therefore, are bitter about coming to work.

For example, suppose a production tester is constantly late by one to two hours a few times a week. He might no longer feeling challenged on the project and might be resentful that his ideas are not more favorably received.

In some cases, there is little you can do to make the position on the project more challenging, especially one involving testing different configurations of the same product over and over again. However, simply ignoring the problems is also not the answer. To deal with this issue, you need to discuss the employees' expectations of their positions, and provide solutions.

Lack of Effort

Are they productive when they are at work? Do they miss deadlines or not care if they do? If they have assigned tasks and deadlines, do they use their time productively completing the tasks? Or do they waste a lot of time away from their desks, chatting with other employees, surfing the Web, or playing games and calling it "research?"

Note that this could also indicate that employees are overwhelmed by their tasks, and are afraid to discuss this with management. Rather than tackling the issue head-on, they just waste time hoping the problem will go away. The mere idea of talking to management can be intimidating for many employees.

Complaints

Do they frequently complain about management? Do they complain about other team members, specifically those in leadership roles? For example, "I could do his job better. Why did they hire this guy? He doesn't know anything about . . ." People who are disgruntled with management tend to think the grass is greener on the other side. The more proactive complainers will look for other jobs. The less proactive complainers will stay on, but their complaining will create an unpleasant work environment for other employees. This environment could potentially lead to more dissenters.

Commitment

Are they reluctant to commit to long-term assignments? Anyone who is thinking about leaving a job will be reluctant to commit to a long-term assignment. They will invent some excuse, but if they are unwilling to commit to long-term tasks, you need to find out why.

Apathy

Have they asked other people about their own job satisfaction? If they are dissatisfied, they will start talking to other employees to see if they can find other people to relate to. Particularly if they are unhappy with management, they will talk to other people to spread their unhappiness. Again, this could create an environment of snowballing discontent.

Unfulfilled Requests

If an employee has requested something, like a new computer, and has yet to have his or her needs addressed without a good explanation, the perceived lack of caring can have long-lasting consequences.


How to Address the Signs

The first thing to do when spotting a potentially unhappy employee is to talk with him or her. If you see any of the aforementioned signs, it is your job as a manager to find out what is going on. Obviously, you would deal with someone who has personal issues differently than with someone who has work-related issues, but you must uncover the issues first. Use questions such as: What do you think about this project? Is there anything you would like to have done differently? How would you handle this situation? (A good question to ask in instances when there are known problems with the project.) The answers to these questions can reveal a considerable amount of information about why the person is unhappy and what can be done to improve the situation.

Open communication is the key to spotting and addressing these signs. Is someone coming to you repeatedly about the same problem, even if you have addressed the problem? This probably means that you have not provided an acceptable solution for this person. You need to be open with this person and find out why he or she are dissatisfied. You cannot be all things to all people and some people will never be happy with what you do; however, some might have specific, fixable, reasonable requests. If you can discuss these reasons with them, you come closer to having a happier employee and creating a better environment.

As a manager, you need to be able to deal with all personality types effectively. Some team members respond well to blunt criticism, while others need more guidance and nurturing. Some people might be motivated by tight deadlines and will do their best and most productive work while they are in crunch mode. You need to deal with your team as both individuals and a team. You need to create the best working environment you can for the individual, while still doing what is best for the team.

Case Study 4.6.1: Real-life Team Leader Tales of and Tips for Success
Start example

In a GIGnews interview, a veteran, seasoned producer, and an art studio director, of a game development company in Austin, revealed some of their keys to successfully forming and keeping a happy team. Their story is comparable to that of the phoenix rising from the ashes and truly displays what a group can overcome and accomplish when working together as a big happy family. The art director briefly outlined the history of the studio, how it grew from 4 to almost 40 employees; they were purchased by a large international publisher that then suffered a bankruptcy; the studio kept going with self-sustaining cash flow from contracts and opted for their freedom again, forming their own company. He tells it so matter-of-factly that it is easy to forget the fact that the company that owned them filed for bankruptcy. How were they able to keep every single studio member during such incredible upheaval when other companies lose scores of employees for reasons that pale by comparison?

The studio management credits their ability to conquer what could have been a devastating situation to not only having two of the finest development teams in the industry, but also some extremely talented senior managers who kept cool heads through the many chaotic transitions. The team worked diligently to keep everyone together and focused on the future of their newly formed company. The producer kept the team on track and healthy, and acted as liaison with the publisher. Having a skilled support staff that stayed focused on getting the group up and running enabled the development team to stay focused on making games. "As far as the teams were concerned," says the producer, "we tried to make it as seamless as possible."

The leaders of the studio put forth the necessary effort to maintain the talented folks that they had. Although saddened by the news of the parent company's bankruptcy, they knew it was their obligation to complete their contracts in good faith for their clients. "Taking this responsibility seriously, weathering the resultant difficulties and seeing these projects through were conscious decisions on the part of every team member," says the art director.

When specifically asked what the magic is in assembling that kind of team and keeping it together, the art director stated that starting with a core of experience and honesty in establishing a studio that encourages the inclusion of ideas and abilities from all team members is paramount to success. He also stressed that management's purpose is to create an environment conducive to creativity and problem solving.

In conclusion, the producer emphasized that the key to keeping a team happy is to be as honest as possible, and provide as much information as you can.

End example


How to Avoid the Problems in the Future

It is important for management to be in touch with what goes on from day to day. Encourage an open door policy and be open to hearing complaints and suggestions.

Several successful studios have used some of the following benefits to create a work environment in which the employees feel welcomed and appreciated. You should consider trying some of these or your own creative ideas.

  • Good benefits (full medical, dental, paternity leave). Start with the basics and add benefits as your company grows.

  • Flexible working hours. The game industry thrives on its wealth of creative geniuses. Not everyone has his or her creative juices flowing by 9 a.m. Countless studies on business psychology have shown that flexible work schedules improve productivity, increase retention, and reduce absenteeism and tardiness.

  • Up-to-date, functional hardware. Employees quickly grow frustrated when dealing with equipment that is inadequate for the task assigned.

  • Downtime to play competitor's games. There is no greater bonding experience than tearing apart the competition's product.

  • Free sodas and snacks. These can be purchased very inexpensively by the case at wholesale clubs.

  • Dinner provided during crunch time. The team appreciates the free meal and less downtime is taken by having dinner at the office.

  • Working with others who are passionate about the project. The quickest way to sabotage a project and ultimately a company is to hire a bunch of burned-out, indifferent sourpusses. Game development has enough obstacles; you don't need any on your payroll.

  • Health club membership. Not only does it keep you fit, exercise is a known mood elevator. Mentally and physically healthy employees result in less absenteeism and increased alertness.

  • Ice Cream Day to celebrate monthly birthdays. Or cake or whatever. It's the thought that counts.

  • Monthly pizza for lunch. An inexpensive gesture that is greatly appreciated by a hungry team of developers.

  • Creative and appealing work environment. This doesn't mean designer copper-topped conference tables. Paint is cheap. Appealing colors inspire creativity, increase productivity, and relieve stress.

  • Launch/ship parties. A development studio in Austin does Mexican food and margaritas. They rent a margarita machine and order loads of the spicy cuisine. Reward the group for a job well done. It's much cheaper than replacing them for the next project.


The Power of Veto

There are certain hiring strategies that companies can also use to better their chances of creating a well-adjusted team. For years, Ensemble Studios has incorporated the veto into the interview and hiring process. Anyone in the company has the right to veto a candidate. Members of a game development team work too closely and rely too heavily on each other's work to not get along. It is imperative that the additions to the team be cohesive with current members for things to run relatively smoothly. Be mindful of the fact that you are asking team members to spend a horrific amount of time working, communicating, eating, and playing with this newest member of your game development family. The only way to determine if the chemistry will work is to allow the individual developers to have a voice in the matter. Without that, you risk creating an environment that could cause project delays, missed bonuses, employee resignations, and ultimately project cancellation. This veto strategy has been successful for Ensemble for years, so successful that other companies such as Big Huge and Iron Lore are now following suit. The psychological benefits of the power of veto are also numerous. By allowing team members to have a voice in the hiring process, you give them a sense of ownership in the company that translates to increased sense of pride and responsibility. With this augmented feeling of commitment to the company and the products created, the team is sure to benefit in quality of work produced, as well as loyalty to the team and company.


Corporate Culture and " Quality of Life " : Not Just a Slogan

Team LiB

Corporate Culture and "Quality of Life": Not Just a Slogan

Everyone has heard the adage "the family that plays together stays together." Well, the same is true for game development teams and companies. If you are able to create an environment that encourages respect and even friendship between the members of the team, retention is certain to increase. If individuals enjoy working with and feel obligated to their counterparts, it makes the decision for them to leave the company a great deal harder. Often the reason employees resist leaving their current company is because they fear disappointing their teammates. Pretty powerful. Many companies such as Turbine Entertainment put a great deal of thought and effort into creating a pleasant work environment that often extends into social events. For example, Debbie Waggenheim, human resources director for Turbine, includes planning movie screenings, company parties, and more as a crucial part of her job, ensuring that the employees feel not only appreciated by the company but also committed to it.


It's Not about the Money

Studies have repeatedly shown that money usually is not the reason why employees develop wandering eyes. Faced with losing a talented game developer, companies often counter offer in an effort at retention. Remember that it's rarely just about the money. Survey after survey has shown that only a small percentage who accept the counter offer remain with the company longer than six months. It's the intangibles that really create that sense of belonging to a studio.

Communication

Management needs to be forthright with the game developers. Learn how to talk and listen to the plethora of personality types involved in the creative and technological world of game development. Encourage communication from the team members; listen to them when they voice their opinions on everything from hiring to game design. When a potential problem begins to arise, address it immediately by talking with, not at, the individual.

Unity

Be mindful of what you are asking your team members to do. Although it sounds like something your Aunt Edna might have needle-pointed on a pillow, the golden rule still works, and works well. If you are going to require your team members to cancel their plans to come in on a Sunday, you, too, had better be present. No faster way to breed feelings of malcontent than to require game developers to be in a fluorescent-lit office while management is out riding jet skis on a sunny afternoon. In addition, creating opportunities for the group to play in a social setting increases the bond they have to the team, the project, and the company.

Appreciation

You don't have to shell out the big bucks to let your game developers know you value their efforts but you do have to actually take the time to say or show it. A simple verbal or written acknowledgment of a job well done still means something. Pick up breakfast on Fridays—a dozen doughnuts are only a few bucks. When milestones are met, send folks home early.


Conclusion

The sweatshop style of studio management should be long gone, but it is still very popular—and still very expensive in the long run. If you squeeze employees until they have nothing left to give, they'll leave at the first available opportunity. Recruiters have actually had programmers call in tears begging to get them out of these sweatshop studio scenarios. Initially, it might seem as if you are getting your money's worth out of that overworked and under appreciated game developer, but remember that you will later be hit with downtime to search for a replacement, downtime while the replacement acclimates to the new environment, a recruiter's fee, a relocation allowance, and several other unforeseen costs. As in so many other areas of game development, when forming and managing a game development team, it is imperative to see the big picture. And when looking at that big picture, you should see one happy, smiling team.


Chapter 4.7: Quality Assurance: Bug Tracking and Test Cases

Overview

Chris Campbell

<torgo@attbi.com>

Before you go to the grocery store, you probably make a list of the things you need so you won't forget anything. As a part of making the list, you check the pantry to see what items you have and which ones you need.

The manager in charge of the game development quality assurance process needs to plan in a similar manner. At all times, the manager needs to know exactly how many bugs already exist in the "pantry," which bugs still need to be found, and how to find them. It's not an easy job, but every game's survival in the marketplace depends on the final quality of the product, so it is essential to do it right.

This article is designed to provide you with ideas on how to start a bug-tracking system and how to formulate ways to find the bugs using test plans and statistical analysis. You will be surprised to learn how easy a system can be to set up, but be ready for the never-ending task of finding bugs.


The First Step Isn't Finding, It's Tracking

Most people mistakenly believe that the primary job of the quality assurance manager is to find software bugs. However, before a manager can find the bugs, he must also have a system in place to trace the bugs when found and track them until they are fixed. Unless you have a tracking system in place, a development team will spin its wheels trying to fix errors while missing new ones.

Why is tracking so important? Obviously, bug tracking allows you to log bugs as you find them so they are not forgotten and can be fixed. The real power in tracking comes when you use the data collected to form patterns and make some simple assumptions on where they might occur in the future. You can also identify programmers who are prone to making coding mistakes and those who ignore fixing requests.

Charts and graphs can be made showing combinations of data to your advantage. Unless you have a way to collect and store data, you will be missing out on many time-saving clues. For example, what if you wanted to know how many bugs were being found each month in a given area (Figure 4.7.1)?

Click To expand
Figure 4.7.1: New bugs found each month in each game development area.

By using time as your x-axis, you can rapidly see areas that might raise alarms. In this example, the number of bugs found in the 3D engine keeps growing. The manager needs to determine why, and whether more resources are needed. On the other hand, there are few bugs found in the Design area at the end of the chart. Maybe the team has solved nearly all of the design issues, but perhaps more attention needs to be focused in that area so it does not become neglected.

Without using a report of some type, this data is hard to see. You can also track your personnel to make sure they are fulfilling their responsibilities to correct errors as they are found (Figure 4.7.2).

Click To expand
Figure 4.7.2: Open bugs at the end of each month by developer.

In June, Monica and Louis are having trouble correcting their bugs at the end of the month. The manager needs to know if this is because of lack of motivation on the developer's part or some other reason. We can also see that Louis consistently closes out his bugs each month. Charts and reports make information like this readily available. Other reports can be generated to show average length of time a bug stays open, developer productivity, and success and failure rates of test cases. All this requires is a bug-tracking database.


Creating a Bug Tracker

What do you need to start a bug-tracking database? You can talk to several vendors who sell software packages that can do the job. If you have the money and are short on time, this can be a good way to get started. In most cases, however, you can save money by doing it yourself with a simple database using SQL or Access as the front end. It's even possible to make a simple tracking system using a spreadsheet or e-mail based system, although this type of system would not be as flexible.

Begin the database creation by outlining on paper what you want your bug entry form to look like. From there, you can determine what is required in the database fields. You would want to include areas for the date and time the bug was found and the version of the program in which the bug was found. Include areas for a description of the bug, the steps to reproduce the error, and any other special notations about the specific bug. It is highly recommended that you include an area for saving metadata such as log files or screenshots. Anything that would help the programmer replicate and understand how the bug was created should be included on this form. In fact, try to get feedback from the programmer about what is needed on the form during the creation process.

Case Study 4.7.1 contains a sample bug report form.

Case Study 4.7.1: How to Report Bugs
Start example

Your Company Name: ________________________ Bug Number: _________

Reported by: ________________________________ Assigned to: __________

Status: (Open/Closed/Hold) | Priority to fix: (High/Low)
Program: _______________ | Version: _____________
Error Type: ________ | Severity: _____

Programming error1. Fatal

Design issue2. Serious

Art3. Minor

Database

Hardware

DirectX

AI/Scripting

Documentation

Attachments? (Y/N)

Description of problem:

_____________________________________________________

_____________________________________________________

_____________________________________________________

_____________________________________________________

Steps to reproduce:

_____________________________________________________

_____________________________________________________

_____________________________________________________

_____________________________________________________

Resolution: ________ Fixed in Version: __________

Fixed

Hold

Not able to reproduce

Not fixed due to design

Not fixed due to other restraint

Withdrawn by tester

Need more info

Comments:

_____________________________________________________

_____________________________________________________

_____________________________________________________

_____________________________________________________

Resolved by: ___________________ Fix Tested by: ________________

End example

Once you have a rough draft on paper, you can quickly identify the database fields needed to store the information. Just by using the Wizard interface in Access, you can easily turn this form into a powerful tracking tool. It is also important to remember that a tracking tool is only beneficial if it is used consistently. Unless your team members use the tool daily, it will quickly become worthless. It is the quality assurance manager's job to ensure that no one treats bug tracking lackadaisically.


Test Case Planning: The Headhunter Method

Quality assurance can be tiring, tedious work. Do what you can to make it fun, but also ensure that the job is getting done. One way to remove the tedium from tracking bugs down is to treat it as a challenge. The following four-step method can help you in this regard.

Step One: Focus on the Target

Test case design starts at the earliest design phases of a game. If the game design calls for lots of role-playing action, you can start gearing your test cases toward heavy database test cases. If it calls for a first-person shooter, then in the initial phases of game testing you can expect to work with more API and game engine testing.

You also want to orient your testing toward the current milestone's requirements and to quantify your results. By using metrics, you can quickly establish baselines for each milestone and see where the project stands from a quality standpoint at any time.

For example, if the milestone requirement states that the game engine needs to be in a "playable state," you quickly need to define "playable." It could mean that the game runs at 20 frames per second or more. It could also mean that 30 out of 40 planned features are functional. Work with the designers and programmers to quantify the expected results of your test.

Step Two: Lay Out the Bait

Now that you have selected a goal, plan the test's execution accordingly. The basic rule is: if something can be measured, it can be tested. Thus, it is often best to work backward when preparing a test case. Ask yourself: if the game were to fail in this area, how would I catch it?

In addition, don't be afraid to combine multiple test cases into one, but be careful not to make your test scenarios so long or complicated that you can't analyze the results.

For example, consider boundary testing. Here you are testing the input and output limits of the program. How many commands can you queue up before the interface breaks? Exactly how many items can you carry? What if your text input box contains more than 255 characters?

Focus on visible state transitions. Every time you perform an action that changes the range of choices available to the player or modifies the display, you have made a state transition. The category includes menu systems, chat windows, display screens, and GUI changes. Test each option in every menu.

Testing the input/output interfaces can also reveal bugs. When the game is accessing the hard drive or CD-ROM, send a heavy load of commands. Can the I/O interface handle the load? What about networking? If too many packets are dropped or a connection is lost, how does it affect the game? Check for malformed data instructions or packets. Seeing how your game can handle extreme cases can quickly show areas of weakness in your programming.

Step Three: Set the Trap

You've planned your test case and now you are ready to execute. The first consideration is your test environment. The machine you are testing on should be as generic and pristine as possible to avoid any potential contamination problems from previous tests and exotic hardware. Therefore, in a test lab, it is advisable to set up a "ghost hard drive" image to copy to other machines when needed to start a new test case.

Make sure you have the tools necessary to perform the test and properly record a log of the test. There are plenty of tools freely available on the Internet that can capture screens, network packets, and chart running API threads.

Set your test run's objectives ahead of time. If testing in a multiplayer environment, make sure everyone involved is trained in proper testing procedures and has received precise instructions concerning their roles. Nothing is more frustrating than one person forgetting what to do at a critical moment in the test.

Step Four: Capture the Bug

When a bug is found, make sure that you have enough information to document it. Were screen captures made? Are the logs complete? The more information you have, the better. If time permits, try to replicate the bug as many times as possible. Vary the conditions to see if you can narrow the variables that cause the bug.

If no bug was found, the game might be working, or your plan might be flawed. Remember, you test to find bugs, not to see if everything in the game is working correctly. Go back to the drawing board. Alter the conditions somewhat in the area that you are testing. Throw everything you have at that area of the game. If your tests continue to reveal no bugs, save your test cases for another day for regression testing.

Retracing Your Steps

The fact that a bug wasn't found one day doesn't mean that it can't be found the next—or in the next version of the game. This is where regression testing comes into play.

Regression testing means retracing your steps and rerunning all your test cases. Perform it at successive milestones, and especially when code is locked down, at which point you should be able to run all of your test cases without a single failure. If one does occur, a bug has been inserted since the last round of regression testing. Fix the code and try again until you are able to achieve a perfect success rate.

Don't Forget to Test the Installation Routine

Once you have built your gold master, don't forget to design a few test cases for the installation and removal routines. With console design, the installation routine isn't important, but it can cause major headaches on personal computers. More than one software recall has been caused by an uninstaller that erased the entire hard drive!

If you have any extra material being placed on the master, make sure that they conform to company standards and formats. While the inclusion of static art assets for the enjoyment of the user wouldn't require a lot of formalized testing, don't forget to test other dynamic content such as screensavers, videos, and even music to ensure that they work with most platforms and players.


Other Resources and Methods to Consider

Once the method is in place, it becomes a matter of finding resources to execute the preceding plan. A common question is how many quality assurance staff should a company hire? Microsoft is often cited as having a 1:1 tester-to-developer ratio. Gaming companies rarely have the financial resources to achieve more than 1:3 or 1:7; the key lies in finding the balance for your company. Hire too many testers, and they won't have enough work to do; hire too few and there will be gaps in your testing strategy.

You should also use quantitative methods to monitor the progress of your testing. Defect seeding consists of purposefully inserting bugs into the code to see how many of them are found and to estimate how many actual bugs remain in the program. The formula [McConnell01] generally states that Total Defects equal the number of planted defects divided by the number of found defects, times the new defects found:

For example, if 30 defects are planted throughout the code and your testers find 14 of those along with 40 new ones, it is likely that the code contains about ( [image] ) × 40 = 85 defects, of which 45 remain to be found.


Conclusion

At some point, you need to release your product to the public. When does testing stop? For practical reasons, the criterion is usually a specific amount of time during which bugs of a certain priority level have not been found, or a mathematical equation like that previously mentioned estimating the number of bugs remaining in the code. Other companies stop testing when they feel adequate test coverage has been given to the game design. And sadly, some companies stop when they run up against the final milestone deadline. Plan ahead and choose a criterion—and do so when you design your test cases, not when the deadline catches up with you.

Careful planning and accurate testing will help you avoid the stigma of a post-release patch. By testing often and testing early with a tracking system in place, a quality assurance manager can avoid many pitfalls that can delay a game's path to the marketplace.


References

[McConnell01] McConnell, S., "Gauging Software Readiness with Defect Tracking," available online at www.stevemcconnell.com/bp09.htm

[Rice02] Rice, R., "The Elusive Tester to Developer Ratio," available online at www.riceconsulting.com/tester_to_developer_ratio.htm

Software Assurance Technology Center, NASA, available online at http://satc.gsfc.nasa.gov

International Organization for Standardization, "ISO 9000," available online at www.iso.ch/iso/en/iso9000-14000/iso9000/iso9000index.html


Index

A

Absolute Quality, 22
Acclaim, 67, 198–201
Accolade, 71
acquisition of companies, 117–124
Activision, 20, 66, 263
Actualize, 72
advance/R&D defined, 46
adver-gaming, 155
advertising agencies, role of, 23
agents, game, 203–208
Agent service, WirelessDeveloper, 142. See also game agents
Aggregator Sales model
general discussion, 131, 132, 136
Java 2Micro Edition (J2ME), 143
RealOne Arcade, 153–154
Wireless Application Protocol (WAP), 140
Aggressive Inline, 199
Aihoshi, Richard, 176, 177, 179
AIM (Alternative Investment Market), 71
Alien, 263
Aliens vs. Predator, 263
alpha milestone, 255
Alternative Investment Market (AIM), 71
amortization, R&D, 26
Anarchy Online, 277, 278, 282
Anderson, Janet, 68
angel financing, 17
anti-piracy techniques, 236–238
application programming interfaces (APIs), 24
Arcane, 40
Argonaut Software, 70, 72, 73, 74
art and animation service providers, 19–20
art design documents, 251–252
art & design teams, role of, 253–254, 257
Artifact, 150, 151
art production, 19, 300–301
Asheron's Call, 155, 276, 277, 278
ATI, 25
audit rights, 219
Average Revenue Per User (ARPU), 135


Index_B

Team LiB

Index

B

Babbages, 30
bad debts, handling, 166–168
Baggaley, Sean Timarco, 81, 83–91
balance sheets, 103
bank funding, 130
Barrett, Mark, 167–168
Bartlett, Ed, 173, 185–202
Best Alternative To Negotiated Agreement (BATNA), 9
Best Buy, 30
Beta Breakers Software Quality Assurance Labs, 22
beta milestone, 256–257
Big Red, 69
billing. See also costs
content aggregators, 143
freelance business, 20, 163–164
J2ME, 141
SMS messages, 135–136
Wireless Application Protocol (WAP) messages, 137, 140
Bioware Corporation, 17–18
Black Cat, 71
Blockbuster Video, 30
Blue Sky, 71
Bonnell, Bruno, 68
box & docs process, 267–268
breakeven point defined, 46
Bristol Coin Equipment (BCE), 70
Britsoft Paradox, 65, 72–74
Brown, Martyn, 191–192
bug trackers
creating, 319–321
debugging, 21
defect seeding, 324
defined, 286
Headhunter Method, 321–323
regression testing, 323
Bullfrog Productions Ltd, 89
bundle deals, 52
Burnout 2: Point of Impact, 199, 200
burn rate, 186
Buscaglia, Thomas, 173, 209–219
business management of development company. See also business plans
common errors, 89–91
communication, 86–87
management basics, 83–85
reputation, 87–88
business plans
business models, online
combined models, 153–157
content updates, 238
copy protection, 236–238
episodic digital distribution, 148–149
order tracking, 238
sales strategies, 235–236
traditional retail model, 145–147
virtual communities, 149–152
Web and retail sales, 3, 147–148
Web sites, 233–235
writing
capital structure, 104–105
company information, 97–98, 119–122
contents of, 94–98, 118–119
development plan, 98–100
financial plan, 100–103
market conditions, summarizing, 95–97
modulating, 95
purpose of, 93–94
unique selling points (USPs), 189, 190
valuation methods, 120–122
Businesswire, 180
buyer controls, retail, 31
buy-sell agreements, 122


Index_C

Team LiB

Index

C

Caen, Eric, 69
Caen, Hervé, 69
Cambron, Beverly, 173, 175–184
Cambron, Melanie, 57, 243, 307–315
Campbell, Chris, 244, 317–324
cancellation, risk of, 43–44
Cannell, Travis, 175, 179
Capcom, 66
capital structure, 104–105
Card Dash, 154
Cardoza Entertainment Inc., 288
Carrier Sales model, 131, 132, 143
cash flow statements, 101–102
Castle Wolfenstein, 107
casual piracy, 236–238
Cavanagh, Jane, 70
Centipede, 154
Centre Gold, 67, 70
Chen, Sande, 145–157
cherry picking, 31
Chronic Logic, 88
Chubb, Jeremy, 198–201
Claessens, Tanya, 35, 50
Clockwork, 72
closed platforms, 24
closeout games, 28
code ownership, 286
CogniToy, 147–148
collections, 166–168
Collins, Van, 148
Columbia Pictures, 263
combined business models, 153–157
commercial failure, risk of, 44
commission, game agents, 206
communication, 62, 63, 86–87, 286, 310
Compaq Computer Corporation, 25
completion bond funding, 17
concept development, 245–246
confidentiality, 213
console platforms, 26–27, 49
console publishers, 20–22, 267
consoles
console platforms, 26–27, 49
console publishers, 20–22, 267
Microsoft Xbox, 18, 26, 27, 191
Nintendo Game Boy Advance, 24, 27
Nintendo Gamecube, 18, 20, 23, 24, 26, 191
Sega Dreamcast, 27
Sony Playstation 2, 18, 20, 26, 191
content aggregators, 136, 140, 143. See also Aggregator Sales model
content specialists, 160
contracts. See also legal issues; licenses
business plans, 95
buy-sell agreements, 122
code ownership, 286
contracts and due diligence review, 122–123
contract testing, 22
cost-based, 33–34
development, 17, 47–48, 186–187
developer-specific considerations, 215–219
importance of contracts, 210–211
letter of intent, 210
payment schedules, 209–210
royalties, 210
standard sections, 212–215
game agents, 205–208
monetary aspects of, 33–35, 101
negotiating tools, 8
Non-Compete Agreement (NCA), 121
outsourcing, 285–286
prototyping, 186
publishing, 9–10, 187
royalty-based, 34–35, 39
work for hire, 186
worldwide publishers, 227
contracts and due diligence review, 122–123
contract testing, 22
convergent iteration, 248–250
Cook, Simon, 67
cooperative channel inventory management, 21
copy protection, 236–238
Core Design, 70
Cornwall, Charles, 69
cost and margin pricing model, 41
cost-based contracts, 33–34
costs. See also billing
art and animation providers, 19–20
game development, 16, 36
of goods, 46
motion capture, 19
"open to buy" budget, 32
price reductions, 52
pricing of games, 236
profitability of projects, 45–47
country-by-country model of publishing, 221, 223, 228–232
creative producer personality type, 60–61
creative risk management, 100
cross-collateralization, 45, 218
Cryo Interactive, 68, 71, 73, 75
customer service. See also employees; volunteers
general discussion, 51
planning, 274–275
policies, 275
staffing, 275–281


Index_D

Team LiB

Index

D

Dark Horse Interactive, 71
deals. See contracts
debt funding, 101. See also finances
debugging of game, 21
defect seeding, 324
delivery media manufacturers, role of, 27–28
Dell Computer Corporation, 25
Delphine Software International, 74
demo, creating, 189–191, 250, 264–265
Denki Ltd., 72
design documents
art, 251–252
content of, 188–189
game bible, 210
general discussion, 5–6, 56, 262, 285
localization, 299
technical, 251
design teams, role of, 253–254, 257
developer, headaches of, 38
developer/producer relationships, 55–64
developer/publisher relationship, 12
Develop magazine, 196
development, guiding
business plans
capital structure, 104–105
contents of, 94–98, 118–119
development plan, 98–100
financial plan, 100–103
purpose of, 93–94
producers, 47–48, 55–64
development companies. See game development companies
development contracts, 186. See also contracts
development kits, proprietary, 18
development software/hardware, license to use, 26
development team desirable attributes, 63
Di Cesare, Chris, 155, 156
DID, 72
Digital Integration, 71
Digital Tome, 148–149
direct expenses defined, 46
Direct Sales model
application of, 147–148, 151–152
general discussion, 131–132, 136–137, 145–146
Java 2Micro Edition (J2ME), 143
Wireless Application protocol (WAP), 139–140
Direct X API, 25
Disciples series, 50
distributors, role of, 28–29
Djafari, Thomas, 125–130
DMA Design, 72
Domark, 69
Doom, 88
Dragonrealms, 277, 278
3D Realms, 17–18
Dreamcatcher, 71
Dream Weavers, 72
due diligence defined, 123


Index_E

Team LiB

Index

E

earnings statements, 103
EBIT (Earnings Before Interest and Taxes) valuation method, 120, 121
Edgar, Les, 89
Edge, 23
editor, defined, 175
Eidos Interactive
acquisitions, 67, 72
finances of, 68, 73, 75
general discussion, 66, 69–70
Elast-O-Mania, 88
Electronic Arts, 20, 66, 89
Electronic Entertainment Expo (E3), 48
Electronic Game Monthly, 23
Electronics Boutique, 30
Elixir Studios, 72
Empire Interactive, 73, 75
employees. See also customer service; volunteers
finding, 109–110
interviewing, 113–115
legal issues, 276–277
management of
creation of positive work environment, 312–315
handling issues, 310–312
warning signs, 309–310
screening, 110–112
skills verification, 112–113
entities, role of, 15–32
equity funding, 101. See also finances
Europa Universalis series, 50
European Institute of Business Administration (INSEAD), 65
European ratings boards, 292
Everquest, 276, 277
executive staff, role of, 57
expansion packs, 52, 238
expected units defined, 46
extreme producer personality type, 61


Index_F

Team LiB

Index

F

feature complete milestone, 255
FICO score, 121–122
FilePlanet, 157
finances
amortization, R&D, 26
audit rights, 219
Average Revenue Per User (ARPU), 135
breakeven point defined, 46
burn rate, 186
buyer-side financing
business plan, 118–119 (See also business plans)
choosing a company, 117
financial data, 119–120
legal issues, 122–123
valuation methods, 120–122
capital structure, 104–105
Financière Legache, 68
general discussion, 88, 95, 100–105, 125–130, 161–164
gross revenue defined, 46
Marché Libre, 69
Nouveau Marché, 68, 69
revenue sharing, 17, 21–22
royalties
general discussion, 20, 25, 27, 215–216, 227, 229
payment of, 17, 38–40, 210
Second Marché, 68, 69
stock markets, role of, 74–75
tax and finance responsibilities, 21
Unlisted Stock Market (USM), 70
venture capital, 17, 101, 128–129
financial statements, pro forma, 101–103
Financière Legache, 68
financing, buyer-side
business plan, 118–119
choosing a company, 117
legal issues, 122–123
valuation methods, 120–122
Firaxis Games, 44
first-party games, 24
first playable demo, 250
freelancing. See also business plans; finances
collections, 166–168
finances, 161–164
marketing, 164–166
qualities necessary to succeed, 159–161
scheduling, 168–170
Frogwares Creative Game Design Labs, 286
functionality testing, 303–304


Index_G

Team LiB

Index

G

game agents, 203–208
game bible, 210. See also design documents
Game Developer magazine, 196
game developers
developer/producer relationships, 55–64
developer/publisher relationship, 12
misconceptions, 5–12, 107–108, 201
role of, 15–20
game development
art production, 19, 300–301
costs, 16, 36
post-production stage, 255–257, 261, 270
pre-production stage
box & docs process, 267–268
concept development, 246–248
console games, 267
convergent iteration, 248–249
design documents, 251, 262
goals of, 250–252
licenses, 262–264
marketing, 264–267
ports, 269
quality assurance, 268–269
production hierarchy, 58–59
production stage, 252–255, 261, 269
product path, entity positions, 16
product types, 187
stages of, 245–258, 268
technical disciplines of, 15–16
game development companies
Absolute Quality, 22
Acclaim, 67, 198–201
Accolade, 71
Activision, 20, 66, 263
Actualize, 72
Argonaut Software, 70, 72, 73, 74
Beta Breakers Software Quality Assurance Labs, 22
Big Red, 69
Bioware Corporation, 17–18
Black Cat, 71
Blue Sky, 71
Bullfrog Productions Ltd, 89
Capcom, 66
Cardoza Entertainment Inc., 288
Centre Gold, 67, 70
Chronic Logic, 88
Clockwork, 72
CogniToy, 147–148
Core Design, 70
Cryo Interactive, 68, 71, 73, 75
Dark Horse Interactive, 71
Delphine Software International, 74
Denki Ltd., 72
DID, 72
Digital Integration, 71
Digital Tome, 148–149
DMA Design, 72
Domark, 69
3D Realms, 17–18
Dreamcatcher, 71
Eidos Interactive
acquisitions, 67, 72
finances of, 68, 73, 75
general discussion, 66, 69–70
Electronic Arts, 20, 66, 89
Electronics Boutique, 30
Elixir Studios, 72
Empire Interactive, 73, 75
Firaxis Games, 44
Frogwares Creative Game Design Labs, 286
Gremlin, 71
GT Interactive, 71
Hasbro Interactive, 71
Havas Interactive, 67
id Software, 17–18
Infogrames Entertainment
finances, 73, 75
games sales, 66, 67
general discussion, 20, 45, 68, 71
Innerloop Studios, 72
Interplay, 65, 69, 71
Just Add Monsters, 72
Kalisto, 73, 74
Konami Global Entertainment Company, 66
Kutoka Industries, 35, 50
LTStudios Ltd., 72
Mainstream Interactive, 72
Midway, 67
Namco Group Worldwide, 67
Ocean Ltd., 71
Particle Systems, 72
Pathé Interactive, 68
Pivotal Games, 72
Pixo Inc., 139
Pure, 72
Pyro Studios, 72
Rage Software, 70, 72, 73, 74, 75
Red Storm Entertainment, 71
RenderWare Studio, 191
Samu Games, 150–151
Sarbakan, 40
SCi, 70–71, 72, 73, 74, 75
Silicon Graphics, 24
Simis, 69
Simutronics, 276
Sinister Games, 71
Square USA, 66
Strategy First, 45, 50–51
Tams11 Gaming Lobby, 151–152
Themis Group, 276
THQ, 20, 66
Titus Interactive, 65, 67, 69, 71, 73, 75
TLC, 71
Ubi Soft, 66, 67, 69, 71, 73, 75
Valve Software, 17–18
Virgin Interactive, 69, 71
Vivendi Universal Publishing (VUP), 66, 67
Wayward Design, 72
WildTangent, 24
game release license, 26
gamer-heavy stores, 31
games discussed
Aggressive Inline, 199
Alien, 263
Aliens vs. Predator, 263
Anarchy Online, 277, 278, 282
Arcane, 40
Artifact, 150, 151
Asheron's Call, 155, 276, 277, 278
Burnout 2: Point of Impact, 199, 200
Card Dash, 154
Castle Wolfenstein, 107
Centipede, 154
Disciples series, 50
Doom, 88
Dragonrealms, 277, 278
Edge, 23
Elast-O-Mania, 88
Europa Universalis series, 50
Everquest, 276, 277
Ghostbusters II, 263
Mind Rover: The Europa Project, 147
Myst, 107
Rayman, 69
Shanghai Second Dynasty, 264, 268
Siege of Avalon, 148
SteppenWolf, 40
Striker, 70
Tomb Raider, 67, 70
Toyota Adrenaline, 155
Ultima Online, 276, 277, 278
GameSpy, 156–157
GameSpy Arcade, 157
Game Spy 3D, 157
GameSpy Daily, 156
GameSpy On Demand, 157
game testing
contract testing, 22
functionality testing, 303–304
localizations, 303–304
playtesting, 21
regression testing, 323
test and integration plan, 252
test bed, 22
Gateway Computer Corporation, 25
generalist freelancers, 160
Ghostbusters II, 263
Gibson, Nick, 75
Golden Rule of Management, 84–86
gold master milestone, 257
Gremlin, 71
gross revenue defined, 46
gross unit price defined, 46
GT Interactive, 71


Index_H

Team LiB

Index

H

Hasbro Interactive, 71
Havas Interactive, 67
Headhunter Method, 321–323
Herashenko, Sergei, 286
hierarchy, production, 58–59
Hindorff, William, 61
Hollywood Video, 30
housekeeping responsibilities, 21
human resource responsibilities, 21


Index_I

Team LiB

Index

I

id Software, 17–18, 88, 236
indemnification, 207, 213. See also contracts
Infogrames Entertainment
finances, 73, 75
games sales, 66, 67
general discussion, 20, 45, 68, 71
ingredient marketing, 25
Innerloop Studios, 72
INSEAD (European Institute of Business Administration), 65
installation routines, 323
Intel Corporation, 25
intellectual property (IP), 17, 187, 211, 222, 263–264. See also legal issues; licenses
inter-carrier messaging, 133
interfaces defined, 86–87
Interplay, 65, 69, 71
inventor mindset, 8
investor relations, 21


Index_J

Team LiB

Index

J

Java 2Micro Edition (J2ME), 131, 139, 140–143
job descriptions, creating, 108–109. See also employees
Just Add Monsters, 72


Index_K

Team LiB

Index

K

Kalisto, 73, 74
Kawahara, Michael, 61
Kernan, Tenzing, 288
Konami Global Entertainment Company, 66
Kroegel, Charles, 50–51
Kutoka Industries, 35, 50


Index_L

Team LiB

Index

L

Lang, Jack, 67
Laramée, François Dominic, 3, 33–41, 43–53, 93–105, 159–170
Larrue, Philippe, 4, 65–77
Lazonick, William, 4, 65–77
Lefranc, Jean-Martial, 68
legal/business affairs, role of, 57
legal issues. See also licenses
buyer-side financing, 122–123
code ownership, 286
confidentiality, 213
employees, 276–277
legal-business affairs, role of, 57
legal services issues, 21
volunteers, 276–277
legal services issues, 21
letter of intent, 210
licenses. See also legal issues
console game development, 26, 27
and contracts, 212
general discussion, 21, 277
localizations, 293
pre-production stage of game development, 262–264
third-party license, 187
lifestyle purchases, 52
linguistic testing, 303
Livingstone, Ian, 69
localizations
budget, 295–296
costs of, 292–294
cultural differences, 291–292
integration of assets, 302–303
licenses, 293
management of, 296–297
schedules, 294–295
staggered vs simultaneous release, 293–294
technical considerations, 297–302
testing, 303–304
LTStudios Ltd., 72
Lycos, 150


Index_M

Team LiB

Index

M

macro design, 248
macro design documents, 251
macro manager producer personality type, 60
Macromedia Flash, 99
Mainstream Interactive, 72
management
bad debts, handling, 166–168
communication, 62, 63, 86–87, 286, 310
cooperative channel inventory, 21
creative risk management, 100
customer service
general discussion, 51
planning, 274–275
policies, 275
staffing, 275–281
development business, 83–91
development team desirable attributes, 63
development teams, 307–315
employees
creation of positive work environment, 312–315
finding, 109–110
handling issues, 310–312
interviewing, 113–115
legal issues, 276–277
screening, 110–112
skills verification, 112–113
warning signs, 309–310
Golden Rule of Management, 84–86
localizations, 296–297
management responsibilities, 21
misconceptions of business managers, 89–90
personality types, of managers, 60
responsibilities, 21
schedules, 168–169
volunteers, role of, 276, 277–278, 279–281
manufacturer's advertised price (MAP) program, 31
manufacturers' representatives, role of, 29
Marché Libre, 69
market conditions, summarizing, 95–97
marketing
country-by-country publishing, 229
defined, 46, 57
expenses, 49
freelance services, 164–166
ingredient, 25
market conditions, summarizing, 95–97
pitching
defined, 185
preparation, 187–189
presentation, 193–194, 196–201
schedule and budget, 191–192
to the press, 48–49
press releases
following up, 180–182
releasing, 179–180
writing, 175–179
product to consumers, 21, 23, 264–266
to retailers, 48
and sales licenses, 26
white space advertising, 31
word-of-mouth, 87–89
worldwide publishing, 225–226
Matsushita, Jeff, 298
Maxwell, Heather, 243, 291–304, 307–315
McCuskey, Mason, 3, 5–12, 174, 233–239
McGilvray, Mitzi, 3, 55–64
Meier, Sid, 44
memetic marketing, 87–89
merchandising teams, role of, 23
Mia the mouse, 35
Michael, David, 150
Michael, Douglas, 150
micro design, 248
micro manager producer personality type, 60
Microsoft, 24
Microsoft Direct X API, 25
Microsoft Xbox, 18, 26, 27, 191
middleware, 190–191
Midway, 67
milestones, 254–257, 285
Mind Rover: The Europa Project, 147
misconceptions
business managers, 89–90
new game developers, 5–12, 107–108, 201
mobile originated messages, 133, 137
mobile terminated messages, 133
mocap. See motion capture
Molyneux, Peter, 66, 74, 89
Moore's law of increasing computing power, 18
motion capture service providers, 18–19
multiplayer online role-playing games (MMORPGs), 150
Myst, 107


Index_N

Team LiB

Index

N

Namco Group Worldwide, 67
national retailers, role of, 30
negotiating tools, 8
NewKidCo International Inc., 47
Newsweek, 23
Nintendo, 69
Nintendo Game Boy Advance, 24, 27
Nintendo Gamecube, 18, 20, 23, 24, 26, 191
Non-Compete Agreement (NCA), 121
Nouveau Marché, 68, 69
NPD, 32
NVIDIA, 25


Index_O

Team LiB

Index

O

Ocean Ltd., 71
offshore outsourcing
benefits of, 283–284
choosing a provider, 287–288
myths of, 284
stages of, 285–287
online business models
combined models, 153–157
content updates, 238
copy protection, 236–238
episodic digital distribution, 148–149
order tracking, 238
sales strategies, 235–236
traditional retail model, 145–147
virtual communities, 149–152
Web & retail sales, 3, 147–148
Web sites, 233–235
online customer support
general discussion, 51
planning, 274–275
policies, 275
staffing, 275–281
online game registration, 235–236, 237, 292
online ordering, 234–235, 238
OpenGL API, 25
open platforms, 24
"open to buy" budget, 32
operations, role of, 268
ordering online, 234–235, 238
O'Sullivan, Mary, 4, 65–77
Otaegui-Sabarasa, Javier, 243
Outsmart, 155
outsourcing, offshore
benefits of, 283–284
choosing a provider, 287–288
myths of, 284
stages of, 285–287
ownership of code, 286


Index_P

Team LiB

Index

P

Park, Andrew, 177, 178, 179, 180
Particle Systems, 72
PartnerMatch service, WirelessDeveloper, 142
Pathé Interactive, 68
PC Gamer, 67
PC platform, 24–26, 49, 191
PC publishers, 20–22
per-character polygon count, 19
Perkins, Terri L., 273–282
permission to create game, 26
personality types, of managers, 60–61
Pfeifer, Borut, 173, 203–208
Philips and Chargeurs, 68
phone home registration method, 237
Pinpoint Fuel Developer Program, 134
Pinpoint Networks Incorporated, 134–135
piracy, 236–238
pitching. See also marketing
defined, 185
preparation, 187–189
presentation, 193–194, 196–201
schedule and budget, 191–192
types of deals, 186–187
Pivotal Games, 72
Pixo Inc., 139
platform, choosing, 190
platform, of games, 11, 38
platform holders, 24–28
playtesting of games, 21
Pontifex, 88
porting process, 269
post-production stage of game development, 255–257, 261, 270
Powell, Jay, 174, 221–232
Predator, 263
pre-production documents, 251, 262
pre-production stage of game development
box & docs process, 267–268
concept development, 246–248
console games, 267
convergent iteration, 248–249
design documents, 251, 262
goals of, 250–252
licenses, 262–264
marketing, 264–267
ports, 269
quality assurance, 268–269
press releases
following up, 180–182
releasing, 179–180
writing, 175–179
price reductions, 52
pricing of games, 236
private investors, 129
PR Newswire, 180
process specialists, 160–161
producer, role of, 47–48, 55–64
production hierarchy, 58–59
production stage of game development, 252–255, 261, 269
product path, entity positions, 16
product types, 187
profitability of projects, 45–47
profitability ratio defined, 46
profits and losses statements, 43, 121
pro forma financial statements, 101–103
project, defined, 61
proof of concept demos, 189
prototyping contracts, 186
public relations, 23, 175–184
publisher/developer relationship, 12
publisher funding, 127–128
publishers
characteristics of, 6–8, 11, 12, 20–22
choosing, 194–196
country-by-country model of publishing, 221, 223, 228–232
follow-up, 200–201
models for distributing titles, 221
PC, 20–22
pitching, 196–200 (See also pitching)
publisher funding, 127–128
publishing contracts, 9–10, 187
responsibilities of, 21, 30–31, 37, 43–53
risks of, 43–45
publishing contracts, 9–10, 187. See also contracts
Pure, 72
Pyro Studios, 72


Index_Q

Team LiB

Index

Q

quality assurance
bug tracking, 317–319
creating a bug tracker, 319–321
defect seeding, 324
general discussion, 21, 22, 252, 268–269
Headhunter Method, 321–323
installation routines, 323
Quirk, Kent, 147


Index_R

Team LiB

Index

R

Rage Software, 70, 72, 73, 74, 75
Rayman, 69
R&D amortization, 26
RealOne Arcade, 153–154
RealOne Arcade Development Service, 154
recording studios, 266–267
Red Storm Entertainment, 71
reductions in price, 52
regional retailers, role of, 29–30
registration of games, 235–236, 237, 292. See also copy protection
regression testing, 323
relationships, maintaining, 21
RenderWare Studio, 191
rental-ready games, 28
rental retailers, role of, 30
rep groups, role of, 29
Request for Proposal, 285
responsibilities of publishers, 21, 30–31, 37, 43–53
retail entities, role of, 28–32, 36–38, 48, 145–147
revenue, gross, 46
revenue sharing, 17, 21–22, 136. See also royalties
risk management, creative, 100
risks of publishing, 43–45
risks vs. returns, 125–127
Roger Wilco, 157
Rosenfeld, Seth, 47
royalties. See also revenue sharing
general discussion, 20, 25, 27, 215–216, 227, 229
payment of, 17, 38–40, 210
royalty-based contracts, 34–35, 39
Rozsa, Balasz, 88
Rule of 800, 163
rules
Golden Rule of Management, 84–86
Moore's law of increasing computing power, 18
Rule of 800, 163
400 Word Rule, 177


Index_S

Team LiB

Index

S

sales of games. See also online business models
Aggregator Sales model
general discussion, 131, 132, 136
Java 2 Micro Edition (J2ME), 143
RealOne Arcade, 153–154
Wireless Application Protocol (WAP), 140
Carrier Sales model, 131, 132, 143
combined models, 153–157
Direct Sales model
application of, 147–148, 151–152
general discussion, 131–132, 136–137, 145–146
Java 2Micro Edition (J2ME), 143
Wireless Application protocol (WAP), 139–140
retail entities, role of, 28–32, 36–38, 48, 145–147
sales strategies, 235–236
statistics, retail, 36
traditional retail models, 145–147
unique selling points (USPs), 189, 190
virtual communities, 149–152
Web & retail sales, 3, 147–148
sales pitch
misconceptions of, 10–11
pitching defined, 185
preparation, 187–189
presentation, 193–194, 196–201
schedule and budget, 191–192
types of deals, 186–187
sales strategies, 235–236
Samu Games, 150–151
San, Jez, 70
Sapet, Christian, 68
Sarbakan, 40
schedules, 10, 168–169
Schoback, Kathy, 3, 15–32
Schreiner, Ole, 273
SCi, 70–71, 72, 73, 74, 75
SCORE (Service Corps of Retired Executives), 123
Second Marché, 68, 69
Sega, 20, 69
Sega Dreamcast, 27
Sellers, Michael, 243, 245–258
sequels to games, 53
service aggregators, 136, 140, 143. See also Aggregator Sales model
Service Corps of Retired Executives (SCORE), 123
Shanghai Second Dynasty, 264, 268
shelf keeping units (SKU), 190
Shiflett, James, 148
shipping of finished game, 21
Short Message Service Centers (SMSC), 133
Short Message Service (SMS), 131, 132–136
Siege of Avalon, 148
Silicon Graphics, 24
Silicon Graphics OpenGL API, 25
Simis, 69
Simutronics, 276
Sinister Games, 71
Sloper, Thomas, 117, 243, 261–270
Small Business Administration (SBA), 121, 122
Small Business Development Center (SBDC), 122
Sony, 69
Sony Playstation 2, 18, 20, 26, 191
Splinter Design, 72
spoofing, 237
Square USA, 66
staffing issues
creating job descriptions, 107–109
finding, 109–110
interviewing, 113–115
screening, 110–112
skills verification, 112–113
Stainless Software, 72
Stanton, Grant, 107–116
statements
financial statements, pro forma, 101–103
profits and losses statements, 43, 121
statistics, retail, 36
SteppenWolf, 40
stock markets, role of, 74–75
Strategy First, 45, 50–51
strategy guides, 266
Striker, 70
success, defined, 5
Surfas, Mark, 156, 157


Index_T

Team LiB

Index

T

Take 2 Interactive, 66
Tams11 Gaming Lobby, 151–152
Target, 30
tax and finance responsibilities, 21
team leader producer personality type, 60
technical design documents, 251
technical directors, role of, 57
technical support. See also employees; volunteers
monitoring, 281–282
planning, 51, 273–275
policies, 275
staffing options, 275–278
staff size, calculating, 278–279
turnover, 279–281
technical team, role of, 253, 254, 264
technologies, proprietary, 21
test and integration plan, 252
test bed, 22
testing, games
contract testing, 22
functionality testing, 303–304
localizations, 303–304
playtesting, 21
regression testing, 323
test and integration plan, 252
test bed, 22
texture memory, limited, 19
THE, 20, 66
The First Quarter: A 25-Year History of Video games (Cent), 66
Themes Group, 276
third-party games, 24
third-party license, 187
Tiptoes Interactive, 65, 67, 69, 71, 73, 75
TLC, 71
Tomb Raider, 67, 70
Toyota Adrenaline, 155
Toys-R Us, 30
tracking bugs, 286, 317–324
trademarks, 21, 26
trade shows, 266
TRSTS data, 32
Tvedt, Ørhan Mathis, 280
Twentieth Century Fox, 263
types of products, 187


Index_U

Team LiB

Index

U

Ubi Soft, 66, 67, 69, 71, 73, 75
Ulrich, Philippe, 68
Ultima Online, 276, 277, 278
uninstallation routines, 323
unique selling points (USPs), 189, 190
United Kingdom Department of Media, Culture, and Art, 65, 75
Unlisted Stock Market (USM), 70
U.S. Labor Law, 276
USA Today, 23
user interfaces, localizing, 298
US Gold, 70


Index_V

Team LiB

Index

V

Vallerand, Richard, 40
valuation methods, 120–122
Valve Software, 17–18
venture capital, 17, 101, 128–129
viral marketing, 87–89
Virgin Interactive, 69, 71
Vivendi Universal Publishing (VUP), 66, 67
volunteers, role of, 276, 277–278, 279–281. See also customer service; employees


Index_W

Team LiB

Index

W

Wal-Mart, 30, 31
Warner Brothers Online, 40
warranties, 213
Warthog, 73
Wayward Design, 72
Web site design, 233–234
white space advertising, 31
WildTangent, 24
Wilson, Johanna, 131–144
Wireless Application Protocol (WAP), 131, 137–140
WirelessDeveloper, 142
word-of-mouth marketing, 87–89
400 Word Rule, 177
work for hire contracts, 186
world-wide model of publishing, 221, 223–228
Wright, Andrew, 154


Index_Y

Team LiB

Index

Y

Yahoo!, 150


Index_Z

Team LiB

Index

Z

Zone.com, 154–156
Zreality, 276


List of Figures

Chapter 1.2: The Role of Each Entity in Game Publishing

Figure 1.2.1: Position of each entity in the product path for a console game.

Chapter 1.5: The Producer, Friend or Foe?

Figure 1.5.1a: Percentage of male and female producers.
Figure 1.5.1b: Producer compensation.
Figure 1.5.2: Production hierarchy.
Figure 1.5.3: A producer's day.

Chapter 2.6: Wireless Business Models

Figure 2.6.1: Sales models.
Figure 2.6.2: SMS connectivity options.
Figure 2.6.3: WAP connectivity options.
Figure 2.6.4: J2ME connectivity options.

Chapter 2.7: Online Business Models: Using the Net for Profit

Figure 2.7.1: In the traditional retail model, the publisher owns and controls the rights to the game. The developer supplies the game to the publisher, who then negotiates with distributors and retailers to reach the customer.
Figure 2.7.2: CogniToy's self-published game, Mind Rover, was sold direct-to-customer via its Web site and through intermediaries. EBWorld, like its parent company, sells on consignment.
Figure 2.7.3: Digital's Tome game, Siege of Avalon, was sold to consumers through a subscription or a la carte. Digital Tome paid Digital River, a third-party transaction company, a percentage of the sales.
Figure 2.7.4: Samu Games' self-published game, Artifact, is free to play, but access time is sold direct-to-customer via the Web site. The company relies on referrals and low-cost word-of-mouth advertising from its virtual community to increase its subscription rate.
Figure 2.7.5: RealOne Arcade aggregates games from publishers and independent developers. Advertisers are eager to reach consumers of the high profile site.
Figure 2.7.6: Zone.com aggregates games from different publishers for retail matchmaking. Advertisers promote products to consumers through sponsored games.
Figure 2.7.7: GameSpy business model.

Chapter 2.8: Creating a Successful Freelance Game Development Business

Figure 2.8.1: Sample schedule.

Chapter 4.1: The Stages of Game Development

Figure 4.1.1: The stages of game development and the approximate duration of each.
Figure 4.1.2: The process of convergent iteration shown over the stages of game development. Note that the upward strokes are define—design—implement, while the downward strokes are evaluation phases. The number of phases shown will vary by project, and is not meant to be taken literally.
Figure 4.1.3: In some cases you might find that your project is not converging on a single game. This can happen if you did not start with a clear concept, or if external requirements change throughout the life of the project.
Figure 4.1.4: If you race into production too quickly, you might find your project wandering through the conceptual space in the late (and expensive) stages.

Chapter 4.7: Quality Assurance: Bug Tracking and Test Cases

Figure 4.7.1: New bugs found each month in each game development area.
Figure 4.7.2: Open bugs at the end of each month by developer.


List of Tables

Chapter 1.2: The Role of Each Entity in Game Publishing

Table 1.2.1: Generalized Breakdown of Revenue from a $50 Console Game

Chapter 1.6: The European Challenge in Videogame Software: The "French Touch" and the "Britsoft Paradox"

Table 1.6.1: Top 15 Independent Videogame Publishers of 2001 Information adapted from the Financial Report 2000/2001 of UbiSoft.
Table 1.6.2: Revenues, Net Profits, and Employees of Leading French and British Videogame Companies, in millions. Information adapted from Thomson Analytics database [Thomson].
Table 1.6.3: Cash Raised Through Share Issues and Long-Term Debt Issues by Leading French and British Videogame Companies, in €millions. Information adapted from Thomson Analytics database [Thomson].

Chapter 2.2: Writing a Business Plan for a Game Development Startup

Table 2.2.1: Simple Cash Flow Statement (Simple Studios Inc.)
Table 2.2.2: Simple Earnings Statement (Simple Studios Inc.)

Chapter 4.3: Customer Support in Massively Multiplayer Online Games

Table 4.3.1: Customer Service Models

Chapter 4.5: Localizations

Table 4.5.1: Asset Overview Form
Table 4.5.2: Estimate for Development Costs
Table 4.5.3: Spreadsheet for Text Translation
Table 4.5.4: Spreadsheet for Audio Translation
Table 4.5.5: Linguistic Bug Report Template


List of Case Studies

Chapter 1.3: How Developers Get Paid: The Retail Market for Games

Case Study 1.3.1: Self-Publishing
Case Study 1.3.2: Royalties versus Guarantees

Chapter 1.4: A Publishing Project: From Concept to Launch and Beyond

Case Study 1.4.1: Estimating a Project's Profitability
Case Study 1.4.2: How a Publisher Selects a Team for Contract Development
Case Study 1.4.3: Self-Publishing (Continued)
Case Study 1.4.4: A Publisher Profile

Chapter 2.1: Development Misery and How to Avoid It

Case Study 2.1.1: A Brief History of MS-DOS

Chapter 2.2: Writing a Business Plan for a Game Development Startup

Case Study 2.2.1: Modulating the Business Plan
Case Study 2.2.2: Creative Risk Management
Case Study 2.2.3: Minimizing the Cost of Money

Chapter 2.6: Wireless Business Models

Case Study 2.6.1: Pinpoint Networks Inc.
Case Study 2.6.2: Pixo
Case Study 2.6.3: WirelessDeveloper

Chapter 2.8: Creating a Successful Freelance Game Development Business

Case Study 2.8.1: Financial Planning
Case Study 2.8.2: Mark Barrett, Prairie Arts

Chapter 3.1: Public Relations: Making the Most of the Gaming Press

Case Study 3.1.1: Game Reviewer Perks and Playola
Case Study 3.1.2: A Sample Press Release

Chapter 3.2: Securing a Development Contract: The Art of Pitching

Case Study 3.2.1: Team 17
Case Study 3.2.2: Acclaim

Chapter 3.5: Pros and Cons of Worldwide and Country-by-Country Deals

Case Study 3.5.1: Evaluating Intellectual Property
Case Study 3.5.2: What to Include in a Package to a Worldwide Publisher
Case Study 3.6.3: What to Include in a Package to a Country-by Country Publisher

Chapter 4.3: Customer Support in Massively Multiplayer Online Games

Case Study 4.3.1: Planning Customer Service
Case Study 4.3.2: Customer Service Policies
Case Study 4.3.3: Volunteers, Games, and the Law
Case Study 4.3.4: Comparison of Games and Support Models
Case Study 4.3.5: Staffing a Volunteer Program
Case Study 4.3.6: Rewarding Customer Service Staff

Chapter 4.4: Offshore Game Development Outsourcing

Case Study 4.4.1: The Provider's Side
Case Study 4.4.2: The Client's Side

Chapter 4.6: Leadership: The Making of Effective and Happy Teams

Case Study 4.6.1: Real-life Team Leader Tales of and Tips for Success

Chapter 4.7: Quality Assurance: Bug Tracking and Test Cases

Case Study 4.7.1: How to Report Bugs


List of Sidebars

Preface

Emerging Game Development Communities
Freedom of Expression

Team LiB
Previous Section