DecalType

DecalText | 0
DecalImage | 1


ImageAlignment

ImageAlignWorld | 0
ImageAlignTopLeft | 1
ImageAlignCenter | 2


KickerType

KickerHidden | 0
KickerHole | 1
KickerCup | 2


LightState

LightStateOff | 0
LightStateOn | 1
LightStateBlinking | 2


RampImageAlignment

ImageModeWorld | 0
ImageModeWrap | 1


RampType

RampTypeFlat | 0
RampType4Wire | 1
RampType2Wire | 2
RampType3WireLeft | 3
RampType3WireRight | 4


ReelType

ReelText | 0
ReelImage | 1


SequencerState

SeqUpOn | 1
SeqUpOff | 2
SeqDownOn | 3
SeqDownOff | 4
SeqRightOn | 5
SeqRightOff | 6
SeqLeftOn | 7
SeqLeftOff | 8
SeqDiagUpRightOn | 9
SeqDiagUpRightOff | 10
SeqDiagUpLeftOn | 11
SeqDiagUpLeftOff | 12
SeqDiagDownRightOn | 13
SeqDiagDownRightOff | 14
SeqDiagDownLeftOn | 15
SeqDiagDownLeftOff | 16
SeqMiddleOutHorizOn | 17
SeqMiddleOutHorizOff | 18
SeqMiddleInHorizOn | 19
SeqMiddleInHorizOff | 20
SeqMiddleOutVertOn | 21
SeqMiddleOutVertOff | 22
SeqMiddleInVertOn | 23
SeqMiddleInVertOff | 24
SeqStripe1HorizOn | 25
SeqStripe1HorizOff | 26
SeqStripe2HorizOn | 27
SeqStripe2HorizOff | 28
SeqStripe1VertOn | 29
SeqStripe1VertOff | 30
SeqStripe2VertOn | 31
SeqStripe2VertOff | 32
SeqHatch1HorizOn | 33
SeqHatch1HorizOff | 34
SeqHatch2HorizOn | 35
SeqHatch2HorizOff | 36
SeqHatch1VertOn | 37
SeqHatch1VertOff | 38
SeqHatch2VertOn | 39
SeqHatch2VertOff | 40
SeqCircleOutOn | 41
SeqCircleOutOff | 42
SeqCircleInOn | 43
SeqCircleInOff | 44
SeqClockRightOn | 45
SeqClockRightOff | 46
SeqClockLeftOn | 47
SeqClockLeftOff | 48
SeqRadarRightOn | 49
SeqRadarRightOff | 50
SeqRadarLeftOn | 51
SeqRadarLeftOff | 52
SeqWiperRightOn | 53
SeqWiperRightOff | 54
SeqWiperLeftOn | 55
SeqWiperLeftOff | 56
SeqFanLeftUpOn | 57
SeqFanLeftUpOff | 58
SeqFanLeftDownOn | 59
SeqFanLeftDownOff | 60
SeqFanRightUpOn | 61
SeqFanRightUpOff | 62
SeqFanRightDownOn | 63
SeqFanRightDownOff | 64
SeqArcBottomLeftUpOn | 65
SeqArcBottomLeftUpOff | 66
SeqArcBottomLeftDownOn | 67
SeqArcBottomLeftDownOff | 68
SeqArcBottomRightUpOn | 69
SeqArcBottomRightUpOff | 70
SeqArcBottomRightDownOn | 71
SeqArcBottomRightDownOff | 72
SeqArcTopLeftUpOn | 73
SeqArcTopLeftUpOff | 74
SeqArcTopLeftDownOn | 75
SeqArcTopLeftDownOff | 76
SeqArcTopRightUpOn | 77
SeqArcTopRightUpOff | 78
SeqArcTopRightDownOn | 79
SeqArcTopRightDownOff | 80
SeqScrewRightOn | 81
SeqScrewRightOff | 82
SeqScrewLeftOn | 83
SeqScrewLeftOff | 84
SeqLastDynamic | 85
SeqAllOff | 1000
SeqAllOn | 1001
SeqBlinking | 1002
SeqRandom | 1003


Shape

ShapeCircle | 0
ShapeCustom | 1


SizingType

AutoSize | 0
AutoWidth | 1
ManualSize | 2


TextAlignment

TextAlignLeft | 0
TextAlignCenter | 1
TextAlignRight | 2


VBColors

vbBlack | 0
vbRed | 255
vbGreen | 65280
vbYellow | 65535
vbBlue | 16711680
vbMagenta | 16711935
vbCyan | 16776960
vbWhite | 16777215


VBComparison

vbBinaryCompare | 0
vbTextCompare | 1


VBDateFormat

vbGeneralDate | 0
vbLongDate | 1
vbShortDate | 2
vbLongTime | 3
vbShortTime | 4


VBDateTime

vbSunday | 1
vbMonday | 2
vbTuesday | 3
vbWednesday | 4
vbThursday | 5
vbFriday | 6
vbSaturday | 7
vbUseSystem | 0
vbUseSystemDayOfWeek | 0
vbFirstJan1 | 1
vbFirstFourDays | 2
vbFirstFullWeek | 3


VBMsgBox

vbOKOnly | 0
vbOKCancel | 1
vbAbortRetryIgnore | 2
vbYesNoCancel | 3
vbYesNo | 4
vbRetryCancel | 5
vbCritical | 16
vbQuestion | 32
vbExclamation | 48
vbInformation | 64
vbDefaultButton1 | 0
vbDefaultButton2 | 256
vbDefaultButton3 | 512
vbDefaultButton4 | 768
vbApplicationModal | 0
vbSystemModal | 4096


VBMsgBoxReturn

vbOK | 1
vbCancel | 2
vbAbort | 3
vbRetry | 4
vbIgnore | 5
vbYes | 6
vbNo | 7


VBTriState

vbUseDefault | -2
vbTrue | -1
vbFalse | 0


VBVarType

vbEmpty | 0
vbNull | 1
vbInteger | 2
vbLong | 3
vbSingle | 4
vbDouble | 5
vbCurrency | 6
vbDate | 7
vbString | 8
vbObject | 9
vbError | 10
vbBoolean | 11
vbVariant | 12
vbDataObject | 13
vbDecimal | 14
vbByte | 17
vbArray | 8192


Ball

Properties

BackDecal
Color
FrontDecal
Image
UserValue
VelX
VelY
VelZ
X
Y
Z

Methods

Events


Ball.X

Property X as Double

See Also
Ball


Ball.Y

Property Y as Double

Ball


Ball.VelX

Property VelX as Double

Ball


Ball.VelY

Property VelY as Double

Ball


Ball.Z

Property Z as Double

Ball


Ball.VelZ

Property VelZ as Double

Ball


Ball.Color

Property Color as OLE_COLOR

Ball


Ball.Image

Property Image as String

Ball


Ball.FrontDecal

Property FrontDecal as String

Ball


Ball.BackDecal

Property BackDecal as String

Ball


Ball.UserValue

Property UserValue as Variant

Ball


Bumper

Properties

BlinkInterval
BlinkPattern
CastsShadow
Color
Disabled
FlashWhenHit
Force
Image
Name
Overhang
Radius
SideColor
State
Surface
Threshold
TimerEnabled
TimerInterval
UserValue
X
Y

Methods

Events

Hit
Init
Timer


Bumper_Init

Sub Bumper_Init()

See Also
Bumper


Bumper_Timer

Sub Bumper_Timer()

See Also
Bumper


Bumper_Hit

Sub Bumper_Hit()

See Also
Bumper


Bumper.Radius

Property Radius as Single

Bumper


Bumper.X

Property X as Single

Bumper


Bumper.Y

Property Y as Single

Bumper


Bumper.State

Property State as LightState

Bumper


Bumper.BlinkPattern

Property BlinkPattern as String

Bumper


Bumper.BlinkInterval

Property BlinkInterval as Integer

Bumper


Bumper.FlashWhenHit

Property FlashWhenHit as Boolean

Bumper


Bumper.SideColor

Property SideColor as OLE_COLOR

Bumper


Bumper.UserValue

Property UserValue as Variant

Bumper


Bumper.Surface

Property Surface as String

Bumper


Bumper.Force

Property Force as Single

Bumper


Bumper.Threshold

Property Threshold as Single

Bumper


Bumper.TimerEnabled

Property TimerEnabled as Boolean

Bumper


Bumper.TimerInterval

Property TimerInterval as Integer

Bumper


Bumper.Overhang

Property Overhang as Single

Bumper


Bumper.Color

Property Color as OLE_COLOR

Bumper


Bumper.Image

Property Image as String

Bumper


Bumper.Name

Property Name as String

Bumper


Bumper.CastsShadow

Property CastsShadow as Boolean

Bumper


Bumper.Disabled

Property Disabled as Boolean

Bumper


Collection

Properties

_NewEnum
Count
Item

Methods

Events

Hit
Init
Slingshot
Spin
Timer
Unhit


Collection_Init

Sub Collection_Init()

See Also
Collection


Collection_Hit

Sub Collection_Hit(Index As Integer)

See Also
Collection


Collection_Slingshot

Sub Collection_Slingshot(Index As Integer)

See Also
Collection


Collection_Timer

Sub Collection_Timer(Index As Integer)

See Also
Collection


Collection_Spin

Sub Collection_Spin(Index As Integer)

See Also
Collection


Collection_Unhit

Sub Collection_Unhit(Index As Integer)

See Also
Collection


Collection._NewEnum

Property _NewEnum as UNKNOWN

Collection


Collection.Item

Property Item as IDispatch

Collection


Collection.Count

Property Count as Integer

Collection


DispReel

Properties

BackColor
Font
FontColor
Height
Image
ImagesPerGridRow
IsShading
IsTransparent
Name
Range
ReelColor
Reels
Sound
Spacing
Steps
TimerEnabled
TimerInterval
Type
UpdateInterval
UseImageGrid
UserValue
Width
X
Y

Methods

AddValue
ResetToZero
SetValue
SpinReel

Events

Init
Timer


DispReel.AddValue

DispReel.AddValue(Value As Integer)

See Also
DispReel


DispReel.ResetToZero

DispReel.ResetToZero()

See Also
DispReel


DispReel.SpinReel

DispReel.SpinReel(ReelNumber As Integer, PulseCount As Integer)

See Also
DispReel


DispReel.SetValue

DispReel.SetValue(Value As Integer)

See Also
DispReel


DispReel_Init

Sub DispReel_Init()

See Also
DispReel


DispReel_Timer

Sub DispReel_Timer()

See Also
DispReel


DispReel.BackColor

Property BackColor as OLE_COLOR

DispReel


DispReel.Image

Property Image as String

DispReel


DispReel.FontColor

Property FontColor as OLE_COLOR

DispReel


DispReel.ReelColor

Property ReelColor as OLE_COLOR

DispReel


DispReel.Font

Property Font as IFontDisp

DispReel


DispReel.Reels

Property Reels as Single

DispReel


DispReel.Width

Property Width as Single

DispReel


DispReel.Height

Property Height as Single

DispReel


DispReel.Spacing

Property Spacing as Single

DispReel


DispReel.IsTransparent

Property IsTransparent as Boolean

DispReel


DispReel.Sound

Property Sound as String

DispReel


DispReel.Steps

Property Steps as Single

DispReel


DispReel.IsShading

Property IsShading as Boolean

DispReel


DispReel.TimerEnabled

Property TimerEnabled as Boolean

DispReel


DispReel.TimerInterval

Property TimerInterval as Integer

DispReel


DispReel.X

Property X as Single

DispReel


DispReel.Y

Property Y as Single

DispReel


DispReel.Type

Property Type as ReelType

DispReel


DispReel.Range

Property Range as Single

DispReel


DispReel.Name

Property Name as String

DispReel


DispReel.UpdateInterval

Property UpdateInterval as Integer

DispReel


DispReel.UserValue

Property UserValue as Variant

DispReel


DispReel.UseImageGrid

Property UseImageGrid as Boolean

DispReel


DispReel.ImagesPerGridRow

Property ImagesPerGridRow as Integer

DispReel


DragPoint

Properties

IsAutoTextureCoordinate
Smooth
TextureCoordinateU
X
Y

Methods

Events


DragPoint.X

Property X as Single

DragPoint


DragPoint.Y

Property Y as Single

DragPoint


DragPoint.Smooth

Property Smooth as Boolean

DragPoint


DragPoint.IsAutoTextureCoordinate

Property IsAutoTextureCoordinate as Boolean

DragPoint


DragPoint.TextureCoordinateU

Property TextureCoordinateU as Single

DragPoint


Flipper

Properties

BaseRadius
Color
CurrentAngle
Elasticity
EndAngle
EndRadius
Length
Name
RubberColor
RubberThickness
Speed
StartAngle
Strength
Surface
TimerEnabled
TimerInterval
UserValue
Visible
X
Y

Methods

RotateToEnd
RotateToStart

Events

Hit
Init
Timer


Flipper.RotateToEnd

Flipper.RotateToEnd()

See Also
Flipper


Flipper.RotateToStart

Flipper.RotateToStart()

See Also
Flipper


Flipper_Init

Sub Flipper_Init()

See Also
Flipper


Flipper_Hit

Sub Flipper_Hit()

See Also
Flipper


Flipper_Timer

Sub Flipper_Timer()

See Also
Flipper


Flipper.BaseRadius

Property BaseRadius as Single

Flipper


Flipper.EndRadius

Property EndRadius as Single

Flipper


Flipper.Length

Property Length as Single

Flipper


Flipper.StartAngle

Property StartAngle as Single

Flipper


Flipper.EndAngle

Property EndAngle as Single

Flipper


Flipper.TimerEnabled

Property TimerEnabled as Boolean

Flipper


Flipper.TimerInterval

Property TimerInterval as Integer

Flipper


Flipper.CurrentAngle

Property CurrentAngle as Single

Flipper


Flipper.X

Property X as Single

Flipper


Flipper.Y

Property Y as Single

Flipper


Flipper.Color

Property Color as OLE_COLOR

Flipper


Flipper.Speed

Property Speed as Single

Flipper


Flipper.RubberColor

Property RubberColor as OLE_COLOR

Flipper


Flipper.RubberThickness

Property RubberThickness as Integer

Flipper


Flipper.Strength

Property Strength as Single

Flipper


Flipper.Visible

Property Visible as Boolean

Flipper


Flipper.Elasticity

Property Elasticity as Single

Flipper


Flipper.Surface

Property Surface as String

Flipper


Flipper.Name

Property Name as String

Flipper


Flipper.UserValue

Property UserValue as Variant

Flipper


Gate

Properties

Color
Length
Name
Open
Rotation
Surface
TimerEnabled
TimerInterval
UserValue
X
Y

Methods

Events

Hit
Init
Timer


Gate_Init

Sub Gate_Init()

See Also
Gate


Gate_Timer

Sub Gate_Timer()

See Also
Gate


Gate_Hit

Sub Gate_Hit()

See Also
Gate


Gate.Name

Property Name as String

Gate


Gate.TimerEnabled

Property TimerEnabled as Boolean

Gate


Gate.TimerInterval

Property TimerInterval as Integer

Gate


Gate.Length

Property Length as Single

Gate


Gate.Rotation

Property Rotation as Single

Gate


Gate.X

Property X as Single

Gate


Gate.Y

Property Y as Single

Gate


Gate.Open

Property Open as Boolean

Gate


Gate.Color

Property Color as OLE_COLOR

Gate


Gate.Surface

Property Surface as String

Gate


Gate.UserValue

Property UserValue as Variant

Gate


IDecal

Properties

Font
FontColor
HasVerticalText
Height
Image
Rotation
SizingType
Surface
Text
Type
Width
X
Y

Methods

Events


IDecal.Rotation

Property Rotation as Single

IDecal


IDecal.Image

Property Image as String

IDecal


IDecal.Width

Property Width as Single

IDecal


IDecal.Height

Property Height as Single

IDecal


IDecal.X

Property X as Single

IDecal


IDecal.Y

Property Y as Single

IDecal


IDecal.Type

Property Type as DecalType

IDecal


IDecal.Text

Property Text as String

IDecal


IDecal.SizingType

Property SizingType as SizingType

IDecal


IDecal.FontColor

Property FontColor as OLE_COLOR

IDecal


IDecal.Font

Property Font as IFontDisp

IDecal


IDecal.HasVerticalText

Property HasVerticalText as Boolean

IDecal


IDecal.Surface

Property Surface as String

IDecal


ITableGlobal

Properties

ActiveBall
AddCreditKey
CenterTiltKey
GameTime
GetPlayerHWnd
LeftFlipperKey
LeftTiltKey
PlungerKey
RightFlipperKey
RightTiltKey
StartGameKey
UserDirectory
VPBuildVersion

Methods

EndMusic
GetTextFile
LoadValue
Nudge
PlayMusic
PlaySound
SaveValue
StopSound

Events


ITableGlobal.PlaySound

ITableGlobal.PlaySound(Sound As String, [LoopCount As Integer], [Volume As Single])

See Also
ITableGlobal


ITableGlobal.PlayMusic

ITableGlobal.PlayMusic(str As String)

See Also
ITableGlobal


ITableGlobal.EndMusic

ITableGlobal.EndMusic()

See Also
ITableGlobal


ITableGlobal.StopSound

ITableGlobal.StopSound(Sound As String)

See Also
ITableGlobal


ITableGlobal.SaveValue

ITableGlobal.SaveValue(TableName As String, ValueName As String, Value As Variant)

See Also
ITableGlobal


ITableGlobal.LoadValue

ITableGlobal.LoadValue(TableName As String, ValueName As String)

See Also
ITableGlobal


ITableGlobal.GetTextFile

ITableGlobal.GetTextFile(FileName As String)

See Also
ITableGlobal


ITableGlobal.Nudge

ITableGlobal.Nudge(Angle As Single, Force As Single)

See Also
ITableGlobal


ITableGlobal.LeftFlipperKey

Property LeftFlipperKey as Integer

ITableGlobal


ITableGlobal.RightFlipperKey

Property RightFlipperKey as Integer

ITableGlobal


ITableGlobal.LeftTiltKey

Property LeftTiltKey as Integer

ITableGlobal


ITableGlobal.RightTiltKey

Property RightTiltKey as Integer

ITableGlobal


ITableGlobal.CenterTiltKey

Property CenterTiltKey as Integer

ITableGlobal


ITableGlobal.PlungerKey

Property PlungerKey as Integer

ITableGlobal


ITableGlobal.StartGameKey

Property StartGameKey as Integer

ITableGlobal


ITableGlobal.UserDirectory

Property UserDirectory as String

ITableGlobal


ITableGlobal.GetPlayerHWnd

Property GetPlayerHWnd as Integer

ITableGlobal


ITableGlobal.ActiveBall

Property ActiveBall as IBall

ITableGlobal


ITableGlobal.AddCreditKey

Property AddCreditKey as Integer

ITableGlobal


ITableGlobal.GameTime

Property GameTime as Integer

ITableGlobal


ITableGlobal.VPBuildVersion

Property VPBuildVersion as Integer

ITableGlobal


Kicker

Properties

Color
DrawStyle
Enabled
Name
Surface
TimerEnabled
TimerInterval
UserValue
X
Y

Methods

CreateBall
DestroyBall
Kick

Events

Hit
Init
Timer


Kicker.CreateBall

Kicker.CreateBall()

See Also
Kicker


Kicker.DestroyBall

Kicker.DestroyBall()

See Also
Kicker


Kicker.Kick

Kicker.Kick(Angle As Single, Speed As Single, [Inclination As Single])

See Also
Kicker


Kicker_Init

Sub Kicker_Init()

See Also
Kicker


Kicker_Timer

Sub Kicker_Timer()

See Also
Kicker


Kicker_Hit

Sub Kicker_Hit()

See Also
Kicker


Kicker.Name

Property Name as String

Kicker


Kicker.TimerEnabled

Property TimerEnabled as Boolean

Kicker


Kicker.TimerInterval

Property TimerInterval as Integer

Kicker


Kicker.X

Property X as Single

Kicker


Kicker.Y

Property Y as Single

Kicker


Kicker.Enabled

Property Enabled as Boolean

Kicker


Kicker.DrawStyle

Property DrawStyle as KickerType

Kicker


Kicker.Color

Property Color as OLE_COLOR

Kicker


Kicker.Surface

Property Surface as String

Kicker


Kicker.UserValue

Property UserValue as Variant

Kicker


Light

Properties

BlinkInterval
BlinkPattern
BorderColor
BorderWidth
Color
Name
Radius
Shape
State
Surface
TimerEnabled
TimerInterval
UserValue
X
Y

Methods

Events

Init
Timer


Light_Init

Sub Light_Init()

See Also
Light


Light_Timer

Sub Light_Timer()

See Also
Light


Light.Radius

Property Radius as Single

Light


Light.State

Property State as LightState

Light


Light.Color

Property Color as OLE_COLOR

Light


Light.TimerEnabled

Property TimerEnabled as Boolean

Light


Light.TimerInterval

Property TimerInterval as Integer

Light


Light.X

Property X as Single

Light


Light.Y

Property Y as Single

Light


Light.Shape

Property Shape as Shape

Light


Light.BlinkPattern

Property BlinkPattern as String

Light


Light.BlinkInterval

Property BlinkInterval as Integer

Light


Light.BorderColor

Property BorderColor as OLE_COLOR

Light


Light.BorderWidth

Property BorderWidth as Single

Light


Light.Surface

Property Surface as String

Light


Light.Name

Property Name as String

Light


Light.UserValue

Property UserValue as Variant

Light


LightSeq

Properties

CenterX
CenterY
Collection
Name
TimerEnabled
TimerInterval
UpdateInterval
UserValue

Methods

Play
StopPlay

Events

Init
PlayDone
Timer


LightSeq.Play

LightSeq.Play(Animation As SequencerState, [TailLength As Integer], [Repeat As Integer], [Pause As Integer])

See Also
LightSeq


LightSeq.StopPlay

LightSeq.StopPlay()

See Also
LightSeq


LightSeq_Init

Sub LightSeq_Init()

See Also
LightSeq


LightSeq_Timer

Sub LightSeq_Timer()

See Also
LightSeq


LightSeq_PlayDone

Sub LightSeq_PlayDone()

See Also
LightSeq


LightSeq.Name

Property Name as String

LightSeq


LightSeq.Collection

Property Collection as String

LightSeq


LightSeq.CenterX

Property CenterX as Single

LightSeq


LightSeq.CenterY

Property CenterY as Single

LightSeq


LightSeq.UpdateInterval

Property UpdateInterval as Integer

LightSeq


LightSeq.TimerEnabled

Property TimerEnabled as Boolean

LightSeq


LightSeq.TimerInterval

Property TimerInterval as Integer

LightSeq


LightSeq.UserValue

Property UserValue as Variant

LightSeq


Plunger

Properties

FireSpeed
Name
PullSpeed
Surface
TimerEnabled
TimerInterval
UserValue
X
Y

Methods

CreateBall
Fire
PullBack

Events

Init
Timer


Plunger.PullBack

Plunger.PullBack()

See Also
Plunger


Plunger.Fire

Plunger.Fire()

See Also
Plunger


Plunger.CreateBall

Plunger.CreateBall()

See Also
Plunger


Plunger_Init

Sub Plunger_Init()

See Also
Plunger


Plunger_Timer

Sub Plunger_Timer()

See Also
Plunger


Plunger.PullSpeed

Property PullSpeed as Single

Plunger


Plunger.FireSpeed

Property FireSpeed as Single

Plunger


Plunger.TimerEnabled

Property TimerEnabled as Boolean

Plunger


Plunger.TimerInterval

Property TimerInterval as Integer

Plunger


Plunger.X

Property X as Single

Plunger


Plunger.Y

Property Y as Single

Plunger


Plunger.Surface

Property Surface as String

Plunger


Plunger.Name

Property Name as String

Plunger


Plunger.UserValue

Property UserValue as Variant

Plunger


Ramp

Properties

CastsShadow
Color
HasWallImage
HeightBottom
HeightTop
Image
ImageAlignment
LeftWallHeight
Name
RightWallHeight
Type
UserValue
VisibleLeftWallHeight
VisibleRightWallHeight
WidthBottom
WidthTop

Methods

Events

Init


Ramp_Init

Sub Ramp_Init()

See Also
Ramp


Ramp.Name

Property Name as String

Ramp


Ramp.HeightBottom

Property HeightBottom as Single

Ramp


Ramp.HeightTop

Property HeightTop as Single

Ramp


Ramp.WidthBottom

Property WidthBottom as Single

Ramp


Ramp.WidthTop

Property WidthTop as Single

Ramp


Ramp.Color

Property Color as OLE_COLOR

Ramp


Ramp.Type

Property Type as RampType

Ramp


Ramp.Image

Property Image as String

Ramp


Ramp.ImageAlignment

Property ImageAlignment as RampImageAlignment

Ramp


Ramp.HasWallImage

Property HasWallImage as Boolean

Ramp


Ramp.LeftWallHeight

Property LeftWallHeight as Single

Ramp


Ramp.RightWallHeight

Property RightWallHeight as Single

Ramp


Ramp.UserValue

Property UserValue as Variant

Ramp


Ramp.CastsShadow

Property CastsShadow as Boolean

Ramp


Ramp.VisibleLeftWallHeight

Property VisibleLeftWallHeight as Single

Ramp


Ramp.VisibleRightWallHeight

Property VisibleRightWallHeight as Single

Ramp


Spinner

Properties

CastsShadow
Color
Friction
Height
ImageBack
ImageFront
Length
Name
Overhang
Rotation
Surface
TimerEnabled
TimerInterval
UserValue
X
Y

Methods

Events

Init
Spin
Timer


Spinner_Init

Sub Spinner_Init()

See Also
Spinner


Spinner_Timer

Sub Spinner_Timer()

See Also
Spinner


Spinner_Spin

Sub Spinner_Spin()

See Also
Spinner


Spinner.Name

Property Name as String

Spinner


Spinner.TimerEnabled

Property TimerEnabled as Boolean

Spinner


Spinner.TimerInterval

Property TimerInterval as Integer

Spinner


Spinner.Length

Property Length as Single

Spinner


Spinner.Rotation

Property Rotation as Single

Spinner


Spinner.Height

Property Height as Single

Spinner


Spinner.Overhang

Property Overhang as Single

Spinner


Spinner.Friction

Property Friction as Single

Spinner


Spinner.ImageFront

Property ImageFront as String

Spinner


Spinner.ImageBack

Property ImageBack as String

Spinner


Spinner.Color

Property Color as OLE_COLOR

Spinner


Spinner.X

Property X as Single

Spinner


Spinner.Y

Property Y as Single

Spinner


Spinner.Surface

Property Surface as String

Spinner


Spinner.UserValue

Property UserValue as Variant

Spinner


Spinner.CastsShadow

Property CastsShadow as Boolean

Spinner


Table

Properties

BackdropColor
BackdropImage
BallBackDecal
BallFrontDecal
BallImage
DisplayBackdrop
DisplayGrid
FieldOfView
GlassHeight
GridSize
Height
Image
Inclination
Name
PlayfieldColor
RenderShadows
Slope
Width
YieldTime

Methods

Nudge

Events

Exit
Init
KeyDown
KeyUp
MusicDone
Paused
UnPaused


Table.Nudge

Table.Nudge(Angle As Single, Force As Single)

See Also
Table


Table_Init

Sub Table_Init()

See Also
Table


Table_KeyDown

Sub Table_KeyDown(keycode As Integer)

See Also
Table


Table_KeyUp

Sub Table_KeyUp(keycode As Integer)

See Also
Table


Table_MusicDone

Sub Table_MusicDone()

See Also
Table


Table_Exit

Sub Table_Exit()

See Also
Table


Table_Paused

Sub Table_Paused()

See Also
Table


Table_UnPaused

Sub Table_UnPaused()

See Also
Table


Table.GlassHeight

Property GlassHeight as Single

Table


Table.PlayfieldColor

Property PlayfieldColor as OLE_COLOR

Table


Table.BackdropColor

Property BackdropColor as OLE_COLOR

Table


Table.Slope

Property Slope as Single

Table


Table.YieldTime

Property YieldTime as Integer

Table


Table.BallImage

Property BallImage as String

Table


Table.BackdropImage

Property BackdropImage as String

Table


Table.Width

Property Width as Single

Table


Table.Height

Property Height as Single

Table


Table.GridSize

Property GridSize as Single

Table


Table.Inclination

Property Inclination as Single

Table


Table.FieldOfView

Property FieldOfView as Single

Table


Table.DisplayGrid

Property DisplayGrid as Boolean

Table


Table.DisplayBackdrop

Property DisplayBackdrop as Boolean

Table


Table.Image

Property Image as String

Table


Table.Name

Property Name as String

Table


Table.RenderShadows

Property RenderShadows as Boolean

Table


Table.BallFrontDecal

Property BallFrontDecal as String

Table


Table.BallBackDecal

Property BallBackDecal as String

Table


Textbox

Properties

Alignment
BackColor
Font
FontColor
Height
IsTransparent
Name
Text
TimerEnabled
TimerInterval
UserValue
Width
X
Y

Methods

Events

Init
Timer


Textbox_Init

Sub Textbox_Init()

See Also
Textbox


Textbox_Timer

Sub Textbox_Timer()

See Also
Textbox


Textbox.BackColor

Property BackColor as OLE_COLOR

Textbox


Textbox.FontColor

Property FontColor as OLE_COLOR

Textbox


Textbox.Text

Property Text as String

Textbox


Textbox.Font

Property Font as IFontDisp

Textbox


Textbox.Width

Property Width as Single

Textbox


Textbox.Height

Property Height as Single

Textbox


Textbox.Alignment

Property Alignment as TextAlignment

Textbox


Textbox.IsTransparent

Property IsTransparent as Boolean

Textbox


Textbox.TimerEnabled

Property TimerEnabled as Boolean

Textbox


Textbox.TimerInterval

Property TimerInterval as Integer

Textbox


Textbox.X

Property X as Single

Textbox


Textbox.Y

Property Y as Single

Textbox


Textbox.Name

Property Name as String

Textbox


Textbox.UserValue

Property UserValue as Variant

Textbox


Timer

Properties

Enabled
Interval
Name
UserValue

Methods

Events

Init
Timer


Timer_Timer

Sub Timer_Timer()

See Also
Timer


Timer_Init

Sub Timer_Init()

See Also
Timer


Timer.Enabled

Property Enabled as Boolean

Timer


Timer.Interval

Property Interval as Integer

Timer


Timer.Name

Property Name as String

Timer


Timer.UserValue

Property UserValue as Variant

Timer


Trigger

Properties

Enabled
Name
Radius
Shape
Surface
TimerEnabled
TimerInterval
UserValue
Visible
X
Y

Methods

Events

Hit
Init
Timer
Unhit


Trigger_Init

Sub Trigger_Init()

See Also
Trigger


Trigger_Timer

Sub Trigger_Timer()

See Also
Trigger


Trigger_Hit

Sub Trigger_Hit()

See Also
Trigger


Trigger_Unhit

Sub Trigger_Unhit()

See Also
Trigger


Trigger.Radius

Property Radius as Single

Trigger


Trigger.TimerEnabled

Property TimerEnabled as Boolean

Trigger


Trigger.TimerInterval

Property TimerInterval as Integer

Trigger


Trigger.X

Property X as Single

Trigger


Trigger.Y

Property Y as Single

Trigger


Trigger.Enabled

Property Enabled as Boolean

Trigger


Trigger.Visible

Property Visible as Boolean

Trigger


Trigger.Shape

Property Shape as Shape

Trigger


Trigger.Surface

Property Surface as String

Trigger


Trigger.Name

Property Name as String

Trigger


Trigger.UserValue

Property UserValue as Variant

Trigger


Wall

Properties

CanDrop
CastsShadow
Disabled
DisplayTexture
Elasticity
FaceColor
HasHitEvent
HeightBottom
HeightTop
Image
ImageAlignment
IsDropped
Name
SideColor
SideImage
SideVisible
SlingshotStrength
Threshold
TimerEnabled
TimerInterval
UserValue
Visible

Methods

Events

Hit
Init
Slingshot
Timer


Wall_Init

Sub Wall_Init()

See Also
Wall


Wall_Hit

Sub Wall_Hit()

See Also
Wall


Wall_Slingshot

Sub Wall_Slingshot()

See Also
Wall


Wall_Timer

Sub Wall_Timer()

See Also
Wall


Wall.Name

Property Name as String

Wall


Wall.TimerEnabled

Property TimerEnabled as Boolean

Wall


Wall.TimerInterval

Property TimerInterval as Integer

Wall


Wall.HasHitEvent

Property HasHitEvent as Boolean

Wall


Wall.Threshold

Property Threshold as Single

Wall


Wall.Image

Property Image as String

Wall


Wall.SideColor

Property SideColor as OLE_COLOR

Wall


Wall.ImageAlignment

Property ImageAlignment as ImageAlignment

Wall


Wall.HeightBottom

Property HeightBottom as Single

Wall


Wall.HeightTop

Property HeightTop as Single

Wall


Wall.FaceColor

Property FaceColor as OLE_COLOR

Wall


Wall.CanDrop

Property CanDrop as Boolean

Wall


Wall.IsDropped

Property IsDropped as Boolean

Wall


Wall.DisplayTexture

Property DisplayTexture as Boolean

Wall


Wall.SlingshotStrength

Property SlingshotStrength as Single

Wall


Wall.Elasticity

Property Elasticity as Single

Wall


Wall.CastsShadow

Property CastsShadow as Boolean

Wall


Wall.SideImage

Property SideImage as String

Wall


Wall.Visible

Property Visible as Boolean

Wall


Wall.Disabled

Property Disabled as Boolean

Wall


Wall.SideVisible

Property SideVisible as Boolean

Wall


Wall.UserValue

Property UserValue as Variant

Wall