WADMangle.DOOM

WAD Mangle Plugin Documentation

WADMangle.DOOM Namespace

The namespace contains all the classes used to manipulate WAD files and the LUMPs contained within

Namespace hierarchy

Classes

Class | Description
DoomException | Namespace exception
FileUtil | Various stream utilities for reading/writing WADs and LUMPs.
PnameList | Maintains a list of patch names (PNAMES)
TextureList | Maintains a list of TEXTURES
TextureList.Patch | Describes a patch index
TextureList.Texture | Describes a texture in the texture list
WAD | Defines a WAD File
WADCollection | Performs operations on a collection of WADs
WADEntry | Describes a directory entry in a WAD file
WADEntryConvert | Provides routines to convert WADEntrys to other entities

Delegates

Delegate | Description
WADCollection.WadAddedEvent | Delegate for WAD added event
WADCollection.WadRemovedEvent | Delegate for WAD removed event

Enumerations

Enumeration | Description
WAD.EWadType | Describes the type of WAD


DoomException Class

Namespace exception

For a list of all members of this type, see DoomException Members.

System.Object
System.Exception
WADMangle.DOOM.DoomException

public class DoomException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: WADMangle.DOOM

Assembly: WADMangle.DOOM (in WADMangle.DOOM.dll)

See Also

DoomException Members | WADMangle.DOOM Namespace


DoomException Members

DoomException overview

Public Instance Constructors

DoomException Constructor Base exception for the namespace

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DoomException Class | WADMangle.DOOM Namespace


DoomException Constructor

Base exception for the namespace

public DoomException(
string message
);

Parameters

message
Error message

See Also

DoomException Class | WADMangle.DOOM Namespace


FileUtil Class

Various stream utilities for reading/writing WADs and LUMPs.

For a list of all members of this type, see FileUtil Members.

System.Object
WADMangle.DOOM.FileUtil

public class FileUtil

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: WADMangle.DOOM

Assembly: WADMangle.DOOM (in WADMangle.DOOM.dll)

See Also

FileUtil Members | WADMangle.DOOM Namespace


FileUtil Members

FileUtil overview

Public Static Methods

ReadLong | Reads a 4-byte int from the supplied stream.
ReadShort | Reads a 2-byte int from the supplied stream.
ReadSignedShort | Reads a signed 2-byte int from the supplied stream.
ReadString | Reads a string of ASCII characters from the supplied stream. Null characters will be stripped from the end of the string.
WriteLong | Writes a 4-byte int to the supplied stream.
WriteShort | Writes a 2-byte int to the supplied stream.
WriteSignedShort | Writes a signed 2-byte int to the supplied stream.
WriteString | Writes an ASCII string to the supplied stream.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FileUtil Class | WADMangle.DOOM Namespace


FileUtil Methods

The methods of the FileUtil class are listed below. For a complete list of FileUtil class members, see the FileUtil Members topic.

Public Static Methods

ReadLong | Reads a 4-byte int from the supplied stream.
ReadShort | Reads a 2-byte int from the supplied stream.
ReadSignedShort | Reads a signed 2-byte int from the supplied stream.
ReadString | Reads a string of ASCII characters from the supplied stream. Null characters will be stripped from the end of the string.
WriteLong | Writes a 4-byte int to the supplied stream.
WriteShort | Writes a 2-byte int to the supplied stream.
WriteSignedShort | Writes a signed 2-byte int to the supplied stream.
WriteString | Writes an ASCII string to the supplied stream.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FileUtil Class | WADMangle.DOOM Namespace


FileUtil.ReadLong Method

Reads a 4-byte int from the supplied stream.

public static int ReadLong(
Stream fs
);

Parameters

fs
The stream

Return Value

The value

See Also

FileUtil Class | WADMangle.DOOM Namespace


FileUtil.ReadShort Method

Reads a 2-byte int from the supplied stream.

public static int ReadShort(
Stream fs
);

Parameters

fs
The stream

Return Value

The value

See Also

FileUtil Class | WADMangle.DOOM Namespace


FileUtil.ReadSignedShort Method

Reads a signed 2-byte int from the supplied stream.

public static int ReadSignedShort(
Stream fs
);

Parameters

fs
The stream

Return Value

The value

See Also

FileUtil Class | WADMangle.DOOM Namespace


FileUtil.ReadString Method

Reads a string of ASCII characters from the supplied stream. Null characters will be stripped from the end of the string.

public static string ReadString(
Stream fs,
int len
);

Parameters

fs
The stream
len
The length of the string

Return Value

The string

See Also

FileUtil Class | WADMangle.DOOM Namespace


FileUtil.WriteLong Method

Writes a 4-byte int to the supplied stream.

public static void WriteLong(
Stream fs,
int l
);

Parameters

fs
The stream
l
The value to write

See Also

FileUtil Class | WADMangle.DOOM Namespace


FileUtil.WriteShort Method

Writes a 2-byte int to the supplied stream.

public static void WriteShort(
Stream fs,
int l
);

Parameters

fs
The stream
l
The value to write

See Also

FileUtil Class | WADMangle.DOOM Namespace


FileUtil.WriteSignedShort Method

Writes a signed 2-byte int to the supplied stream.

public static void WriteSignedShort(
Stream fs,
int l
);

Parameters

fs
The stream
l
The value to write

See Also

FileUtil Class | WADMangle.DOOM Namespace


FileUtil.WriteString Method

Writes an ASCII string to the supplied stream.

public static void WriteString(
Stream fs,
string s,
int len
);

Parameters

fs
The stream
s
The value to write
len
The length to output. If s is shorter, then the output is padded with nul characters.

See Also

FileUtil Class | WADMangle.DOOM Namespace


PnameList Class

Maintains a list of patch names (PNAMES)

For a list of all members of this type, see PnameList Members.

System.Object
WADMangle.DOOM.PnameList

public class PnameList : IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: WADMangle.DOOM

Assembly: WADMangle.DOOM (in WADMangle.DOOM.dll)

See Also

PnameList Members | WADMangle.DOOM Namespace


PnameList Members

PnameList overview

Public Instance Constructors

PnameList Constructor Constructs a PnameList based on the PNAME lump passed in.

Public Instance Properties

Count | Returns the number of patches in the list.
Item | Indexes into the list of patch names
LumpData | Returns the PNAMES lump data for this list.

Public Instance Methods

Add | Adds a new patch name
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Enumerates over the patch names (as strings) in the list
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert | Inserts a new patch
RemoveAt | Removes the patch at the specified index
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PnameList Class | WADMangle.DOOM Namespace


PnameList Constructor

Constructs a PnameList based on the PNAME lump passed in.

public PnameList(
WADEntry lump
);

Parameters

lump
The PNAMES Lump

Exceptions

Exception Type | Condition
DoomException | Lump was not named PNAMES, or was invalid.

See Also

PnameList Class | WADMangle.DOOM Namespace


PnameList Properties

The properties of the PnameList class are listed below. For a complete list of PnameList class members, see the PnameList Members topic.

Public Instance Properties

Count | Returns the number of patches in the list.
Item | Indexes into the list of patch names
LumpData | Returns the PNAMES lump data for this list.

See Also

PnameList Class | WADMangle.DOOM Namespace


Count Property

WAD Mangle Plugin Documentation

PnameList.Count Property

Returns the number of patches in the list.

public int Count {get;}

See Also

PnameList Class | WADMangle.DOOM Namespace


Item Property

WAD Mangle Plugin Documentation

PnameList.Item Property

Indexes into the list of patch names

public string this[
int index
] {get; set;}

See Also

PnameList Class | WADMangle.DOOM Namespace


LumpData Property

WAD Mangle Plugin Documentation

PnameList.LumpData Property

Returns the PNAMES lump data for this list.

public byte[] LumpData {get;}

See Also

PnameList Class | WADMangle.DOOM Namespace


PnameList Methods

The methods of the PnameList class are listed below. For a complete list of PnameList class members, see the PnameList Members topic.

Public Instance Methods

Add | Adds a new patch name
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Enumerates over the patch names (as strings) in the list
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert | Inserts a new patch
RemoveAt | Removes the patch at the specified index
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PnameList Class | WADMangle.DOOM Namespace


PnameList.Add Method

Adds a new patch name

public void Add(
string name
);

Parameters

name
The patch name

See Also

PnameList Class | WADMangle.DOOM Namespace


PnameList.GetEnumerator Method

Enumerates over the patch names (as strings) in the list

public IEnumerator GetEnumerator();

Return Value

Implements

IEnumerable.GetEnumerator

See Also

PnameList Class | WADMangle.DOOM Namespace


PnameList.Insert Method

Inserts a new patch

public void Insert(
int index,
string name
);

Parameters

index
The index to insert at (use Count to append)
name
The name of the wall patch

Exceptions

Exception Type | Condition
DoomException | Invalid name

See Also

PnameList Class | WADMangle.DOOM Namespace


PnameList.RemoveAt Method

Removes the patch at the specified index

public void RemoveAt(
int index
);

Parameters

index
The index to remove

See Also

PnameList Class | WADMangle.DOOM Namespace


TextureList Class

Maintains a list of TEXTURES

For a list of all members of this type, see TextureList Members.

System.Object
WADMangle.DOOM.TextureList

public class TextureList : IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: WADMangle.DOOM

Assembly: WADMangle.DOOM (in WADMangle.DOOM.dll)

See Also

TextureList Members | WADMangle.DOOM Namespace


TextureList Members

TextureList overview

Public Instance Constructors

TextureList Constructor Constructs a TextureList based on the TEXTURE lump passed in.

Public Instance Properties

Count | Returns the number of patches in the list.
Item | Indexes into the list of texture names
LumpData | Returns the TEXTURE lump data for this list.

Public Instance Methods

Add | Adds a new texture
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Enumerates over the patch names (as strings) in the list
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert | Inserts a new texture
RemoveAt | Removes the patch at the specified index
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TextureList Class | WADMangle.DOOM Namespace


TextureList Constructor

Constructs a TextureList based on the TEXTURE lump passed in.

public TextureList(
WADEntry lump
);

Parameters

lump
The TEXTURE Lump

Exceptions

Exception Type | Condition
DoomException | Lump was invalid.

See Also

TextureList Class | WADMangle.DOOM Namespace


TextureList Properties

The properties of the TextureList class are listed below. For a complete list of TextureList class members, see the TextureList Members topic.

Public Instance Properties

Count | Returns the number of patches in the list.
Item | Indexes into the list of texture names
LumpData | Returns the TEXTURE lump data for this list.

See Also

TextureList Class | WADMangle.DOOM Namespace


Count Property

WAD Mangle Plugin Documentation

TextureList.Count Property

Returns the number of patches in the list.

public int Count {get;}

See Also

TextureList Class | WADMangle.DOOM Namespace


Item Property

WAD Mangle Plugin Documentation

TextureList.Item Property

Indexes into the list of texture names

public TextureList.Texture this[
int index
] {get; set;}

See Also

TextureList Class | WADMangle.DOOM Namespace


LumpData Property

WAD Mangle Plugin Documentation

TextureList.LumpData Property

Returns the TEXTURE lump data for this list.

public byte[] LumpData {get;}

See Also

TextureList Class | WADMangle.DOOM Namespace


TextureList Methods

The methods of the TextureList class are listed below. For a complete list of TextureList class members, see the TextureList Members topic.

Public Instance Methods

Add | Adds a new texture
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Enumerates over the patch names (as strings) in the list
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert | Inserts a new texture
RemoveAt | Removes the patch at the specified index
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TextureList Class | WADMangle.DOOM Namespace


TextureList.Add Method

Adds a new texture

public void Add(
Texture t
);

Parameters

t
The texture

See Also

TextureList Class | WADMangle.DOOM Namespace


TextureList.GetEnumerator Method

Enumerates over the patch names (as strings) in the list

public IEnumerator GetEnumerator();

Return Value

Implements

IEnumerable.GetEnumerator

See Also

TextureList Class | WADMangle.DOOM Namespace


TextureList.Insert Method

Inserts a new texture

public void Insert(
int index,
Texture t
);

Parameters

index
The index to insert at (use Count to append)
t
The texture

Exceptions

Exception Type | Condition
DoomException | Invalid name

See Also

TextureList Class | WADMangle.DOOM Namespace


TextureList.RemoveAt Method

Removes the patch at the specified index

public void RemoveAt(
int index
);

Parameters

index
The index to remove

See Also

TextureList Class | WADMangle.DOOM Namespace


TextureList.Patch Class

Describes a patch index

For a list of all members of this type, see TextureList.Patch Members.

System.Object
WADMangle.DOOM.TextureList.Patch

public class TextureList.Patch

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: WADMangle.DOOM

Assembly: WADMangle.DOOM (in WADMangle.DOOM.dll)

See Also

TextureList.Patch Members | WADMangle.DOOM Namespace


TextureList.Patch Members

TextureList.Patch overview

Public Instance Constructors

TextureList.Patch Constructor Construct a patch index

Public Instance Properties

Index | The index of the patch in the PNAMES lump
X | The X offset of the patch
Y | The Y offset of the patch

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TextureList.Patch Class | WADMangle.DOOM Namespace


TextureList.Patch Constructor

Construct a patch index

public TextureList.Patch(
int index,
int x,
int y
);

Parameters

index
The index into the PNAMES lump
x
The X offset of this patch
y
The Y offset of this patch

See Also

TextureList.Patch Class | WADMangle.DOOM Namespace


TextureList.Patch Properties

The properties of the TextureList.Patch class are listed below. For a complete list of TextureList.Patch class members, see the TextureList.Patch Members topic.

Public Instance Properties

Index | The index of the patch in the PNAMES lump
X | The X offset of the patch
Y | The Y offset of the patch

See Also

TextureList.Patch Class | WADMangle.DOOM Namespace


Index Property

WAD Mangle Plugin Documentation

TextureList.Patch.Index Property

The index of the patch in the PNAMES lump

public int Index {get; set;}

See Also

TextureList.Patch Class | WADMangle.DOOM Namespace


X Property

WAD Mangle Plugin Documentation

TextureList.Patch.X Property

The X offset of the patch

public int X {get; set;}

See Also

TextureList.Patch Class | WADMangle.DOOM Namespace


Y Property

WAD Mangle Plugin Documentation

TextureList.Patch.Y Property

The Y offset of the patch

public int Y {get; set;}

See Also

TextureList.Patch Class | WADMangle.DOOM Namespace


TextureList.Texture Class

Describes a texture in the texture list

For a list of all members of this type, see TextureList.Texture Members.

System.Object
WADMangle.DOOM.TextureList.Texture

public class TextureList.Texture

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: WADMangle.DOOM

Assembly: WADMangle.DOOM (in WADMangle.DOOM.dll)

See Also

TextureList.Texture Members | WADMangle.DOOM Namespace


TextureList.Texture Members

TextureList.Texture overview

Public Instance Constructors

TextureList.Texture Constructor Create a texture

Public Instance Properties

Height | The height of the texture
Name | The name of the texture
Patches | The list of Patch items making up the texture
Width | The width of the texture

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TextureList.Texture Class | WADMangle.DOOM Namespace


TextureList.Texture Constructor

Create a texture

public TextureList.Texture(
string name,
int width,
int height,
ArrayList patches
);

Parameters

name
The name
width
The width
height
The height
patches
The list of Patch items making this texture

See Also

TextureList.Texture Class | WADMangle.DOOM Namespace


TextureList.Texture Properties

The properties of the TextureList.Texture class are listed below. For a complete list of TextureList.Texture class members, see the TextureList.Texture Members topic.

Public Instance Properties

Height | The height of the texture
Name | The name of the texture
Patches | The list of Patch items making up the texture
Width | The width of the texture

See Also

TextureList.Texture Class | WADMangle.DOOM Namespace


Height Property

WAD Mangle Plugin Documentation

TextureList.Texture.Height Property

The height of the texture

public int Height {get; set;}

See Also

TextureList.Texture Class | WADMangle.DOOM Namespace


Name Property

WAD Mangle Plugin Documentation

TextureList.Texture.Name Property

The name of the texture

public string Name {get; set;}

See Also

TextureList.Texture Class | WADMangle.DOOM Namespace


Patches Property

WAD Mangle Plugin Documentation

TextureList.Texture.Patches Property

The list of Patch items making up the texture

public System.Collections.ArrayList Patches {get;}

See Also

TextureList.Texture Class | WADMangle.DOOM Namespace


Width Property

WAD Mangle Plugin Documentation

TextureList.Texture.Width Property

The width of the texture

public int Width {get; set;}

See Also

TextureList.Texture Class | WADMangle.DOOM Namespace


WAD Class

Defines a WAD File

For a list of all members of this type, see WAD Members.

System.Object
WADMangle.DOOM.WAD

public class WAD : IEnumerable, IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: WADMangle.DOOM

Assembly: WADMangle.DOOM (in WADMangle.DOOM.dll)

See Also

WAD Members | WADMangle.DOOM Namespace


WAD Members

WAD overview

Public Instance Constructors

WAD Overloaded. Initializes a new instance of the WAD class.

Public Instance Properties

Count | Returns the number of lumps in the WAD
Current | Get the current object from the enumerator
Item | Index into the lumps
Path | Get/set the path of the WAD file on disk
WadType | Get the type of WAD file

Public Instance Methods

AddEntry | Adds a new lump to the WAD
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindEntry | Find a lump
GetEnumerator | Gets an enumerator
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
InsertEntry | Insert a new lump into the WAD
Load | Load a WAD file
MoveNext | Move the enumerator to the next item.
RemoveEntry | Removes a lump from the WAD
Reset | Reset the enumerator to the start of the collection.
Save | Saves the WAD file
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WAD Class | WADMangle.DOOM Namespace


WAD Constructor

Construct a new, empty WAD file

Overload List

Construct a new, empty WAD file

public WAD();

Load a WAD file from disk

public WAD(string);

See Also

WAD Class | WADMangle.DOOM Namespace


WAD Constructor ()

Construct a new, empty WAD file

public WAD();

See Also

WAD Class | WADMangle.DOOM Namespace | WAD Constructor Overload List


WAD Constructor (String)

Load a WAD file from disk

public WAD(
string path
);

Parameters

path
The WAD file

Exceptions

Exception Type | Condition
IOException | I/O errors

See Also

WAD Class | WADMangle.DOOM Namespace | WAD Constructor Overload List


WAD Properties

The properties of the WAD class are listed below. For a complete list of WAD class members, see the WAD Members topic.

Public Instance Properties

Count | Returns the number of lumps in the WAD
Current | Get the current object from the enumerator
Item | Index into the lumps
Path | Get/set the path of the WAD file on disk
WadType | Get the type of WAD file

See Also

WAD Class | WADMangle.DOOM Namespace


Count Property

WAD Mangle Plugin Documentation

WAD.Count Property

Returns the number of lumps in the WAD

public int Count {get;}

See Also

WAD Class | WADMangle.DOOM Namespace


Current Property

WAD Mangle Plugin Documentation

WAD.Current Property

Get the current object from the enumerator

public object Current {get;}

Implements

IEnumerator.Current

See Also

WAD Class | WADMangle.DOOM Namespace


Item Property

WAD Mangle Plugin Documentation

WAD.Item Property

Index into the lumps

public WADEntry this[
int index
] {get;}

See Also

WAD Class | WADMangle.DOOM Namespace


Path Property

WAD Mangle Plugin Documentation

WAD.Path Property

Get/set the path of the WAD file on disk

public string Path {get; set;}

See Also

WAD Class | WADMangle.DOOM Namespace


WadType Property

WAD Mangle Plugin Documentation

WAD.WadType Property

Get the type of WAD file

public WAD.EWadType WadType {get;}

See Also

WAD Class | WADMangle.DOOM Namespace


WAD Methods

The methods of the WAD class are listed below. For a complete list of WAD class members, see the WAD Members topic.

Public Instance Methods

AddEntry | Adds a new lump to the WAD
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindEntry | Find a lump
GetEnumerator | Gets an enumerator
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
InsertEntry | Insert a new lump into the WAD
Load | Load a WAD file
MoveNext | Move the enumerator to the next item.
RemoveEntry | Removes a lump from the WAD
Reset | Reset the enumerator to the start of the collection.
Save | Saves the WAD file
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WAD Class | WADMangle.DOOM Namespace


WAD.AddEntry Method

Adds a new lump to the WAD

public void AddEntry(
WADEntry e
);

Parameters

e
The lump

See Also

WAD Class | WADMangle.DOOM Namespace


WAD.FindEntry Method

Find a lump

public WADEntry FindEntry(
string name
);

Parameters

name
The name to find

Return Value

The first lump that matches the name, or null for no match

See Also

WAD Class | WADMangle.DOOM Namespace


WAD.GetEnumerator Method

Gets an enumerator

public IEnumerator GetEnumerator();

Return Value

The enumerator

Implements

IEnumerable.GetEnumerator

See Also

WAD Class | WADMangle.DOOM Namespace


WAD.InsertEntry Method

Insert a new lump into the WAD

public void InsertEntry(
WADEntry before,
WADEntry e
);

Parameters

before
The lump before which to insert the new one. If the lump doesn't exist then the new lump is appended.
e
The lump

See Also

WAD Class | WADMangle.DOOM Namespace


WAD.Load Method

Load a WAD file

public void Load();

Exceptions

Exception Type | Condition
IOException | I/O errors

See Also

WAD Class | WADMangle.DOOM Namespace


WAD.MoveNext Method

Move the enumerator to the next item.

public bool MoveNext();

Return Value

True if there are more objects to enumerate over

Implements

IEnumerator.MoveNext

See Also

WAD Class | WADMangle.DOOM Namespace


WAD.RemoveEntry Method

Removes a lump from the WAD

public void RemoveEntry(
WADEntry e
);

Parameters

e
The lump

See Also

WAD Class | WADMangle.DOOM Namespace


WAD.Reset Method

Reset the enumerator to the start of the collection.

public void Reset();

Implements

IEnumerator.Reset

See Also

WAD Class | WADMangle.DOOM Namespace


WAD.Save Method

Saves the WAD file

public void Save();

Exceptions

Exception Type | Condition
IOException | I/O errors

See Also

WAD Class | WADMangle.DOOM Namespace


WAD.EWadType Enumeration

Describes the type of WAD

public enum WAD.EWadType

Members

Member Name | Description
IWAD | An Interal WAD (eg. DOOM 2)
PWAD | A Patch WAD (eg. a user-defined level)

Requirements

Namespace: WADMangle.DOOM

Assembly: WADMangle.DOOM (in WADMangle.DOOM.dll)

See Also

WADMangle.DOOM Namespace


WADCollection Class

Performs operations on a collection of WADs

For a list of all members of this type, see WADCollection Members.

System.Object
WADMangle.DOOM.WADCollection

public class WADCollection : IEnumerable, IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: WADMangle.DOOM

Assembly: WADMangle.DOOM (in WADMangle.DOOM.dll)

See Also

WADCollection Members | WADMangle.DOOM Namespace


WADCollection Members

WADCollection overview

Public Instance Constructors

WADCollection Constructor Create an empty collection of WADs

Public Instance Properties

Count | Returns the number of WADs in the collection
Current | Get the current object from the enumerator
Item | Index into the WADs

Public Instance Methods

AddWad | Add a WAD to the collection
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Gets an enumerator
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPalette | Get the first palette (PLAYPAL) lump from the WAD files
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Move the enumerator to the next item.
QueryDirectory | Queries the WAD directories for the named lump. Note it searches back from the last loaded WAD as DOOM does.
RemoveWad | Remove a WAD from the collection
Reset | Reset the enumerator to the start of the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

WadAdded | Called when a WAD is added to the collection
WadRemoved | Called when a WAD is removed from the collection

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WADCollection Class | WADMangle.DOOM Namespace


WADCollection Constructor

Create an empty collection of WADs

public WADCollection();

See Also

WADCollection Class | WADMangle.DOOM Namespace


WADCollection Properties

The properties of the WADCollection class are listed below. For a complete list of WADCollection class members, see the WADCollection Members topic.

Public Instance Properties

Count | Returns the number of WADs in the collection
Current | Get the current object from the enumerator
Item | Index into the WADs

See Also

WADCollection Class | WADMangle.DOOM Namespace


Count Property

WAD Mangle Plugin Documentation

WADCollection.Count Property

Returns the number of WADs in the collection

public int Count {get;}

See Also

WADCollection Class | WADMangle.DOOM Namespace


Current Property

WAD Mangle Plugin Documentation

WADCollection.Current Property

Get the current object from the enumerator

public object Current {get;}

Implements

IEnumerator.Current

See Also

WADCollection Class | WADMangle.DOOM Namespace


Item Property

WAD Mangle Plugin Documentation

WADCollection.Item Property

Index into the WADs

public WAD this[
int index
] {get;}

See Also

WADCollection Class | WADMangle.DOOM Namespace


WADCollection Methods

The methods of the WADCollection class are listed below. For a complete list of WADCollection class members, see the WADCollection Members topic.

Public Instance Methods

AddWad | Add a WAD to the collection
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Gets an enumerator
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPalette | Get the first palette (PLAYPAL) lump from the WAD files
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Move the enumerator to the next item.
QueryDirectory | Queries the WAD directories for the named lump. Note it searches back from the last loaded WAD as DOOM does.
RemoveWad | Remove a WAD from the collection
Reset | Reset the enumerator to the start of the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WADCollection Class | WADMangle.DOOM Namespace


WADCollection.AddWad Method

Add a WAD to the collection

public void AddWad(
WAD w
);

Parameters

w
The WAD

See Also

WADCollection Class | WADMangle.DOOM Namespace


WADCollection.GetEnumerator Method

Gets an enumerator

public IEnumerator GetEnumerator();

Return Value

The enumerator

Implements

IEnumerable.GetEnumerator

See Also

WADCollection Class | WADMangle.DOOM Namespace


WADCollection.GetPalette Method

Get the first palette (PLAYPAL) lump from the WAD files

public WADEntry GetPalette();

Return Value

The lump containing the palette, or null if not found

See Also

WADCollection Class | WADMangle.DOOM Namespace


WADCollection.MoveNext Method

Move the enumerator to the next item.

public bool MoveNext();

Return Value

True if there are more objects to enumerate over

Implements

IEnumerator.MoveNext

See Also

WADCollection Class | WADMangle.DOOM Namespace


WADCollection.QueryDirectory Method

Queries the WAD directories for the named lump. Note it searches back from the last loaded WAD as DOOM does.

public WADEntry QueryDirectory(
string name
);

Parameters

name
The lump name

Return Value

The lump, or null if it doesn't exist

See Also

WADCollection Class | WADMangle.DOOM Namespace


WADCollection.RemoveWad Method

Remove a WAD from the collection

public void RemoveWad(
WAD w
);

Parameters

w
The WAD

See Also

WADCollection Class | WADMangle.DOOM Namespace


WADCollection.Reset Method

Reset the enumerator to the start of the collection.

public void Reset();

Implements

IEnumerator.Reset

See Also

WADCollection Class | WADMangle.DOOM Namespace


WADCollection Events

The events of the WADCollection class are listed below. For a complete list of WADCollection class members, see the WADCollection Members topic.

Public Instance Events

WadAdded | Called when a WAD is added to the collection
WadRemoved | Called when a WAD is removed from the collection

See Also

WADCollection Class | WADMangle.DOOM Namespace


WADCollection.WadAdded Event

Called when a WAD is added to the collection

public event WadAddedEvent WadAdded;

See Also

WADCollection Class | WADMangle.DOOM Namespace


WADCollection.WadRemoved Event

Called when a WAD is removed from the collection

public event WadRemovedEvent WadRemoved;

See Also

WADCollection Class | WADMangle.DOOM Namespace


WADCollection.WadAddedEvent Delegate

Delegate for WAD added event

public delegate void WADCollection.WadAddedEvent(
WADCollection collection,
WAD wad
);

Requirements

Namespace: WADMangle.DOOM

Assembly: WADMangle.DOOM (in WADMangle.DOOM.dll)

See Also

WADMangle.DOOM Namespace


WADCollection.WadRemovedEvent Delegate

Delegate for WAD removed event

public delegate void WADCollection.WadRemovedEvent(
WADCollection collection
);

Requirements

Namespace: WADMangle.DOOM

Assembly: WADMangle.DOOM (in WADMangle.DOOM.dll)

See Also

WADMangle.DOOM Namespace


WADEntry Class

Describes a directory entry in a WAD file

For a list of all members of this type, see WADEntry Members.

System.Object
WADMangle.DOOM.WADEntry

public class WADEntry

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: WADMangle.DOOM

Assembly: WADMangle.DOOM (in WADMangle.DOOM.dll)

See Also

WADEntry Members | WADMangle.DOOM Namespace


WADEntry Members

WADEntry overview

Public Instance Constructors

WADEntry Overloaded. Initializes a new instance of the WADEntry class.

Public Instance Properties

Data | Get/set the lump data
Item | Overloaded. Index into the lump data as bytes
Length | Get the length of the lump's data
Name | Get/set the lump's name
Stream | Get the lump data as a MemoryStream

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WADEntry Class | WADMangle.DOOM Namespace


WADEntry Constructor

Create an empty lump

Overload List

Create an empty lump

public WADEntry();

Create a lump

public WADEntry(string,byte[]);

Create a lump

public WADEntry(WADEntry);

See Also

WADEntry Class | WADMangle.DOOM Namespace


WADEntry Constructor ()

Create an empty lump

public WADEntry();

See Also

WADEntry Class | WADMangle.DOOM Namespace | WADEntry Constructor Overload List


WADEntry Constructor (String, Byte[])

Create a lump

public WADEntry(
string name,
byte[] data
);

Parameters

name
The name
data
The data

See Also

WADEntry Class | WADMangle.DOOM Namespace | WADEntry Constructor Overload List


WADEntry Constructor (WADEntry)

Create a lump

public WADEntry(
WADEntry we
);

Parameters

we
The lump to copy

See Also

WADEntry Class | WADMangle.DOOM Namespace | WADEntry Constructor Overload List


WADEntry Properties

The properties of the WADEntry class are listed below. For a complete list of WADEntry class members, see the WADEntry Members topic.

Public Instance Properties

Data | Get/set the lump data
Item | Overloaded. Index into the lump data as bytes
Length | Get the length of the lump's data
Name | Get/set the lump's name
Stream | Get the lump data as a MemoryStream

See Also

WADEntry Class | WADMangle.DOOM Namespace


Data Property

WAD Mangle Plugin Documentation

WADEntry.Data Property

Get/set the lump data

public byte[] Data {get; set;}

See Also

WADEntry Class | WADMangle.DOOM Namespace


Item Property

WAD Mangle Plugin Documentation

WADEntry.Item Property

Index into the lump data as bytes

Overload List

Index into the lump data as bytes

public byte this[int] {get; set;}

Index into the lump data as bytes

public byte this[uint] {get; set;}

See Also

WADEntry Class | WADMangle.DOOM Namespace


Item Property (Int32)

WAD Mangle Plugin Documentation

WADEntry.Item Property (Int32)

Index into the lump data as bytes

public byte this[
int index
] {get; set;}

See Also

WADEntry Class | WADMangle.DOOM Namespace | WADEntry.Item Overload List


Item Property (UInt32)

WAD Mangle Plugin Documentation

WADEntry.Item Property (UInt32)

Index into the lump data as bytes

public byte this[
uint index
] {get; set;}

See Also

WADEntry Class | WADMangle.DOOM Namespace | WADEntry.Item Overload List


Length Property

WAD Mangle Plugin Documentation

WADEntry.Length Property

Get the length of the lump's data

public int Length {get;}

See Also

WADEntry Class | WADMangle.DOOM Namespace


Name Property

WAD Mangle Plugin Documentation

WADEntry.Name Property

Get/set the lump's name

public string Name {get; set;}

See Also

WADEntry Class | WADMangle.DOOM Namespace


Stream Property

WAD Mangle Plugin Documentation

WADEntry.Stream Property

Get the lump data as a MemoryStream

public System.IO.MemoryStream Stream {get;}

See Also

WADEntry Class | WADMangle.DOOM Namespace


WADEntryConvert Class

Provides routines to convert WADEntrys to other entities

For a list of all members of this type, see WADEntryConvert Members.

System.Object
WADMangle.DOOM.WADEntryConvert

public class WADEntryConvert

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: WADMangle.DOOM

Assembly: WADMangle.DOOM (in WADMangle.DOOM.dll)

See Also

WADEntryConvert Members | WADMangle.DOOM Namespace


WADEntryConvert Members

WADEntryConvert overview

Public Static Methods

Flat | Overloaded. Converts a flat-style lump into a bitmap
Gfx | Overloaded. Converts a Doom texture/sprite lump into a bitmap. Transparent sections are drawn with an alpha of zero.
Palette | Converts a palette lump into an array of 256 colours.
Wav | Overloaded. Converts a sample lump to a WAV file
ZDOOMFlat | Overloaded. Converts a flat-style lump into a bitmap, allowing large ZDOOM flats

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WADEntryConvert Class | WADMangle.DOOM Namespace


WADEntryConvert Methods

The methods of the WADEntryConvert class are listed below. For a complete list of WADEntryConvert class members, see the WADEntryConvert Members topic.

Public Static Methods

Flat | Overloaded. Converts a flat-style lump into a bitmap
Gfx | Overloaded. Converts a Doom texture/sprite lump into a bitmap. Transparent sections are drawn with an alpha of zero.
Palette | Converts a palette lump into an array of 256 colours.
Wav | Overloaded. Converts a sample lump to a WAV file
ZDOOMFlat | Overloaded. Converts a flat-style lump into a bitmap, allowing large ZDOOM flats

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WADEntryConvert Class | WADMangle.DOOM Namespace


Flat Method

WAD Mangle Plugin Documentation

WADEntryConvert.Flat Method

Convert a flat into a lump

Overload List

Convert a flat into a lump

public static WADEntry Flat(string,Bitmap,Color[]);

Convert a flat into a lump

public static WADEntry Flat(string,Bitmap,Color[],int[]);

Converts a flat-style lump into a bitmap

public static Bitmap Flat(WADEntry,Color[]);

Converts a flat-style lump into a bitmap

public static Bitmap Flat(WADEntry,Color[],int[]);

See Also

WADEntryConvert Class | WADMangle.DOOM Namespace


WADEntryConvert.Flat Method (String, Bitmap, Color[])

Convert a flat into a lump

public static WADEntry Flat(
string name,
Bitmap bmp,
Color[] pal
);

Parameters

name
The name to give the new lump
bmp
The bitmap
pal
The DOOM palette

Return Value

The lump

Exceptions

Exception Type | Condition
DoomException | There aren't 256 colours in the palette
DoomException | The bitmap isn't in an allowable format

See Also

WADEntryConvert Class | WADMangle.DOOM Namespace | WADEntryConvert.Flat Overload List


WADEntryConvert.Flat Method (String, Bitmap, Color[], Int32[])

Convert a flat into a lump

public static WADEntry Flat(
string name,
Bitmap bmp,
Color[] pal,
int[] sizes
);

Parameters

name
The name to give the new lump
bmp
The bitmap
pal
The DOOM palette
sizes
The allowed sizes for the flat (assumed square)

Return Value

The lump

Exceptions

Exception Type | Condition
DoomException | There aren't 256 colours in the palette
DoomException | The bitmap isn't in an allowable format
DoomException | The bitmap is in incorrect size

See Also

WADEntryConvert Class | WADMangle.DOOM Namespace | WADEntryConvert.Flat Overload List


WADEntryConvert.Flat Method (WADEntry, Color[])

Converts a flat-style lump into a bitmap

public static Bitmap Flat(
WADEntry e,
Color[] pal
);

Parameters

e
The lump
pal
The palette

Return Value

The bitmap

Exceptions

Exception Type | Condition
DoomException | There aren't 256 colours in the palette

See Also

WADEntryConvert Class | WADMangle.DOOM Namespace | WADEntryConvert.Flat Overload List


WADEntryConvert.Flat Method (WADEntry, Color[], Int32[])

Converts a flat-style lump into a bitmap

public static Bitmap Flat(
WADEntry e,
Color[] pal,
int[] sizes
);

Parameters

e
The lump
pal
The palette
sizes
Allowed sizes (flats are assumed square)

Return Value

The bitmap

Exceptions

Exception Type | Condition
DoomException | There aren't 256 colours in the palette

See Also

WADEntryConvert Class | WADMangle.DOOM Namespace | WADEntryConvert.Flat Overload List


Gfx Method

WAD Mangle Plugin Documentation

WADEntryConvert.Gfx Method

Convert a bitmap into a graphical lump

Overload List

Convert a bitmap into a graphical lump

public static WADEntry Gfx(string,Bitmap,Color[],bool);

Convert a bitmap into a graphical lump

public static WADEntry Gfx(string,Bitmap,Color[],int,int,bool);

Converts a Doom texture/sprite lump into a bitmap. Transparent sections are drawn with an alpha of zero.

public static Bitmap Gfx(WADEntry,Color[]);

Converts a Doom texture/sprite lump into a bitmap and returns the offset of the DOOM graphic. Transparent sections are drawn with an alpha of zero.

public static Bitmap Gfx(WADEntry,Color[],out int,out int);

See Also

WADEntryConvert Class | WADMangle.DOOM Namespace


WADEntryConvert.Gfx Method (String, Bitmap, Color[], Boolean)

Convert a bitmap into a graphical lump

public static WADEntry Gfx(
string name,
Bitmap bmp,
Color[] pal,
bool trans
);

Parameters

name
The name to give the new lump
bmp
The bitmap
pal
The DOOM palette
trans
If true, assume colour 247 is transparent in 8-bit Bitmaps

Return Value

The lump

Exceptions

Exception Type | Condition
DoomException | There aren't 256 colours in the palette
DoomException | The bitmap isn't in an allowable format
DoomException | The bitmap is over 255 pixels high

See Also

WADEntryConvert Class | WADMangle.DOOM Namespace | WADEntryConvert.Gfx Overload List


WADEntryConvert.Gfx Method (String, Bitmap, Color[], Int32, Int32, Boolean)

Convert a bitmap into a graphical lump

public static WADEntry Gfx(
string name,
Bitmap bmp,
Color[] pal,
int xoff,
int yoff,
bool trans
);

Parameters

name
The name to give the new lump
bmp
The bitmap
pal
The DOOM palette
xoff
The X-offset to set in the graphic lump
yoff
The Y-offset to set in the graphic lump
trans
If true, assume colour 247 is transparent in 8-bit Bitmaps

Return Value

The lump

Exceptions

Exception Type | Condition
DoomException | There aren't 256 colours in the palette
DoomException | The bitmap isn't in an allowable format
DoomException | The bitmap is over 255 pixels high

See Also

WADEntryConvert Class | WADMangle.DOOM Namespace | WADEntryConvert.Gfx Overload List


WADEntryConvert.Gfx Method (WADEntry, Color[])

Converts a Doom texture/sprite lump into a bitmap. Transparent sections are drawn with an alpha of zero.

public static Bitmap Gfx(
WADEntry e,
Color[] pal
);

Parameters

e
The lump
pal
The palette

Return Value

The bitmap

Exceptions

Exception Type | Condition
DoomException | There aren't 256 colours in the palette
DoomException | Empty lump
DoomException | Nonsense size
DoomException | Short lump

See Also

WADEntryConvert Class | WADMangle.DOOM Namespace | WADEntryConvert.Gfx Overload List


WADEntryConvert.Gfx Method (WADEntry, Color[], Int32, Int32)

Converts a Doom texture/sprite lump into a bitmap and returns the offset of the DOOM graphic. Transparent sections are drawn with an alpha of zero.

public static Bitmap Gfx(
WADEntry e,
Color[] pal,
out int x_offset,
out int y_offset
);

Parameters

e
The lump
pal
The palette
x_offset
Returns the X-offset of the graphic
y_offset
Returns the Y-offset of the graphic

Return Value

The bitmap

Exceptions

Exception Type | Condition
DoomException | There aren't 256 colours in the palette
DoomException | Empty lump
DoomException | Nonsense size
DoomException | Short lump

See Also

WADEntryConvert Class | WADMangle.DOOM Namespace | WADEntryConvert.Gfx Overload List


WADEntryConvert.Palette Method

Converts a palette lump into an array of 256 colours.

public static Color[] Palette(
WADEntry e
);

Parameters

e
The palette lump, or null for the default DOOM 2 palette

Return Value

The colours

Exceptions

Exception Type | Condition
DoomException | Lump is too small to hold a palette

See Also

WADEntryConvert Class | WADMangle.DOOM Namespace


Wav Method

WAD Mangle Plugin Documentation

WADEntryConvert.Wav Method

Converts a sample lump to a WAV file

Overload List

Converts a sample lump to a WAV file

public static void Wav(Stream,WADEntry);

Converts a WAV file to a sample lump

public static WADEntry Wav(string,Stream);

See Also

WADEntryConvert Class | WADMangle.DOOM Namespace


WADEntryConvert.Wav Method (Stream, WADEntry)

Converts a sample lump to a WAV file

public static void Wav(
Stream file,
WADEntry e
);

Parameters

file
The stream to write the WAV into. Closed on exit.
e
The lump containing the sample data

Exceptions

Exception Type | Condition
DoomException | Not a sample lump

See Also

WADEntryConvert Class | WADMangle.DOOM Namespace | WADEntryConvert.Wav Overload List


WADEntryConvert.Wav Method (String, Stream)

Converts a WAV file to a sample lump

public static WADEntry Wav(
string name,
Stream file
);

Parameters

name
The name to give the new lump
file
The stream containing the WAV. Closed on exit.

Return Value

The lump

Exceptions

Exception Type | Condition
DoomException | Must be a WAV, uncompressed, mono, 8-bits and less than 65535 samples

See Also

WADEntryConvert Class | WADMangle.DOOM Namespace | WADEntryConvert.Wav Overload List


ZDOOMFlat Method

WAD Mangle Plugin Documentation

WADEntryConvert.ZDOOMFlat Method

Convert a flat into a lump, allowing large ZDOOM flats

Overload List

Convert a flat into a lump, allowing large ZDOOM flats

public static WADEntry ZDOOMFlat(string,Bitmap,Color[]);

Converts a flat-style lump into a bitmap, allowing large ZDOOM flats

public static Bitmap ZDOOMFlat(WADEntry,Color[]);

See Also

WADEntryConvert Class | WADMangle.DOOM Namespace


WADEntryConvert.ZDOOMFlat Method (String, Bitmap, Color[])

Convert a flat into a lump, allowing large ZDOOM flats

public static WADEntry ZDOOMFlat(
string name,
Bitmap bmp,
Color[] pal
);

Parameters

name
The name to give the new lump
bmp
The bitmap
pal
The DOOM palette

Return Value

The lump

Exceptions

Exception Type | Condition
DoomException | There aren't 256 colours in the palette
DoomException | The bitmap isn't in an allowable format

See Also

WADEntryConvert Class | WADMangle.DOOM Namespace | WADEntryConvert.ZDOOMFlat Overload List


WADEntryConvert.ZDOOMFlat Method (WADEntry, Color[])

Converts a flat-style lump into a bitmap, allowing large ZDOOM flats

public static Bitmap ZDOOMFlat(
WADEntry e,
Color[] pal
);

Parameters

e
The lump
pal
The palette

Return Value

The bitmap

Exceptions

Exception Type | Condition
DoomException | There aren't 256 colours in the palette

See Also

WADEntryConvert Class | WADMangle.DOOM Namespace | WADEntryConvert.ZDOOMFlat Overload List


WADMangle.Plugin

WAD Mangle Plugin Documentation

WADMangle.Plugin Namespace

Contains the classes and itnerfaces that define WAD Mangle plugins

Namespace hierarchy

Classes

Class | Description
BasePlugin | A base implementation of IPlugin. It is suggested that this is used as a base for plugins, rather than IPlugin directly, as it defines default actions for unsupported actions.
PluginUtils | Provides core functionality for plugins

Interfaces

Interface | Description
IPlugin | Describes a WADMangle plugin. Note plugins may use this interface, but it may be preferable to use the BasePlugin class instead and override the required interfaces.

Delegates

Delegate | Description
PluginUtils.Export | Delegate for exporting of lump data
PluginUtils.Import | Delegate for importing of lump data

Enumerations

Enumeration | Description
PluginType | Defines the plugin type. The values can be ORed together if the plugin provides more than one service.


BasePlugin Class

A base implementation of IPlugin. It is suggested that this is used as a base for plugins, rather than IPlugin directly, as it defines default actions for unsupported actions.

For a list of all members of this type, see BasePlugin Members.

System.Object
WADMangle.Plugin.BasePlugin

public class BasePlugin : IPlugin

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: WADMangle.Plugin

Assembly: WADMangle.Plugin (in WADMangle.Plugin.dll)

See Also

BasePlugin Members | WADMangle.Plugin Namespace


BasePlugin Members

BasePlugin overview

Public Instance Properties

Author | Author
FileExtensions | FileExtensions
FileType | FileType
LongName | LongName
LumpRegexp | LumpRegexp. This base definition defaults to allowing all lump names.
MenuName | MenuName
PluginType | PluginType

Public Instance Methods

ConvertFile | ConvertFile
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Export | Export
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GlobalEdit | GlobalEdit
Import | Import
LumpEdit | LumpEdit
LumpView | LumpView
Tool | Tool
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

BasePlugin Constructor Constructor.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BasePlugin Class | WADMangle.Plugin Namespace


BasePlugin Constructor

Constructor.

protected BasePlugin();

See Also

BasePlugin Class | WADMangle.Plugin Namespace


BasePlugin Properties

The properties of the BasePlugin class are listed below. For a complete list of BasePlugin class members, see the BasePlugin Members topic.

Public Instance Properties

Author | Author
FileExtensions | FileExtensions
FileType | FileType
LongName | LongName
LumpRegexp | LumpRegexp. This base definition defaults to allowing all lump names.
MenuName | MenuName
PluginType | PluginType

See Also

BasePlugin Class | WADMangle.Plugin Namespace


Author Property

WAD Mangle Plugin Documentation

BasePlugin.Author Property

Author

public virtual string Author {get;}

Implements

IPlugin.Author

See Also

BasePlugin Class | WADMangle.Plugin Namespace


FileExtensions Property

WAD Mangle Plugin Documentation

BasePlugin.FileExtensions Property

FileExtensions

public virtual string[] FileExtensions {get;}

Implements

IPlugin.FileExtensions

See Also

BasePlugin Class | WADMangle.Plugin Namespace


FileType Property

WAD Mangle Plugin Documentation

BasePlugin.FileType Property

FileType

public virtual string FileType {get;}

Implements

IPlugin.FileType

See Also

BasePlugin Class | WADMangle.Plugin Namespace


LongName Property

WAD Mangle Plugin Documentation

BasePlugin.LongName Property

LongName

public virtual string LongName {get;}

Implements

IPlugin.LongName

See Also

BasePlugin Class | WADMangle.Plugin Namespace


LumpRegexp Property

WAD Mangle Plugin Documentation

BasePlugin.LumpRegexp Property

LumpRegexp. This base definition defaults to allowing all lump names.

public virtual string LumpRegexp {get;}

Implements

IPlugin.LumpRegexp

See Also

BasePlugin Class | WADMangle.Plugin Namespace


MenuName Property

WAD Mangle Plugin Documentation

BasePlugin.MenuName Property

MenuName

public virtual string MenuName {get;}

Implements

IPlugin.MenuName

See Also

BasePlugin Class | WADMangle.Plugin Namespace


PluginType Property

WAD Mangle Plugin Documentation

BasePlugin.PluginType Property

PluginType

public virtual PluginType PluginType {get;}

Implements

IPlugin.PluginType

See Also

BasePlugin Class | WADMangle.Plugin Namespace


BasePlugin Methods

The methods of the BasePlugin class are listed below. For a complete list of BasePlugin class members, see the BasePlugin Members topic.

Public Instance Methods

ConvertFile | ConvertFile
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Export | Export
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GlobalEdit | GlobalEdit
Import | Import
LumpEdit | LumpEdit
LumpView | LumpView
Tool | Tool
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BasePlugin Class | WADMangle.Plugin Namespace


BasePlugin.ConvertFile Method

ConvertFile

public virtual WADEntry[] ConvertFile(
WADCollection wads,
WAD wad,
string path
);

Implements

IPlugin.ConvertFile

See Also

BasePlugin Class | WADMangle.Plugin Namespace


BasePlugin.Export Method

Export

public virtual void Export(
WADCollection wads,
WAD wad,
ArrayList lumps
);

Implements

IPlugin.Export

See Also

BasePlugin Class | WADMangle.Plugin Namespace


BasePlugin.GlobalEdit Method

GlobalEdit

public virtual bool GlobalEdit(
WADCollection wads,
WAD wad
);

Implements

IPlugin.GlobalEdit

See Also

BasePlugin Class | WADMangle.Plugin Namespace


BasePlugin.Import Method

Import

public virtual bool Import(
WADCollection wads,
WAD wad,
WADEntry lump
);

Implements

IPlugin.Import

See Also

BasePlugin Class | WADMangle.Plugin Namespace


BasePlugin.LumpEdit Method

LumpEdit

public virtual bool LumpEdit(
WADCollection wads,
WAD wad,
WADEntry lump
);

Implements

IPlugin.LumpEdit

See Also

BasePlugin Class | WADMangle.Plugin Namespace


BasePlugin.LumpView Method

LumpView

public virtual void LumpView(
WADCollection wads,
WAD wad,
WADEntry lump
);

Implements

IPlugin.LumpView

See Also

BasePlugin Class | WADMangle.Plugin Namespace


BasePlugin.Tool Method

Tool

public virtual void Tool();

Implements

IPlugin.Tool

See Also

BasePlugin Class | WADMangle.Plugin Namespace


IPlugin Interface

Describes a WADMangle plugin. Note plugins may use this interface, but it may be preferable to use the BasePlugin class instead and override the required interfaces.

For a list of all members of this type, see IPlugin Members.

public interface IPlugin

Types that implement IPlugin

Type | Description
BasePlugin | A base implementation of IPlugin. It is suggested that this is used as a base for plugins, rather than IPlugin directly, as it defines default actions for unsupported actions.

Requirements

Namespace: WADMangle.Plugin

Assembly: WADMangle.Plugin (in WADMangle.Plugin.dll)

See Also

IPlugin Members | WADMangle.Plugin Namespace


IPlugin Members

IPlugin overview

Public Instance Properties

Author | Gets the author of the plugin
FileExtensions | Gets the default extensions (eg. ["bmp","png"]). This is used by the PluginUtils helpers and when dropping files.
FileType | Gets the file type string (eg. "Bitmap Files"). This is used by the PluginUtils helpers
LongName | Defines a long name that will appear in information dialogs.
LumpRegexp | Get a regular expression defining what lumps are supported.
MenuName | Defines the name that will appear in the menus. It is also the name that WAD Mangle with use to index the plugins and also the title that appears in file selectors if using the PluginUtils helpers.
PluginType | Defines the type of plugin.

Public Instance Methods

ConvertFile | Converts the supplied file to an appropiate lump, or set of lumps. Used for file dropping.
Export | Export lumps.
GlobalEdit | Globally edit a WAD file.
Import | Import lumps.
LumpEdit | Edit a lump.
LumpView | View a lump.
Tool | Interface to launch a tool.

See Also

IPlugin Interface | WADMangle.Plugin Namespace


IPlugin Properties

The properties of the IPlugin interface are listed below. For a complete list of IPlugin interface members, see the IPlugin Members topic.

Public Instance Properties

Author | Gets the author of the plugin
FileExtensions | Gets the default extensions (eg. ["bmp","png"]). This is used by the PluginUtils helpers and when dropping files.
FileType | Gets the file type string (eg. "Bitmap Files"). This is used by the PluginUtils helpers
LongName | Defines a long name that will appear in information dialogs.
LumpRegexp | Get a regular expression defining what lumps are supported.
MenuName | Defines the name that will appear in the menus. It is also the name that WAD Mangle with use to index the plugins and also the title that appears in file selectors if using the PluginUtils helpers.
PluginType | Defines the type of plugin.

See Also

IPlugin Interface | WADMangle.Plugin Namespace


Author Property

WAD Mangle Plugin Documentation

IPlugin.Author Property

Gets the author of the plugin

string Author {get;}

See Also

IPlugin Interface | WADMangle.Plugin Namespace


FileExtensions Property

WAD Mangle Plugin Documentation

IPlugin.FileExtensions Property

Gets the default extensions (eg. ["bmp","png"]). This is used by the PluginUtils helpers and when dropping files.

string[] FileExtensions {get;}

See Also

IPlugin Interface | WADMangle.Plugin Namespace


FileType Property

WAD Mangle Plugin Documentation

IPlugin.FileType Property

Gets the file type string (eg. "Bitmap Files"). This is used by the PluginUtils helpers

string FileType {get;}

See Also

IPlugin Interface | WADMangle.Plugin Namespace


LongName Property

WAD Mangle Plugin Documentation

IPlugin.LongName Property

Defines a long name that will appear in information dialogs.

string LongName {get;}

See Also

IPlugin Interface | WADMangle.Plugin Namespace


LumpRegexp Property

WAD Mangle Plugin Documentation

IPlugin.LumpRegexp Property

Get a regular expression defining what lumps are supported.

string LumpRegexp {get;}

See Also

IPlugin Interface | WADMangle.Plugin Namespace


MenuName Property

WAD Mangle Plugin Documentation

IPlugin.MenuName Property

Defines the name that will appear in the menus. It is also the name that WAD Mangle with use to index the plugins and also the title that appears in file selectors if using the PluginUtils helpers.

string MenuName {get;}

See Also

IPlugin Interface | WADMangle.Plugin Namespace


PluginType Property

WAD Mangle Plugin Documentation

IPlugin.PluginType Property

Defines the type of plugin.

PluginType PluginType {get;}

See Also

IPlugin Interface | WADMangle.Plugin Namespace


IPlugin Methods

The methods of the IPlugin interface are listed below. For a complete list of IPlugin interface members, see the IPlugin Members topic.

Public Instance Methods

ConvertFile | Converts the supplied file to an appropiate lump, or set of lumps. Used for file dropping.
Export | Export lumps.
GlobalEdit | Globally edit a WAD file.
Import | Import lumps.
LumpEdit | Edit a lump.
LumpView | View a lump.
Tool | Interface to launch a tool.

See Also

IPlugin Interface | WADMangle.Plugin Namespace


IPlugin.ConvertFile Method

Converts the supplied file to an appropiate lump, or set of lumps. Used for file dropping.

WADEntry[] ConvertFile(
WADCollection wads,
WAD wad,
string path
);

Parameters

wads
The collection of WAD files being edited
wad
The WAD file the entries are intended for
path
The file

Return Value

The new lump(s). DoomException must be thrown if file could not be converted.

See Also

IPlugin Interface | WADMangle.Plugin Namespace


IPlugin.Export Method

Export lumps.

void Export(
WADCollection wads,
WAD wad,
ArrayList lumps
);

Parameters

wads
The collection of WAD files being edited
wad
The WAD the lumps are from
lumps
The lumps to export

See Also

IPlugin Interface | WADMangle.Plugin Namespace


IPlugin.GlobalEdit Method

Globally edit a WAD file.

bool GlobalEdit(
WADCollection wads,
WAD wad
);

Parameters

wads
The collection of WAD files being edited
wad
The WAD file to edit

Return Value

True if WAD is edited

See Also

IPlugin Interface | WADMangle.Plugin Namespace


IPlugin.Import Method

Import lumps.

bool Import(
WADCollection wads,
WAD wad,
WADEntry lump
);

Parameters

wads
The collection of WAD files being edited
wad
The WAD to insert the imported lumps into
lump
The lump to insert in front of (null if none)

Return Value

True if any lumps were imported

See Also

IPlugin Interface | WADMangle.Plugin Namespace


IPlugin.LumpEdit Method

Edit a lump.

bool LumpEdit(
WADCollection wads,
WAD wad,
WADEntry lump
);

Parameters

wads
The collection of WAD files being edited
wad
The WAD the lump is from
lump
The lump to edit

Return Value

True if lump is edited

See Also

IPlugin Interface | WADMangle.Plugin Namespace


IPlugin.LumpView Method

View a lump.

void LumpView(
WADCollection wads,
WAD wad,
WADEntry lump
);

Parameters

wads
The collection of WAD files being edited
wad
The WAD the lump is from
lump
The lump to view

See Also

IPlugin Interface | WADMangle.Plugin Namespace


IPlugin.Tool Method

Interface to launch a tool.

void Tool();

See Also

IPlugin Interface | WADMangle.Plugin Namespace


PluginType Enumeration

Defines the plugin type. The values can be ORed together if the plugin provides more than one service.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum PluginType

Members

Member Name | Description | Value
eNone | No plugins. | 0
eImport | The plugin supports the importing of lumps via Import. | 1
eExport | The plugin supports the exporting of lumps via Export. | 2
eLumpView | The plugin supports the viewing of specific lumps via LumpView. | 4
eLumpEdit | The plugin supports the editing of specific lumps via LumpEdit. | 8
eGlobalEdit | The plugin edits lumps in the WAD as a whole, managing the lumps itself via GlobalEdit. | 16
eTool | The plugin provides a top level tool that does nothing to the wads. See Tool. | 32
eDropFile | The plugin allows file and drop operation. See ConvertFile. | 64

Requirements

Namespace: WADMangle.Plugin

Assembly: WADMangle.Plugin (in WADMangle.Plugin.dll)

See Also

WADMangle.Plugin Namespace


PluginUtils Class

Provides core functionality for plugins

For a list of all members of this type, see PluginUtils Members.

System.Object
WADMangle.Plugin.PluginUtils

public class PluginUtils

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: WADMangle.Plugin

Assembly: WADMangle.Plugin (in WADMangle.Plugin.dll)

See Also

PluginUtils Members | WADMangle.Plugin Namespace


PluginUtils Members

PluginUtils overview

Public Static Methods

Error | Displays an error
LumpName | Converts a filename into a viable lump name
Message | Displays a message
YesNo | Asks the user a question

Public Instance Constructors

PluginUtils Constructor Constructs the class

Public Instance Methods

DoExport | Wraps the file selection around the exporting of lump data
DoImport | Wraps the file selection around the importing of lump data
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

ExportCallback | Used as a callback when calling DoExport
ImportCallback | Used as a callback when calling DoImport

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PluginUtils Class | WADMangle.Plugin Namespace


PluginUtils Constructor

Constructs the class

public PluginUtils(
IPlugin owner
);

Parameters

owner
The IPlugin using these utilities

See Also

PluginUtils Class | WADMangle.Plugin Namespace


PluginUtils Methods

The methods of the PluginUtils class are listed below. For a complete list of PluginUtils class members, see the PluginUtils Members topic.

Public Static Methods

Error | Displays an error
LumpName | Converts a filename into a viable lump name
Message | Displays a message
YesNo | Asks the user a question

Public Instance Methods

DoExport | Wraps the file selection around the exporting of lump data
DoImport | Wraps the file selection around the importing of lump data
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PluginUtils Class | WADMangle.Plugin Namespace


PluginUtils.DoExport Method

Wraps the file selection around the exporting of lump data

public void DoExport(
WADCollection wads,
WAD wad,
ArrayList lumps,
object client_data
);

Parameters

wads
The WADCollection being edited
wad
The WAD this lump is from
lumps
The list of lumps to export
client_data
Client data passed onto the export callback

See Also

PluginUtils Class | WADMangle.Plugin Namespace


PluginUtils.DoImport Method

Wraps the file selection around the importing of lump data

public bool DoImport(
WADCollection wads,
WAD wad,
WADEntry insert,
object client_data
);

Parameters

wads
The WADCollection being edited
wad
The WAD these lumps are to be imported into
insert
The lump to insert in front of (null if none)
client_data
Client data passed onto the export callback

Return Value

True if any lumps were imported

See Also

PluginUtils Class | WADMangle.Plugin Namespace


PluginUtils.Error Method

Displays an error

public static void Error(
string s
);

Parameters

s
The error message

See Also

PluginUtils Class | WADMangle.Plugin Namespace


PluginUtils.LumpName Method

Converts a filename into a viable lump name

public static string LumpName(
string from_path
);

Parameters

from_path
The path

Return Value

The lump name

See Also

PluginUtils Class | WADMangle.Plugin Namespace


PluginUtils.Message Method

Displays a message

public static void Message(
string s
);

Parameters

s
The message

See Also

PluginUtils Class | WADMangle.Plugin Namespace


PluginUtils.YesNo Method

Asks the user a question

public static bool YesNo(
string s
);

Parameters

s
The question

Return Value

True if the user selects yes

See Also

PluginUtils Class | WADMangle.Plugin Namespace


PluginUtils Events

The events of the PluginUtils class are listed below. For a complete list of PluginUtils class members, see the PluginUtils Members topic.

Public Instance Events

ExportCallback | Used as a callback when calling DoExport
ImportCallback | Used as a callback when calling DoImport

See Also

PluginUtils Class | WADMangle.Plugin Namespace


PluginUtils.ExportCallback Event

Used as a callback when calling DoExport

public event Export ExportCallback;

See Also

PluginUtils Class | WADMangle.Plugin Namespace


PluginUtils.ImportCallback Event

Used as a callback when calling DoImport

public event Import ImportCallback;

See Also

PluginUtils Class | WADMangle.Plugin Namespace


PluginUtils.Export Delegate

Delegate for exporting of lump data

public delegate void PluginUtils.Export(
string path,
WADCollection collection,
WAD wad,
WADEntry lump,
object client_data
);

Requirements

Namespace: WADMangle.Plugin

Assembly: WADMangle.Plugin (in WADMangle.Plugin.dll)

See Also

WADMangle.Plugin Namespace


PluginUtils.Import Delegate

Delegate for importing of lump data

public delegate WADEntry PluginUtils.Import(
string path,
object client_data
);

Requirements

Namespace: WADMangle.Plugin

Assembly: WADMangle.Plugin (in WADMangle.Plugin.dll)

See Also

WADMangle.Plugin Namespace


WADMangle.DOOMHierarchy

WAD Mangle Plugin Documentation

WADMangle.DOOM Hierarchy

System.Object
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
WADMangle.DOOM.WADCollection.WadAddedEvent
WADMangle.DOOM.WADCollection.WadRemovedEvent
System.Exception ---- System.Runtime.Serialization.ISerializable
WADMangle.DOOM.DoomException
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
WADMangle.DOOM.WAD.EWadType
WADMangle.DOOM.FileUtil
WADMangle.DOOM.PnameList ---- System.Collections.IEnumerable
WADMangle.DOOM.TextureList ---- System.Collections.IEnumerable
WADMangle.DOOM.TextureList.Patch
WADMangle.DOOM.TextureList.Texture
WADMangle.DOOM.WAD ---- System.Collections.IEnumerable, System.Collections.IEnumerator
WADMangle.DOOM.WADCollection ---- System.Collections.IEnumerable, System.Collections.IEnumerator
WADMangle.DOOM.WADEntry
WADMangle.DOOM.WADEntryConvert

See Also

WADMangle.DOOM Namespace


WADMangle.PluginHierarchy

WAD Mangle Plugin Documentation

WADMangle.Plugin Hierarchy

System.Object
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
WADMangle.Plugin.PluginUtils.Export
WADMangle.Plugin.PluginUtils.Import
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
WADMangle.Plugin.PluginType
WADMangle.Plugin.BasePlugin ---- WADMangle.Plugin.IPlugin
WADMangle.Plugin.IPlugin
WADMangle.Plugin.PluginUtils

See Also

WADMangle.Plugin Namespace